Dokumentation - Bezierkurven

From The Document Foundation Wiki
Jump to: navigation, search
· Diese Seite ist noch im Aufbau!


Vorwort

In den Kapiteln wird davon ausgegangen, dass Sie schon erste Erfahrungen mit Draw oder Impress gesammelt haben, aber kaum etwas über Bézierkurven wissen. Es ist geplant, dass parallel zu diesen Kapiteln Videos entstehen.

Falls Sie Fragen oder Verbesserungsvorschläge zu diesen Texten haben oder Sie ein spezielles Thema für ein neues Kapitel vorschlagen möchten, benutzen Sie die Diskussion Seite.

Link zu den Videos

Bézierkurven - Erste Erkundungen - Kap.1
Bézierkurven - Zwei Kurvensegmente - Kap.2
Bézierkurven - Gerade Segmente - Kap.3
Bézierkurven - Gefüllte Kurven - Kap.4

Erste Erkundung einer Bézierkurve - Kap. 1

In diesem Kapitel zeichnen Sie eine einfache Bézierkurve und erkunden grundlegende Eigenschaften.

Werkzeug „Kurve“

Abreißleiste

Starten Sie mit einem neuen Dokument, Typ „Zeichnung“. In der Symbolleiste „Zeichnung“ finden Sie ein Symbol „Kurve“. Öffnen Sie die zugehörige Abreißleiste und klicken Sie dann auf das Symbol „Kurve“ LibreOffice 3.4 tango icon lc bezier unfilled.png.

Setzen Sie nun den Mauszeiger auf den Arbeitsbereich und ziehen Sie mit gedrückter Maustaste ca. 3cm nach rechts unten. Dann lassen Sie die Maustaste los und bewegen die Maus ca. 3cm nach rechts oben. Beobachten Sie, dass eine Kurve an dem Mauszeiger „klebt“ und sich beim Bewegen der Maus anpasst. Beenden Sie nun das Zeichnen mit einem Doppelklick. Ihre erste Bézierkurve ist fertig.

Objektmodus

Die Bézierkurve sollte nun grüne Griffe haben. In diesem Objektmodus lässt sie sich wie die meisten anderen Zeichenobjekte transformieren, beispielsweise skalieren oder spiegeln. Die besonderen Eigenschaften von Bézierkurven werden jedoch erst im Punktmodus sichtbar.


Punktmodus, Ankerpunkte und Steuerpunkte

Punkte bearbeiten
Klick auf Ankerpunkt

Klicken Sie auf das Symbol „Punkte bearbeiten“LibreOffice 3.4 tango icon lc toggleobjectbeziermode.png. Dies ist ein Umschalter. Der nächste Klick darauf bringt das Zeichenobjekt wieder zurück in den Objektmodus.

Die Kurve hat an den Linienenden kleine Quadrate. Diese stellen die Griffe für die Endpunkte der Kurve dar. Gehen Sie mit der Maus zu dem linken Quadrat, dort wo Sie mit dem Zeichnen begonnen haben. Sobald die Maus über dem Quadrat schwebt, ändert sich der Mauszeiger und erhält ein kleines Quadrat Bezier movept 24bit.png. Ein solcher Punkt ist ein Ankerpunkt und gehört zu der Linie, wie sie später in der Zeichnung zu sehen ist.

Klicken Sie nun auf das Quadrat. Der Punkt ist nun ausgewählt und die Farbe des Quadrats hat sich geändert. Gleichzeitig erscheint eine gestrichelte Linie mit einem Kreis am anderen Ende. Dieser ist der Griff für einen Steuerpunkt. Gehen Sie mit der Maus zu diesem runden Griff. Nun erhält der Mauszeiger ein Symbol für Steuerpunkte Bezier movebw 24bit.png.

Hilfslinien

  • Hilfslinie als Tangente
  • Hilfslinie als „Geschwindigkeit“

Klicken Sie auf den runden Punkt und halten die Maustaste gedrückt. Bewegen Sie die Maus etwa auf einem Kreis um den Ankerpunkt und beobachten Sie, wie sich die Kurve der Richtung der Hilfslinie anpasst. Die Hilfslinie zwischen Ankerpunkt und Steuerpunkt ist immer eine Tangente an die Kurve. Sie gibt an, in welcher Richtung die Kurve den Ankerpunkt verlässt.

Nun bewegen Sie die Maus mit weiterhin gedrückter Maustaste so, dass die Richtung der Hilfslinie möglichst gleich bleibt, aber die Entfernung zum Ankerpunkt größer oder kleiner wird. Je weiter Sie vom Ankerpunkt weg sind, umso größer wird der Bogen der Kurve. Stellen Sie sich die Kurve als Spur der Bewegung eines Partikels vor. Wenn das Partikel den Ankerpunkt mit hoher Geschwindigkeit verlässt, benötigt es einen großen Bogen um zum anderen Ankerpunkt zu gelangen. Die Länge der Hilfslinie entspricht der Geschwindigkeit des Partikels.

Sonderfall Steuerpunkt auf Ankerpunkt

Steuerpunkt und Ankerpunkt an selber Position

Nun wenden wir uns dem rechten Punkt zu, dort wo Sie das Zeichnen mit Doppelklick beendet haben. Klicken Sie auf den Endpunkt. Diesmal sehen Sie keine Hilfslinie. Aber wenn Sie genau hinschauen, sehen Sie, dass auf dem Quadrat ein Kreis zu sehen ist. Auch der Mauszeiger enthält das Symbol für einen Steuerpunkt. Nur wenn Sie mit dem Mauszeiger ganz am Rand des Quadrats sind, außerhalb des Kreises, erhält der Mauszeiger das kleine Quadrat für einen Ankerpunkt und der Klick wählt diesen Ankerpunkt aus. Hier liegen Steuerpunkt und Ankerpunkt direkt aufeinander. Der Steuerpunkt hat in einer solchen Situation gar keinen Einfluss auf den Verlauf der Kurve.

Ziehen Sie an diesem rechten Steuerpunkt. Nun erhalten Sie auch hier die Hilfslinie. Umgekehrt ist es etwas knifflig, einen Steuerpunkt direkt auf einen Ankerpunkt zu legen. Das geht am besten, wenn Sie eine der unter dem Stichwort „fangen“ in der Hilfe beschriebenen Methoden benutzen.

Übungsdatei

Die Datei enthält einige Übungen für dieses Kapitel.

Kurvensegmente - Kap. 2

In diesem Kapitel zeichnen Sie einen Kurvenzug aus zwei Kurvensegmenten und gestalten den Übergang zwischen den Kurvensegmenten.

Erzeugen mit der Maus

Schalten Sie den Punktmodus ein. Fangen Sie dann wie im ersten Kapitel an: Klicken Sie auf das Symbol „Kurve“ LibreOffice 3.4 tango icon lc bezier unfilled.png. Setzen Sie den Mauszeiger auf den Arbeitsbereich und ziehen Sie mit gedrückter Maustaste nach rechts unten. Dann lassen Sie die Maustaste los. Dort haben Sie einen Steuerpunkt erzeugt. Bewegen Sie die Maus nach rechts oben. Die Kurve folgt dem Mauszeiger, das kennen Sie schon. Nun beenden Sie das Zeichnen nicht mit einem Doppelklick, sondern klicken Sie nur einmal und halten die Maustaste gedrückt. Das erzeugt einen Ankerpunkt.

Ziehen Sie dann die Maus mit weiterhin gedrückter Maustaste nach rechts unten. Lassen Sie die Maustaste dann los. An dieser Position wird ein Steuerpunkt erzeugt und das erste Segment ist fertig. Bewegen Sie die Maus dann nach rechts oben. Etwas überraschend springt die Kurve nach oben. Das liegt daran, dass nicht nur ein Steuerpunkt für das erste Segment erzeugt wurde, sondern automatisch auch ein Steuerpunkt für das zweite Segment. Auch nun folgt die Kurve der Maus. Beenden Sie das Zeichnen mit Doppelklick, was gleichzeitig den abschließenden Ankerpunkt und einen darauf liegenden Steuerpunkt erzeugt.

  • Erster Steuerpunkt
  • Zweiter Ankerpunkt
  • zweiter Steuerpunkt
  • kompletter Kurvenzug

Symmetrischer Übergang

Symmetrischer Übergang

Bei eingeschaltetem Punktmodus[1] sehen Sie nun eine Kurve mit drei Ankerpunkten. Klicken Sie auf den mittleren Ankerpunkt. Weil er nun markiert ist, werden seine Steuerpunkte und ihre Hilfslinien sichtbar. Bewegen Sie einen Steuerpunkt hin-und-her. Beobachten Sie, dass sich der gegenüberliegende Steuerpunkt so mitbewegt, dass beide Hilfslinien stets zusammen eine gerade Linie bilden. Mehr noch, ziehen Sie einen Steuerpunkt vom Ankerpunkt weg oder bewegen Sie ihn zum Ankerpunkt hin. Beobachten Sie, dass der gegenüberliegende Steuerpunkt sich in gleicher Weise bewegt.

Die beiden Steuerpunkte sind miteinander so gekoppelt, dass ihre Positionen punktsymmetrisch zum Ankerpunkt sind. Man sagt, dass dieser Ankerpunkt einen „symmetrischen Übergang“ besitzt. Wegen dieser Eigenschaft waren oben beim Zeichnen auch keine weiteren Benutzeraktionen nötig, um den Steuerpunkt zu erzeugen.

Symbolleiste „Punkte bearbeiten“

In welcher Weise ein Kurvensegment ins nächste übergeht, lässt sich nachträglich ändern. Dazu benötigen Sie die Symbolleiste „Punkte bearbeiten“. Wenn Sie in den Punktmodus geschaltet haben, sollte diese Symbolleiste automatisch erscheinen sobald eine Bézierkurve ausgewählt ist. Wenn dies bei Ihnen nicht der Fall ist, schauen Sie zuerst, ob sich diese Leiste am rechten Rand neben der Standardleiste verbirgt.Bezier Toolbar right.png

Verbreitern Sie in diesem Fall das Programmfenster oder ziehen Sie die Symbolleiste an dem Griff Bezier Toolbar handle.png an eine andere Stelle.

Bezier PointEditFloating.png

Wenn die Symbolleiste gar nicht vorhanden ist, schalten Sie die Leiste über das Menü Ansicht ▸ Symbolleisten ▸ Punkte bearbeiten ein. Es ist eine kontext-gebundene Leiste. Sie wird nur angezeigt, wenn ein Objekt aktiv ist, das man mit Hilfe dieser Leiste bearbeiten kann. Wenn Sie beispielsweise das Symbol „Smiley“ markiert haben, erscheint die Leiste trotz Punktmodus nicht.

Übergänge in der Symbolleiste

Neben anderen Einstellungen enthält die Symbolleiste „Punkte bearbeiten“ einen Abschnitt für die Übergänge. Für die nächsten Aktionen klicken Sie (falls noch nicht geschehen) auf den mittleren Ankerpunkt, so dass er markiert ist und die Hilfslinien sichtbar sind. Nun sollte in der Symbolleiste das Symbol „symmetrischer Übergang“ Lc beziersymmetric.png aktiv sein. Links davon liegt das Symbol „glatter Übergang“ Lc beziersmooth.png und daneben das Symbol „Eckpunkt setzen“Lc bezieredge.png.

Bezier TooltipsUebergang.png

Glatter Übergang

Glatter Übergang

Klicken Sie auf das Symbol „glatter Übergang“. Geduld! Die Symbole reagieren mit merkbarer Verzögerung. Ziehen Sie wieder an einem der Steuerpunkte. Auch jetzt passt der gekoppelte Steuerpunkt seine Richtung an. Aber wenn Sie den Abstand zum Ankerpunkt ändern, folgt der gekoppelte Steuerpunkt nicht mehr. Die Kopplung ist also schwächer, nur noch die Richtung ist gekoppelt, aber nicht mehr die „Geschwindigkeit“. Sie können auf einer Seite durch den Steuerpunkt den Bogen der Kurve weit herausziehen, ohne dass sich die gegenüberliegende Seite ändert. Weil aber immer noch die gleiche Richtung vorliegt, bildet die Verbindungslinie der Steuerpunkte weiterhin eine Tangente an die Kurve.

Eckpunkt

Eckpunkt setzen

Klicken Sie nun auf das Symbol „Eckpunkt setzen“ und bewegen dann die Steuerpunkte. Beobachten Sie, dass sich nun die beiden Steuerpunkte völlig unabhängig voneinander bewegen lassen. Positionieren Sie die Steuerpunkte nun so, dass ihre Hilfslinien einen kleinen Winkel bilden. Die beiden Kurvensegmente laufen nun im Ankerpunkt spitz zusammen. Diese Übergangsart wird daher auch „spitzer Übergang“ genannt.

Probleme mit Übergängen

Es kommt vor, dass ein Wechsel der Übergangsart gar nicht möglich ist. Für diese Probleme wurde tdf#49319 eingerichtet. Leider ist es noch nicht gelungen, einen Ablauf zu finden, der die Fehlersituation jedes mal erzeugt und ein Beheben des Fehlers erlauben würde.

Es kommt in seltenen Fällen vor, dass die Information "symmetrischer Übergang" beim Speichern verloren geht, siehe tdf#106310. Auch hier konnte der Fehler noch nicht verlässlich reproduziert werden.

Das OpenDocument Format kennt für Übergänge nur die Arten "Symmetrisch" und "Eckpunkt". Daher geht die Information "Glatter Übergang" beim Speichern verloren. LibreOffice versucht beim Öffnen des Dokuments diese Art Übergang aus den Koordinaten der Steuerpunkte zu rekonstruieren, aber das gelingt wegen Rundungsungenauigkeiten nicht immer.


Gerade Segmente - Kap. 3

In diesem Kapitel untersuchen Sie die Beziehung zwischen Kurvensegmenten und geraden Liniensegmenten.

Gerades Liniensegment beim Erzeugen der Kurve mit der Maus

Schalten Sie den Punktmodus ein. Fangen Sie dann wie im ersten Kapitel an: Klicken Sie auf das Symbol „Kurve“ LibreOffice 3.4 tango icon lc bezier unfilled.png. Setzen Sie den Mauszeiger auf den Arbeitsbereich und ziehen Sie mit gedrückter Maustaste nach rechts unten. Dann lassen Sie die Maustaste los und bewegen die Maus nach rechts oben. Beenden Sie das Zeichnen nicht mit einem Doppelklick, sondern klicken Sie nur einmal. Das erzeugt einen Ankerpunkt und das erste Segment ist damit fertig.

Drücken Sie keine Maustaste, sondern bewegen Sie die Maus ein Stück weiter und beenden das Zeichnen dann mit einem Doppelklick. Sie haben nun offensichtlich ein Kurvensegment und ein gerades Liniensegment erzeugt. Ziehen Sie den Steuerpunkt vom mittleren Ankerpunkt herunter, damit Sie den Ankerpunkt besser erreichen können. Dabei bemerken Sie, dass sich dieser Steuerpunkt nur auf das erste Segment bezieht.

Umwandeln zwischen Liniensegment und Kurvensegment

Schaltfläche „In Kurve umwandeln“ als Indikator

In Kurve umwandeln

Liniensegmente und Kurvensegmente sind miteinander verwandt. Klicken Sie nacheinander auf die Ankerpunkte und schauen Sie sich jeweils an, wie die Schaltfläche „In Kurve umwandeln“ Lc bezierconvert.png in der Symbolleiste „Punkte bearbeiten“ aussieht. Sie sollten folgende Beobachtung machen:

  • Folgt auf einen Ankerpunkt ein Kurvensegment, ist die Schaltfläche eingedrückt.Bezierconvert pressed.png
  • Folgt auf einen Ankerpunkt ein Liniensegment, ist die Schaltfläche nicht eingedrückt.Bezierconvert not pressed.png
  • Folgt auf einen Ankerpunkt gar kein Segment, steht die Schaltfläche nicht zur Verfügung.Bezierconvert disabled.png

Es wurde die Sprechweise „folgt auf einen Ankerpunkt“ benutzt. Doch in welcher Richtung? Vergleichen Sie die Ankerpunkte miteinander. Sie bemerken, dass das Quadrat des linken Ankerpunkts etwas größer ist als bei den anderen Ankerpunkten. Dadurch ist festgelegt, dass dieser Punkt der Anfangspunkt ist.

Schaltfläche „In Kurve umwandeln“ zum Umwandeln

Mit der Schaltfläche „In Kurve umwandeln“ kann man das Segment, das auf den markierten Ankerpunkt folgt, von einem Liniensegment in ein Kurvensegment umwandeln oder umgekehrt. Probieren Sie es an dem Material aus!

Schalten Sie in den Punktmodus. Markieren Sie den linken Punkt und klicken Sie auf die Schaltfläche „In Kurve umwandeln“. Aus einem Kurvensegment wird eine einfache Strecke. Achten Sie auch auf die Information links in der Statusleiste. Wenn Sie alle Segmente in Liniensegmente umgewandelt haben, also gar keine Steuerpunkte mehr existieren, erkennt LibreOffice dies und vereinfacht die interne Darstellung zu einer Vielfachlinie.

  • Bezierkurve
  • Vielfachlinie

Nun klicken Sie wieder auf die Schaltfläche „In Kurve umwandeln“. Jetzt wird aus dem Liniensegment eine Kurve. Diese ist allerdings zunächst noch gerade, weil der Steuerpunkt direkt auf die Kurve gelegt wurde. Aber ein Blick in die Statuszeile sagt Ihnen, dass dies eine Bezierkurve ist. Und wenn Sie den Steuerpunkt bewegen, biegt sich die Linie entsprechend.

Nehmen Sie nochmals das ursprüngliche Objekt. Wählen Sie nun den mittleren Ankerpunkt aus und klicken Sie dann auf die Schaltfläche „In Kurve umwandeln“. Auch hier wird der Steuerpunkt direkt auf die Linie gelegt, so dass das Segment weiterhin gerade aussieht. Beachten Sie außerdem, dass Ihre Operation nur das Segment verändert hat, das nach dem Ankerpunkt kommt. Das vorige Segment hat sich nicht verändert.

Bezeichnungen

Die Bezeichnung für ein Objekt, das nur aus geraden Liniensegmenten besteht, ist nicht einheitlich. Sie werden die Begriffe „Vielfachlinie“, „Polylinie“, „Pfad“ oder „offenes Polygon“ in der Benutzeroberfläche und in der Hilfe finden. Wenn mindestens ein Steuerpunkt vorhanden ist, wird das Objekt insgesamt von LibreOffice eine „Bézierkurve“ genannt.

In der Literatur und von anderen Zeichenprogrammen werden manchmal andere Begriffe benutzt. Beispielsweise nennt Inkscape ein einzelnes Kurvensegment eine „Bézierkurve“ und ein Objekt, das aus mehreren Segmenten besteht, einen „Pfad“. CorelDraw nennt das Gesamtobjekt eine „Kurve“ unabhängig davon, ob es aus geraden oder gebogenen Segmenten besteht.

Steuerpunkte sichtbar machen

Objekt nicht ausgewählt

Ob ein Linienzug eine Bezierkurve oder eine Vielfachlinie ist, hängt nicht von der Form der Segmente ab, sondern nur davon, ob Steuerpunkte vorhanden sind oder nicht. Diese sieht man aber im Normalmodus nicht.

Objekt im Punktmodus

Selbst bei eingeschaltetem Punktmodus sehen die Objekte noch gleich aus.

Alle Steuerpunkte sichtbar

Erst wenn man sich auch Steuerpunkte anzeigen lässt, erkennt man ob gerade Liniensegmente oder Kurvensegmente vorliegen.

Sie wissen schon, dass im Punktmodus bei einem ausgewählten Punkt seine Steuerpunkte und ihre Hilfslinien angezeigt werden. Um alle Steuerpunkte zu sehen, müssen alle Ankerpunkte ausgewählt sein. Wenn der Punktmodus eingeschaltet ist und ein Objekt ausgewählt ist, können Sie durch Aufziehen eines Auswahlrechtecks oder mit der Tastenkombination Strg+A alle Ankerpunkte gleichzeitig auswählen. Dadurch werden dann auch alle Steuerpunkte mit ihren Hilfslinien angezeigt. Mit der Taste Esc beenden Sie diesen Modus.

Möchten Sie nicht nur vorübergehend alle Steuerpunkte sehen, schalten Sie die Benutzeroberfläche entsprechend um. Die Einstellung „Alle Steuerpunkte im Bezier-Editor“ finden Sie unter Extras ▸ Optionen ▸ LibreOffice Draw ▸ Ansicht.

In den Beispielen ist das linke Objekt eine Vielfachlinie ‒ was man auch in der Statusleiste erfahren hätte. Das Objekt in der Mitte besteht aus zwei Kurvensegmenten und das rechte Objekt besteht aus einem Kurvensegment und einem Liniensegment.

Übergangsart eines Ankerpunkts ändern

Sie können die Umwandlung eines geraden Segments in ein Kurvensegment auch dadurch erzwingen, dass Sie für den Ankerpunkt einen Übergang setzen. Bei Anfangs- und Endpunkt kann dies natürlich nur ein Eckpunkt sein. Wenn Sie den Anfangs- oder Endpunkt ausgewählt haben, wird die Schaltfläche „Eckpunkt“ schon gedrückt angezeigt Active lc bezieredge.png. Klicken Sie einfach nochmals darauf, um einen Steuerpunkt zu erzeugen.

Bei einem mittleren Punkt sind auch die anderen Übergänge möglich. Klicken Sie also auf den mittleren Punkt um ihn auszuwählen und dann auf das Symbol „glatter Übergang“ Lc beziersmooth.png bzw. „symmetrischer Übergang“ Lc beziersymmetric.png.

  • Glatter Übergang
  • Ausgangssituation mit Eckpunkt
  • Symmetrischer Übergang

Weil bei einem glatten und bei einem symmetrischen Übergang die Steuerpunkte gekoppelt sind, werden für das davorliegende und das folgende Segment die Steuerpunkte gleichzeitig erzeugt. Ist der Ankerpunkt zwischen zwei geraden Linien, werden daher beide Segmente gleichzeitig umgewandelt.

  • Glatter Übergang
  • Ausgangssituation mit Punkt zwischen Liniensegmenten
  • Symmetrischer Übergang

Damit lassen sich sehr schnell Vielfachlinien in gebogene Linien umwandeln, aber die umgekehrte Richtung ist damit nicht möglich.

Übungsdatei

Die Datei enthält einige Übungen für dieses Kapitel.

Gefüllte Kurven - Kap. 4

In diesem Kapitel erstellen Sie geschlossene Kurven und erforschen den prinzipiellen Unterschied zwischen offenen und geschlossenen Kurven.

Von vornherein geschlossene Kurve

WerkzeugKurveGefuellt.png
Öffnen Sie die Abreißleiste „Kurve“ (Titelleiste „Linien“) und klicken Sie auf das Symbol „Kurve, gefüllt“. Zeichnen Sie nun eine einfache Bézierkurve: Ziehen mit gedrückter Maustaste vom Start-Ankerpunkt zum ersten Steuerpunkt, Loslassen, Doppelklick für den End-Ankerpunkt.
GefuellteBezier.png
Sie sehen, dass im Vergleich zu der offenen Bézierkurve ein gerades Liniensegment hinzugekommen ist, das zum Start-Ankerpunkt zurückführt, und dass die Fläche innerhalb der Kurve gefüllt ist.
WerkzeugPolygonGefuellt.png Sie wissen schon, dass sich gerade Liniensegmente und Kurvensegmente ineinander umwandeln lassen. Sie können daher hier auch mit dem Werkzeug „Polygon, gefüllt“ oder „Polygon (45°), gefüllt“ starten. Zeichnen Sie beispielsweise ein Dreieck mit dem Polygonwerkzeug: Ziehen, Loslassen, Doppelklick. Um das Polygon in eine Bézierkurve zu verwandeln, klicken Sie z.B. auf einen Ankerpunkt und dann auf das Werkzeug „Symmetrischer Übergang“ aus der Symbolleiste „Punkte bearbeiten“.

Kurven nachträglich schließen

Kontextmenü mit Eintrag „Objekt schließen“

Sie können auch erst einen offenen Kurvenzug zeichnen und ihn anschließend schließen. Benutzen Sie das Werkzeug „Bézierkurve“ LibreOffice 3.4 tango icon lc bezier unfilled.png und zeichnen Sie eine einfache, nicht geschlossene Bézierkurve. Dann wählen Sie aus dem Kontextmenü („rechte Maustaste“) den Eintrag „Objekt schließen“ oder Sie wechseln in den Punktmodus und benutzen aus der Symbolleiste „Punkte bearbeiten“ das Werkzeug „Bezier schließen“Lc bezierclose.png. Zum Schließen wird eine gerade Linie vom End-Ankerpunkt zum Start-Ankerpunkt gezogen. Auch bei Polygonen können Sie zunächst mit einer offenen Vielfachlinie anfangen und diese dann schließen.

Beim Erzeugen der nicht geschlossenen Bézierkurve hat diese automatisch die Formatvorlage „Objekt ohne Füllung“ erhalten. Bei dieser Vorlage ist die Flächenfüllung auf den Wert „Keine“ gesetzt. Daher hat das Objekt auch nach dem Schließen keine Füllung.

Weisen Sie dem Objekt die Vorlage „Standard“ zu, wird wie bei der von vornherein geschlossenen Bézierkurve die voreingestellte Füllfarbe benutzt.

VorlageObjektOhneFuellung.png

VorlageStandardGefuellt.png


Punkte aufeinander legen

Schalten Sie die Option „Am Raster fangen“ ein (z.B. Menu Ansicht, Eintrag Raster). Zeichnen Sie nun von einem Rasterpunkt aus einen offenen Kurvenzug oder Linienzug mit drei Segmenten. Klicken Sie dann auf den End-Ankerpunkt und ziehen Sie ihn auf den Start-Ankerpunkt. Durch das „Fangen“ haben die Punkte identische Koordinaten. Schauen Sie in die Statusleiste, das Objekt hat vier Ankerpunkte.

PolygonOffen.png

Obwohl Start-Ankerpunkt und End-Ankerpunkt an identischer Position liegen, ist die Kurve nicht geschlossen. Öffnen Sie das Menü „Format“; der Eintrag „Fläche“ ist nicht aktiv. Nur geschlossene Objekte können eine Flächenfüllung erhalten.

Wenn Sie nun auf die Schaltfläche „Bézier schließen“ klicken oder den Eintrag „Objekt schließen“ des Kontextmenüs benutzen, dann wird ein Punkt entfernt und die Kurve tatsächlich geschlossen. Kontrollieren Sie in der Statusleiste, dass Ihr Objekt wirklich nur 3 Punkte hat. Im Menü Format ist nun der Eintrag „Fläche“ aktiv.

PolygonGeschlossen.png

Ob eine Kurve offen oder geschlossen ist, richtet sich nicht nach der Position von Start-Ankerpunkt und End-Ankerpunkt, sondern ist ein besonderer Zustand des Objekts. Sie können immer an der Schaltfläche „Bezier schließen“ erkennen, ob die Kurve geschlossen ist:
nicht gedrückt = offenIconBezierOffen.png
gedrückt = geschlossenIconBezierGeschlossen.png

Schließen mit Doppelklick auf Start-Ankerpunkt

In der Hilfe lesen Sie den Satz „Um eine geschlossene Form zu erzeugen, doppelklicken Sie auf den Startpunkt der Kurve.“ Dass dies etwas problematisch ist, sollen Sie im folgenden ausprobieren.

Schalten Sie die Option „Am Raster fangen“ bzw. „An Fanglinien fangen“ aus. Zeichnen Sie zunächst zwei Segmenten (d.h 3 Ankerpunkte) und beenden dann das Zeichnen mit Doppelklick auf den Start-Ankerpunkt. Ist nun die Schaltfläche „Bézier schließen“ gedrückt? Wenn nicht, haben Sie den Start-Ankerpunkt weit verfehlt. Falls Ihre Bézierkurve als geschlossen angezeigt wird, kann aber trotzdem ein Problem vorliegen. Wählen Sie wieder alle Ankerpunkte aus. Steht in der Statusleiste „4 Punkte von Bézierkurve ausgewählt“, dann war Ihr Klick zwar nahe genug des Start-Ankerpunkts, aber Sie haben nicht so genau getroffen, dass die Koordinaten wirklich identisch sind. Es wurde ein neuer vierter Ankerpunkt gesetzt und dann mit einem minimalen geraden Liniensegment die Kurve geschlossen. Es liegen nun zwei Punkte so nahe beieinander, dass Sie diese optisch in der Zeichnung nicht unterscheiden können, was zu vielfältigen Problemen führen wird.

Sie sollten daher die Möglichkeit, einen Kurvenzug mit Doppelklick auf den Start-Ankerpunkt zu schließen, nur benutzen, wenn Sie gleichzeitig „Am Raster fangen“ einschalten oder mit Fangpunkten arbeiten.

Geschlossene Kurven verändern

Auch geschlossene Objekte können Sie wie in den Kapiteln 2 und 3 beschrieben weiter verändern. Versuchen Sie beispielsweise wie abgebildet ein „Osterei“ zu zeichnen.

Oster1.png Oster2.png Oster4.png Oster5.png Oster6.png Oster8.png
ziehen, loslassen, Doppelklick einfache, geschlossene Bézierkurve Punktmodus einschalten, Steuerpunkt vom Ankerpunkt weg ziehen symmetrische Übergänge setzen Steuerlinien waagerecht, falls nötig im Halbkreis ziehen; oben enge Rundung, unten weite Rundung „Osterei“ färben





  1. Falls Sie den Punktmodus noch nicht eingeschaltet haben, holen Sie dies bitte nach, siehe Kapitel Erste Erkundung einer Bézierkurve.