Documentatie/Calc-functies/AFRONDEN

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page Documentation/Calc Functions/ROUND and the translation is 100% complete.
Other languages:
English • ‎Nederlands • ‎dansk



Functienaam:

AFRONDEN

Categorie:

Wiskundig

Samenvatting:

Rondt een getal af op het dichtstbijzijnde veelvoud van een opgegeven macht van 10.

Syntaxis:

AFRONDEN(Getal[; Aantal])

Retourneert:

Retourneert een echte waarde die het opgegeven getal is, afgerond op de opgegeven precisie.

Argumenten:

Getal is een reëel getal of een verwijzing naar een cel die dat getal bevat, dat moet worden afgerond.

Aantal is een geheel getal of een verwijzing naar een cel die dat getal bevat, dat wordt gebruikt om de precisie van de afronding te specificeren. Als Aantal wordt weggelaten, wordt uitgegaan van een standaardwaarde van 0. De waarde van Aantal wordt als volgt gebruikt:

  • Als Aantal een positief geheel getal is, vindt afronding rechts van het decimaalteken plaats. Als Aantal bijvoorbeeld gelijk is aan 1 dan worden getallen afgerond op het dichtstbijzijnde veelvoud van [math]\displaystyle{ \frac{1}{10}\text{th} }[/math]; als Aantal gelijk is aan 2, dan worden getallen afgerond op het dichtstbijzijnde veelvoud van [math]\displaystyle{ \frac{1}{100}\text{th} }[/math]; enzovoorts.
  • Als Aantal gelijk is aan nul, dan wordt afgerond op het dichtstbijzijnde gehele getal.
  • Als Aantal een negatief geheel getal is, dan vindt afronding plaats aan de linkerkant van het decimaalteken. Als Aantal bijvoorbeeld gelijk is aan -1, worden getallen afgerond op het dichtstbijzijnde veelvoud van 10; als Aantal gelijk is aan -2, dan worden getallen afgerond op het dichtstbijzijnde veelvoud van 100; enzovoorts. De waarde die door AFRONDEN wordt geretourneerd, is altijd een geheel getal als Aantal negatief is.

De volgende omstandigheden (inclusief fouten) kunnen optreden:

  • Als Getal of Aantal niet-numeriek is, dan retourneert AFRONDEN als fout #WAARDE!.
  • Als Aantal een niet-gehele waarde is, wordt deze afgerond op het volgende gehele getal in de richting van 0.

Aanvullende details:

  • Deze functie rondt af op de dichtstbijzijnde geschikte waarde, afhankelijk van de geselecteerde precisie. Als Getal op gelijke afstand ligt van twee dichtstbijzijnde waarden, wordt er vanaf 0 afgerond naar de waarde met de hoogste grootte. 7,5 ligt bijvoorbeeld op gelijke afstand van 7 en 8, zodat de formule =AFRONDEN(7,5; 0) de waarde 8 retourneert. Op dezelfde manier is de formule =AFRONDEN(-7,5; 0) retourneert de waarde -8.
  • Als u onverwachte resultaten krijgt met AFRONDEN, controleer dan het volgende:
  1. Zorg ervoor dat het aantal weergegeven decimalen niet wordt beïnvloed door de instelling van de optie Aantal decimalen van Decimalen beperken voor de algemene getalopmaak in het gedeelte Algemene berekeningen van de Tools ▸ Opties  ▸ LibreOffice Calc ▸ Berekenen dialoogvenster (LibreOffice ▸ Voorkeuren ▸ LibreOffice Calc ▸ Berekenen op macOS).
  2. Ga naar het tabblad Getallen in het dialoogvenster Cellen opmaken (Opmaak ▸ Cellen of gelijkwaardige interactie) om ervoor te zorgen dat relevante cellen geen opmaak hebben die het aantal weergegeven decimalen beïnvloedt.

Voorbeelden:

Formule Beschrijving Retourneert
=AFRONDEN(2,348; 2) Hier rondt de functie 2,348 af op 2 decimalen. 2,35
=AFRONDEN(D1; D2) waarbij de cellen D1 en D2 respectievelijk de getallen -32,4834 en 3,2 bevatten. De waarde van het argument Aantal wordt afgekapt tot 3. Hier rondt de functie -32,4834 af op 3 decimalen. -32,483
=AFRONDEN(2,348; 0) Hier rondt de functie 2,348 af op het dichtstbijzijnde gehele getal. De alternatieve formule =AFRONDEN(2,348) geeft dezelfde waarde terug. 2
=AFRONDEN(2,5) Hier rondt de functie 2,5 af op het dichtstbijzijnde gehele getal. Omdat 2,5 echter op gelijke afstand van 2 en 3 ligt, wordt de waarde 3 gekozen. 3
=AFRONDEN(887,65; -2) Hier rondt de functie 887,65 af op het dichtstbijzijnde honderdtal. 900

Gerelateerde LibreOffice-functies:

GEH.GET.

AFRONDEN.NAAR.BENEDEN

AFRONDEN.NAAR.BOVEN

GEHEEL

ODF standaard:

Section 6.17.5, part 2

Gelijkwaardige Excel-functies:

AFRONDEN