Documentation/Calc Functions/SUM.HVIS

From The Document Foundation Wiki
Jump to: navigation, search
This page is a translated version of the page Documentation/Calc Functions/SUMIF and the translation is 100% complete.

Other languages:
dansk • ‎English

Funktionsnavn:

SUM.HVIS

Kategori:

Matematisk

Resume:

Adderer de celler, der er bestemt med et givet kriterium. Denne funktion bruges til at bladre gennem et område, når du søger efter en bestemt værdi.

Syntaks:

SUM.HVIS(Område; Kriterium [; Sum-område])

Returnerer:

Argumenter:

Område er det område, som kriteriet skal anvendes på.

Kriterium er den celle, hvor søgekriteriet vises, eller selve søgekriteriet. Hvis kriteriet skrives ind i formlen, skal den omsluttes af dobbelte anførselstegn.

Sum-område er det område, som værdierne opsummeres fra. Hvis denne parameter ikke er angivet, opsummeres de værdier, der findes i Område.

SUM.HVIS understøtter standard sammenkædningsoperatoren (~) udelukkende i parameteren Kriterium og kun, hvis den valgfrie parameter Sum-område ikke er angivet.

Yderligere oplysninger:

Søgningen understøtter jokertegn eller regulære udtryk. Når regulære udtryk er aktiveret, kan du for eksempel indtaste "alle.*", for at finde den første forekomst af "alle" fulgt af vilkårlige tegn. Hvis du vil søge efter en tekst, der også er et regulært udtryk, skal du enten sætte tegnet "\" foran hvert tegn eller indramme teksten med \Q...\E. Du kan slå den automatiske evaluering af jokertegn eller regulære udtryk til og fra under Funktioner > Indstillinger > LibreOffice Calc > Beregn.

Gnome-dialog-warning.svg

Warning:
Advarsel Når bruger du funktioner, hvor et eller flere argumenter er søgekriteriestrenge, der repræsenterer et regulært udtryk, er det første forsøg at prøve at konvertere kriteriestrengen til tal. Fx bliver ".0" konverteret til 0.0 osv. Hvis det lykkes, bliver matchet ikke et match med et regulært udtryk, men et numerisk match. Efter skift til en lokalisering, hvor decimalskilletegnet ikke er punktum, virker imidlertid konverteringen til et regulært udtryk. Til at gennemtvinge evaluering af det regulære udtryk i stedet for et numerisk udtryk bruger du et udtryk, der ikke kan fejllæses som numerisk, som fx ".[0]", ".\0" eller "(?i).0".


  • Find flere eksempler på syntaks, som kan bruges sammen med SUM.HVIS() under TÆL.HVIS().

Eksempler:

Formel Beskrivelse Returnerer
=SUM.HVIS(A1:A4;"<0") hvor A1, A2, A3 OG A4 er -3, -4,-5,-6 opsummerer kun negative tal -15
=SUM.HVIS(A1:A3;">0";B1:B3) hvor A1, A2, A3 er 3, -4 og 5 og B1, B2 og B3 er 2, 3, 4 opsummerer udelukkende værdier fra området B1:B3, hvis de tilsvarende værdier i området A1:A3 er større end 0, så her er 3 og 5 >0, hvorfor der returneres 2+4 6

Beslægtede LibreOffice-funktioner:

SUM.FLERE.HVIS

SUM

TÆL.HVIS

TÆL.FLERE.HVIS

ODF standard:

Section 6.16.62, part 2

Tilsvarende Excel-funktion:

SUM.HVIS