FB 5.2 öffnet nicht mit LibO 5.3 - FAQ Base

From The Document Foundation Wiki
< Faq‎ | Base‎ | 145
Jump to: navigation, search

Meine Firebird 2.5 Daten können nicht mit LibreOffice 5.3 geöffnet werden

Firebird wurde auf die Version 3.0 aktualisiert. Es ist mit dieser Version nicht möglich, Daten, die mit Firebird 2.5 geschrieben wurden, zu lesen, sodass eingebettete Firebird-ODB-Dateien, die mit LibreOffice 5.2 oder früher erstellt wurden, nicht mit LibreOffice 5.3 geöffnet werden können. Falls eine zukünftige Firebird-Version abwärtskompatibel sein sollte und ältere Firebird-Datenbanken lesen können sollte, wird auch LibreOffice (sobald diese zukünftige Version von Firebird in LibreOffice integriert sein wird) in der Lage sein, ältere Dateien wieder zu öffnen.

Das eingebettete Firebird-Modul wurde in Firebirds „Archiv“-Format geändert, welches versionsunabhängig ist, sodass dieser Fehler zukünftig nicht wieder passieren dürfte.

Um ODB-Dateien, die mit Versionen von LibreOffice älter als 5.3 erstellt wurden, von Hand zu konvertieren, müssen Sie eine eigenständige Installation von Firebird 2.5 verwenden. Konvertieren Sie mithilfe der „gback“-Funktion die in der ODB-Datei enthaltene Datei „database.fdb“ in „database.fdk“ und ersetzen Sie diese. Vergessen Sie also nicht, die alte FDB-Datei zu löschen.