Faq/Base/145/fr

From The Document Foundation Wiki
< Faq‎ | Base‎ | 145
Jump to: navigation, search

LibreOffice 5.3 ne peut ouvrir ma base de données Firebird 2.5

Montée de version pour Firebird en 3.0.0. Cette version ne peut pas lire les données de Firebird 2.5 donc les fichiers odb incorporant firebird et créés jusqu'en version LibreOffice 5.2 ne peuvent être ouverts avec LibreOffice 5.3. Comme une version future de firebird disposera d'un module de compatibilité antérieure, une prochaine version de LibreOffice (incluant cette future version de firebird) sera ausi capable d'ouvrir ces anciens fichiers.

Firebird incorporé passe au format "archive" de Firebird, indépendant des versions, donc ce problème ne se posera plus.

Les fichiers ODB créés avec une version de LibreOffice antérieure à 5.3 peuvent être convertis manuellement au format LibreOffice 5.3 en utilisant Firebird 2.5 pour convertir les données au format archive, et en remplaçant les données de la base par les données au format archive. Pour cela, installer Firebird 2.5 (version stand-alone), et utiliser l'outil "gbak" pour convertir le fichier "database.fdb" en "database.fbk" à l'intérieur du fichier odb. Ne pas oublier de supprimer le fichier .fdb.