Neuerungen und Veränderungen in LibreOffice 3.3

From The Document Foundation Wiki
Jump to navigation Jump to search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 3.3 von LibreOffice.

Allgemeine Änderungen

  • Unterstützung von Flachem XML: Das Bearbeiten von Dokumenten ist jetzt auch in Format Flaches XML möglich. Das erleichtert die Weiterverarbeitung mittels XSLT.
  • Schnellzugriff auf Lizenzinformation: Die Lizenzinformation ist jetzt über das Menü Hilfe ▸ Informationen zur Lizenz... direkt einsehbar.
  • Online Wiki-Hilfe: Die Hilfe ist jetzt auch online über ein Wiki verfügbar: help.libreoffice.org/de.
  • Experimenteller Modus: Es gibt jetzt einen Experimentellen Modus, mit dem interessierte Nutzer unfertige Funktionen testen können. Hierzu muss die Option Experimentelle (instabile) Funktionen aktivieren im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Allgemein eingeschaltet werden.
  • Neue Schriftarten: Die Schriftarten Linux Libertine G und Linux Biolinum G sind jetzt im Installationspaket enthalten.
  • Neue Farben: Die LibreFarben wurden bei der Farbpalette ergänzt.
  • Verbesserter Dialog Speichern: Im Dialog Speichern unter wurde die Voreinstellung so angepasst, dass alle passenden Formate angezeigt werden.
  • Intuitiveres Verhalten: Bei sich gegenseitig ausschließenden Optionen wurde von Markierfeldern auf Optionsfelder umgestellt.
  • Speichern ohne Änderungen: Das Speichern von Dokumenten ist jetzt auch ohne erfolgte Änderungen möglich. Hierzu muss die Option Speichern unveränderter Dokumente erlauben im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Allgemein eingeschaltet werden.
  • Schnellstarter für Unix: Es gibt jetzt auch für Unix-Versionen einen Schnellstarter (nur in Distributionsversionen verfügbar).
  • Korrektur bei Kapitälchen: Der Vergrößerungsfaktor für Pseudokapitälchen wurde korrigiert.
  • Alpha-Kanal für TIF: Ein Alpha-Kanal-Import für RGBA-Tiffs wurde implementiert (tdf#30472).

Writer

  • Einfache Verwaltung von Titelseiten: Es gibt jetzt einen neuen, einfacher Dialog zum Erstellen und Verwalten von Titelseiten.
  • Importfilter für Lotus Word Pro: Ein Importfilter für Lotus Word Pro wurde hinzugefügt.
  • Verbesserer RTF-Export: Ein deutlich verbesserter RTF-Exportfilter behebt etliche kritische Fehler.
  • Verbesserte AutoKorrektur: Die AutoKorrektur-Ersetzungen halten sich an die Groß- und Kleinschreibung des ersetzten Wortes.
  • Zehlerkennung deaktivierbar: Neue Optionen zum Abschalten der Zahlenerkennung in Writer wurden hinzugefügt. Diese sind im Menü Extras ▸ Optionen... ▸ LibreOffice Writer ▸ Tabelle zu finden.
  • Standardsprache wiederherstellbar: Ein Text in Writer kann nun auf die Standardsprache zurückgesetzt werden.
  • Textrendering verbessert: Das Textrendering von Formular-Kontrollelementen ist nun in Writer möglich.

Calc

  • Bessere Standard-Tastaturkombinationen:
    • Die Tabulatortaste schließt beim AutoVervollständigen die Eingabe der momentanen Auswahl ab und bewegt den Fokus zur nächsten Zelle.
    • Umschalt+Tabulator rotiert durch die Auswahlmöglichkeiten beim AutoVervollständigen.
    • Die Tastenkombination Strg+⇧ Umschalt+D öffnet eine Auswahlliste.
    • Das neue Register Kompatibilität im Menü Extras ▸ Optionen... ▸ LibreOffice Calc hilft beim Konfigurieren der Benutzeroberfläche (tdf#30559).
  • Verbesserte Ergonomie:
    • Eine neue Schaltfläche mit Plus-Symbol zum Einfügen eines neuen Tabellenblattes wurde hinzugefügt. Sie wird im Modus Schreibgeschützt nicht angezeigt.
    • Eine neue Schaltfläche zum Ein- bzw. Ausblenden der Gitterlinien für die aktuelle Tabelle wurde hinzugefügt.
    • Es werden jetzt 3 verschiedene Formel-Syntaxen unterstätzt: Calc A1, Excel A1 und Excel Z1S1.
    • Das Suchen und Ersetzen' spart jetzt ausgefilterte (versteckte) Zellen aus, um unbeabsichtigte Änderungen zu vermeiden.
    • Beim Kopieren eines Bereichs wird dieser jetzt hervorgehoben. Der Inhalt der Zwischenablage kann nun auch durch Betätigen von Eingabe eingefügt werden. Esc hebt die Hervorhebung auf.
    • Während der Auswahl von Bereichen bleibt der Zellcursor in der Ursprungszelle stehen.
  • Mehr Zeilen: Die maximale Zeilenzahl von Tabellenblättern wurde auf 1.048.576 (2^20) angehoben.
  • Schnellerer Export: Der Import von Excel-, DBF- und ODS-Formaten erfolgt jetzt schneller.
  • Verbesserte Kompatibilität: Bessere Interoperabilität mit Excel.
  • Neue Umrandung: Es sind nun auch punktiert-gestrichelte Umrandungen in Calc möglich.
  • Englische Formeln: In lokalisierten Versionen können alternativ auch die englischen Formelbezeichnungen verwendet werden. Hierzu muss die Option Englische Funktionsnamen benutzen im Menü Extras ▸ Optionen... ▸ LibreOffice Calc ▸ Formel aktiviert werden.
  • Möglichkeiten der verteilten Ausrichtung hinzugefügt: Dies erlaubt die Angaben Verteilt und Block für die horizontale sowie die Angabe Verteilt für die vertikale Textausrichtung in Zellen. Nützlich ist dies speziell für CJK-Sprachen.
  • Wählbare Trenner: Argument- und Feldtrenner in Formelausdrücken können jetzt konfiguriert werden. Im Menü Extras ▸ Optionen... ▸ LibreOffice Calc ▸ Formel können diese festgelegt werden.
  • Externe Bezüge: Externe Bezüge funktionieren jetzt auch mit der Funktion VERSCHIEBUNG().
  • Erweiterter Tabellenschutz: Der Tabellenschutz hat zwei neue Optionen zum Positionieren des Cursors in geschützten bzw. ungeschützten Bereichen bekommen.
  • Verbesserter CSV-Import: Die Optionseinstellungen für den Import von Daten im CSV-Format (kommagetrennte Werte) wurden verbessert.
  • Automatische Anpassung: Beim Zellformat Standard wird die Nachkommastellenanzeige jetzt automatisch an die Zellgröße angepasst.
  • Farbige Register: Es sind nun auch farbige Register bei Calc-Tabellen möglich.
  • Bessere Auswahl: Die Auswahl in Calc wird nun an gefilterte Bereiche angepasst.

Datenpilot

  • Sortieren möglich: Der Datenpilot in Calc besitzt nun eine Sortiermöglichkeit.
  • Bezeichnungen: Benutzerdefinierte Bezeichnungen für Datenpilot-Felder, -Einträge und -Summen ist nun in Calc möglich.

Diagramme

  • Bessere Voreinstellung: Die Voreinstellungen bei Diagrammen wurden verbessert.
  • Zeichenobjekte einfügen: Das Einfügen von Zeichenobjekten in Diagramme ist nun möglich.
  • Hierarchische Achsenbeschriftung: Diagrammen wurde eine hierarchische Achsenbeschriftungen hinzugefügt.

Impress/Draw

  • SVG-Import: Der Import von SVG-Grafiken ist nun möglich.
  • PPTX-Diagramme: Der Import von PPTX-Diagrammen wird jetzt unterstützt.
  • Geänderte Präsentationsbildschirm-Ausgabe: Die Voreinstellung der Präsentationsbildschirm-Ausgabe unter Linux wurde auf Laptop geändert (zuvor Projektor).
  • Fehler bei Übergängen behoben: Probleme bei der Zufallswiedergabe von Übergängen der Art Auflösen wurden beseitigt.

Base

  • Neue Darstellungseigenschaften: Bei Kontrollelementen wurden Darstellungseigenschaften hinzugefügt.
  • Manueller Primärschlüssel: Die Primärschlüssel-Unterstüzung für Datenbanken ist jetzt manuell einstellbar.
  • Verbesserte Datenbank-Registrierung: Die Datenbank-Registrierung ist jetzt auch im Modus Schreibgeschützt möglich.

Math

  • Verbesserter Ausdruck: Die Voreinstellung in Math wurde geändert, sodass standardmäßig nur noch die Formel selbst gedruckt wird.
  • Korrigierte Klammerdarstellung: Die Klammerdarstellung im Präsentationsmodus wurde korrigiert.
  • Interaktive Formelbearbeitung: Die Formelbearbeitung ist nun interaktiv im Dokument möglich. Hierzu muss die Option Experimentelle (instabile) Funktionen aktivieren im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Allgemein eingeschaltet werden.
  • Abstände unterdrückbar: Neuer Befehl "nospace", um Abstände zu unterdrücken.

Produktivität

  • Verbesserunge der Dokumenteigenschaften: Die Handhabung der Benutzerspezifischen Eigenschaften wurde überarbeitet. Diese sind im Menü Datei ▸ Eigenschaften... zu finden.
  • Schriftarten eingebettet: Die Standard-PDF-Schriftarten werden nun mit eingebettet.
  • Verbesserter Dokumentschutz: Der Dokumentschutz in Writer und Calc wurde verbessert.
  • Neue Schriftfamilie: Die Schriftfamilie Narrow wurde neu hinzugefügt.

Benutzbarkeit und Oberfläche

  • Neue Suchleiste: Es gibt jetzt eine in allen Komponenten einheitliche Suchleiste.
  • Neuer Dialog Drucken: Der Dialog Drucken wurde verbessert und vereinfacht.
  • Mehr Optionen: Die Optionen bei Groß-Kleinschreibung wurde erweitert.
  • Besserer Thesaurus: Der Thesaurus wurde überarbeitet.

Entwicklung und Erweiterbarkeit

  • MetaData-Knoten: Neuer MetaData-Knoten für Datenbanken.
  • Datenbanktreiber erweiterbar: Die Funktionalität von Datenbanktreibern kann über Extensions erweitert werden.
  • Verbesserte Kommentare: Wechsel auf eine neue UNO-APIs für Größe und Verschiebeschutz (moveProtect) bei Kommentaren.
  • Gallery erweiterbar: Die UNO-API erlaubt jetzt auch das Hinzufügen von Zeichnungen zur Gallery.