The Gallery LibreOffice

From The Document Foundation Wiki
Jump to: navigation, search

Template:TopMenu/en Template:Menu/en

Other languages:

In Work!

Foreword

The video shows the application ″The Gallery LibreOffice" and links to this page here, which provides further information and details.

This description refers to the LibreOffice 7.0 version on Windows 10.

Basis of this description and the video is the FAQ-Draw in the LibreOffice-Wiki.

Link to the Video

Link to the Video (in German [DE]): The Gallery LibreOffice 7.0

What is the Gallery?

Gallery in Sidebar

Presentation

The Gallery is a library containing objects (pictures or sounds), which you can easily insert into your documents.

It is available in all modules of LibreOffice.

To open the Gallery, open the Sidebar (Ctrl+F5) and click on the tab "Gallery" 202009 LOEN Seitenleiste Symbol Gallery.png.

Themes

Objects of the Gallery are gathered by themes, such as Bullets, Forms, etc.

You can also create your own themes, as much as you need.

On the top of the Gallery, all available themes bundled with LibreOffice are listed.

Click on a theme to see its content in the main window of the Gallery.

Display

The Gallery can be displayed either as Icon View or Detailed View by clicking on buttons 202009 LODE Seitenleiste Gallery - Schaltflächen.png.

How do I use the Gallery?

Theme Context Menu

Themes bundled with LibreOffice

During the standard installation of LibreOffice you will receive a package of themes.

With a right click on a theme the context menu with the selection appears:

  • Update in relation to the previously defined source directory, the theme will be updated with the contents from the directory.
  • Delete the theme is deleted.
  • Rename the theme can be renamed.
  • Properties... opens the "Properties of <Theme>" dialog box.

Add a new theme to the Gallery

Create a new theme with your own files

  • Click New Theme... button at the top of the Gallery.
  • Enter a name for your topic in the "General" tab, e.g. "My Theme".
  • Click on the "Files" tab and there on the Find Files... button.

Dialog "Select folder" is open, Figure: Select folder for files.

Select folder for files
  • Browse to directory containing the drawing files you want to add to your theme and then click Select folder.
  • Click in the File Type combo box to limit to one file type and accept the file list update with Yes.
  • Select files you want to add:
    • click Add All to install all files contained in the list,
    • or Ctrl+Click on specific files you want to add, and then validate with Add button.
  • Click OK when you have done.
Selected file list for the new Theme
 NB:  You can always add or remove drawings subsequently, even in different directories (see below).

Add themes through extensions

On LibreOffice extensions website, you can search for extensions providing themes for the Gallery.

Simply install the chosen extension (you can check this entry for details) and restart LibreOffice.

Add an object to the Gallery

By file selection

  • Right click on theme's name in themes list ("My Theme" for instance) and select Properties in context menu.
  • Click on "Files" tab.
  • Click Add.
  • Select a directory and the desired file and click Open.

The object is added to the theme.

By drag & drop

Select an object in your document.

Click+hold the left mouse button on your object for approx. 2 seconds without moving it.

The mouse pointer is modified and you can now drag the object to the Gallery and drop it to the right of the bottom last object of the topic.

See also "How can I reuse a drawing with the help of the Gallery?"

Remove objects in the Gallery

To remove an object in a theme:

  • Select the theme where you want to remove an object.
  • Right click on the object and select  ▸ Delete.
  • Confirm you really want to delete this object by clicking Yes.
 NB:  The file which object refers to is not deleted, only the object in the Gallery is removed.

Remove a theme in the Gallery

To remove a theme from the Gallery:

  • Click on "Gallery" tab in the sidebar.
  • Right click on the theme you want to remove.
  • Select  ▸ Delete in context menu.
  • Confirm you really want to delete this theme by clicking Yes.

How can I reuse a drawing with the help of the Gallery?

The Gallery is a very convenient way to make available to all modules (Draw, Impress, Writer, and so on) some customized objects and more particularly drawings made with Draw, such as logos for instance.

Once your drawings are created, you will add them to a theme of the Gallery and they will instantaneous be available in all modules, to be inserted with a simple drag & drop.

Finalize the drawing

Once the drawing is done:

  • Select all objects belonging to the drawing, with a click and drag surrounding all these objects, or type Ctrl+A if there is no other objects on this page.
  • Group these objects with a right click on one and select  ▸ Group or select menu Shape ▸ Group ▸ Group or type ⇧ Shift+Ctrl+G.

This first step is not compulsory but it will ease handling of the drawing as a whole when it will be inserted.

Add the drawing to the Gallery

Example of user theme

Show the Gallery

  • Click on the

Tab "Gallery" in the sidebar or choose the menu View ▸ Gallery.

Choose a theme where to add the drawing

The Gallery is organized with different themes, which list is displayed at the top of the Gallery:

You can:

  • either click on theme's name where you want to insert your drawing, My theme for instance:
  • or create a new empty theme by clicking on New Theme... button; type its name and validate with OK.
 NB:  If you don't have administration rights, you must choose a theme you created and not a bundled one.

Drag the drawing in the Gallery

This is obviously the most sensitive step of the whole procedure.

To let LibreOffice knows that you do not want to move your drawing on your page, but to copy it in the Gallery, a simple drag and drop does not work.

You must proceed as follow:

  • Click once on the drawing to select it.
  • Click+hold the left mouse button on your drawing for approx. 2 seconds without moving it.
  • The mouse pointer is modified, and you can now drag the drawing to the Gallery and drop it to the right of the bottom last object of the topic.
NB:
  • If the drawing is simply moved on the page and cannot be dropped in the Gallery, it probably means that you have not wait long enough before moving the mouse.
  • If you cannot drop the drawing in the Gallery, it probably means that you are not allowed to modify this theme. Then choose one of your themes (right click should show several entries if it is a user theme).

Insert a drawing from the Gallery

In the document where you want to insert the drawing:

  • Click on "Gallery" tab in the sidebar or select menu View ▸ Gallery.
  • Select the theme where the drawing has been added.
  • Click+hold+drag the drawing and place it on your document.

To go further

If you want to share your Gallery's theme, an easy way is to create an extension which will facilitate its installation.

Please check this how-to How to create an extension - Application to the creation of a theme for the Gallery for more information.

Where are the files in the Gallery?

Locating the Gallery

Dialog to display the path of the Gallery
Dialog for editing the Gallery path
New directory of the Gallery

The location of your Gallery is specified in Tools ▸ Options ▸ LibreOffice ▸ Paths.

This path obviously depends on your operating system:

  • On Windows:
    • Before Vista: C:\DocumentsandSettings\UserName\Application\Data\libreoffice\4\user\gallery
    • Vista: C:\Users\UserName\AppData\Roaming\libreoffice\4\user\gallery
    • 7 or 8: C:\Users\UserName\AppData\Roaming\Libreoffice\4\user\gallery
    • 10: C:\Users\UserName\AppData\Roaming\Libreoffice\4\user\gallery
  • On GNU/Linux:
    • /home/UserName/.config/libreoffice/4/user/gallery
  • On MacOS:
    • /Users/UserName/Library/Application Support/libreoffice/4/user/gallery
 NB:  These directories are hidden; you must set the option from your operating system to be able to see these hidden directories.

Storage of the objects of the Gallery

All graphical objects and sounds which are present in the Gallery can be located anywhere on your hard disk, or a network system, or an external disk, or an USB key.

If you add objects to the Gallery, corresponding files won't be moved nor copied: only the location of each new object will be added as a reference.

 NB:  In case of a network workgroup, you can have access to a shared theme on a server, but you cannot modify its contents if you have no administration rights.

Define a new location for the Gallery

You may require a new location for the future themes of your Gallery?

  • Select menu Tools ▸ Options ▸ LibreOffice ▸ Paths, then "Gallery" in "Type" column.
  • Click Edit.
  • In dialog "Edit Paths: Gallery", click Add.
  • Go to a desired directory on your system and click - OK or {select folder - depending on your operating system.
  • Check the radio button corresponding to the new path.
  • Validate with OK.
  • Close the dialog Tools ▸ Options ▸ LibreOffice ▸ Paths by clicking again OK.
 NB:  A restart of all LibreOffice components is required to take into account these new parameters. (bevore: all modules closed)
 Warning:  Choose a directory where you have Read/Write access.

Further Informations

List of keyboard shortcuts in the Gallery

List of keyboard shortcuts in the Gallery

Documentation / Manuals

Documentation / Manuals

Any questions?

For questions on this topic go to Ask.LibreOffice