Creating a table in Writer

From The Document Foundation Wiki
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English

Foreword

The video "Creating a table in Writer" links to this page here, which contains further information.

This description refers to the version LibreOffice 6.

Supplementary to this page enter in the online help in the left side of the search bar: Table - and select the desired one from the table topics below.

Link to the Video

Link to the Video (in German [DE]):

Eine Tabelle erstellen in Writer

Create a table in Writer

The video shows two ways to create or insert a table in Writer.

One is to use the table function directly in Writer and the other is to link to a Calc table.

Simple table in Writer

"Table" toolbar

Open Writer.

Press Enter once.

You will now insert a table.

In the menu you select Table ▸ Insert Table….

In the "Insert table" dialog enter = '6 for "Columns".

For "Rows" enter = 25.

Click Insert.

The table has now been inserted.

With right mouse click in the table, you select "Table Properties…".

Click on the tab "Columns".

Adjust the column widths as follows:

Column 1 = 6,00 cm | Column 2 = 2,60 cm | Column 3 = 1,20 cm | Column 4 = 1,20 cm | Column 5 = 3,00 cm | Column 6 = 3,00 cm

Click OK.

As soon as the cursor is positioned in the table or the table is selected, the "Table" toolbar is automatically activated.

Mark the table with the "Table" symbol 201803 LO HB Symbol Tabelle.png and select Font = Dosis and font size = 10.

Now enter in the top line on the left: "Delivery note".

In the fifth column the word "Date:"

And in the sixth column, the actual date.

Select the line and choose font size = 15.

In the third line on the left start with the headlines.

"Article" | "Order no." | "Size" | "Quantity" | "Value of goods EURO" | "Final price EURO"

Mark line 3 and select "Align centered".

Starting in line 4, mark columns 2, 3 and 4 and select "Align centered".

From row 4 also mark columns 5 and 6 and select "Align right".

Immediately afterwards click on the "Number format" symbol 201803 LO HB Symbol Zahlenformat.png.

In the dialog "Format number" that opens, select the "Decimal number" entry under "Category" and under "Options" we select "'2" Decimal places.

Click OK.

The formatting in the cells of the tables, can be done as you wish.

Get creative with your own tables.

The table has now been further formatted and then saved.

The name used for saving was "Lieferschein.odt".

We will now continue working with this document.

If you move the mouse pointer over the last cell at the bottom right, we see that a sum 201803 LO HB ist sum.png is entered there.

Save the document under the name: "Delivery note - filled in.odt".

Now enter some items with articles.

Format the order numbers.

For the final price per article enter a Formula.

Format the final price.

In the last position "Men's trousers", enter "2" for quantity and click in the cell for "Final price".

You can now look at the sum of all items.

Click Save.

 Note 
 How calculations are performed in Writer tables, you can read in the help of LibreOffice.
 Enter "Calculations" as search term and then double-click "Calculations in text documents".
 For more information, see the documentation of LibreOffice Writer ("Writer manual").

Simple table in Writer - Layout

Table Properties

You can design the table for your purposes.

Right-click on the table and select "Table properties..." from the context menu.

In the "Table properties" dialog there are the tabs

In the "Table properties" dialog you can make your desired settings.

"Table Properties | Spacing" dialog

Table properties | Table

Set the distance of the table from the page margin

Tables extend from edge to edge by default (from left to right).

To indent the table from the margin, go to the Table ▸ Properties… menu, click the "Table" tab in the dialog there, and for "Alignment", click "Manual".

This activates the input fields for the lateral distances to the edge.

You can now set the values for the lateral distances to the page margin.

Table Properties | Text flow

Tables longer than one page

"Table Properties | Text Flow" dialog

If you have tables that are larger than one page, then be sure to look at the properties of the table, allow to split across page boundaries.

If it doesn't, the table will be "moved" to the next page. And if it doesn't quite fit on the page, it will be split as a last resort (to avoid being moved endlessly).

Table Properties | Borders

Tables with Padding

If you find the text in the table too close to the cell borders, increase the Padding.

You can set the Padding in the "Table Properties | Borders" dialog.

Insert/remove paragraphs above and below tables

Header and Textarea
Footer

1 , 3 and 5

With the ↵ Enter key you can move the table down by one paragraph marker.

Place the cursor in the paragraph marker above the table and press Delete to drag the table into the paragraph marker.

2, 4 and 6

Press Alt + ↵ Enter to create a paragraph mark below the table.

4

There will always be a paragraph marker below the table.

2 and 6

With Ctrl + ⇧ Shift + Delete you remove the paragraph mark below the table.

See also: https://ask.libreoffice.org/t/alt-enter-alternative/85079 (in German [DE]).

Simple table in Writer - Calculating Complex Formulae

Calculating Complex Formulae in Text Documents

Calculating Complex Formulae in Text Documents

Calc table in Writer

Open Writer.

Now we insert an existing Calc table.

In the menu choose Insert ▸ Object ▸ OLE-Object….

In the dialog "Insert OLE-Object" select "LibreOffice 6.0 Workbook" and "Create from file".

In the next selection click on Search….

In the "Open" dialog select the "ODS.ods table" file and click Open.

You still set a check mark at "Link to file".

Click OK.

Now the Calc table has been inserted into the Writer document as an object.

A double click on the Calc table object opens the Calc edit view.

The table can now be edited exactly as in Calc.

Finally you should save the document.

We assign the name, "Delivery note with Calc table".

Click Save.

Further Informations

Work files

Work files for the Writer table

Delivery Note.odt

Delivery note - completed.odt

Work files for the Calc table in Writer

Delivery note with Calc table.odt

Table ODS.ods

Documentation / Manuals

Here you will find the Documentation / Manuals:

Documentation / Manuals

Any questions?

For questions on this topic go to:

Ask.LibreOffice

Get Involved

Join us today and help us to make it even better!

Get Involved

LibreOffice is Free Software and is made available free of charge.

Your donation, which is purely optional, supports our worldwide community.

If you like the software, please consider a Donation.