Rahmen in Writer

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page Videos/Frame in Writer and the translation is 100% complete.
Other languages:
Deutsch • ‎English

Vorwort

Das Video zeigt, wie ″Rahmen in Writer″ unter LibreOffice erstellt und bearbeitet werden können, und verlinkt zu dieser Seite hier, die weitergehende Informationen und Details bietet.

Diese Beschreibung bezieht sich auf die Version LibreOffice 7.4 unter Windows 10/11.

Grundlage dieser Beschreibung ist die Online-Hilfe: Einfügen, Bearbeiten und Verketten von Rahmen

Link zum Video

Link zum Video:

Rahmen in Writer - LibreOffice 7.4

Einfügen, Bearbeiten und Verketten von Rahmen

Die Rahmen (im Englischen: Frames) sind eigenständige Ojekte.

Ein Rahmen ist ein "Behälter" für Text und Grafiken, den Sie auf der Seite beliebig positionieren können.

So fügen Sie einen Rahmen ein

Menü Einfügen>Rahmen>Rahmen

Markieren Sie den in den Rahmen aufzunehmenden Text.

Wählen Sie Einfügen ▸ Rahmen ▸ Rahmen… und klicken Sie auf OK.

Oder wählen Sie im Menü Einfügen ▸ Rahmen ▸ Rahmen…, um eine leeren Rahmen zu erzeugen.

Wenn Sie Rahmen häufiger benötigen, können Sie auch z.B. die Symbolleiste "Standard" anpassen, indem Sie das Symbol "Rahmen" dort integrieren.

Die Symbolleiste passen Sie an im Menü Extras ▸ Anpassen… oder Rechts-klicken Sie auf die Symbolleiste "Standard" und wählen Symbolleiste anpassen….

Es erscheint der Dialog "Anpassen".

Geben Sie bei "Suchen" Rahmen ein.

Sie sehen nun die verfügbaren Befehle für Rahmen.

Den Befehl "Rahmen" können Sie mittels des Pfeils in der Mitte zu den "Zugewiesene Befehle" zuordnen.

 Hinweis 
 Eingefügte Rahmen sind mit der Formatvorlage/Rahmenvorlage "Rahmen" verbunden.

So bearbeiten Sie einen Rahmen

Seitenleiste Formatvorlagen/Rahmenvorlagen

Inhalt bearbeiten

Um den Inhalt eines Rahmens zu bearbeiten, klicken Sie in den nicht markierten Rahmen und nehmen die gewünschten Änderungen vor.

Der Text im Rahmen wird behandelt wie normaler Text auf einer Seite.

Der beste Weg ist also den Text mit Formatvorlagen (Absatz- und Zeichenvorlagen) zu formatieren.

Rahmenvorlage bearbeiten

Rahmenvorlagen finden Sie in der Seitenleiste bei Formatvorlagen.

Mit Rahmenvorlagen können Sie Text- und Grafikrahmen formatieren.

Rahmen haben beim Einfügen die Rahmenvorlage "Rahmen" zugeordnet.

Die in der Rahmenvorlage "Rahmen" enthaltenen Einträge sind die Grundlage für neu einzufügende Rahmen.

Wenn Sie häufiger einen bestimmten Rahmen benötigen sollten Sie alle erforderlichen Einstellungen in der Rahmenvorlage "Rahmen" vornehmen.

Rechts-klicken auf die Rahmenvorlage "Rahmen" und wählen Sie "Ändern…".

Wählen Sie dann die folgenden Tabs im Dialog "Rahmenvorlage: Rahmen", um Ihre Einstellungen vorzunehmen:

Tab - Typ

Hier machen Sie Vorgaben für Größe, Position und Verankerung.

  • Größe: Breite und Höhe
  • Position: Horizontal und Vertikal
  • Verankerung: An der Seite, Am Absatz, Am Zeichen und Als Zeichen
Tab - Optionen

Hier können Sie Einstellungen für Schützen, Eigenschaften und Inhaltsausrichtung vornehmen.

Tab - Umlauf

Hier machen Sie Einträge für Einstellungen (Umlauf), Abstand und Optionen.

Tab - Fläche

Sie können auswählen zwischen Ohne, Farbe, Farbverlauf, Bild, Muster und Schraffur.

Tab - Transparenz

Vorgane für den Bereich des Transparenzmodus.

Tab - Umrandung

Hier haben Sie die Möglichkeiten für Linienanordnung, Linie, Innenabstand und Schatten.

Tab - Spalten

Einstellungen für Spaltenzahl, Breite und Abstand und Trennlinie.

Tab - Macro

Hier können Sie ein Macro zuordnen.

Dokument als Dokumentvorlage speichern mit geänderter Rahmenvorlage "Rahmen"

Wenn Sie im leeren Dokument die Rahmenvorlage "Rahmen" für Ihre Zwecke geändert haben, sollten Sie das Dokument als Dokumentvorlage speichern.

Eingefügte Rahmen ändern

Wenn Sie am eingefügten Rahmen noch Änderungen vornehmen möchten, Rechts-klicken Sie auf den Rahmen und wählen im Kontextmenü Eigenschaften….

Die Rahmenvorlage bleibt von diesen Einstellungen unbeeinflusst.

Der bessere Weg ist jedoch, eine oder mehrere Rahmenvorlagen für eigene Zwecke zu erstellen.

Ändern Sie in den zusätzlichen Rahmenvorlagen jeweils die Einstellungen, die Sie benötigen.

Ein eingefügter Rahmen wird jedoch immer zunächst mit der Rahmenvorlage "Rahmen" verbunden sein.

Wenn Sie einen Rahmen eingefügt haben und möchten eine andere Rahmenvorlage zuorden, so markieren Sie diesen Rahmen und Doppel-klicken Sie auf die gewünschte Rahmenvorlage.

Das Verhältnis Rahmenvorlage zu Eigenschaften Rahmen

Ein Rahmen der neu eingefügt wird, hat grundsätzlich die Formatvorlage "Rahmen" und übernimmt die dort festgelegten Eigenschaften.

Es gibt nun zwei Möglichkeiten, einen eingefügten Rahmen zu ändern:

  1. Sie erstellen eigene Rahmenvorlagen und ordnen diese den gewünschten Rahmen zu.
  2. Rechts-klicken Sie auf den Rahmen und wählen im Kontextmenü Eigenschaften und ändern Sie sie. Dadurch hat der Rahmen nun quasi seine eigenen innere Rahmenvorlage. Diese Eigenschaften bleiben aber nur solange erhalten, bis dem Rahmen eine vorhandene Rahmenvorlage zugeordnet wird.

Den Rahmen beschriften

In Textdokumenten können Sie Rahmen mit fortlaufend nummerierten Beschriftungen versehen.

Sie können den Beschriftungstext sowie die Zahlenkreise je Kategorie für die verschiedenen Beschriftungen festlegen und bearbeiten.

Für die Kategorie können Sie zum Beispiel "Textrahmen" eingeben

Für Rahmen mit Bildern könnten Sie z.B. "Grafik" eingeben

 Hinweis 
 Beim Einfügen einer Beschriftung für Rahmen wird der Beschriftungstext an den unteren Rand des Rahmen gesetzt.
 Um den ausgewählten Rahmen zusammen mit der Beschriftung zu verschieben, wählen Sie den Rahmen aus und ziehen Sie ihn an die gewünschte Position.
 Um die Beschriftungsnummer nach dem Verschieben zu aktualisieren, drücken Sie F9.

Um eine Beschriftung zu erstellen, gehen Sie wie folgt vor:

Rechts-klicken Sie auf den mit einer Beschriftung zu versehende Rahmen.

Wählen Sie im Kontextmenü Beschriftung einfügen….

Wählen Sie die gewünschten Optionen und klicken Sie dann auf OK.

 Hinweis 
 Den Beschriftungstext können Sie auch noch direkt im Dokument bearbeiten.

Beschriftungen werden mit der Absatzvorlage formatiert, die dem Namen ihrer Kategorie entspricht.

Wenn Sie beispielsweise eine Beschriftung für eine "Tabelle" einfügen, wird für den dazugehörigen Beschriftungstext die Absatzvorlage "Tabelle" verwendet.

 Hinweis 
 LibreOffice kann auch automatisch eine Beschriftung hinzufügen, wenn Sie z.B. einen Rahmen einfügen.
 Wählen Sie Extras ▸ Optionen… ▸ LibreOffice Writer ▸ Automatische Beschriftung.

Rahmen verankern und positionieren

Ein Objekt, beispielsweise ein Rahmen oder ein Bild, wird innerhalb eines Dokuments mithilfe von Ankern positioniert, die an anderen Elementen (Seite, Absatz, Zeichen) angebracht sind.

Ein Rahmen hat immer einen Anker und damit einen Bezugspunkt.

Der Bezugspunkt (Anker) des Rahmens könnte die Seite, ein Absatz oder sogar ein Zeichen sein.

Ein Anker bewegt sich mit dem Element, an das er angehängt ist, während das Dokument bearbeitet wird.

Ein Objekt behält seine Position relativ zu dem durch seinen Anker bestimmten Referenzpunkt bei, sodass sich das Objekt immer dann relativ zu ihm bewegt, wenn sich der Bezugspunkt bewegt oder ändert.

Die folgenden Verankerungen stehen zur Verfügung:

Siehe auch Verankerung von Objekten.

Am Absatz

Verankert den ausgewählten Rahmen im aktuellen Absatz.

Als Zeichen

Verankert den ausgewählten Rahmen als Zeichen im aktuellen Text.

Wenn die Höhe des ausgewählten Objekts größer als die aktuelle Schriftgröße ist, wird die Höhe der Zeile, die das Objekt enthält, erhöht.

Zum Zentrieren einer Grafik auf einer HTML-Seite fügen Sie die Grafik ein, verankern sie "Als Zeichen" und zentrieren dann den Absatz.

Am Zeichen

Verankert den ausgewählten Rahmen an einem Zeichen im Absatz, an das der Anker angehängt ist.

An der Seite

Verankert das ausgewählte Objekt an der aktuellen Seite.

Markieren Sie den Rahmen.

Wählen Sie im Menü Format ▸ Rahmen und Objekt ▸ Eigenschaften….

Im Dialog "Rahmen" im Tab "Position und Größe" können Sie den Rahmen z.B. an der Seite verankern.

So schließen Sie Text vom Drucken aus

Jeder Writer-Rahmen kann so eingestellt werden, dass er zwar auf dem Bildschirm, nicht aber im Ausdruck sichtbar ist.

Wählen Sie den Rahmen aus (die acht Auswahlgriffe werden sichtbar).

Wählen Sie Format ▸ Rahmen und Objekt ▸ Eigenschaften… den Tab Optionen.

Deaktivieren Sie im Bereich Eigenschaften das Markierfeld Drucken, und klicken Sie auf OK.

So verketten Sie Rahmen

73DE Writer Symbolleiste Rahmen.png

Sie können Writer-Rahmen so miteinander verketten, dass ihr Text-Inhalt automatisch von einem Rahmen in den nächsten fließt.

Klicken Sie auf die Kante des zu verkettenden Rahmens, um ihn zu markieren.

An den Kanten des Rahmens erscheinen acht Auswahlgriffe.

In der Symbolleiste "Rahmen" klicken Sie auf das Symbol "Verketten". Sc chainframes.png

Der Cursor besteht nun aus drei verbundenen Kreisen, die symbolisch eine Kette darstellen. Cursor verkettet 03.png

Klicken Sie auf den Rahmen, der mit dem ersten Rahmen verknüpft werden soll.

Die Verkettung von Rahmen ist nur unter folgenden Voraussetzungen möglich:

  • Der Zielrahmen ist leer.
  • Der Zielrahmen ist nicht mit einem anderen Rahmen verkettet.
  • Quell- und Zielrahmen befinden sich in demselben Bereich. Es ist beispielsweise nicht möglich, einen Kopfzeilenrahmen mit einem Fußzeilenrahmen zu verketten.
  • Der Quellrahmen ist noch nicht mit einem Folgerahmen verkettet.
  • Quell- und Zielrahmen sind nicht ineinander verschachtelt.
  • Die Rahmen haben keine Beschriftung.

Wenn Sie einen verketteten Rahmen auswählen, erscheint eine Verbindungslinie zwischen den verketteten Rahmen.

Verkettung von Rahmen lösen

So heben Sie die Verkettung zweier Rahmen auf.

Es kann jeweils nur die Verknüpfung vom ausgewählten zum Zielrahmen aufgehoben werden.

Klicken Sie in der Symbolleiste "Rahmen" auf das Symbol "Verkettung lösen". Sc unchainframes.png

Beispiele Rahmen

73DE Writer Beispiele Rahmen.png

Weitere Informationen

Dateien zum Thema

Zum Video.odt

Beispiele Textrahmen Grafikrahmen.odt

Dokumentation / Handbücher

Hier finden Sie die Dokumentation / Handbücher:

Dokumentation / Handbücher

Noch Fragen?

Für Fragen zum Thema gehen Sie zu:

Ask.LibreOffice

Mitarbeit bei LibreOffice

Besuchen Sie uns auch auf der Seite

Dabei sein!

Spenden

LibreOffice ist freie Software und wird kostenfrei zur Verfügung gestellt.

Ihre Spende, die rein freiwillig ist, unterstützt unsere weltweite Gemeinschaft.

Wenn Ihnen die Software gefällt, freuen wir uns über eine Spende.