ドキュメンテーション/LibreOfficeユーザーガイドの作成

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page Documentation/DocumentationTeamInfo/ProducingLibreOfficeUserGuides and the translation is 38% complete.
Other languages:
English • ‎日本語
ドキュメンテーション寄稿者ガイド
第2章 LibreOfficeユーザーガイドの作成
前へ: 第1章 上へ: はじめに 次へ: 第3章

はじめに

このドキュメントは、LibreOfficeを使って作成されたユーザーガイドを、.ODT、.PDF、および、ePub、wiki、HTMLなどの他の形式で配布するために作成されました。

Writer(ワープロ)の利用にある程度慣れていることを前提にしています。

Im-jabber.svg

Note:
英語版ユーザーガイドを作成する場合は、英語(英国)版やその他の英語版ではなく、英語(米国)版LibreOfficeをダウンロードしてご利用ください。これはガイド内での一貫性を高めるためです。

ユーザーガイドの作業のためのLibreOffice設定方法

ユーザーガイドを作成するときには、LibreOfficeのオプション設定を変更する必要があるかもしれません。また、ファイルをダウンロードしてインストールする必要もあります。

全般オプションの変更

  • もし、ダイアログ、ツールバー、メニューのスクリーンショットを撮る場合は、可能な限りLibreOfficeをクリーンインストールした状態で既定のオプションを使用し、ユーザーインターフェイスのカスタマイズは避けてください。
  • ロケールは、ツール ▸ オプション ▸ 言語設定 ▸ 言語 ▸ ユーザーインターフェースで設定したen-US(英語(米国))を使ってください。これにより、米国英語のスペルチェックと文法チェックが有効になります。インストールのとき、これらのツールが利用可能かどうかを確認してください。
  • オプション全般のツール ▸ オプション ▸ LibreOffice ▸ 全般 ▸ LibreOfficeダイアログを使用するの設定は、ユーザーガイドを確認したり、一部の画面をキャプチャしたりする際に一貫性を持たせるために重要です。デフォルトの[開く]ダイアログと[保存]ダイアログのレイアウトや外観はオペレーティングシステムによって異なりますが、LibreOfficeのダイアログはオペレーティングシステムに関係なく同じなので、ガイドではキャプチャ画像ではLibreOfficeダイアログを使用しています。

表示オプションの変更

The setting for one View option (Icon size and style) is important for consistency when capturing screens to illustrate our documents.

Go to Tools ▸ Options ▸ LibreOffice ▸ View and make sure the choices are

  • Set Icon style in the User Interface section near the top to Colibre (SVG). Use of SVG (scalable vector graphics) provides perfect rendering when icons are resized.
  • Set Icon size to Small for the Toolbar, Notebookbar, and Sidebar.

If you are using Ubuntu or another Linux distribution and the icon style drop-down list does not show Colibre as one of the choices, go into the distribution’s package manager and install the libreoffice-style-colibre package.

If necessary, you can download the Colibre SVG icon set from Media:Colibre_svg_icons.zip

上級者向け設定の変更(必要に応じて)

Depending on what you are writing about, you may need to enable some of the options found in Tools ▸ Options ▸ LibreOffice ▸ Advanced: Use a Java runtime environment, and Enable macro recording (may be limited). Normally you should NOT choose Enable experimental features (may be unstable), because most chapters of most books do not discuss them and having them enabled can cause some features to work different and/or some dialogs to have extra fields, which may be confusing to new users.

Liberationフォントのダウンロードとインストール(必要に応じて)

Tip.svg

Tip:
If you install LibreOffice downloaded from the official website, then Liberation fonts are also installed.


The LibreOffice user guides use Liberation fonts. If these are not present on your computer, you need to download and install them. To make this easier, we have put a file containing these fonts in the Resources section the TDF NextCloud website.

  1. Download liberation-fonts-ttf-2.00.1.tar.gz from the TDF NextCloud server.
  2. Decompress this file, which contains a folder of .ttf (TrueType Font) files.
  3. Install the font files, using the procedures appropriate to your operating system. On Windows and macOS, this can be done by double-clicking on the font name and then clicking the Install Font button on the window that opens. If you know where fonts are stored on your system, you can also copy the font files into the appropriate folder; on Linux, copying font files into the appropriate folder is the standard way to install them.

When you next open LibreOffice, the fonts will be available for your use.

章テンプレートのダウンロードとインストール

章テンプレートのダウンロード、インストール、新規の章の作成については、「 第5章 LibreOffice章テンプレートの利用」をご覧ください。

LibreOfficeユーザーガイドの命名規則

ファイル名に使用される書籍のイニシャル:

GS = Getting Started(入門ガイド)
BG = Base Guide(Baseガイド)
CG = Calc Guide(Calcガイド)
DG = Draw Guide(Drawガイド)
IG = Impress Guide(Impressガイド)
MG = Math Guide(Mathガイド)
WG = Writer Guide(Writerガイド)
LOOLG = LibreOffice Online

草稿の章の命名規則

File names take the following form: AANxBB-Name_Author_Date, where AA=book initials, N=LibreOffice Version, x=the next digit in the version, BB=chapter number, Name=chapter name, Author=initials of author/editor/reviewer, Date=date of review: please use DDMmmYYYY, NOT all numerals).

In the chapter name, each word begins with a capital letter and there are no spaces between words.

For example, the third chapter of the LO 6.4 Writer Guide, Working with Text, updated by Jean Hollis Weber on 24 April 2020, has the following file name: WG6403-WorkingWithText_JHW_24Apr2020.odt

査読済みの章の命名規則

If you are reviewing a draft chapter, add your initials and change the date to the day you return the reviewed file. For example, Dan Lewis reviews the third chapter of the LO 6.4 Writer Guide on 15 May 2020. Dan saves the reviewed file with the name WG6403-WorkingWithText_JHW_DL_15May2020.odt

公開された章の命名規則

Remove reviewers' initials and dates from the filename; otherwise the same as for draft chapters.

For example, the third chapter of the LO 6.4 Writer Guide, Working with Text, has the following file name: WG6403-WorkingWithText.odt

出版された書籍の命名規則

File names take the following form: AANx-Name.odt, where AA=book initials, N=LibreOffice Version, x=the next digit in the version, and Name=book name (may be abbreviated).

In the book name, each word begins with a capital letter and there are no spaces between words.

For example, the file name for Getting Started [with LibreOffice 6.4] is GS64-GettingStarted.odt

ステータス・スプレッドシートを使った進捗状況の確認

Each book has a status spreadsheet, discussed in Chapter 3.

When you are working on a chapter, please place your initials and the date in the Checkout column of the appropriate table on the Status spreadsheet for the book.

When you return the file to TDF NextCloud, please remove your initials and date from the Checkout column and add your initials and the date to the appropriate column (reviewed, edited).

テンプレートから新しい章を作成する

手順については「 第5章 LibreOffice章テンプレートを使う」をご覧ください。

LibreOfficeユーザーガイド用画像の作成方法

Images may be screen captures, photographs, or graphics (such as diagrams) created in Draw or another program.

This section describes how to create images that show what the reader needs to know, can be read easily on screen and when printed in grayscale.

スクリーン・キャプチャ

Members of the Documentation team use a variety of operating systems and desktop themes (color schemes), but we want the images in our user guides to look reasonably consistent. Here are some suggestions for creating consistency.

  • Preferably use a neutral (primarily grey or similar) theme with high contrast. Highlight colors can be green, blue, orange, dark gray, or brown. Green is the LibreOffice color, so that is a good choice.
  • Use the Colibre icon set (in Tools ▸ Options ▸ LibreOffice ▸ View), not Automatic (which can vary with your operating system). On the same page, set Icon size to Small.
  • Capture only the required dialog or other area, or crop the image after capturing it. If you include the mouse pointer, be sure it is pointing to a relevant item, not randomly positioned.
Tip.svg

Tip:
LibreOffice has a nice internal feature for perfect dialog screenshooting. See page Creating screenshots manually for more information.

  • Read the text carefully to ensure you set up any data that should be shown and have marked any selections (such as checkboxes or radio buttons) that are discussed. If the image is supposed to show the dialog before you make changes, be sure it does not show the results instead.
  • We rarely need to capture the full LibreOffice window, except for the introductory chapters where the parts of the window are labelled and described. When a full window is required, reduce its size as much as possible (while retaining essential information) and then capture the image.

トリミング

Some screen captures can be used without further modification. Many, however, benefit from cropping (cutting off parts of the original image). There are two reasons for cropping: to fit an image on the page and still have the relevant parts readable, and to reduce wasted space and focus the reader’s attention on a particular portion of the screen.

Some screen capture programs have a feature for choosing an area when you do the capture. You can also crop the images in a graphics package. Do not crop them in LibreOffice itself, because that cropping is not retained when the file is exported to MediaWiki, HTML, and possibly other formats (PDF does retain the cropping).

Here are some suggestions for choosing what to crop:

  • Focus the readers’ attention on the part being discussed, especially when the full dialog has already been shown and the text is referring to one particular part of it.
  • Remove blank space in dialogs that are of standard size but use only a small portion of the area for data or selections. In most cases, cutting off the bottom portion (with the standard OK, Cancel, and Next buttons) does not reduce readers’ comprehension, especially when the full dialog has already been shown.
  • Make a wide dialog (such as the Tools ▸ Options one) fit on a page by cropping off the portion that is not essential to the discussion, for example the navigation tree on the left. In some cases (such as the dialog for customizing a Table of Contents), the optional Preview section can be deselected.

注釈 (ラベリング)

Do not use Writer's drawing tools to label an image. Instead, use Draw or a graphics package to label screen captures, group and save the result as a single image so the labels are part of the image. In addition, save the original as an editable file such as .ODG and upload it to the TDF NextCloud website along with the chapter .ODT file. When exporting to image format, prefer PNG format and set for maximum quality.

To assist translators, label images without text (such as toolbars) using numbers, not words, and put explanations in the figure caption. Screen captures with text (such as dialogs) need to be recaptured by the translators anyway, so you can label them with text.

When creating labels:

  • Use a line weight and font size and weight that will be compatible with the surrounding text when the image is at its final size in the document (images may be reduced in size when in the document).
  • Use a white background for the area surrounding an image, when labels are outside the image. You can use a light color for the background of labels placed inside an image (to help them be noticeable), but choose a color that will print as pale grey in black-and-white.
  • Ensure all numbers or words in the labels are lined up neatly.
  • When labelling dialogs, it is often best to put the labels above or below the image, not to the sides, to help fit the image on the Writer page. With small images, labels beside the image may work well or better; this is a matter of judgment.

フローチャートとその他の図版

Do not use Writer's drawing tools to create flowcharts and other diagrams for use in published documents. Instead, use Draw or another program of your choice, and then export the diagram to PNG before including it in the Writer document. In addition, save the original as an editable file such as .ODG and upload it to the TDF NextCloud website along with the chapter .ODT file.

When diagrams contain text, use a line weight and font size and weight that will be compatible with the surrounding text when the image appears in the document.

If a diagram needs color to improve its usefulness, choose colors that provide good contrast when printed in black-and-white (grayscale). Consider using hatching patterns. Be sure any text has good contrast with its background when printed in grayscale.

図版を画像として書き出すには

In the LibreOffice Draw page that contains the drawing:

  1. Select all the contents to be exported. You can select with the mouse of use Ctrl+A to select all the elements in the page.
  2. Group all elements Shape ▸ Group ▸ Group or Ctrl+⇧ Shift+G.
  3. Export image with File ▸ Export, choose a name for the file and select PNG as file type. Click Save.
  4. The Export to PNG dialog opens (PNG is a raster-graphics file format that supports lossless data compression).
  5. Keep the size in pixels suggested and the resolution to 96 pixels/inch. Keep all other setting as default. Click OK.


GraphicExportDialog PNG.png

ODTファイルに画像を挿入する方法

Olivierの査読済み

To prevent images from moving around during editing (especially when you are adding or deleting text), please follow the procedure below.

Im-jabber.svg

Note:
These instructions apply mainly to screenshots and other images that are large enough to put between paragraphs of text.

  1. Have paragraph marks turned on (helps you to see what's happening, View ▸ Formatting Marks).
  2. Press ↵ Enter at the end of a paragraph to create a new blank paragraph.
  3. Change the new paragraph’s style to Figure. The paragraph marker should now be centered on the page.
  4. Choose Insert ▸ Image or use copy-and-paste to insert the image.
  5. Adjust the size of the image. Hint: Select one of the corner handles and drag to the desired size. The resizing will keep the image proportions.
  6. With the image selected, right-click and choose Caption. Select Figure as the Category (if it shows anything else in that box) and type the caption. If Figure is not one of the choices, type the word Figure in the Category box to create that category.
  7. When adding the caption, LibreOffice automatically adds a frame that contains the image and the caption paragraph. That frame needs some tweaks.
    1. Select the frame, right-click on it, and choose Anchor ▸ As Character.
    2. Select the image inside the frame, right-click on it, and choose Anchor ▸ To Paragraph.
    3. Delete any spurious line break that may appear between the image and the caption.
  8. Click anywhere outside the frame to deselect it, then click in the caption line and change the paragraph style to Caption.
Insertimage.png


Im-jabber.svg

Note:
We do not follow the practice that every figure and table must have a numbered caption and must be cross-referenced in the text. For example, when the figure immediately follows the paragraph in which it is discussed and it is obvious which figure is being discussed, and when the figure will not be cross-referenced from elsewhere in the document, a caption and cross-reference are optional. In this case, anchor the image to the Figure paragraph As Character.

文書内で相互参照する方法

Do not type in cross-references to other parts of the document, because those references can easily get out of date if you reword a heading, add or remove figures, or reorganize topics. Instead, use Writer’s automatic cross-references; when you update fields, all the references will update automatically to show the current wording or page numbers.

The Cross-references tab of the Fields dialog lists some items, such as headings, numbered paragraphs, and bookmarks. If figure captions, table captions, user-defined number range variables, and some other items have been defined in a document, they also appear in the Type list. You can leave this dialog open while you insert many cross-references.

To insert a cross-reference to a heading, figure, or other item shown on the Cross-references tab:

  1. In your document, place the cursor where you want the cross-reference to appear.
  2. If you are cross-referencing to a figure or table, type the word Figure or Table, followed by a space.
  3. Choose Insert ▸ Cross Reference. On the Cross-references tab, in the Type list, click the type of item you are referencing (for example, Heading or Figure).
  4. Click on the required item in the Selection list, which shows both automatically created entries (for example Headings) as well as user-defined references (for example bookmarks).
  5. In the Insert reference to list, choose the type of reference required. The choices vary with the item being referenced.
    • For headings, usually you will choose Reference (to insert the full text of the heading) or Page (to insert the number of the page the heading is on).
    • For figures, choose Numbering (to insert the figure number) or Page (to insert the number of the page the figure is on). We do not use Category and Number, because that causes problems for the translation software.
  6. Click Insert.

Occasionally you might want to insert a cross-reference to something that is not automatically shown on the Cross-references page. Before you can do that, you must prepare the item as a target to be referenced. We generally use bookmarks for this purpose.

  1. Select the text you want to bookmark. Click Insert ▸ Bookmark.
  2. On the Bookmark dialog, the larger box lists any previously defined bookmarks. Type a name for this bookmark in the top box. Click OK.

Now you can cross-reference to the bookmark as described above.

他のドキュメントとの相互参照をする方法

Writer provides methods for automatic cross-referencing to other documents (usually chapters in the same or different books), but we do not use them at this time. Instead, follow the instructions below.

  • When refering to a chapter in the same book, use Chapter N, Chapter Title.
  • When refering to a chapter in another book, use Chapter N, Chapter Title, in the [Component] Guide. Here the book title is in italics.

In both cases, it’s best to avoid referring to a section in the referenced chapter, because section names are more likely to change. Sometimes chapter numbers or names are changed; in that case, writers and reviewers need to manually change the references in other documents.

ユーザーガイドの章のインデックスの付け方

この話題は、独立したページにあります。

章の更新と査読について

章を更新するということは、以前、書かれたソフトウェアのバージョンから、あなたが書いているバージョンに更新することを意味します。

Reviewing a chapter means that you are checking the work of the person who updated it, to see if they missed anything.

In both cases:

  1. Download the chapter from the TDF NextCloud website. (See Chapter 3 for details.)
    • For updating, the folder is usually the Published folder for the previous edition of the book.
    • For reviewing, the folder is usually the Drafts folder for the current edition of the book.
  2. If your browser gives you a choice of opening or saving the file, choose Save File.
  3. In LibreOffice, turn on change recording (Edit ▸ Track Changes ▸ Record).
  4. To leave a comment, use Insert ▸ Comment. Additionally, use Tools ▸ Options ▸ LibreOffice ▸ User Data to get your name attached to your comments.
  5. Add your name to the Contributors section of the chapter’s copyright page.
  6. Change the file name to include your initials and the date when you return the file; see #Naming convention for reviewed chapters.
  7. When done, upload the reviewed file to the Feedback folder for the relevant book.

更新や査読で見るべきこと

Chapters must be checked carefully against the latest released version of LibreOffice (or the forthcoming version, when writing or updating in preparation for a new release). Please do not just improve the wording or grammar; that is important, but well-worded wrong instructions are worse than poorly-worded correct information.

When updating, also check the Release Notes for every release between the one the chapter was previously written for and the one you’re writing about. This can also be useful when reviewing.

  1. Make sure the correct template is applied to the chapter; sometimes we change templates between releases (for example, between LibreOffice 4.x and 5.x).
  2. Go through the instructions in the chapter. Follow the instructions exactly as they are written, so you can see if anything is different between the instructions and the software or if any essential steps are missing or unclear.
  3. Pay close attention to the screenshots. If anything is different, make a note of it. If you can capture new screenshots, then you can replace the out-of-date ones with up-to-date ones. If you cannot capture new screenshots, then leave a comment in the file that Figure x needs to be replaced. Note that some minor differences in appearance may exist between dialogs in Windows, Linux, and macOS.
  4. Ensure that the text and the illustrations (such as screenshots) agree with each other. For example, sometimes the name of an option is changed in the program (and thus in a new screenshot), but the writer fails to change the name in the text.
  5. Please also suggest other topics that should be included in the chapter, or better ways of explaining things, or any other improvements you can think of. These might include adding topics or examples (or creating stand-alone tutorials or how-tos and referring to them from the user guide), revising topics to make them more useful, or reorganizing chapters (either moving topics within a chapter or, in some cases, moving material from one chapter to another).
  6. Be aware that in some cases a topic may be covered in another chapter; in that case a cross-reference would be helpful, or in some cases duplicating some information might be the best solution.
  7. Check that the paragraph and character styles used are correct (see Chapter 5, Using the Chapter Template). Check the spelling.

章の公開方法

When you have decided that a chapter is ready for publishing, do the following:

  1. Make a final pass to check page breaks and make any necessary changes. (Use the keep-with-next attribute, not manual page breaks, and/or change the sequence of text and figures.)
  2. Verify that the first item in the first numbered list in the chapter is explicitly set to start at 1 (this is to make sure the chapter works properly when it is included in a compiled book). To do this, right-click on the first list paragraph and choose Bullets and Numbering > Restart numbering.
  3. Update the Table of Contents. Make sure there is no (alphabetic) index at the end of the chapter.
  4. On the copyright page:
    • Make sure the date and the software version are correct.
    • Verify that the correct email address for feedback, and the correct URL for documentation (in the footer), are shown.
    • Make sure the list of contributors is correct, and that any empty rows are removed from the table.
  5. Save the ODT file with the correct file name, using the naming convention for published chapters (see below).
  6. Export the file to PDF, using these settings:
    • On the General tab, select JPEG compression and Export bookmarks.
    • On the Initial View tab, select Page only, Default magnification, and Default page layout.
    • On the User Interface tab, select Display document title (under Window Options) and All bookmark levels. Leave all the other options unselected.
    • On the Links tab, select Default mode under Cross-document Links and leave other options unselected.
    • n the Security tab, make sure that NO passwords are set.
  7. Upload the ODT file to the Published folder for the relevant book on TDF NextCloud. (See details in Chapter 3, Using the Documentation Team Website.)
  8. Tell the Documentation list that you have published the chapter.

書籍のコンパイル方法

The user guides consist of a set of individual chapter files, plus a book file that contains the cover page, copyright page, table of contents page, title page for the preface, and index page. It also has front and back cover images. These components are all in the Published folder for the book.

We are not using master documents to compile books.

To compile a full book, do this:

  1. Download the ODT files for the book and all of its chapters from the Published folder for the book.
  2. Open the book file and go to the title page for the preface.
  3. Open the file for the book’s preface and copy the contents from the first Heading 1 (usually “Who is this book for?”) to the end of the file. Paste this into the book file at the end of the title page for the preface.
  4. Check that the page style changes from First Page (on the title page for the preface) to Default for the other pages of the preface. Fix if necessary.
  5. Close the preface file and open the file for chapter 1.
  6. In the book file, go to the end of the preface and copy-paste the title page from chapter 1, then copy-paste the contents of chapter 1 from the first Heading 1 (usually the Introduction) to the end of the file.
  7. Repeat steps 4–6 for each of the other chapters in the book, inserting each at the end of the previous chapter.
  8. Regenerate the table of contents and index by right-clicking on each of them and choosing Update index from the pop-up menu.
  9. On the copyright page:
    • Change the publication date to the current date.
    • Check that the Contributors section includes all the contributors’ names from all the chapters in the book.
    • Check that the LibreOffice version information is correct.
  10. Check that the information in File ▸ Properties is correct, especially on the Description page.
  11. Check that the footers show the correct information: book title on left-hand (even) pages and chapter title on right-hand (odd) pages. Fix if necessary.
  12. Check that the first item in the first numbered list in each chapter is numbered 1 as it should be. Fix if necessary: right-click on the first list paragraph and choose Bullets and Numbering > Restart numbering.
  13. Review the compiled index. If any entries need to be changed, make the changes in the chapters, not in the index itself. See also “Compiling and editing the index for a book” and “Tips for indexing chapters” in Indexing LibreOffice User Guides.
  14. At the end of the file, place the cursor in the blank page at the end and insert the back cover image. Anchor the image To Page, stretch the image to fill the entire page, and change its Wrap to Wrap Through.
  15. Select File ▸ Export as PDF. Choose the following settings:
    • On the General tab, select JPEG compression and Export bookmarks.
    • On the Initial View tab, select Page only, Default magnification, and Default page layout.
    • On the User Interface tab, select Display document title (under Window Options) and All bookmark levels. Leave all the other options unselected.
    • On the Links tab, select Default mode under Cross-document Links and leave other options unselected.
    • On the Security tab, make sure that no passwords are set.
  16. Name the PDF according to the instructions in #Naming convention for published books.

書籍の公開方法

  1. Log in to TDF NextCloud and upload the ODT and PDF files to the Published folder for the book.
  2. If any chapter files were modified during book production, upload the changed ODT files to the Published folder for the book, replacing the previous versions.
  3. Log in to the LibreOffice wiki and add the ODT and PDF files for the book and its chapters to the Publications page.
  4. Tell the Documentation list that you have published the book.