DECALER

From The Document Foundation Wiki
Jump to: navigation, search


Renvoie une référence modifiée, une référence, un décalage et une taille souhaitée étant donnés.

Syntaxe

DECALER(référence; ligne_décalage; colonne_décalage; nouvelle_hauteur; nouvelle_largeur)

référence est la référence données, qui peut être une plage.
ligne_décalage et colonne_décalage sont les nombres de lignes / colonne pour déplacer référence par le bas / la droite. Les nombres négatifs sont autorisés.
nouvelle_hauteur et nouvelle_largeur paramètrent la hauteur et la largeur de la nouvelle référence en ajustant l'angle bas à droite. Ces paramètres sont facultatifs.

Exemple

=DECALER(A1; 1; 2)

dans une cellule, renvoie le contenu de la cellule C2. Les paramètres nouvelle_hauteur et nouvelle_largeur ont été omis.

=DECALER(B3; -2; 0; 1; 1)

dans une cellule, renvoie le contenu de la cellule B1. Un décalage négatif est permis.

=SOMME(DECALER(A1; 2; 2; 2; 3))

dans une cellule, renvoie la somme du contenu des cellules C3:E4. 2 lignes et 2 colonnes sont ajoutées à A1 pour la décaler en C3, et ensuite, la nouvelle taille étant la plage à E4.

=SOMME(DECALER(C1:G1; 0; 0; 1; 3))

dans une cellule, renvoie la somme du contenu des cellules C1:E1.

Issues

DECALER(A1;{0|1};0;1;1) dans une formule de matrice renvoie un résultat inattendu, voir i#86658.

Voir également

CHOISIR, RECHERCHEH, INDEX, RECHERCHE, EQUIV, RECHERCHEV

LIGNE, LIGNES COLONNE COLONNES

SOMME

Fonctions classeur

Fonctions listées alphabétiquement, Fonctions listées par catégories

Heckert GNU white.svg

Content on this page is licensed under the Public Documentation License (PDL).