Faq/Calc/113/fr

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 113
Jump to: navigation, search

Comment importer des tableaux de données automatiquement actualisés d'un site Internet ?

  • Créer un nouveau document LibreOffice Calc.
  • Se positionner sur une cellule du tableau (A1 par exemple)
  • Sélectionner dans le menu : Insertion > Lien vers des données externes.
  • La boite de dialogue Données externes s'ouvre :

Donnees-externes.jpg

  • Si la page internet qui vous intéresse a été sauvegardée en local :
    • Cliquer sur le bouton "..." à droite de la zone de saisie de l'URL source.
    • Sélectionner Type de fichier = Requête pages Web (LibreOffice Calc) (*.html) (dans le bas de la liste).
    • Choisir alors dans la liste l'URL de la page source.
    • Cliquer sur le bouton Ouvrir.
  • Dans le cas contraire :
    • Écrire dans la zone URL de la source de données externes, l'adresse de la page internet souhaitée comportant le tableau à récupérer, par exemple : http://www.boursorama.com/cours.phtml?symbole=1rPCAC. Il est aussi possible de copier celle-ci à partir de la barre d'adresse du navigateur, puis, dans la zone URL de la boite de dialogue Données externes, de coller cette adresse (avec Ctrl+V par exemple).
    • Appuyer sur la touche Entrée pour valider cette adresse.
  • Au bout de quelques secondes (cela peut parfois être un peu long…) apparaît une nouvelle fenêtre :

Options-import.jpg

  • Cocher la case Détecter les nombres spéciaux.
  • Cliquer sur le bouton OK.
  • La boite de dialogue concernant les options d'import disparaît. La boite de dialogue "données externes" réapparaît au premier plan. La zone Feuilles/plages disponibles s'enrichit alors d'une liste du type (dans l'exemple ci-dessus) :
HTML_1
HTML_all
HTML_tables
HTML_base
  • Sélectionner en cliquant sur la ligne HTML_tables (ou une autre ligne si les données ne correspondent pas au tableau souhaité).
  • Pour que les données récupérées soient actualisées périodiquement, cocher la case Actualiser toutes les en bas de la boite de dialogue Données externes et indiquer la périodicité souhaitée.
  • Valider par OK.

Les données du serveur internet sont alors recopiées dans votre feuille à partir de la cellule sélectionnée initialement et sont utilisables. Attention, à chaque actualisation, les informations précédentes sont écrasées. Il ne faut donc pas y insérer de formules par exemple. On utilisera les éléments de cette zone sur une autre feuille par exemple avec une formule du style =Feuille1.A3.

Remarques

  • L'actualisation des données :
Si la case Actualisation des données n'a pas été cochée, l'actualisation sera manuelle, c'est à dire qu'elle sera proposée lors de l'ouverture de votre tableau (si, dans Outils > Options > LibreOffice Calc > Général, le choix Actualiser les liens au chargement > Sur demande est coché), ou à partir de Édition > Liens > Actualiser (éventuellement en choisissant le lien à actualiser s'il y a plusieurs liens dans la liste des liens).
Le choix du mode d'actualisation peut être modifié à tout moment en utilisant Édition > Liens > Modifier (toujours en ayant choisi le lien à modifier s'il y en a plusieurs).
  • Le format des données importées du serveur internet :
Si les données importées ressemblent à des nombres, mais sont en fait du texte (par exemple, impossible de rajouter une décimale en cliquant dans le menu « format numérique : ajouter une décimale »), il faut dans ce cas vérifier dans Outils > Options > Chargement/enregistrement > Compatibilité HTML, que la case Utiliser l'environnement Anglais (USA) pour les nombres n'est pas cochée si les données sur le site internet sont en format français (exemple 123 245,90).
Bien entendu, si le format des nombres sur le site est du type 123,453.90, il faut dans ce cas là avoir coché la case Utiliser l'environnement Anglais (USA) pour les nombres les chiffres sont alors importés au bon format, soit 123 453,90 !