Hidden Gems In Draw

From The Document Foundation Wiki
Jump to: navigation, search


Foreword

This series of video shows hidden functions in Draw and how these are applied under version 5.2. The working document for the video series can be downloaded here.

This video series is based on 'the presentation of 'Hidden Gems In Draw/Impress' by ARMIN LE GRAND' . The videos "Draw - Hidden Features" link to this page, which contains further information and details.

Links to Videos "Draw - Hidden Features"

Playlist

Video 1

Colors and Palette

Palette at the bottom
Palette floating

Open LibreOffice Draw, then open the color bar from the main menu View ▸ Toolbar ▸ Color Bar. The color bar will be displayed in a rectangle at the bottom of the document window.
The rectangle has an overlapping line with an arrow-down symbol. This can be used to hide or show the color bar.
If you move the mouse pointer over this line, a double arrow appears. This line can be moved upwards (become larger) or downwards by dragging with left mouse button.

Floating the Color Bar

If you work with colors frequently, you can grab the gray panel with the left mouse button and pull it upwards so that the color bar, now called "color palette", floats. The color palette can be enlarged by dragging the bottom edge. You can place the color palette at the top, next to the document. This allows fast color selection.
To re-dock the color palette, hold the Ctrl and double-click the gray area of the color palette window. The Color Palette window will be docked back to the document window.

Video 2

Slide 1, Red Oval selected

Colors on Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg". Now let's color the objects.

In slide 1, select the object "red oval".
When you click on a color in the color palette with the left mouse button, the object takes on the selected color.
When you right-click on a color in the color palette, the border (outline) of the object takes on the selected color.
Alternatively, the fill color and the border color can be selected by using "drag and drop", i.e. dragging the color from the color palette, and placing it on the object or on the border.
The fill color and the line color can also be selected transparently.

Video 3

Slide 2
Slide 3
Slide 6

Select and Deselect Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg". Now let's select the objects.
There are several ways to select items. Click on the slide 2 on the left. The left mouse button is used to select a slide or a single object.
You can select multiple objects by holding the left mouse button. Use Ctrl + A to select all objects.
Click the slide 3 on the left, and select one of the objects. The next object is selected with the Tab ↹ key. The previous object is selected with the ⇧ Shift and Tab ↹ keys.
Click the slide 6 on the left. With Alt and left mouse click, we can select several arbitrary objects as a group.
With ⇧ Shift and left mouse click, we can select and deselect individual objects.

Arrow buttons

Use the arrow keys to move objects.
The arrow keys move the object by one tenth of a grid square (depending on your configuration settings).
Using the arrow keys in combination with the ⇧ Shift moves an object by one grid square (depending on your settings).
We can also use the arrow keys to increase or decrease the size of an object. Press Ctrl + Tab ↹ twice. The upper middle blue dot will flash.
Now you can use the up-arrow key to increase the oval size and down-arrow to decrease it.
Press Ctrl + Tab ↹ again, and another blue dot will flash.

Video 4

Toolbar "Standard"
Slide 9





Arranging Objects

Arrangement refers to the location within the layer system, i.e., which object is located over which. Now let's try to change the arrangement of objects. Click on slide 9.
In the Standard toolbar, find the "Arrange" button. Open the menu by clicking the triangle beside the button. In the menu, the icons in sequence are: "Bring to front", "Bring forward", "Send backward", "Send to back", "In front of object" and "Behind object".

Click on an object, e.g. the circle. Then open the "Arrange" menu. Now you can change the layer for the selected object.
You can also float the menu by dragging the handle in the bottom of the menu. Now you can play with the arrangement of multiple objects.

Aligning Objects

To align objects in their position within a layer, a check mark must be set in the menu Tools | Options | Grid. Snapping of objects to snap lines can be found in the menu, Tools | Options | Grid, where the value of the snap range, e.g. 20 pixels, may be adjusted.
Click on the slide 6. In the Standard toolbar, find the "Align" button. Open the menu by clicking the triangle beside the button. Again, we can float the menu by dragging the handle in the bottom of the menu.
The functions in the Align menu in sequence are: "Left", "Centered", "Right", "Top", "Middle" and "Bottom". We can now execute the individual alignments. For a single selected object, the orientation refers to the page (slide). For several selected objects, the orientation is relative to the other objects.

Slide 6: Objects alignment

Aligning Objects to Snap Lines

You can also align to snap lines. By holding down the left mouse button on the ruler, you can pull down a snap line. Any number of lines, horizontal and vertical, can be pulled down. You can also add snap lines using the Insert Snap Point / Line... in the Insert menu. A new dialog box with the options, including position and type will be shown.
Right clicking on the snap line you can select to "Edit Snap Line ..." or "Delete Snap Line".
In the View menu there is an item Snap Lines. You can Display Snap Lines, Snap to Snap Lines, and Snap Lines to Front. If the snap lines are not visible, they will have no effect.
Now you can drag objects with the mouse, and they will snap to the nearest snap line when you drop them.
Snap lines can also be pushed back onto the ruler.

Video 5

Example: Curve
Example: Curve with help lines
Toolbar: Edit points
Example: Curve with all help lines

Edit and Convert Objects

Edit Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg".

Draw a Curve

Click on the slide 5. If the "Curve" icon 2017 HB LO Symbol Kurve.png is not visible on the "Drawing" toolbar, select "View | Toolbar | Customize ..." from the main menu. In the "Customize" dialog box, select "Drawing" from "Toolbar". For "Toolbar content" | "Commands", scroll down, and check "Curve", then click "OK". Now you can use the "Curve" button.
Click the "Curve" icon, then click with the left mouse button on the slide, and drag to create a curve. Release the mouse button, and move the mouse to one of the square handles. Drag to deform the curve. You can continue the click-hold-drag-release sequence to extend the curve. When you are finished, double-click and the curve is completed. See the example curve on the right.

Draw a Curve With Help Lines

The curve can be edited further. Select the curve by clicking on it. Then click the "Edit points" icon or the F8 key. Hold ⇧ Shift and left-click the mouse; a tangent line with two end points will appear. By manipulating the ends of the tangent, we can further deform the curve.

Add Points

You can also add points to the curve. Select from the main menu View ▸ Toolbar ▸ Edit Points. In the toolbar "Edit Points", click on "Insert Point" 2017 HB LO Symbol Punkte einfügen.png. Then click on the curve where you want the new point to be placed.

Delete Points

You can also delete points from the curve. Click on the point, then click on "Edit Points", then select "Delete points" 2017 HB LO Symbol Punkte löschen.png in the toolbar.

Split the Curve

A curve can also be split. Select the point at the desired point, or set and select a new point using "Edit Points". After that, click on the icon "Split curve" 2017 HB LO Symbol Kurve auftrennen.png in the toolbar.

Display all points with help lines

When the curve is selected, hold and drag the left mouse button to assign a rectangular range covering the entire curve. It will display all the points with their help lines.

Points - other functions

If you click on a point with the curve selected, additional functions can be selected, including "Corner Point", "Smooth Transition", and "Symmetrical Transition" 90px.

Close the curve (Bezier)

You can also close the curve. When the curve is selected, click on the "close Bezier" icon 30px to close the curve.

Further explanations on Bézier Curves

Here are some further explanations on Bézier curve (In German): Dokumentation - Bézierkurven, von Regina Henschel und
Bézierkurve (OpenOffice.org-Wiki)

Convert Objects

Slide 8
Gallery: User-folder
Slide 2 with 10 copied ellipses
Slide 7

Convert curve

You can also convert objects to other forms. Click on the curve with the right mouse button. In the menu, select Convert  ▸ To Polygon. In order to keep an overview, you can watch the status of the object during processing in the lower left corner of the status bar. Then, if you click the polygon with the right mouse button, you can select Convert  ▸ To Curve. Now you have a curve that has more points than before.

Basic Shapes Transform and Deform

Click on the slide 2. In the 'Drawing' toolbar, Select the circle for standard shapes and draw a circle. Now click on the circle with the right mouse button, and choose Convert  ▸ To curve and you can deform the circle.

Convert Text Symbols

Simple text can also be converted just like curves. Click on the slide 8. In the "Standard" toolbar, click the "Text box" 2017 HB LO Symbol Textfeld.png icon and place a text box on the slide. In the main menu Insert ▸ Special character... we can select the font, e.g. "Webdings". Write some characters in the text box and select a larger font, e.g. '150 pt' . Right-click on the frame of the text box and select Convert  ▸ To curve. Then right-click the characters and select Ungroup. Now the individual characters can be deformed, colored, and added to the gallery.

Create And modify gallery shapes

A user folder must be created in the Gallery. With "drag and drop" you can drag the converted text symbols into the Gallery. The Gallery objects can now be added arbitrarily with Add.

Video 6

Copy objects

Click on the slide 2. Draw any object, e.g. an ellipse. Hold Ctrl, drag the object with the left mouse button and drop it. A copy of the object appears. The Ctrl key can also be used to copy multiple selected objects at the same time.
Alternatively, the number of copies of a selected object can be set with ⇧ Shift and F3. Press ⇧ Shift and F3 will open the dialog "Duplicate", and you can enter the number of copies desired. Also, you can set the "Placement", the "Enlargement" and the "Colors" for "Start" and "End". For "Placement", "X-axis", enter '-0.50 cm' . For "Start" and "End", select two different colors and click OK. Now you have e.g. 10 copies. With ⇧ Shift and F3, this process can also be carried out with several objects.

Basic Forms

Objects can also be inserted quickly. Click on the slide 7. On the 'Drawing' toolbar, click the black arrow at the right of 'Basic shapes' icon. The selection of the basic shapes is displayed. With Ctrl and clicking the left mouse button on a shape, this shape with the standard attributes is inserted into the slide.


Video 7

Merging, subtracting, and cutting objects

Merging
Subtracting
Cutting

Object Merging

Click on the slide 9. In the drawing toolbar, you can use the Ellipse icon to draw a circle or an ellipse. Then use the Rectangle to draw a rectangle. We move the rectangle partially over the circle and select both circle and rectangle. Now select "Modify | Shapes | Merge" from the main menu. The circle and rectangle have now merged into a new shape.

Object Subtracting

Following the circle and rectangle example, lay the circle over the rectangle. Now select "Modify | Shapes | Subtract" from the main menu. We can repeat this with other shapes.

Object Cutting

Again, we select both the rectangle and the circle. Now select "Modify | Shapes | Intersect" from the main menu. The shapes will be cut and only the intersection part will be left.

Working file

Draw-Objects.odg