FR/Math/Personnalisation

From The Document Foundation Wiki
Jump to: navigation, search

Personnalisation de Math

Bouton Fr.HT Math bouton Math.png

Illustration 12.1 : Ajout d’un bouton pour l’insertion de formule

Par défaut, le bouton est présent dans la barre d’outils Insérer des modules Writer et Impress. Vous pouvez cependant ajouter cette icône à d’autres barres d’outils :

  • Affichage>Barre d'outils>Personnaliser (Alt+A,T,P) ou clic sur la petite flèche tout à droite d’une barre de menu > Personnaliser la barre d’outils. Choisir l’onglet Barres d'outils et la barre d’outils souhaitée.
  • Sélectionner la position où insérer le bouton puis cliquer sur Ajouter.
  • Choisir la catégorie Insérer, puis la commande Formule, celle correspondant à l’icône Fr.HT Math bouton Math.png (la commande Fr.HT Math bouton f x.png correspond à l’équivalent d’une formule du tableur).
  • Cliquer sur Ajouter puis continuer à ajouter des boutons ou cliquer sur Fermer.
  • Utiliser les boutons flèches vers le haut et vers le bas pour déplacer éventuellement des boutons, avant de valider par OK.

Raccourci

Illustration 12.2 : Ajout d’un raccourci clavier

Vous pouvez affecter un raccourci clavier de votre choix à l’insertion de formule :

  • Menu Outils>Personnaliser, onglet Clavier.
  • Sélectionner le niveau du raccourci : LibreOffice pour en disposer dans tous les modules (si le raccourci n’est pas déjà affecté dans ce module) ou uniquement dans le module en cours.
  • Choisir la catégorie Insérer, puis la commande Formule ne correspondant pas au raccourci F2 (cette commande correspond à l’équivalent d’une formule du tableur).
  • Sélectionner le raccourci à affecter, puis cliquer sur Modifier.
  • Procéder de la même façon pour d’autres raccourcis, puis valider par OK.

Mise en forme par défaut

Illustration 12.3 : Styles de cadre

Dans Writer, les formules sont mises en forme en suivant le style de cadre Formule. Dans la fenêtre du styliste (affichage par F11), cliquez sur le 3e bouton Styles de cadre. Cliquez droit sur Formule et sélectionnez Modifier. Vous pouvez modifier ainsi directement toutes les formules du document.

Pour que cette mise en forme soit appliquée à tous les nouveaux documents Writer, vous devez intégrer le style Formule dans le modèle par défaut. Pour cela, créez un nouveau document et modifiez le style Formule comme souhaité. Enregistrez le document par Fichier > Modèles > Enregistrer. Pour le définir comme modèle par défaut, sélectionnez Fichier > Modèles > Gérer ; double-cliquez sur Mes modèles : votre modèle doit apparaître juste en dessous. Cliquez droit dessus et sélectionnez Définir comme modèle par défaut. La commande Rétablir le modèle par défaut, permet de revenir au modèle par défaut fourni lors de l’installation de LibO.

Les nouveaux documents texte suivront ce modèle.


Chapitre précédent : Pour aller plus loin

Chapitre suivant : Annexe 2 Opérateurs et fonctions