Perguntas Frequentes sobre extensões e configuração do LibreOffice

From The Document Foundation Wiki
< Faq
Jump to: navigation, search

O que é uma extensão do LibreOffice?

Uma extensão é um pacote que implementa recursos adicionais no LibreOffice e que pode ser instalado através do menu Ferramentas > Gerenciador de extensão. Em geral, uma extensão do LibreOffice é geralmente identificada como um arquivo OXT embora também possa ser distribuída como um arquivo ZIP. A composição mais comum de uma extensão é o código-fonte da funcionalidade implementada mais a configuração de algum recurso de interface para acioná-lo (em especial botões ou itens de menu). Além disso, também podemos encontrar dicionários de verificação ortográfica e pacotes de modelos distribuídos na forma de extensões. Clique aqui para conhecer o projeto de Extensões do LibreOffice.


Como posso instalar uma extensão no LibreOffice?

Consulte o tutorial Instalar extensões no LibreOffice da seção Como fazer do projeto de Documentação.


Onde posso encontrar extensões para o LibreOffice?

Você encontrará dezenas de extensões no [repositório oficial de extensões do projeto. Todas as extensões nesse repositório são distribuídas sob licenças livres. Também há uma lista de extensões livres disponível nono portal LibrePlanet. Em geral, as extensões disponíveis para o OpenOffice.org também são compatíveis com o LibreOffice.

Existem diferenças entre o LibreOffice para Windows e o LibreOffice para Linux?

Não, o LibreOffice para Windows é o mesmo LibreOffice para Linux. No entanto, podem existir algumas diferenças em relação a recursos externos à aplicação, como, por exemplo, fontes ou drives de acesso a bancos de dados.


Como preencher os dados pessoais do usuário?

  1. Abra uma das aplicações do LibreOffice. O Writer, por exemplo.
  2. Clique no menu Ferramentas > Opções;#será aberta a tela de configuração de opções do LibreOffice.
  3. Clique na seção LibreOffice e, depois, na subseção Dados do usuário;#preencha os dados que você considerar relevantes e clique OK para finalizar.

A partir de agora, funcionalidades como as anotações (menu Inserir > Anotação) ou o registro de alterações (menu Editar > Alterações > Registrar), além das propriedades do arquivo (menu Arquivo > Propriedades) utilizarão os dados do usuário para identificar os registros de uso do documento.


Onde posso configurar o tempo de salvamento automático dos arquivos do LibreOffice?

  1. Abra uma das aplicações do LibreOffice. O Writer, por exemplo.
  2. Clique no menu Ferramentas > Opções;#será aberta a tela de configuração de opções do LibreOffice.
  3. Clique na seção Carregar/Salvar e, depois, na subseção Geral;#no conjunto de opções que serão apresentadas, você encontrará a opção Salvar informações de autorrecuperação a cada marcada e, ao lado dela, um campo contendo o valor de 15 minutos;
  4. altere o valor do campo para o valor em minutos desejado;
  5. clique OK para finalizar.

A opção Salvar informações de autorrecuperação a cada e o valor em minutos inserido pelo usuário valem para todos os aplicativos do pacote LibreOffice.


Como posso adicionar um dicionário de verificação ortográfica de um outro idioma?

Dicionários de verificação ortográfica, de sinônimos e de separação silábica são distribuídos através de extensões. Consulte a pergunta O que é uma extensão do LibreOffice?


Como posso adicionar um idioma adicional para a interface do LibreOffice?

Você deve adicionar o pacote de idioma (languagepack) correspondente ao idioma desejado para a interface. Para localizar o download dos pacotes de idioma:

  1. abra a página http://pt-br.libreoffice.org/baixe-ja/
  2. localize o link Other way to download LibreOffice, the productivity suite;#clique sobre ele e, depois, escolha a versão correspondente ao seu LibreOffice;
  3. em seguida, clique sobre o seu sistema operacional e, após, em Languagepacks. Você terá acesso a lista de languagepacks.

Observe agora os sufixos que identificam o idioma: es (espanhol), en (inglês), it (italiano), etc... Escolha o pacote de idioma correspondente e faça o download para instalação.