Mail Merge in Writer

From The Document Foundation Wiki
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎dansk

Foreword

The video "Serienbrief in Writer" links to this page here, which contains more detailed information.

This description here refers to the version LibreOffice 7.2.

This page describes how to create a form letter.

The basis is the Online-Help.

Link to the Video

Link to the Video (in German [DE]):

Serienbrief in Writer – LibreOffice 7.2

Create the Mail Merge

Scheme: Create Mail Merge and swap Data Source

To create a mail merge letter, you need a text document that you make the source document for your mail merge letters.

 Note 
 An Outgoing document is created by merging a Text document with the Address data.

To do this, open the "202110_Musterbrief".

Open the [[Media:202110_Menu Tools Mail Merge Wizard.png|{bc|Tools|Mail Merge Wizard…}}] menu.

The Mail Merge Wizard dialog appears in which you can define the Outgoing document of the Mail Merge.

If your address data source is not registered yet, you will receive a message.

Register Data sources

Step 1 - Select Starting document

At "Select Starting Document - Step 1", select "Use the current document" and click Next >.

Step 2 - Select Document type

At "Select Document Type - Step 2", select "Letter" and click the Next > button.

Step 3 - Insert Address Block

3.1

At "Insert Address Block - Step 3", select the "Musteradressen" via "Select Address List…" and click OK.

 Note 
 The button appears as Select address list… if no address list has been selected yet.
 The button appears as Select other address list… if an address list was already selected.

3.2

With the selection More… you have four Address forms to choose from, but leave it at the default.

3.3

Click the Match Fields… Button.

Matches to field and click OK.

In our example, the assignments of the fields correspond to this table:

Title = Anrede
Forename = Vorname
Surname = Nachname
Address Line 1 = Strasse
Postcode = PLZ
Post Town = Wohnort
alle anderen = [Keine]

3.4

"Bottom - at Step 3.4" you can see if all assigned address fields are displayed.

Outgoing document

When all the fields are displayed as desired, click the Next > button.

Step 4 - Create letter salutation

In the dialog "Create a Salutation - Step 4", check "This document should contain a salutation" and "Insert personalised salutation".

Add "Field name" and "Field value" as shown in the screenshot.

Right below the "Preview" you can jump to the next documents to see the corresponding preview.

Click Next >.

Step 5 - Adjust Layout of Adress Block and Salutation

At "Adjust Layout of Adress Block and Salutation - Step 5", the position for the address block in the letter is displayed.

You can adjust the position of the address field according to your needs.

You exit the Mail Merge Wizard and click Finish.

You can now still manually intervene in the layout if necessary.

Save Outgoing document

Save the Outgoing document in the File ▸ Save menu.

Further procedure via the "Mail merge" toolbar

"Mail Merge" Toolbar

The further control or the process is done via the "Mail Merge" Toolbar, via View ▸ Toolbars ▸ Mail Merge menu.

Prepare Outgoing document

The Outgoing document contains the address fields and the resulting triple salutation and now shows the salutation possibilities (!) for for the individual documents.

 Note 
 Please, this leave absolutely so! It is correctly assigned in the form letter.

Personalize Mail Merge documents

"Mail Merge" Toolbar

Via the toolbar: "Mail Merge" Toolbar Edit individual Documents… you will get the individual mail merge letters in a new window.

In the individual document (Example) you can now make corrections if necessary.

If all individual mail merge letters are as you want them, you can save the complete mail merge document, which is now still called "Untitled 1", as a document with File ▸ Save or File ▸ Save as… and enter a Document name, e.g. "Mail merge letter -finished-".

Save, print, send

Via the toolbar: "Mail Merge" Toolbar you can furthermore

  • "Save Merged Documents"
  • "Print Merged Documents"
  • "Send Email Messages".

To save, click Save Merged Documents and enter a document name, e.g. "Mail Merge -finished-", and click Save.

Alternatively, click "Print Merged Documents" or "Send Email Messages".

Exchange Database

You can exchange the database for your Outgoing document.

Select Edit ▸ Exchange Database… in the menu.

In the "Exchange database" dialog click on the Browse… button.

In the "Open" dialog, select the desired database and click Open.

In the "Exchange database" dialog, select the previously selected database.

Click the Define button.

Further Informations

Register Data sources

If your data source for addresses has not been registered yet, you must register the data source now.

See: Registering an Address Book

See also: Database Overview

- To the Top -

Work files

"202110_Musterbrief.odt"

"202110_Musterbrief - Ausgangsdokument.odt"

"202110_Musteradressen.ods"

- To the Top -

Creating a mail merge in Writer - Version 5.2

Creating a mail merge in Writer - Version 5.2

Documentation / Manuals

Here you will find the Documentation / Manuals:

Documentation / Manuals

Any questions?

For questions on this topic go to:

Ask.LibreOffice

Get Involved

Join us today and help us to make it even better!

Get Involved

LibreOffice is Free Software and is made available free of charge.

Your donation, which is purely optional, supports our worldwide community.

If you like the software, please consider a Donation.

- To the Top -