How to Create Accessible LibreOffice files

From The Document Foundation Wiki
Jump to: navigation, search


Contents

How to Create Accessible LibreOffice PDFs and documents

Creating accessible content using LibreOffice not only helps people with disabilities access, navigate and understand your content, but there are many benefits for everyone else too. Good accessibility means better use of your content in many other technologies, assistive or otherwise. This page outlines a list of actions that accumulatively contribute to accessibility.


How to save a tagged PDF

Saving a tagged PDF using LibreOffice 5.2 (PC and Mac)

  1. Open the original in LibreOffice 5.2
  2. Click File from the menu and select Export as PDF.
  3. In the PDF Options dialog box, make sure the Tagged PDF (add document structure) and the Export bookmarks boxes are selected.
  4. Click Export.


How to add headings

Adding headings in LibreOffice Writer 5.2 (PC and Mac)

Turning text into headings.

  1. Open the original in LibreOffice Writer 5.2.
  2. Select the text that should become a heading.
  3. In the Formatting bar, open the Apply Paragraph Style dropdown and select the appropriate heading level. If you don’t see the heading level you are looking for, click More options.
  4. Repeat this for all the text that should become headings.
    Screen capture of the Paragraph Style dropdown menu in LibreOffice on a PC


Styling headings in LibreOffice Writer 5.2

Customizing the visual appearance of a heading style.

  1. Open the Apply Paragraph Style dropdown. Click the arrow next to the heading style of which you want to change the visual appearance.
  2. Click Edit Style from the menu.
  3. Make any formatting changes that you would like to make (e.g. Font, font size, etc) in the Font and Font Effects tabs and click OK. All text which has that heading applied will automatically be updated.
  4. Save the document.
    Screen capture of the Paragraph Style dropdown menu in LibreOffice on a PC


Adding titles in LibreOffice Impress 5.2 (PC)

  1. Open the original in LibreOffice Impress 5.2.
  2. Click the first slide which contains a title.
    Screen capture of a LibreOffice Impress file on a PC
  3. Open the Properties menu on the right side. Open the Layouts section. As your slide contains a title, choose one of the layouts that best fit the structure of your slide.
    Screen capture of Layouts in LibreOffice Impress on a PC
  4. If the already existing title and content show up nicely within the provided title and content boxes, it means the slide uses the layout correctly.
    Screen capture of a Title in LibreOffice Impress on a PC
  5. If an empty title and text box show up on top of the already existing text boxes, it means the title and text have to be transferred to these boxes. Transfer the text for the title to the title box, and content to the content boxes.
    Screen capture of Layouts being applied in LibreOffice Impress on a PC
  6. Repeat these steps for all the slides that appear to have titles and save the document.


Adding titles in LibreOffice Impress 5.2 (Mac)

  1. Open the original in LibreOffice Impress 5.2.
  2. Click the first slide which contains a title.
    Screen capture of a LibreOffice Impress file on a Mac
  3. Open the Properties menu on the right side. Open the Layouts section. As your slide contains a title, choose one of the layouts that best fit the structure of your slide.
    Screen capture of Layouts in LibreOffice Impress on a Mac
  4. If the already existing title and content show up nicely within the provided title and content boxes, it means the slide uses the layout correctly.
    Screen capture of a Title in LibreOffice Impress on a Mac
  5. If an empty title and text box show up on top of the already existing text boxes, it means the title and text have to be transferred to these boxes. Transfer the text for the title to the title box, and content to the content boxes.
    Screen capture of Layouts being applied in LibreOffice Impress on a Mac
  6. Repeat these steps for all the slides that appear to have titles and save the document.


How to add alternative descriptions to images in a document

Adding an image description in LibreOffice Writer 5.2 (PC)

  1. Open the original in LibreOffice Writer 5.2.
  2. Double click the image. The Image dialog box shows up.
  3. Click the Options tab in the Image dialog box.
    Screen capture of an image's options in LibreOffice Writer on a PC
  4. Enter a brief description for the image in the Name field.


Adding an image description in LibreOffice Writer 5.2 (Mac)

  1. Open the original in LibreOffice Writer 5.2.
  2. Double click the image. The Image dialog box shows up.
  3. Click the Options tab in the Image dialog box.
    Screen capture of an image's options in LibreOffice Writer on a Mac
  4. Enter a brief description for the image in the Name field.


Adding an image description in LibreOffice Impress 5.2 (PC)

  1. Open the original in LibreOffice Impress 5.2
  2. Select the image. Click Format in the menu bar and select Description from the list. The Description panel shows up.
    Screen capture of an image's options in LibreOffice Impress on a PC
  3. Enter a brief description for the image in the Description box. If the description is long, a summarized Title should also be provided.
  4. Click OK to save your changes.
  5. Repeat these steps for all images in the document. Save the document.


Adding an image description in LibreOffice Impress 5.2 (Mac)

  1. Open the original in LibreOffice Impress 5.2
  2. Select the image. Click Format in the menu bar and select Description from the list. The Description panel shows up.
    Screen capture of an image's options in LibreOffice Impress on a Mac
  3. Enter a brief description for the image in the Description box. If the description is long, a summarized Title should also be provided.
  4. Click OK to save your changes.
  5. Repeat these steps for all images in the document. Save the document.


How to add headers to a table

Adding headers to a table in LibreOffice Writer 5.2 (PC)

  1. Open the original in LibreOffice Writer 5.2.
  2. Ensure the text in the first row functions as a title and identifies what each column is for. E.g: Week, Topic, Date and so on.
  3. Right-click the table and select Table Properties. Or, select Table Properties from the bottom or top menu. The Table Format dialog box shows up.

  4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check box is selected and that at least the first row is filled out.
    Screen capture of Table Format options in LibreOffice Writer on a PC
  5. Repeat these steps for tables in the document. Save the document.


Adding headers to a table in LibreOffice Writer 5.2 (Mac)

  1. Open the original in LibreOffice Writer 5.2.
  2. Ensure the text in the first row functions as a title and identifies what each column is for. E.g: Week, Topic, Date and so on.
  3. Right-click the table and select Table Properties. Or, select Table Properties from the bottom or top menu. The Table Format dialog box shows up.

  4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check box is selected and that at least the first row is filled out.
    Screen capture of Table Format options in LibreOffice Writer on a Mac
  5. Repeat these steps for tables in the document. Save the document.


Adding headers to a table in LibreOffice Impress 5.2 (PC)

  1. Open the original in LibreOffice Writer 5.2.
  2. Ensure the text in the first row functions as a title and identifies what each column is for. E.g: Week, Topic, Date and so on.
  3. Right-click the table and select Table Properties. Or, select Table Properties from the bottom or top menu. The Table Format dialog box shows up.

  4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check box is selected and that at least the first row is filled out.
    Screen capture of Table Design options highlighting the "Header row" option in LibreOffice Impress on a PC
  5. Repeat these steps for tables in the document. Save the document.


Adding headers to a table in LibreOffice Impress 5.2 (Mac)

  1. Open the original in LibreOffice Writer 5.2.
  2. Ensure the text in the first row functions as a title and identifies what each column is for. E.g: Week, Topic, Date and so on.
  3. Right-click the table and select Table Properties. Or, select Table Properties from the bottom or top menu. The Table Format dialog box shows up.

  4. In the Table Format dialog box, select the Text Flow tab. Make sure the Repeat heading check box is selected and that at least the first row is filled out.
    Screen capture of Table Design options highlighting the "Header row" option in LibreOffice Impress on a Mac
  5. Repeat these steps for tables in the document. Save the document.


How to set a language

Setting the document language in LibreOffice Writer 5.2 (PC)

  1. Open the original in LibreOffice Writer 5.2.
  2. Determine the main language of the text. When a lot of text is underlined with red squiggly lines, this is often an indication that the language isn’t set correctly.
  3. Set the correct document language by clicking on Tools > Language > For all Text > More…. The Options - Language Settings - Languages dialog box shows up.
    Screen capture of the "Tools" menu highlighting "Language" in LibreOffice Writer on a PC
  4. Under Default Languages for Documents, select the correct document language from the dropdown. If you check For the current document only, your choice will only apply to the current document.
  5. Click OK and save the document.
    Screen capture of the "Language" options modal in LibreOffice Writer on a PC


Setting the document language in LibreOffice Impress 5.2 (PC)

  1. Open the original in LibreOffice Impress 5.2.
  2. Determine the main language of the text. When a lot of text is underlined with red squiggly lines, this is often an indication that the language isn’t set correctly.
  3. Set the correct document language by clicking on Tools > Language > For all Text > More…. The Options - Language Settings - Languages dialog box shows up.
    Screen capture of the "Tools" menu highlighting "Language" in LibreOffice Impress on a PC
  4. Under Default Languages for Documents, select the correct document language from the dropdown. If you check For the current document only, your choice will only apply to the current document.
  5. Click OK and save the document.
    Screen capture of the "Language" options modal in LibreOffice Impress on a PC


Setting the document language in LibreOffice Writer 5.2 (Mac)

  1. Open the original in LibreOffice Writer 5.2.
  2. Determine the main language of the text. When a lot of text is underlined with red squiggly lines, this is often an indication that the language isn’t set correctly.
  3. Set the correct document language by clicking on Tools > Language > For all Text > More…. The Options - Language Settings - Languages dialog box shows up.
    Screen capture of the "Tools" menu highlighting "Language" in LibreOffice Writer on a Mac
  4. Under Default Languages for Documents, select the correct document language from the dropdown. If you check For the current document only, your choice will only apply to the current document.
  5. Click OK and save the document.
    Screen capture of the "Language" options modal in LibreOffice Writer on a Mac


Setting the document language in LibreOffice Impress 5.2 (Mac)

  1. Click on the View tab and select Outline. Select the text from all the slides that need changing.
  2. Right-click and choose Character… from the menu. The Character dialog box shows up.
  3. On the Fonts tab, select the correct language for the selected text and click OK.
  4. Repeat these steps for all the text that needs changing.
  5. Save the document.
    Screen capture of the "Language" options modal in LibreOffice Impress on a Mac


Choosing a language for selected text in LibreOffice Writer 5.2 (PC)

Text that is still underlined with red squiggly lines or paragraphs in a different language need their language set separately.



  1. Select all the text in specific text boxes that need changing.
  2. Right-click the selected text, and choose Character… from the menu. The Character dialog box shows up.
  3. On the Font tab, select the correct language for the selected text and click OK.
  4. Repeat these steps for all the text that needs changing.
  5. Save the document.
    Screen capture of the "Character" options modal in LibreOffice Writer on a PC


Choosing a language for selected text in LibreOffice Impress 5.2 (PC)

Text that is still underlined with red squiggly lines or paragraphs in a different language need their language set separately.



  1. Select all the text in specific text boxes that need changing.
  2. Right-click the selected text, and choose Character… from the menu. The Character dialog box shows up.
  3. On the Fonts tab, select the correct language for the selected text and click OK.
  4. Repeat these steps for all the text that needs changing.
  5. Save the document.
    Screen capture of the "Character" options modal in LibreOffice Impress on a PC


Choosing a language for selected text in LibreOffice Writer 5.2 (Mac)

Text that is still underlined with red squiggly lines or paragraphs in a different language need their language set separately.



  1. Click on the View tab and select Outline. Select the text from all the slides that need changing.
  2. Right-click and choose Character… from the menu. The Character dialog box shows up.
  3. On the Font tab, select the correct language for the selected text and click OK.
  4. Repeat these steps for all the text that needs changing.
  5. Save the document.
    Screen capture of the "Character" options modal in LibreOffice Writer on a Mac


Choosing a language for selected text in LibreOffice Impress 5.2 (Mac)

Text that is still underlined with red squiggly lines or paragraphs in a different language need their language set separately.



  1. Select all the text in specific text boxes that need changing.
  2. Right-click the selected text, and choose Character… from the menu. The Character dialog box shows up.
  3. On the Fonts tab, select the correct language for the selected text and click OK.
  4. Repeat these steps for all the text that needs changing.
  5. Save the document.
    Screen capture of the "Character" options modal in LibreOffice Impress on a Mac