DE/Doku/Allgemein/09 GettingStartedMath

From The Document Foundation Wiki
< DE‎ | Doku‎ | Allgemein
Jump to: navigation, search


Was ist Math?

Stefan H. Ralf k-j Jochen, Kü

Mit Math können mathematische Formeln geschrieben werden. Meist wird Math als Formel-Editor in Textdokumenten genutzt. Genauso gut kann Math in anderen Komponenten von LibreOffice oder ganz allein für sich genutzt werden. Bei Nutzung von Math innerhalb von Writer wird die Formel als Objekt innerhalb des Textdokuments behandelt.

Hinweis
Der Formel-Editor ist gedacht, um Formeln in symbolischer Form wie in Formel XYZ darzustellen. Zur numerischen Berechnung eines Wertes schauen Sie in das Calc-Handbuch.

Erster Schritt

Stefan H. Ralf Jochen Stefan H., Kü

Zum Einfügen einer Formel in Writer wählen Sie Einfügen → Objekt → Formel.

Nun öffnet sich der Formeleditor am unteren Bildschirmrand und es erscheint das Fenster Elemente. In Ihrem Dokument können Sie auch eine kleine Box mit grauer Umrandung sehen, in der die Formel angezeigt wird.

Eingabe einer Formel

Stefan H. Ralf Jochen Stefan H., Kü

Der Formeleditor benutzt eine Markup-Sprache zum Darstellen der Formeln. So erzeugt z. B. "%beta" den griechischen Buchstaben β. Die Bezeichnungen orientieren sich an englischen Ausdrücken. Der Ausdruck "a over b" (a über b) erzeugt z. B. einen Bruch.

Formeln können auf drei Arten eingegeben werden:

  • Durch Wahl der entsprechenden Symbole im Element-Fenster.
  • Durch Rechts-Klick auf den Formelditor und Wahl eines Symbols aus dem Kontext-Menü.
  • Durch Eingabe einer Bezeichnung wie z. B. "a over b" in den Formeleditor.

Das Kontext-Menü und das Element-Fenster fügen die zum gewählten Symbol gehörige Bezeichnung in den Formel-Editor ein. Dadurch können die in Math genutzten Bezeichnungen leicht erlernt werden.

Hinweis
Durch Anklicken des Hauptdokumentes wird der Formel-Editor verlassen.
Doppel-Klick auf eine Formel öffnet den Formel-Editor erneut.

Das Fenster Elemente

Stefan H. Ralf Stefan H.

Die einfachste Methode (für Ungeübte) zur Eingabe einer Formel ist die Benutzung des Fensters Elemente.

Das Elemente-Fenster ist in zwei Teile unterteilt:

  • Der obere Teil zeigt die Symbol-Kategorien. Durch Anklicken einer Kategorie ändern sich die angezeigt Detail-Symbolliste.
  • Im unteren Teil werden die zur aktuellen Kategorie gehörigen Symbole angezeigt.
Tip
Das Element-Fenster kann über den Menüpunkt Ansicht → Elemente ein- bzw. ausgeblendet werden.

Beispiel 1

Stefan H. reisi007 Stefan H.

In diesem Beispiel soll eine einfache Formel eingegeben werden: (FORMEL: "5 cdot 4").

Gehen Sie im Fenster Elemente wie folgt vor:

  1. Aktivieren Sie die linke obere Schaltfläche "Unäre/Binäre Operatoren" im Bereich Elemente (Siehe Abbildung XYZ). Wenn Sie dieses Fenster nicht sehen können, blenden Sie es in Ansicht → Elemente ein.
  2. Klicken Sie auf die Schaltfläche für die Multiplikation (Punkt).

Wenn Sie die Schaltfläche für die Multiplikation anklicken, geschehen zwei Dinge:

  • Der Formeleditor zeigt den Text: (Abbildung XYZ: <?> cdot <?>)
  • In Ihrem Dokument erscheint folgende Box: (Abbildung XYZ)

Die Ausdrücke "<?>" in Abbildung XYZ sind Platzhalter, die sie durch Zahlen ersetzen können, in obigem Beispiel durch "5" und "4". Die Formel in Ihrem Dokument wird automatisch aktualisiert und das Ergebnis sollte wie in Abbildung XYZ aussehen.

Tipp
Wenn Sie nicht möchten, dass die Formel nicht automatisch aktualisiert wird, wählen Sie im Menü Ansicht -> Ansicht automatisch aktualisieren (wenn Sie nochmal auf Ansicht klicken, ist das Häkchen vor dem Eintrag nicht mehr vorhanden). Um die Formel anschließend manuell zu aktualisieren, drücken Sie die Taste F9 oder wählen Sie im Menü Ansicht -> Aktualisieren oder Sie wählen in der Symbolleiste Werkzeuge den Button Aktualisieren [ICON einfügen].

Übers Kontextmenü

Stefan H. reisi007 Stefan H.

Eine andere Möglichkeit ist es, mit einem Rechtsklick das Kontextmenü aus Abbildung XYZ zu öffnen. Dieses Menü enthält die selben Einträge wie das Fenster Elemente.

Über den Formeleditor

Stefan H. reisi007 Stefan H.

Sie können den Markup-Code auch direkt in den Formeleditor eingeben. Für obiges Beispiel müssen Sie "5 cdot 4" direkt eingeben. Wenn Sie den Markup-Code kennen, ist dieses der schnellste Weg, eine Formal einzugeben.

  • Der Markup-Code ist an die englische Sprache angelehnt.

In der folgenden Tabelle sehen Sie eine Liste mit gebräuchlichen Ausdrücken und ihren Markup-Äquivalenten.

(TABELLE mit Beispielen: direkt aus dem englischen Original übernehmen!)

Griechische Buchstaben

Stefan H. reisi007 Stefan H.

Griechische Buchstaben (wie z. B. α, β, γ, θ u. s. w.) kommen häufig in mathematischen Formeln vor. Diese sind nicht im Fenster Elemente und auch nicht im Kontextmenü enthalten. Sie können Sie im Menü über Extras -> Katalog einfügen. Doppelklicken Sie auf den entsprechenden Buchstaben und der Markup-Code wird in die Formeln eingefügt.

Der einfachere Weg ist aber, direkt im Formeleditor ein %-Zeichen gefolgt vom Namen des Buchstaben einzugeben. (Die Namen müssen in der Oberflächensprache von LibreOffice eingegeben werden.)

  • Um einen kleinen Buchstaben zu bekommen, geben Sie den Namen in Kleinbuchstaben ein.
  • Um einen großen Buchstaben zu erhalten, geben Sie den Namen in Großbuchstaben ein (dabei müssen alle Zeichen Großbuchstaben sein, sonst kann LibreOffice das Symbol nicht darstellen).

In der unten stehenden Tabelle sind einige Beispiele aufgeführt.

(TABELLE mit Beispielen: aus dem englischen Original übernehmen!)

Hinweis
Eine vollständige Tabelle mit griechischen Buchstaben und ihren Markup-Äquivalenten finden Sie im Math-Handbuch.

Eine andere Möglichkeit, griechische Buchstaben einzufügen, ist, den Katalog zu verwenden. Wählen Sie im Menü Extras -> Katalog... und im Auswahlmenü Symbolset den Eintrag "Griechisch" aus. Der Markup-Code des jeweils ausgewählten Buchstaben wird unter dem Bereich angezeigt. Um den ausgewählten Buchstaben einzufügen, klicken Sie auf übernehmen.

Beispiel 2

Stefan H. reisi007 Stefan H.

Folgende Formel soll eingegeben werden: (Abbildung XYZ)

Für dieses Beispiel sollen folgende Voraussetzungen gegeben sein:

  • Sie möchten die oben stehende Formel eingeben (Pi auf fünf Stellen nach dem Komma gerundet).
  • Sie kennen den Namen des griechischen Buchstaben (pi).
  • Aber Sie kennen das Markup-Äquivalent für das Symbol (BILD) nicht
  1. Geben Sie "%" gefolgt vom Text "pi" in den Formeleditor. Im Fenster wird der griechische Buchstabe (BILD) angezeigt.
  2. Öffnen Sie das Fenster Elemente (z. B. über Ansicht -> Elemente) (Abbildung XYZ).
  3. Das Symbol ist eine Relation, also klicken Sie auf die Schaltfläche "Relationen". Wenn Sie mit der Maus über die Schaltflächen wandern, sehen Sie in Tooltipps die Bezeichnungen der Symbole (Abbildung XYZ).
  4. Klicken Sie auf die Schaltfläche (ICON) "ist ähnlich oder gleich". Der Ausdruck erscheint nun im Formeleditor, wo jetzt folgendes steht: (Siehe Abbildung XYZ: %pi<?> simeq <?>).
  5. Löschen Sie den Text "<?>" vor dem Markup-Ausdruck und ersetzen Sie den Text "<?>" am Ende durch 3,14159. Es steht jetzt der Markup-Code (BILD: %pi simeq 3,14159) im Formeleditor. Das Ergebnis im Fenster sehen Sie in Abbildung XYZ.

Math anpassen

Stefan H. Stefan H. Jochen

Im Folgenden werden einige Möglichkeiten beschrieben, wie Sie Math an Ihre Bedürfnisse anpassen können.

Formeleditor als ein schwebendes Fenster

Stefan H. Stefan H. Jochen

Der Formeleditor kann einen großen Teil des Writer-Fensters einnehmen. Deshalb gibt es die Möglichkeit, den Formeleditor als schwebendes Fenster einzurichten:

  1. Bewegen Sie den Mauszeiger über den Rahmen des Formeleditors.
  2. Drücken Sie die Strg-Taste und doppelklicken Sie mit der Maus.

Abbildung XYZ zeigt das Ergebnis. Sie können das Fenster wieder fixieren, indem Sie die selben Schritte noch einmal ausführen.

Schriftgröße einer Formel verändern

Stefan H. Stefan H. Jochen

Um die Grundschriftgröße der Formeln zu verändern, führen Sie folgende Schritte aus:

  1. Wählen Sie den Menüeintrag Format -> Schriftgrößen...
  2. Stellen Sie eine andere Schriftgröße im Feld Basisgröße ein (oberster Eintrag).

Das Ergebnis sehen Sie in Abbildung XYZ.

Layout einer Formel

Stefan H. Jochen Stefan H.

Bei der Nutzung von Math treten erfahrungsgemäßig die größten Schwierigkeiten bei der Erstellung von komplexen Formeln auf. Der folgende Abschnitt enthält einige Tipps bezüglich der Erstellung von komplexen Formeln.

Klammen setzen

Stefan H. Stefan H. Jochen

Math kennt keine Rechengesetze. Deshalb müssen Sie Klammen benutzen, um die Reihenfolge der Rechenoperationen anzugeben. Beachten Sie folgende Beispiele.

(TABELLE mit Beispielen: ähnlich der im englischen Original)

Gleichungen über mehrere Zeilen

Stefan H. Stefan H. Jochen

Wenn Sie eine Gleichung erstellen möchten, die über mehrere Zeilen geht (Beispiel s. BILD mit Gleichung aus dem englischen Original), müssen Sie folgenden Besonderheit beachten.

Wenn Sie die Eingabetaste drücken, springt der Corser im Editor zwar in die nächste Zeile, das Ergebnis der Gleichung hat aber keinen Zeilenumbruch. Sie müssen explizit "newline" als Ausdruck eingeben, um einen Zeilenumbruch in der Gleichung zu erhalten. Dies ist in folgender Tabelle illustriert:

(TABELLE mit Beispielen: ähnlich dem englischen Original)

Grenzen einer Summe oder eines Integrals eingeben

Stefan H. Stefan H. Jochen

Die Befehle "sum" und "int" können (optional) um die Parameter "from" (von) und "to" (bis) ergänzt werden. Diese geben die untere und die obere Grenze der Summe oder des Integrals an. Sie können gemeinsam oder nur einer von beiden bzw. keiner benutzt werden. Grenzen werden gewöhnlich unter bzw. über das Symbol geschrieben.

(TABELLE mit Beispielen: ähnlich dem englischen Original)

Weitere Details zu Summen und Integralen finden Sie im Math-Handbuch.

Klammen bei Matrizen

Stefan H. Stefan H. Jochen

Hier finden Sie eine Muster-Tabelle, die das Grundgerüst von Matrizen darstellt:

(TABELLE für Matrizen: ähnlich dem englischen Original)

Hinweis
Zeilen werden durch zwei Rauten ("##") getrennt. Innerhalb jeder Zeile wird jede Zelle durch eine einfache Raute ("#") getrennt.

Beachten Sie, dass einfache Klammern nicht auf die Größe der Matrix skaliert werden.

(TABELLE mit Beispiel: ähnlich dem im englischen Original)

Verwenden Sie dafür skalierbare Klammern. Dies sind Klammern, die sich an der Größe des Inhalts orientieren. Setzen Sie dazu den Ausdruck "left" vor die öffnende bzw. "right" vor die schließende Klammer.

(TABELLE mit Beispiel: ähnlich dem englischem Original)

Tipp
Für eckige Klammen können Sie ebenso die Ausdrücke "left" für "[" und "right" für "]" verwenden.

Ableitungen schreiben

Stefan H. Stefan H. Jochen

Um Ableitungen aufzuschreiben, bedient man sich dem Trick, einen Bruch zu verwenden. Hierzu verwenden Sie den Ausdruck "over".

Schreiben Sie für eine absolute Ableitung den Buchstaben "d" bzw. für eine partielle Ableitung den Ausdruck "partial", um die Ableitung zu notieren.

(TABELLE mit Beispielen: ähnlich dem englischen Original)

Hinweis
Beachten Sie, dass Klammern (geschweifte Klammern) verwendet werden müssen, um die Ableitung machen.

Elemente anordnen

Stefan H. Stefan H. Jochen

Um z. B. mehrere Gleichungen so untereinander zu notieren, dass das Gleichheitszeichen jeweils untereinander steht, muss man sich einem Trick bedienen.

Hinweis:
Bitte beachten Sie, dass sich die folgenden Angaben auf die Einbettung in einem Writer-Dokument beziehen.

Verwenden Sie eine Matrix, um Elemente anzuordnen, wie Sie es in folgenden Tabelle sehen können:

(TABELLE einfügen: ähnlich dem englischen Original)

Die leeren Klammen um das Gleichheitszeichen sind nötig, weil "=" eine Eingabe auf jeder der beiden Seiten erwartet. Andernfalls werden nur Platzhalter angezeigt.

Um den Platz beidseitig des Gleichheitszeichens zu verringern, müssen Sie den Freiraum der Matrix verändern:

  1. Wählen Sie im Menü Format -> Abstände...
  2. Im Dialog Abstände (Abbildung XYZ) klicken Sie auf das Dreieck neben "Kategorien" und wählen Sie den Eintrag "Matrizen" aus der Auswahlliste.
  3. Geben Sie "0%" für den Spaltenabstand ein und beenden Sie den Dialog mit OK.

Gleichungen nummerieren

Stefan H. Stefan H. Jochen

Die Nummerierung von Gleichungen ist eine der am besten versteckten Funktionen in Math. Aber die Umsetzung ist einfach:

  1. Rufen Sie ein Writer-Dokument auf bzw. erstellen Sie ein neues Writer-Dokument.
  2. Geben Sie in einer leeren Zeile (= Absatz) "fn" ein und drücken Sie die Taste F3.

Der Ausdruck "fn" wird durch eine nummerierte Formel ersetzt (mit der berühmtesten Formel Albert Einsteins als Ausgangsgleichung). Das Ergebnis ist im Folgenden zu sehen:

(FORMEL: mit Nummerierung)

Mit einem Doppelklick auf die Formel können Sie diese nun ändern. Geben Sie z. B. die Formel für die Reimann'sche Zetafunktion ein. Das Ergebnis sieht dann wie folgt aus:

(FORMEL: Riemann'sche Zetafunktion)

Um eine Referenz zu einer Gleichung herzustellen, führen Sie folgende Schritte aus:

  1. Wählen Sie im Menü den Eintrag Einfügen -> Querverweis...
  2. Es öffnet sich der Dialog Feldbefehle mit dem Register Querverweis (Abbildung XYZ). In der Liste unter Feldtyp wählen Sie den Eintrag "Feldtext".
  3. Im Bereich Auswahl wählen Sie die Gleichungsnummer.
  4. Wählen Sie im Feld Format den Eintrag "Referenz" aus.
  5. Klicken Sie auf Einfügen.

Wenn Sie im Nachhinein weitere nummerierte Gleichungen oberhalb bestehender Gleichung einfügen, werden die bestehenden Gleichungen neu nummeriert und die Referenzen aktualisiert.

Tipp
Um die Referenzen zu nummerierten Gleichungen ohne die runden Klammen einzufügen, wählen Sie den Eintrag "Nummerierung" anstelle von "Referenz" im Feld Format aus.