Nejčastější dotazy/Base/118

From The Document Foundation Wiki
< Faq‎ | Base
Jump to navigation Jump to search
This page is a translated version of the page Faq/Base/118 and the translation is 100% complete.
Other languages:
English • ‎Nederlands • ‎dansk • ‎français • ‎italiano • ‎čeština

Návod k použití nástroje Návrhář sestavy

Výukový program Návrhář sestav včetně snímků obrazovky je k dispozici k vytištění nebo ke stažení zde (v současné době pouze ve francouzštině, čeká se na překlad) :

Tutoriel de l'Assistant de création de rapport

Pokud se rozhodnete zobrazit dokument v prohlížeči, počkejte prosím několik okamžiků, než se načte.

Proč bych měl používat sestavu ?

Někteří lidé mají pocit, že jediným smyslem sestavy je formátovat data z databáze tak, aby je bylo možné vytisknout.

Návrhář sestav však poskytuje uživateli řadu základních nástrojů pro využití dat uložených v databázi. Umožňuje data podrobně prezentovat různými způsoby. Jedním z příkladů může být sledování času stráveného na projektu, zobrazení zisků za poslední týden nebo zjištění, který klient je nejziskovější. Přehledy lze například použít k vytváření faktur připravených k odeslání. Pokud se učíte cizí jazyk, lze je použít k vytištění seznamu slovíček vztahujících se k danému oboru nebo k zaznamenání pokroku ve studiu této slovní zásoby. Dalším nápadem může být sledování vašich výtvorů nebo návrhů pomocí jednoduché databáze a následné vytvoření pomocí programu Report Designer dokumentu typu katalogu nebo brožury obsahujícího ilustrace a text. Jinými slovy, nástroj Reports lze použít k mnoha různým účelům.

Návrhář sestav poskytuje přístup k řadě užitečných nástrojů, které umožňují vytvářet propracované sestavy : k dispozici jsou pokročilé možnosti třídění a seskupování a také možnost používat dotazy, příkazy a funkce jazyka SQL. Návrhář sestav výrazně usnadňuje koncipování a navrhování složitých sestav pomocí funkce drag and drop. Návrhář sestav navíc umožňuje uživateli vkládat také grafy a obrázky.

Požadovaná konfigurace

Návrhář sestav je ve výchozím nastavení integrován do LibreOffice. Je však napsán v programovacím jazyce Java, a proto vyžaduje, aby počítač, na kterém je spuštěn, měl nejen předinstalované prostředí Java Runtime Environment (JRE), ale aby byl LibreOffice nakonfigurován tak, aby toto prostředí JRE rozpoznal, aby jej bylo možné používat.

V podnabídce Nástroje -> Možnosti -> LibreOffice -> Java (v Macu je to v podnabídce LibreOffice -> Předvolby) zkontrolujte, zda bylo nalezeno a rozpoznáno běhové prostředí Java a zda bylo zaškrtnuto/aktivováno příslušné přepínač pro vybrané JRE. Pokud se v dialogovém okně žádné JRE neobjeví, pak buď vaše verze JRE není v LibreOffice rozpoznána, nebo nemáte JRE nainstalováno a budete si ho muset stáhnout a odpovídajícím způsobem nainstalovat JRE download site .

Instalace nástroje Návrháře sestav

Návrhář sestav je vlastně rozšíření dodávané s výchozí instalací LibreOffice, alespoň pro Windows a Mac. Některé linuxové distribuce pro své vlastní verze LibreOffice toto rozšíření stále dodávají jako samostatnou komponentu, kterou je případně nutné nainstalovat pomocí systému správy balíčků dané distribuce.

Rozhraní návrháře sestav

Vzorová databáze použitá pro tento výukový program byla získána pomocí výchozího Průvodce vytvořením tabulky a výběrem HouseholdInventory z osobního seznamu navrhovaných databází.

Panel nástrojů Návrháře sestav

Panel nástrojů Ovládací prvky sestav

Panel nástrojů Ovládací prvky sestavy obsahuje řadu tlačítek, pomocí kterých lze do sestavy přidávat pole, popisky, obrázky (obrázky, loga, fotografie atd.) a grafy.

Hlavní panel nástrojů

Hlavní Panel nástrojů umožňuje přidávat pole do sestavy, zapínat a vypínat Navigátor sestavy a spravovat možnosti třídění a seskupování.*

Panel nástrojů Zarovnání

Panel nástrojů Zarovnání slouží k umístění polí a dalších prvků v rámci sestavy.*

Nabídka

Nabídka umožňuje přístup k dalším modulům LibreOffice. Podrobněji se zde zmíníme o dvou funkcích : Insert pro vkládání obrázků do sestavy a Format pro využití možností podmíněného formátování pro dané pole.

Výchozí stránka sestavy

Výchozí stránka, která se zobrazí při spuštění nástroje Report Designer, je rozdělena na 3 části : Záhlaví stránky, Detail a Zápatí stránky.

Plovoucí panely nástrojů

Přidat panel pole

Tento panel slouží k přidání databázového pole do sestavy přetažením nebo pomocí nabídky Vložit.

Panel pro třídění a seskupování

Tento panel slouží ke správě možností třídění a seskupování různých prvků sestavy.

Panel Navigátor sestav

Tento panel umožňuje uživateli procházet dokumentem sestavy pomocí stromově orientované hierarchie seznamů objektů. Dvojklikem na některou z položek v seznamu navigátoru vyberete danou položku v dokumentu sestavy pro výběr nebo úpravy.

Vlastnosti Panelu

Tento panel umožňuje uživateli upravovat vlastnosti aktuálně vybraného ovládacího prvku, prvku nebo objektu.

Když například vyberete pole v sestavě, můžete pomocí panelu vlastností definovat zdroj dat pro toto pole a také další vlastnosti, jako je výška a šířka prvku, jeho pozice, formátování atd...

Tento panel také umožňuje zvolit typ dokumentu, který má být použit jako výstupní formát sestavy: buď dokument Writer (ODT), nebo dokument Calc (ODS).

Vytvoření sestavy

Vytvoření seskupení

Chcete-li vytvořit sestavu, která seskupuje data, je třeba přidat novou sekci Záhlaví seskupení, a to výběrem pole, na základě kterého se má seskupovat, pomocí tlačítka "Třídění a seskupování", panelu nebo odpovídající položky v Navigátoru sestavy (v tomto příkladu jsme použili pole Datum nákupu). Zvolte požadované možnosti třídění (vzestupně nebo sestupně) a poté Prezentovat v rozevíracích seznamech Záhlaví skupiny a Zápatí skupiny.

Pomocí panelu Přidat pole umístěte seskupené pole do části Záhlaví skupiny. Poté můžete použít různé dostupné možnosti formátování v položce Obecné na panelu Vlastnosti a naformátovat pole podle svých představ.

Sekce Detail

Sekce Detail je určena k zobrazení seznamu dat z databáze. Pomocí panelu Přidat pole přidejte do sekce Detail pole, která chcete v sestavě použít. Zarovnání polí a štítků může být poněkud obtížné, proto si pomozte panelem nástrojů Zarovnání. Jak bude vaše výsledná sestava vypadat, si můžete prohlédnout klepnutím na tlačítko Spustit sestavu na hlavním panelu nástrojů.

Vytvoření vypočteného pole

v zápatí stránky :

I když je možné použít zprávu tak, jak jste ji právě vytvořili, lze ji také vylepšit. Můžete například přidat pole, které vypočítá součet hodnot pro každou skupinu dat, nebo získat celkový součet.

Chcete-li získat celkový součet, klikněte na tlačítko Textová oblast na panelu nástrojů Ovládací prvky sestavy a nakreslete myší oblast v části Zápatí stránky sestavy. V panelu Vlastnosti tohoto nového prvku sestavy klikněte na kartu Data a nastavte následující možnosti :

Typ datového pole

Funkce

Pole

Nákupní cena

Funkce

Shromažďování

Rozsah

Zpráva

v sekci Zápatí skupiny :

Chcete-li přidat pole, které vypočítá součet hodnot pro každou skupinu, musíte nejprve vložit oddíl Zápatí skupiny, pokud jste tak ještě neučinili. Poté nakreslete pole v sekci Zápatí skupiny a zvolte následující možnosti :

Typ datového pole

Funkce

Datové pole

Nákupní cena

Funkce

Shromažďování

Rozsah

Skupina Datum nákupu

Vložení diagramu

Je také možné vložit graf, například zobrazit trendovou čáru dat indexovaných do seskupení. K tomu je třeba nejprve vytvořit dotaz, který z databáze získá požadovaná data, aby je bylo možné poskytnout pro diagram grafu.

Zavřete sestavu a v otevřeném souboru databáze ODB klikněte na tlačítko Dotaz. Vytvořte nový dotaz. Vyberte tabulku nebo tabulky obsahující data, která mají být extrahována, a přidejte pole do dotazu. V tomto příkladu jsme použili pole DatePurchased a PurchasePrice. Ve funkčních kritériích dotazu vyberte pro pole DatePurchased možnost Group (Skupina) a pro pole PurchasePrice možnost Sum (Součet).

Dotaz uložte a poté otevřete sestavu v režimu úprav, abyste ji mohli změnit. Klikněte na tlačítko Diagram na hlavním panelu nástrojů a nakreslete myší oblast v části Zápatí, která bude obsahovat graf. V panelu Vlastnosti na kartě Data vyberte jako zdroj dat právě vytvořený dotaz.

Pokud odpovídající výchozí graf histogramu neodpovídá vašim představám, můžete jeho vlastnosti změnit poklepáním na graf, čímž vstoupíte do režimu úprav grafu. Výchozí graf histogramu pak můžete změnit na graf, který více vyhovuje vašim potřebám, například na 3D graf.

Příklad grafu v sestavě

Vložení obrázku nebo loga do záhlaví sestavy

Toho lze dosáhnout pomocí nabídky Vložit. Takto vložený obrázek se zobrazí na každé stránce sestavy.

Podmíněné formátování vypočteného pole

Abyste to mohli provést, musíte nejprve v režimu úprav vybrat pole v sestavě. Poté v hlavní nabídce klikněte na možnost Formát > Podmíněné formátování.

V našem současném příkladu se pro účely podmíněného formátování zobrazí v závorkách alias dotazu použitého k vytvoření sestavy.

Příklad databázové sestavy s podmíněným formátováním polí

Jakmile si osvojíte základní principy používání nástroje Report Designer, budete moci využívat všechny jeho funkce k formátování dat poskytnutých databází a vytváření úžasných sestav.

Navigátor sestavy

Tuto funkci lze spustit pomocí funkční klávesy F5 nebo kliknutím na příslušné tlačítko na hlavním panelu nástrojů. Zobrazí všechny prvky a objekty obsažené v sestavě. Kontextová nápověda je k dispozici také pro různé položky ve stromové hierarchii seznamu, a to jednoduše stisknutím funkční klávesy F1 po výběru položky.

Kompletní seznam hierarchických prvků obsažených v sestavě lze zobrazit kliknutím na malé znaménko "plus" nebo šipku, která se zobrazí před položkou. Pokud se takové znaménko nebo šipka neobjeví, pak daný prvek nemá žádné dceřiné prvky.

Navigátor sestavy -> Sestava

Tab : Obecné

Následující prvky umožňují konfigurovat parametry zobrazení sestavy :

Název Toto je název, který jste dali svému hlášení, zobrazí se v Navigátoru hlášení, jakmile po zadání názvu a ověření stisknete klávesu enter.
Záhlaví stránky zde máte možnost povolit/zakázat tisk z rozbalovací nabídky obsahu vloženého do záhlaví stránky.
Zápatí stránky zde máte možnost povolit/zakázat tisk z rozbalovací nabídky obsahu vloženého do zápatí stránky.
Tisk opakovaných hodnot ano

Tab : Data

Následující prvky umožňují konfigurovat parametry zdroje dat pro vaši sestavu :

Typ obsahu

Zvolte typ dat, která chcete použít: tabulka, uložený dotaz nebo přímý dotaz SQL.

Obsah

Zvolte název zdroje dat

Analýza SQL

ano nebo ne, podle toho, jakým způsobem přistupujete k datům. Výběr možnosti "ano" odpovídá aktivaci nativní funkce analyzátoru SQL v režimu návrhu dotazu. Volba "ne" deaktivuje nativní SQL parser LO a předává instrukce dotazu přímo databázovému ovladači. To je vyžadováno u některých pokročilých databázových funkcí a serverových backendů a závisí to na použitém databázovém stroji.

Filtr

vyberte ano nebo ne v závislosti na zdroji dat

Výstupní formát sestavy

Pokud potřebujete v sestavě použít pokročilejší matematické zpracování výsledků, zvolte ODF Spreadsheet, jinak zvolte ODF Text.

Prohlížeč sestav -> Funkce

Budete moci vytvořit funkce, které pak použijete v sestavě. Chcete-li vytvořit novou funkci, klikněte na tlačítko Funkce a poté pravým tlačítkem myši na položku Nová funkce. Chcete-li získat přístup k dalším příkladům, postupujte podle odkazů na konci této stránky.

Název Výslovně pojmenujte svou funkci bez mezer mezi slovy (např.: SumPurchases).
Vzorec Kliknutím na 3 malé tečky se spustí průvodce vytvářením vzorců.

Můžete také přímo zadat vlastní vzorec. Například pro výpočet součtu několika hodnot bude syntaxe následující: [NameOfInitialValue] + [NameOfFunction] (např.: [PurchasePrice] + [PurchaseSum]).

Počáteční hodnota V hranatých závorkách zadáte název pole, na které se funkce použije (např.: [PurchasePrice]).
Hloubkový kurz Akce neuvedená v původní příručce
Předběžné hodnocení Pokud zvolíte možnost ano, bude zpráva vypočítána během jejího vytváření. Tato akce spotřebovává zdroje a můžete raději nečekat až do konce vytváření sestavy, aby se provedly všechny výpočty.

Navigátor sestavy -> Záhlaví stránky

Tab: Obecné

Následující prvky umožňují konfigurovat prezentaci sestavy:

Název

Záhlaví stránky můžete zachovat nebo ji pojmenovat jinak.

Viditelné

Chcete-li zobrazit obsah záhlaví, zvolte ano.

Výška Rozměr výšky můžete zadat nebo upravit pomocí myši přímo na stránce sestavy v režimu úprav.
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Průhlednost pozadí

Pokud zvolíte ne, budete moci nakonfigurovat barvu pozadí pro záhlaví stránky.

Prohlížeč sestav -> Záhlaví sestavy

Tab : Obecné

Následující prvky umožňují konfigurovat prezentaci záhlaví sestavy:

Název

Záhlaví zprávy můžete ponechat nebo ji pojmenovat jinak.

Vynucení nové stránky Pokud nechcete vytvořit jinou stránku podle dat nebo seskupení dat, vyberte možnost Žádné. V opačném případě zvolte vytvoření nové stránky podle požadovaného nastavení rozvržení, například Za oddílem.
Držet pohromadě Umožňuje v případě potřeby tisknout data skupiny na druhou stránku.
Viditelné Obecně platí, že odpovíte ano
Výška Rozměr výšky můžete zadat nebo upravit pomocí myši přímo na stránce sestavy v režimu úprav.
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Průhlednost pozadí Výběrem možnosti ne můžete nakonfigurovat barvu pozadí pro záhlaví sestavy.

Navigátor sestavy: Skupiny -> Panel třídění a seskupování

Způsob seskupování dat z databáze v sestavě můžete nastavit pomocí panelu Třídění a seskupování (viz výše: Vytvoření seskupení). Ve výchozím nastavení je název skupiny shodný s názvem pole, které jste zvolili pro seskupení.

Navigátor sestavy: Skupiny -> "Název skupiny" -> záložka Obecné

Držet pohromadě Zvolte ano
Založení nového sloupce Zvolte ne
Obnovení čísla stránky Zvolte ne

Navigátor sestavy: Skupiny -> "Název skupiny" -> Funkce

Viz výše v kapitole Navigátor ve zprávě: Funkce

Navigátor sestavy: Skupiny -> "Název skupiny" -> Záhlaví skupiny

Karta Obecné obsahuje výše uvedené parametry.

Prohlížeč sestav -> Detail

Jedná se o hlavní část zprávy. Může obsahovat další komponenty, jako jsou pole s popisky, která umožňují zadávat text do sestavy, textová pole, která umožňují zobrazovat data, ovládací prvky pro zobrazení obrázků (velmi praktické pro tvorbu trombinoskopu nebo katalogu), grafiky, čáry, tvary, které nakreslíte a umístíte na pozadí textového pole, atd... Souhrnně řečeno, tato část obsahuje údaje z databáze, které chcete zobrazit v sestavě.

Navigátor sestavy -> Zápatí sestavy

Tab : Obecné

Výše uvedené prvky umožňují konfigurovat prezentaci záhlaví sestavy.

Prohlížeč sestav -> Zápatí

Tab : Obecné

Výše uvedené prvky umožňují konfigurovat prezentaci zápatí.

Složky společné pro všechny oddíly.

Panel nástrojů Ovládací prvky sestavy -> Pole se štítkem

Tab : Obecné

Název Navrhovaný název můžete ponechat nebo jej pojmenovat jinak, abyste jej v Navigátoru odlišili.
Štítek Toto je název, který se objeví ve vydání zprávy. Můžete mu dát jednoznačnější název, než je ten navržený (název databázového pole).
Držet pohromadě Umožňuje v případě potřeby tisknout data skupiny na druhou stránku.
Pozice X Udává vzdálenost v cm mezi levým okrajem ovládacího prvku a levým okrajem stránky.
Pozice Y Udává vzdálenost v cm mezi horním okrajem ovládacího prvku a horním okrajem sekce.
Šířka Udává rozměr šířky ovládacího prvku v cm.
Výška Udává výškový rozměr ovládacího prvku v cm.
Tisk opakovaných hodnot Zvolte ano nebo ne
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Tisknout při změně skupiny Zvolte ano
Průhlednost pozadí Výběrem možnosti ne můžete nakonfigurovat barvu pozadí pro záhlaví sestavy.
Policie Zvolte nastavení
Vodorovné zarovnání Zvolte nastavení
Svislé zarovnání Zvolte nastavení

Panel nástrojů Ovládací prvky sestavy -> Formátované pole (textová oblast)

Tab : Obecné

Název Navrhovaný název můžete ponechat nebo jej pojmenovat jinak, abyste jej v Navigátoru odlišili.
Pozice X Udává vzdálenost v cm mezi levým okrajem ovládacího prvku a levým okrajem stránky.
Pozice Y Udává vzdálenost v cm mezi horním okrajem ovládacího prvku a horním okrajem sekce.
Šířka Udává rozměr šířky ovládacího prvku v cm.
Výška Udává výškový rozměr ovládacího prvku v cm.
Tisk opakovaných hodnot Zvolte ano nebo ne
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Tisknout při změně skupiny Zvolte ano
Průhlednost pozadí Výběrem možnosti ne můžete nakonfigurovat barvu pozadí pro záhlaví sestavy.
Policie Zvolte nastavení
Vodorovné zarovnání Zvolte nastavení
Svislé zarovnání Zvolte nastavení
Formátování Zvolte parametry, zejména zda chcete zobrazit měnu nebo datum.

Tab : Data

Typ datového pole Vyberte typ datového pole:

Pole nebo vzorec: musíte vybrat pole nebo vzorec. Funkce: budete muset zvolit typ funkce. Počítadlo: budete muset zvolit, zda se vztahuje na skupinu, nebo na celou sestavu. Uživatelsky definovaná funkce: budete muset vybrat funkci z těch, které jste vytvořili.

Datové pole Vyberte datové pole databáze nebo vzorec. Chcete-li například vytisknout logická pole ve formě zaškrtnutých/odškrtnutých políček, vzorec bude IF ([Boolean]; "U+E531"; "U+E470") pro logická pole Boolean z tabulky nebo dotazu, který byl použit k vytvoření sestavy.
Funkce Zvolte funkci:

Akumulace sečte data vybraného pole.

Oblast působnosti Použít funkci na skupinu nebo na celou zprávu podle vašeho výběru.

Panel nástrojů Ovládací prvky sestavy -> Obrázek

Tab : Obecné

Název Navrhovaný název můžete ponechat nebo jej pojmenovat jinak, abyste jej v Navigátoru odlišili.
Směr textu Navrhovanou verzi můžete ponechat nebo ji upravit.
Ponechat jako odkaz volbou neintegrovat obrázek do dokumentu (výhoda: přenositelnost; nevýhoda: zvýšení objemu dat).
Viditelné Vyberte ano nebo ne podle toho, co chcete
Pozice X Udává vzdálenost v cm mezi levým okrajem ovládacího prvku a levým okrajem stránky.
Pozice Y Udává vzdálenost v cm mezi horním okrajem ovládacího prvku a horním okrajem sekce.
Šířka Udává rozměr šířky ovládacího prvku v cm.
Výška Udává výškový rozměr ovládacího prvku v cm.
Tisk opakovaných hodnot Zvolte ano nebo ne
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Tisknout při změně skupiny Zvolte ano
Průhlednost pozadí Výběrem možnosti ne můžete nakonfigurovat barvu pozadí pro záhlaví sestavy.
Svislé zarovnání Zvolte nastavení
Obrázky Vyberte obrázek, který chcete vložit
Upravit velikost Vyberte parametr, aby se obrázek přizpůsobil nebo nepřizpůsobil velikosti ovládacího prvku.

Tab : Data

Typ datového pole Zvolte Pole nebo vzorec, pokud chcete mít pro každou položku v sekci Detail jiný obrázek (např. katalog, trombinoskop).
Datové pole Vyberte datové pole databáze, které obsahuje obrázky <OBJECT>.
Funkce
Oblast působnosti

Panel nástrojů Ovládací prvky sestavy -> Diagram

Tab : Obecné

Název Navrhovaný název můžete ponechat nebo jej pojmenovat jinak, abyste jej v Navigátoru odlišili.
Pozice X Udává vzdálenost v cm mezi levým okrajem ovládacího prvku a levým okrajem stránky.
Pozice Y Udává vzdálenost v cm mezi horním okrajem ovládacího prvku a horním okrajem sekce.
Šířka Udává rozměr šířky ovládacího prvku v cm.
Výška Udává výškový rozměr ovládacího prvku v cm.
Tisk opakovaných hodnot Zvolte ano nebo ne
Podmíněný tiskový výraz V případě potřeby zvolte podmínky
Tisknout při změně skupiny Zvolte ano
Typ diagramu

Výchozí typ histogramu můžete změnit na jiný typ grafu.

Přehled linek Výběr parametrů
Policie Budete moci nastavit písmo a jeho styly.
Zarovnání horizontální/vertikální Výběr parametrů pro umístění diagramu

Tab : Data

Typ obsahu Výběr typu zdroje dat
Obsah Zvolte název zdroje
Analýza příkazu SQL Ano nebo ne v závislosti na zdroji
Filtrování Aktivujte, pokud chcete nakonfigurovat filtr.
Třídění Vyberte požadované pole a typ třídění
Pole hlavního odkazu Vyberte požadované pole
Pole podřízených odkazů Vyberte požadované pole

Panel nástrojů Ovládací prvky sestavy -> Pevný řádek

Tab : Obecné

Název Navrhovaný název můžete ponechat nebo jej pojmenovat jinak, abyste jej v Navigátoru odlišili.
Viditelné Vyberte ano nebo ne podle toho, co chcete
Pozice X Udává vzdálenost v cm mezi levým okrajem ovládacího prvku a levým okrajem stránky.
Pozice Y Udává vzdálenost v cm mezi horním okrajem ovládacího prvku a horním okrajem sekce.
Šířka Udává rozměr šířky ovládacího prvku v cm.
Výška Udává výškový rozměr ovládacího prvku v cm.
Svislé zarovnání Zvolte nastavení
Orientace Zvolte, zda chcete mezi dvěma okraji vodorovnou čáru, nebo svislou čáru mezi dvěma oddíly.

Nápověda k syntaxi

syntaxe Report Builder naleznete na francouzské wiki stránce AOO.

Vestavěné funkce

Funkce nástroje Report Builder naleznete na francouzské wiki stránce AOO.

Příklady použití nástroje Report Builder

Několik příkladů použití nástroje Report Builder je k dispozici zde forum podle návrhů různých uživatelů OpenOffice.org i LibreOffice.

Pro vyhledání daného slova, výrazu nebo termínu můžete použít vyhledávání ve fóru. Můžete například vyhledávat zde bool v sekci fóra věnované otázkám na základnu.