Domande frequenti - Base

From The Document Foundation Wiki
< Faq‎ | Base
Jump to navigation Jump to search
This page is a translated version of the page Faq/Base/118 and the translation is 100% complete.
Other languages:
English • ‎Nederlands • ‎dansk • ‎français • ‎italiano • ‎čeština

Tutorial sull'uso di Progettazione di un rapporto

Il tutorial di Progettazione rapporto, inclusi gli screenshot, è disponibile in un formato stampabile o scaricabile qui (attualmente solo in francese, in attesa di traduzione):

Esercitazione guidata creazione report (in francese)

Se scegliete di visualizzare il documento nel vostro browser, attendete qualche istante affinché si carichi.

Perché dovrei usare un rapporto?

Alcune persone ritengono che l'unica ragione per avere un report sia formattare i dati da un database in modo che possa essere stampato.

Un progettista di rapporti, tuttavia, fornisce all'utente una serie di strumenti essenziali per sfruttare i dati memorizzati in un database. Permette di presentare i dati in dettaglio in vari modi. Un esempio potrebbe essere quello di seguire il tempo trascorso su un progetto, visualizzare i profitti dell'ultima settimana o verificare quale sia il cliente più redditizio. I report possono, ad esempio, essere utilizzati per creare fatture pronte per l'invio. Se state studiando una lingua straniera, possono essere utilizzati per stampare un elenco di vocaboli relativi a un determinato campo o per registrare i vostri progressi nell'apprendimento di quel vocabolario. Un'altra idea potrebbe essere quella di seguire le vostre creazioni o progetti, attraverso l'uso di un semplice database, e quindi tramite il Creatore di rapporti, creando un tipo di catalogo o documento di brochure contenente illustrazioni e testo. In altre parole, i rapporti possono essere utilizzati per vari scopi.

Il creatore di rapporti consente di accedere a una serie di strumenti utili che consentono di creare rapporti elaborati: sono presenti opzioni di ordinamento e raggruppamento avanzate, nonché la possibilità di utilizzare ricerche, istruzioni e funzioni SQL. Il creatore di rapporti semplifica notevolmente l'ideazione e la progettazione di rapporti complessi con la funzionalità di trascinamento della selezione. Inoltre, il Creatore di rapporti consente all'utente di inserire grafici e immagini.

Configurazione richiesta

Il creatore di rapporti è integrato in LibreOffice per impostazione predefinita. È comunque scritto nel linguaggio di programmazione Java, e quindi richiede che il computer su cui viene eseguito non abbia solo un Java Runtime Environment (JRE) preinstallato, ma che LibreOffice sia configurato per riconoscere quel JRE per poterlo usare.

Nel sottomenu Strumenti -> Opzioni -> LibreOffice -> Java (su Mac, si trova nel sottomenu LibreOffice -> Preferenze), verifica che sia stato trovato e riconosciuto un ambiente runtime Java e che sia stato spuntato il corrispondente pulsante di opzione / attivato, per il JRE che avete scelto. Se nessun JRE appare nella finestra di dialogo, allora la vostra versione di JRE non viene riconosciuta da LibreOffice, altrimenti non avete un JRE installato e dovrete scaricarlo e installarlo di conseguenza dal sito di download di JRE.

Installare il creatore di rapporti

Il creatore di rapporti è in realtà un'estensione fornita con l'installazione predefinita di LibreOffice, almeno per Windows e Mac. Alcune distribuzioni Linux, per le proprie versioni di LibreOffice, forniscono ancora questa estensione come componente separato che potrebbe essere necessario installare con il sistema di gestione dei pacchetti di quella distribuzione.

L'interfaccia del creatore di rapporti

Il database di esempio utilizzato per la presente esercitazione è stato ottenuto utilizzando la Creazione guidata tabella predefinita fornita e scegliendo HouseholdInventory dall'elenco Personale dei database suggeriti.

Barre degli strumenti del creatore di rapporti

Barra degli strumenti dei controlli dei rapporti

La barra degli strumenti dei controlli dei rapporti contiene una serie di pulsanti che possono essere utilizzati per aggiungere campi, etichette, immagini (immagini, loghi, foto, ecc.) e grafici al rapporto.

barra degli strumenti principale

La barra degli strumenti principale consente l'aggiunta di campi a un report, l'attivazione o disattivazione del navigatore nel report e la gestione delle opzioni di ordinamento e raggruppamento.*


Barra degli strumenti di allineamento

La barra degli strumenti di allineamento viene utilizzata per posizionare i campi e altri elementi all'interno del rapporto.*

Menu

Il menu dà accesso agli altri moduli di LibreOffice. Due funzioni verranno qui menzionate più in dettaglio: Inserisci per inserire immagini nel report e Formato per utilizzare le possibilità di formattazione condizionale per un dato campo.

Pagina report predefinita

La pagina predefinita visualizzata all'avvio del costruttore di report è divisa in 3 parti: Intestazione pagina, Dettagli e Piè di pagina.

Pannelli strumenti mobile

Aggiungere pannello campo

Questo pannello viene utilizzato per aggiungere un campo database al report tramite trascinamento della selezione o tramite il menu Inserisci.

Pannello di ordinamento e raggruppamento

Questo pannello viene utilizzato per gestire le opzioni di ordinamento e raggruppamento per i vari elementi del report.

Pannello del navigatore del report

Questo pannello consente a un utente di navigare nel documento del report tramite una gerarchia di elenchi di oggetti orientata ad albero. Facendo doppio clic su una delle voci nell'elenco del navigatore si evidenzierà quell'elemento nel documento del report per la selezione o la modifica.

Pannello delle proprietà

Questo pannello consente a un utente di modificare le proprietà del controllo, dell'elemento o dell'oggetto attualmente selezionato.

Ad esempio, quando si seleziona un campo in un report, è possibile utilizzare il pannello delle proprietà per definire l'origine dei dati per quel campo e anche altre proprietà come l'altezza e la larghezza dell'elemento, la sua posizione, la formattazione, ecc ...

Questo pannello consente anche di scegliere il tipo di documento da utilizzare come formato di output per il report: un documento Writer (ODT) o un documento Calc (ODS).

Creazione di un rapporto

Creazione di un raggruppamento

Per creare un report che raggruppa i dati, è necessario aggiungere una nuova sezione Intestazione di raggruppamento, scegliendo il campo su cui raggruppare tramite il pulsante, il pannello Ordinamento e raggruppamento o la voce corrispondente nel Navigatore report (nella presente esempio, abbiamo utilizzato il campo DatePurchased). Scegliete le opzioni di ordinamento desiderate (crescente o decrescente) e quindi Presenta negli elenchi a discesa Intestazione di gruppo e Piè di pagina di gruppo.

Utilizzate il pannello Aggiungi campo per posizionare il campo raggruppato all'interno della sezione Intestazione gruppo. Potete quindi utilizzare le varie opzioni di formattazione disponibili sotto la voce Generale del pannello Proprietà per formattare il campo come desiderate.

Sezione Dettagli

La sezione dettagli è progettata per visualizzare un elenco di dati dal database. Utilizzando il pannello Aggiungi campo, aggiungete i campi che desiderate utilizzare nel vostro rapporto nella sezione dettagli. L'allineamento del campo e dell'etichetta può essere leggermente difficoltoso, quindi usate la barra degli strumenti di allineamento per dare semplificare. Potrete vedere come sarà il vostro rapporto finale facendo clic sul pulsante Esegui rapporto nella barra degli strumenti principale.

Creazione di un campo calcolato

a piè di pagina :

Sebbene sia possibile utilizzare il rapporto così come è stato appena creato, può anche essere migliorato. Ad esempio, potreste voler aggiungere un campo che calcoli la somma dei valori per ogni gruppo di dati o per ottenere un totale complessivo.

Per ottenere un totale complessivo, fate clic sul pulsante Area di testo nella barra degli strumenti dei controlli del report e tracciate un'area con il mouse nella sezione Piè di pagina del report. Nel pannello Proprietà di questo nuovo elemento del report, fate clic sulla scheda Dati e impostate le seguenti opzioni:

Tipo di dati del campo

Funzione

Campo

PrezzoDiAcquisto

Funzione

Accumulo

Estensione

Rapporto

nella sezione Piè di pagina del gruppo :

Per aggiungere un campo che calcoli la somma dei valori per ogni gruppo, dovete prima, se non lo avete già fatto, inserire una sezione Piè di pagina del gruppo. Quindi disegnate un campo nella sezione Piè di pagina gruppo e scegliete le seguenti opzioni :

Tipo di campo dati

Funzione

Campo dati

PrezzoDiAcquisto

Funzione

Accumulo

Estensione

Gruppo DataDiAcquisto

Inserimento di un diagramma

È anche possibile inserire un diagramma, ad esempio, per mostrare una linea di tendenza dei dati indicizzati al raggruppamento. Per fare ciò, dovete prima creare una query per estrarre i dati richiesti dal database per poterli fornire per il diagramma grafico.

Chiudete il rapporto, quindi fate clic su Query nel file del database ODB aperto. Create una nuova query. Scegliete la tabella o le tabelle contenenti i dati da estrarre e aggiungete i campi alla query. Nel presente esempio, abbiamo utilizzato i campi DataDiAcquisto e PrezzoDiAcquisto. Nei criteri della funzione della tua query, scegliete Gruppo per il campo Data di acquisto e Somma per il campo Prezzo d'acquisto.

Salvate la query e aprite il rapporto in modalità Modifica per modificarlo. Fate clic sul pulsante Diagramma nella barra degli strumenti principale e disegnate con il mouse un'area nella sezione Piè di pagina per contenere il grafico. Nel pannello Proprietà, nella scheda Dati, scegliete la query appena creata come origine dati.

Se il corrispondente grafico dell'istogramma predefinito non è quello che desiderate, modificate le sue proprietà facendo doppio clic sul grafico, entrando così in modalità di modifica per il grafico. È quindi possibile modificare il grafico dell'istogramma predefinito con uno più adatto alle proprie esigenze, ad esempio un grafico 3D.

Esempio di grafico in un report

Inserimento di un'immagine o di un logo nell'intestazione del rapporto

Ciò si ottiene tramite il menu Inserisci. Un'immagine così inserita apparirà in ogni pagina del rapporto.

Formattazione condizionale di un campo calcolato

Per fare ciò, dovete prima selezionare il vostro campo nel rapporto mentre siete in modalità Modifica. Quindi, dal menu principale, fate clic su Formato > Formattazione condizionale.

Nel nostro esempio, l'alias per la query utilizzata per creare il report viene visualizzato tra parentesi ai fini della formattazione condizionale.

Esempio di un rapporto di un database con formattazione del campo condizionale

Una volta acquisiti i principi fondamentali dell'utilizzo di Report Designer, sarete in grado di utilizzare tutte le sue funzionalità per formattare i dati forniti dal vostro database per creare rapporti sorprendenti.

Navigatore rapporti

Questo può essere raggiunto utilizzando il tasto funzione F5 o facendo clic sul pulsante corrispondente nella barra degli strumenti principale. Visualizza tutti gli elementi e gli oggetti contenuti in un report. È inoltre disponibile un aiuto contestuale per le varie voci della gerarchia dell'elenco ad albero, semplicemente premendo il tasto funzione F1 dopo aver selezionato una voce.

L'elenco completo degli elementi gerarchici contenuti all'interno di un rapporto può essere visualizzato facendo clic sul piccolo "segno più" o freccia che compare davanti a una voce. Se non c'è tale segno o freccia, allora quell'elemento non ha elementi figli.

Navigatore rapporto -> Rapporto

Scheda : Generale

I seguenti elementi vi consentono di configurare i parametri di visualizzazione per il vostro rapporto:

Nome Questo è il nome che hai dato al tuo report, apparirà nel Navigatore rapporti una volta premuto invio dopo aver digitato il nome e convalidato.
Intestazione di pagina qui potete scegliere di abilitare/disabilitare la stampa dal menu a tendina del contenuto inserito nell'Intestazione di pagina
Piè di pagina qui potete scegliere di abilitare/disabilitare la stampa dal menu a tendina del contenuto inserito nel Piè di pagina
Stampa valori ripetuti

Scheda : Dati

I seguenti elementi vi consentono di configurare i parametri di visualizzazione per il vostro rapporto:

Tipo di contenuto

Scegli il tipo di dati da utilizzare: tabella, query salvata o query SQL diretta

Contesto

Scegliete il nome dell'origine dati

Analizza SQL

sì o no, a seconda di come accedete ai vostri dati. Scegliere "sì" equivale ad attivare la funzionalità del parser SQL nativo in modalità di progettazione query. Scegliendo "no" si disattiva il parser SQL nativo di LO e passa l'istruzione di query direttamente al driver del database. Ciò è necessario per alcune funzioni avanzate del database e per i backend del server e dipende dal motore del database utilizzato.

Filtro

scegliete sì o no a seconda dell'origine dati

Formato di visualizzazione del rapporto

Scegliete Foglio di calcolo ODF se dovete applicare una gestione matematica più avanzata dei risultati dei dati del vostro rapporto, altrimenti scegli Testo ODF.

Browser dei rapporti -> Funzioni

Sarete in grado di creare le funzioni che utilizzerete poi nel rapporto. Per creare una nuova funzione, fate clic su Funzione, quindi fate clic con il pulsante destro del mouse su Nuova funzione. Per accedere ad altri esempi, seguite i collegamenti alla fine di questa pagina.

Nome Assegnate un nome esplicito alla vostra funzione, senza spazi tra le parole (es: SommaAcquisti)
Formula Cliccando sui 3 puntini si avvia la procedura guidata per la creazione delle formule.

Potete anche inserire direttamente la vostra formula. Ad esempio, per calcolare una somma di più valori, la sintassi sarà: [NomeDelValoreIniziale] + [NomeDellaFunzione] (es: [PrezzoDiAcquisto] + [SommaAcquisti]

Valore iniziale Inserite tra parentesi quadre il nome del campo su cui si applicherà la funzione (es: [PrezzoAcquisto])
Corso profondo Azione non indicata nella guida originale
Pre-valutazione Scegliendo sì, il report verrà calcolato durante la sua creazione. Questa azione consuma risorse e potreste preferire non attendere la fine della creazione del report per eseguire tutti i calcoli

Navigatore rapporti -> Intestazione di pagina

Scheda: Generale

I seguenti elementi consentono di configurare la presentazione del rapporti:

Nome

Potete mantenere l'intestazione del rapporto o nominarla in modo diverso

Visibile

Scegli sì per visualizzare il contenuto dell'intestazione

Altezza Potete inserire la dimensione dell'altezza o modificarla utilizzando il mouse direttamente nella pagina del report in modalità Modifica
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Trasparenza dello sfondo

Scegliendo no, sarete in grado di configurare un colore di sfondo per l'intestazione della pagina

Browser dei rapporti -> Intestazione del rapporto

Scheda: Generale

I seguenti elementi consentono di configurare la presentazione dell'intestazione del rapporto:

Nome

Potete mantenere l'intestazione del rapporto o nominarla in modo diverso

Forza una nuova pagina Scegliete Nessuno se non desiderate creare una pagina diversa per dati o raggruppamento di dati. Altrimenti scegliete la creazione di una nuova pagina secondo le vostr impostazioni di layout desiderate, ad esempio Dopo la sezione
Tenere insieme Consente la stampa dei dati del gruppo su una seconda pagina, se necessario
Visibile In generale, potrete rispondere sì
Altezza Potrete inserire la dimensione dell'altezza o modificarla utilizzando il mouse direttamente nella pagina del report in modalità Modifica
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Trasparenza dello sfondo Scegliendo no, sarete in grado di configurare un colore di sfondo per l'intestazione della pagina

Navigatore rapporti: Gruppi -> Pannello Ordinamento e raggruppamento

Potete configurare come raggruppare i dati dal database nel rapporto utilizzando il pannello Ordinamento e raggruppamento (vedi sopra: Creazione di un raggruppamento). Per impostazione predefinita, il nome del gruppo è quello del campo che avete scelto per il Raggruppamento.

Navigatore rapporti: Gruppi -> "Nome gruppo" -> scheda Generale

Tenere insieme Scegliete sì
Inizia una nuova colonna Scegliete no
Ripristina il numero di pagina Scegliete no

Navigatore rapporti: Gruppi -> "Nome gruppo" -> Funzioni

Vedi sopra, nel capitolo Navigatore della relazione: Funzioni

Navigatore rapporti: Gruppi -> "Nome gruppo" -> Gruppo intestazione

La scheda Generale contiene i parametri visti sopra.

Navigatore dei rapporti -> Dettagli

È il corpo principale del rapporto. Può contenere altri componenti come campi etichetta che consentono di inserire testo nel referto, caselle di testo che consentono la visualizzazione dei dati, controlli per visualizzare immagini (molto pratici per realizzare un trombinoscopio o un catalogo), grafici, linee, forme che disegnerai e posizionerai sullo sfondo di una casella di testo, ecc... In sintesi, questa sezione contiene i dati del database che volete vedere nel vostro rapporto.

Navigatore rapporti -> Rapporto piè di pagina

Scheda : Generale

I seguenti elementi consentono di configurare la presentazione dell'intestazione del rapporto.

Navigatore dei rapporti -> Piè di pagina

Scheda: Generale

I seguenti elementi consentono di configurare la presentazione del piè di pagina.

Componenti comuni a tutte le sezioni.

Barra degli strumenti dei controlli del rapporto -> Campo etichetta

Scheda: Generale

Nome Potete mantenere quella proposta o nominarla diversamente per distinguerla nel Navigatore
Etichetta Questo è il nome che apparirà nell'edizione del rapporto. Potete dargli un nome più esplicito di quello proposto (il nome del campo del database)
Tenere insieme Consente la stampa dei dati del gruppo su una seconda pagina, se necessario
Posizione X Indica la distanza in cm tra il bordo sinistro del controllo e il margine sinistro della pagina
Posizione Y Indica la distanza in cm tra la parte superiore del comando e la parte superiore della sezione
Larghezza Indica in cm la dimensione della larghezza del controllo
Altezza Indica in cm la dimensione della larghezza del controllo
Stampa valori ripetuti Scegliete sì o no
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Stampa quando il gruppo cambia Scegliete sì
Trasparenza dello sfondo Scegliendo no, sarete in grado di configurare un colore di sfondo per l'intestazione del rapporto
Polizia Scegliete impostazioni
Allineamento orizzontale Scegliete impostazioni
Allineamento verticale Scegliete impostazioni

Barra degli strumenti dei controlli del rapporto -> Campo formattato (area di testo)

Scheda: Generale

Nome Potete mantenere quella proposta o nominarla diversamente per distinguerla nel Navigatore
Posizione X Indica la distanza in cm tra il bordo sinistro del controllo e il margine sinistro della pagina
Posizione Y Indica la distanza in cm tra la parte superiore del comando e la parte superiore della sezione
Larghezza Indica in cm la dimensione della larghezza del controllo
Altezza Indica in cm la dimensione della larghezza del controllo
Stampa valori ripetuti Scegliete sì o no
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Stampa quando il gruppo cambia Scegliete sì
Trasparenza dello sfondo Scegliendo no, sarete in grado di configurare un colore di sfondo per l'intestazione del rapporto
Polizia Scegliete impostazioni
Allineamento orizzontale Scegliete impostazioni
Allineamento verticale Scegliete impostazioni
Formattazione Scegliete i parametri, in particolare se volete una visualizzazione particolare della valuta, o la data

Scheda: Dati

Tipo di campo dati Scegliete il tipo di campo dati:

Campo o formula: dovrete scegliere il campo o la formula Funzione: dovrete scegliere il tipo di funzione Contatore: dovrete scegliere se vale per il gruppo o per l'intero rapporto Funzione definita dall'utente: dovrete scegliere una funzione tra quelle che avete creato

Campo dati Sceglete il campo dati del database o la formula. Ad esempio, per stampare i campi booleani sotto forma di caselle selezionate/deselezionate, la formula sarà IF ([Boolean];"U+E531";"U+E470") per i campi booleani Boolean dalla tabella o dalla query che è stata utilizzata per creare il rapporto
Funzione Scegliete la funzione:

l'accumulo sommerà i dati del campo selezionato

Intervallo Applicate la funzione a un Gruppo o all'intero rapporto secondo la vostra scelta

Barra degli strumenti dei controlli del rapporto -> Immagine

Scheda: Generale

Nome Potete mantenere quella proposta o nominarla diversamente per distinguerla nel Navigatore
Direzione del testo Potrete mantenere quello proposto o modificarlo
Mantieni come link Scegliendo no l'immagine viene integrata nel documento (vantaggio: portabilità; svantaggio: aumento di peso)
Visibile Scegliete sì o no a seconda di quello che desiderate
Posizione X Indica la distanza in cm tra il bordo sinistro del controllo e il margine sinistro della pagina
Posizione Y Indica la distanza in cm tra la parte superiore del comando e la parte superiore della sezione
Larghezza Indica in cm la dimensione della larghezza del controllo
Altezza Indica in cm la dimensione della larghezza del controllo
Stampa valori ripetuti Scegliete sì o no
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Stampa quando il gruppo cambia Scegliete sì
Trasparenza dello sfondo Scegliendo no, sarete in grado di configurare un colore di sfondo per l'intestazione del rapporto
Allineamento verticale Scegliete impostazioni
Immagini Selezionate l'immagine che volete inserire
Aggiusta le dimensioni Selezionate il parametro in modo che l'immagine si adatti o meno alla dimensione del controllo

Scheda: Dati

Tipo di campo dati Scegliete Campo o formula se volete avere un'immagine diversa per ogni articolo nella sezione Dettagli (es. catalogo, trombinoscopio))
Campo dati Scegliete il campo dati del database che contiene le immagini <OBJECT>
Funzione
Intervallo

Barra degli strumenti dei controlli del rapporto -> Diagramma

Scheda: Generale

Nome Potete mantenere quella proposta o nominarla diversamente per distinguerla nel Navigatore
Posizione X Indica la distanza in cm tra il bordo sinistro del controllo e il margine sinistro della pagina
Posizione Y Indica la distanza in cm tra la parte superiore del comando e la parte superiore della sezione
Larghezza Indica in cm la dimensione della larghezza del controllo
Altezza Indica in cm la dimensione della larghezza del controllo
Stampa valori ripetuti Scegliete sì o no
Espressione di stampa condizionale Scegliete le condizioni se applicabili
Stampa quando il gruppo cambia Scegliete sì
Tipo di diagramma

Potete cambiare il tipo di istogramma predefinito con un altro tipo di diagramma

Anteprima linea Scegliete i parametri
Polizia Potete configurare un carattere e i suoi stili
Allineamento orizzontale/verticale Selezionate i parametri per posizionare il diagramma

Scheda: Dati

Tipo di contenuto Scegliete il tipo di origine dati
Contesto Scegliete il nome della sorgente
Analizza le istruzioni SQL Sì o no dipende dalla sorgente
Filtrato Attivatelo se volete configurare un filtro
Ordinamento Scegliete il campo e il tipo di ordinamento desiderati
Campo collegamento principale Scegliete il campo desiderato
Collega campi secondari Scegliete il campo desiderato

Barra degli strumenti dei controlli del rapporto -> Linea fissa

Scheda: Generale

Nome Potete mantenere quella proposta o nominarla diversamente per distinguerla nel Navigatore
Visibile Scegliete sì o no a seconda di quello che desiderate
Posizione X Indica la distanza in cm tra il bordo sinistro del controllo e il margine sinistro della pagina
Posizione Y Indica la distanza in cm tra la parte superiore del comando e la parte superiore della sezione
Larghezza Indica in cm la dimensione della larghezza del controllo
Altezza Indica in cm la dimensione della larghezza del controllo
Allineamento verticale Scegliete impostazioni
Orientamento Scegliete se volete una linea orizzontale tra i due margini o verticale tra due sezioni

Guida alla sintassi

Vedere la pagina wiki francese di AOO per la sintassi di Report Builder.

Funzioni integrate

Vedere la pagina wiki AOO francese per le funzioni di Report Builder.

Esempi di utilizzo del Generatore di report

Diversi esempi di utilizzo di Generatore di rapporti sono disponibili qui forum come proposto da vari utenti sia di OpenOffice.org che di LibreOffice.

Potete utilizzare una ricerca all'interno del forum per cercare una determinata parola, espressione o termine. Ad esempio, puoi cercare qui bool nella sezione del forum dedicata alle domande Base.