Faq/Base/118/fr

From The Document Foundation Wiki
< Faq‎ | Base‎ | 118
Jump to: navigation, search

Contents

Tutoriel de l'Assistant de création de rapport

Le tutoriel de l'Assistant de création de rapport, ou pour imprimer une version "papier", avec les copies d'écran pour en faciliter l'usage, est à cette adresse : Tutoriel de l'Assistant de création de rapport.

Si vous avez choisi l'affichage dans votre navigateur internet, patientez quelques secondes pour le chargement.

Des rapports : pour quoi faire ?

Peut-être pensez-vous, et c'est légitime, que le seul intérêt des rapports est la mise en forme des enregistrements d'une base de données pour l'impression.

Un éditeur de rapports fournit pourtant des outils essentiels à l'exploitation pratique des données. Il permet de détailler et d'afficher les données de manières très variées. Par exemple, il est possible de suivre le temps passé sur un projet, afficher les gains d'un mois donné ou encore vérifier quel est son meilleur client grâce aux rapports. Les rapports peuvent être utilisés pour établir des factures prêtes à l'envoi. Si vous étudiez une langue étrangère, il est possible d'utiliser les rapports pour imprimer une liste de vocabulaire relative à un domaine précis et pour enregistrer vos progrès. Vous pouvez encore créer une base de données élémentaire pour le suivi de vos réalisations et, grâce à l'éditeur de rapport, en extraire une édition illustrée et professionnelle. En d'autres termes, vous pouvez utiliser les rapports pour une grande variété de tâches.

L'Assistant de Rapport permet l'utilisation d'un grand nombre d'outils ingénieux autorisant la conception de rapports élaborés : des options avancées de tri et de groupement ainsi que la possibilité d'utiliser des requêtes SQL et des fonctions. L'Assistant de Rapport facilite de manière significative la conception de rapports complexes grâce au glisser-déposer. Enfin, l'Assistant de Rapport rend possible l'insertion de graphiques.

Configuration requise

L'Assistant de création de Rapport est intégré à LibreOffice. Comme l'Assistant de création de Rapport est écrit en Java, il vous faudra également vérifier que l'environnement d'exécution Java (JRE : Java Runtime Environment) est bien installé sur votre ordinateur et que LibreOffice est correctement configuré pour l'utiliser.

Dans le menu Outils > Options > LibreOffice > Java, assurez-vous que l'option Utiliser un environnement d'exécution Java est cochée et qu'un JRE est sélectionné dans la liste des JRE installés. Si cette liste est vide, il vous faudra installer le JRE disponible en téléchargement sur le site de téléchargement du JRE.

Installer l'Assistant de création de Rapport

L'assistant de création de Rapport étant une extension de LibreOffice, son installation est faite par défaut.

Il est cependant possible de la télécharger sur le site des extensions LibreOffice.

L'interface de l'Assistant de création de Rapport

La base exemple utilisée ici est celle que vous obtenez en utilisant l'Assistant de création d'une table InventaireBiens dans la liste des applications personnelles.

Les barres d'outils

La barre d'outil des Contrôles de rapport

La barre d'outil des Contrôles de rapport contient des boutons que vous pouvez utiliser pour ajouter des champs, des étiquettes, des images (images, logos, photos) et des graphiques au rapport.

La barre d'outil principale

La barre d'outil principale vous permet d'ajouter des Champs, d'activer le Navigateur du rapport et de créer ou de modifier les Tris et Groupements.

La barre d'outils d'Alignement

La barre d'outils Alignement vous aide à positionner les champs et d'autres éléments (formes, images, etc.) dans le rapport.

Le Menu

Le menu affiche les icônes des modules de LibO. Deux fonctionnalités seront détaillées plus loin : Insertion pour l'insertion d'images dans le Rapport et Format pour le formatage conditionnel d'un champs sélectionné.

La page de rapport par défaut

La page de rapport est, par défaut, divisée en trois sections : En-tête de Page, bloc Détail et Pied de Page.

Les panneaux

Le panneau Ajouter un champ

Le panneau Ajouter un champ vous permet de les insérer rapidement sur le rapport par glisser-déposer ou en cliquant sur Insérer.

Le panneau Tri et groupement

Le panneau Tri et groupement peut être utilisé pour grouper et classer les éléments du rapport.

Le panneau Navigateur du Rapport

Le panneau Navigateur du Rapport vous permet de localiser et sélectionner un élément particulier du rapport.

Le panneau Propriétés

Le panneau Propriétés vous permet de spécifier les propriétés du contrôle que vous avez sélectionné.

Par exemple, lorsque vous choisissez un champ, vous pouvez utiliser le panneau de Propriétés pour spécifier la source de données du champ et les propriétés comme la hauteur, la position, le format, etc.

Vous pouvez aussi sélectionner le format du document de sortie du Rapport : soit un format Texte.odt soit un format Calc.ods, ce qui peut vous permettre des traitements supplémentaires.

La création d'un rapport

La création d'un groupement

Pour créer un rapport qui regroupe les données déterminées pour ce rapport, vous devrez ajouter une nouvelle section d'En-tête de groupe en choisissant le champ de groupement dans la fenêtre de Tri et groupement (DateAchat dans la base exemple). Spécifiez l'option de classement désirée (croissant ou décroissant) et choisissez Présent dans la liste déroulante aussi bien pour l'En-tête que pour le Pied de page de groupe. Utilisez la fenêtre Ajouter un champ pour placer le champ de groupement à l'intérieur de la section d'En-tête de groupe. Vous pouvez alors utiliser les options de formatage disponibles sous l'étiquette générale dans la fenêtre de Propriétés pour formater le champ selon vos souhaits.

La section Détail

La section Détail de la page est conçue pour afficher une liste de données issues de la base de données (Table, Vue, Requête, code SQL). En utilisant le panneau Ajouter un champ, ajoutez les champs désirés dans la section Détail. L’alignement des champs et des étiquettes dans les rapports peut être un peu délicat, et vous pouvez vous aider de la barre d'outils Alignement des champs. Vous pouvez avoir une édition du rapport en appuyant sur le bouton Exécuter le rapport dans la barre d'outil Principale.

La création d'un champ de calcul

dans le pied de page du rapport

Bien que vous puissiez utiliser le rapport comme vous l'avez créé, vous pouvez l'améliorer. Par exemple, vous pourriez vouloir ajouter un champ qui calcule la somme des valeurs pour chaque groupe de données ou le total général.

Commençons avec le total général. Cliquez sur le bouton Zone de texte dans la barre d'outil de Commandes de Rapport et dessinez un champ dans la section de Pied de Page du Rapport, pour calculer le total général.

Dans la fenêtre des Propriétés, cliquez sur l'onglet des Données et choisissez les options comme suit :

Type de Champ de données

Fonction

Champ de données

PrixAchat

Fonction

Accumulation

Étendue

Rapport

dans le pied de page du Groupe

Pour ajouter un champ qui affiche la somme des valeurs pour chaque groupe, vous devez d'abord, si ce n'est pas déjà fait lorsque vous avez créé le groupement, demander qu'une section de Pied de page de Groupe soit présente. Dessinez alors un champ dans le Pied de page de Groupe et spécifiez les options du champ comme suit :

Type de Champ de données

Fonction

Champ de données

PrixAchat

Fonction

Accumulation

Étendue

Groupe DateAchat

L'insertion d'un diagramme

Vous pouvez aussi ajouter un diagramme pour afficher la courbe des données indexées sur la donnée du groupe. Pour le faire, vous devez d'abord créer une requête qui extraira les données pour le graphique.

Fermez le rapport en cours, puis cliquez sur Requête. Créez la nouvelle requête. Choisissez la table, ou les tables, contenant les données à traiter et ajoutez les champs à la requête. Dans notre exemple, il s'agira des champs DateAchat et PrixAchat. Dans la ligne Fonction, choisissez Groupe dans la colonne DateAchat et Somme dans la colonne de PrixAchat.

Sauvegardez la requête créée et ouvrez le rapport pour le modifier. Cliquez sur le bouton de Diagramme dans la barre d'outil Principale et tracez son cadre dans la section de Pied de page. Dans la fenêtre des Propriétés, dans l'onglet Données, choisissez la requête créée précédemment comme source de données. Si le graphique standard en histogramme ne correspond pas à ce que vous souhaitez, vous pouvez modifier ses propriétés, par double clic sur le graphique, en entrant dans le mode édition/modification. Vous pouvez changer le graphique en histogramme en graphique à secteurs ou en 3D.

Exemple de diagramme dans un rapport.

L'insertion d'une image ou logo dans l'En-tête du rapport

L'insertion d'une image dans l'en-tête de rapport se fait dans le menu Insertion.

L'image qui sera insérée dans l'en-tête sera imprimée sur chaque page du rapport.

Le formatage conditionnel d'un champ de calcul

Pour accéder à cette fonctionnalité, sélectionner d'abord le champ dans le Rapport en mode Édition/Modification. Puis, dans la barre de Menu, cliquer sur Format > Formatage conditionnel.

Dans cet exemple, c'est l'alias de la requête utilisée pour la création du Rapport qui est repris entre crochets pour le paramétrage du formatage conditionnel.

Exemple d'une Base avec un formatage conditionnel d'un champ.

En conclusion : dès que vous avez maîtrisé les principes fondamentaux, vous pouvez utiliser toutes les capacités de mise en forme du rapport pour mettre en évidence les données conservées dans la Base de données.

L'affichage des cases à cocher des champs booléens

Lorsque des données d'un champ booléen d'une Table de la base ont été saisies à l'aide de cases à cocher d'un formulaire, ces données s'impriment dans le Rapport sous la forme VRAI ou FAUX.

Pour des raisons de présentation du Rapport, il peut être souhaité de remplacer VRAI / FAUX par des cases cochées ou non.

Le paramétrage est à faire à la fois dans le format conditionnel et dans les propriétés du contrôle du Rapport.

Le navigateur du rapport

L'accès au Navigateur de rapport se fait soit par F5, soit en cliquant sur l'icône de la Barre d'outils principale. Il affiche tous les éléments et objets contenus dans le rapport.

De plus, l'aide de contexte est disponible pour les différents dialogues en appuyant sur F1. Pour dérouler les éléments d'un rapport, il faut cliquer sur les +.

Navigateur du rapport -> Rapport

Onglet : Général

Les éléments suivants vous permettent de paramétrer la présentation du rapport :

Nom Le nom que vous donnez à votre rapport, il apparaîtra dans le Navigateur de rapport après validation
En-tête de page choisir dans la liste déroulante si vous voulez ou non l'impression de ce que vous avez inséré dans l'en-tête de page
Pied de page choisir dans la liste déroulante si vous voulez ou non l'impression de ce que vous avez inséré dans le pied de page
Imprimer les valeurs répétées oui

Onglet : Données

Les éléments suivants vous permettent de paramétrer la présentation des données de la Base de données dans le rapport :

Type de contenu

Choisir le type de la source des données : table, requête ou commande SQL

Contenu

Choisir le nom de la source

Analyser l'instruction SQL

oui ou non en fonction de la source

Filtre

oui ou non en fonction de la source

Format de sortie du rapport

Choisir Classeur ODF si vous pensez que vous aurez à faire des traitements mathématiques sur le rapport, autrement choisissez texte ODF

Navigateur du rapport -> Fonctions

Vous allez pouvoir créer les fonctions que vous utiliserez ensuite dans le rapport. Pour créer une nouvelle fonction, cliquez sur Fonction puis clic droit Nouvelle fonction. Pour accéder à d'autres exemples, suivre les liens à la fin de cette page.

Nom Nommez votre fonction, sans espace entre les mots, de façon explicite (ex : SommeAchats)
Formule Le clic sur les 3 petits points déclenche l’Assistant de création de formules.

Vous pouvez aussi entrer votre propre formule directement. Par exemple, pour calculer une somme de plusieurs valeurs, la syntaxe sera : [NomDeLaValeurInitiale]+[NomDeLaFonction] (ex : [PrixAchat]+[SommeAchats]

Valeur initiale Vous saisissez entre crochets le nom du champ sur lequel la fonction va s'appliquer( ex : [PrixAchat])
Parcours en profondeur Action non renseignée dans le guide original
Pré-évaluation En choisissant oui, le rapport sera calculé pendant sa création. Cette action consomme de la ressource, et vous pouvez préférer non de façon à attendre la fin de la création du rapport pour effectuer tous les calculs

Navigateur du rapport -> En-tête de page

Onglet : Général

Les éléments suivants vous permettent de paramétrer la présentation du rapport :

Nom

Vous pouvez conserver En-tête de page ou nommez différemment

Visible

Choisissez oui pour visualiser le contenu de l'en-tête

Hauteur Vous pouvez saisir la dimension de la hauteur ou la modifier à l'aide de la souris directement dans la page du rapport en mode Édition
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Transparence d'arrière-plan

En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de page

Navigateur du rapport -> En-tête de rapport

Onglet : Général

Les éléments suivants vous permettent de paramétrer la présentation de l'en-tête du rapport :

Nom

Vous pouvez conserver En-tête de rapport ou nommez différemment

Forcer une nouvelle page Choisissez Aucun(e) si vous ne voulez pas créer une page différente par donnée ou groupement de données. Autrement, choisissez la création d'une nouvelle page selon vos paramètres de mise en page souhaitée, par exemple Après la section
Conserver ensemble Permet l'impression des données d'un groupe sur une deuxième page si nécessaire
Visible En général, vous répondrez oui
Hauteur Vous pouvez saisir la dimension de la hauteur ou la modifier à l'aide de la souris directement dans la page du rapport en mode Édition
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport

Navigateur du rapport : Groupes -> Panneau Tri et groupement

Vous pouvez paramétrer comment grouper des données de la base de données dans le rapport en utilisant le panneau Tri et groupement (voir plus haut : La création d'un groupement). Par défaut, le nom du groupe est celui du champ que vous avez choisi pour le Groupement.

Navigateur du rapport : Groupes -> "Nom du groupe" -> onglet Général

Conservez ensemble Choisissez oui
Démarrez une nouvelle colonne Choisissez non
Restaurer le numéro de page Choisissez non

Navigateur du rapport : Groupes -> "Nom du groupe" -> Fonctions

Voir plus haut, au chapitre Navigateur du rapport : Fonctions.

Navigateur du rapport : Groupes -> "Nom du groupe" -> Grouper l'en-tête

L'onglet Général reprend les paramètres vus plus haut.

Navigateur du rapport -> Détail

C'est le corps principal du rapport. Il peut contenir d'autres composantes comme les champs d'étiquettes qui permettent de saisir un texte dans le rapport, les zones de texte qui permettent l'affichage des données, les contrôles pour afficher des images (bien pratique pour faire un trombinoscope ou un catalogue), les graphiques, les lignes, les formes que vous dessinerez et placerez en arrière-plan d'une zone de texte, etc... En résumé, cette section contient les données de la base de données que vous voulez voir dans votre rapport.

Navigateur du rapport -> Pied de page de rapport

Onglet : Général

Les éléments vus plus haut vous permettent de paramétrer la présentation de l'en-tête du rapport.

Navigateur du rapport -> Pied de page

Onglet : Général

Les éléments vus plus haut vous permettent de paramétrer la présentation du pied de page.

Les composants communs à toutes les sections

Barre d'outils des Contrôles de rapport -> Champ d'étiquette

Onglet : Général

Nom

Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur

Étiquette

C'est le nom qui va apparaître dans l'édition du rapport. Vous pouvez lui donner un nom plus explicite que celui proposé (le nom du champ de la base de données)

Conserver ensemble Permet l'impression des données d'un groupe sur une deuxième page si nécessaire
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Police Choisissez les paramètres
Alignement horizontal Choisissez les paramètres
Alignement vertical Choisissez les paramètres

Barre d'outils des Contrôles de rapport -> Champ formaté (Zone de texte)

Onglet : Général

Nom

Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur.

Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Police Choisissez les paramètres
Alignement horizontal Choisissez les paramètres
Alignement vertical Choisissez les paramètres
Formatage Choisissez les paramètres, en particulier si vous voulez un affichage de la monnaie, ou de la date, particulier

Onglet : Données

Type de Champ de données Choisissez le type de champ des données :

Champ ou formule : vous aurez ensuite à choisir le champ ou la formule Fonction : vous aurez ensuite à choisir le type de fonction Compteur : vous aurez ensuite à choisir si celui-ci s'applique au groupe ou à tout le rapport Fonction définie par l'utilisateur : vous aurez ensuite à choisir une fonction parmi celles que vous avez créées

Champ de données Choisissez le champ de données de la base ou la formule. Par exemple, pour imprimer les champs booléens sous la forme de cases cochées/décochées, la formule sera IF([Booléen];"U+E531";"U+E470") pour les champs booléens Booléen de la table ou de la requête qui a servi à la création du rapport
Fonction Choisissez la fonction :

Accumulation fera la somme des données du champ que vous avez sélectionné

Étendue Appliquera la fonction à un Groupe ou à tout le rapport selon votre choix

Barre d'outils des Contrôles de rapport -> Image

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Direction du texte

Vous pouvez conserver celui proposé ou le modifier

Conserver comme lien En choisissant non l'image est intégrée dans le document (avantage : portabilité; inconvénient : augmentation du poids)
Visible Choisissez oui ou non selon ce que vous désirez
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Transparence d'arrière-plan En choisissant non, vous pourrez paramétrer une couleur d'arrière-plan pour l'en-tête de rapport
Alignement vertical Choisissez les paramètres
Images Sélectionnez l'image que vous voulez insérer
Adapter la taille

Sélectionnez le paramètre pour que l'image s'adapte ou non à la taille du contrôle

Onglet : Données

Type de Champ de données Choisissez Champ ou formule si vous souhaitez avoir une image différente pour chaque donnée de la section Détail (ex : catalogue, trombinoscope)
Champ de données Choisissez le champ de données de la base qui contient les images <OBJET>
Fonction
Étendue

Barre d'outils des Contrôles de rapport -> Diagramme

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Imprimer les valeurs répétées Choisir oui ou non
Expression d'impression conditionnelle Choisissez les conditions s'il y a lieu
Imprimer lorsque le groupe change Choisissez oui
Type de diagramme

Vous pouvez modifier le type Histogramme par défaut pour choisir un autre type de diagramme

Aperçu des lignes Choisissez les paramètres
Police Vous pourrez paramétrer une police de caractère et ses styles
Alignement horizontal/Vertical Sélectionnez les paramètres pour positionner le diagramme

Onglet : Données

Type de contenu Choisir le type de la source des données
Contenu Choisir le nom de la source
Analyser l'instruction SQL Oui ou non en fonction de la source
Filtre Activer si vous souhaitez paramétrer un filtre
Tri Choisissez le champ et le type de tri souhaité
Champ de lien maîtres

Choisissez le champ souhaité

Lier les champs esclaves Choisissez le champ souhaité

Barre d'outils des Contrôles de rapport -> Ligne fixe

Onglet : Général

Nom Vous pouvez conserver celui proposé ou le nommer différemment pour le distinguer dans le Navigateur
Visible Choisissez oui ou non selon ce que vous désirez
Position X Indique la distance en cm entre le bord gauche du contrôle et la marge gauche de la page
Position Y Indique la distance en cm entre le haut du contrôle et le haut de la section
Largeur Indique en cm la dimension de la largeur du contrôle
Hauteur Indique en cm la dimension de la hauteur du contrôle
Alignement vertical Choisissez les paramètres
Orientation Choisissez si vous voulez une ligne horizontale entre les deux marges, ou verticale entre deux sections


Éléments de syntaxe

Voir sur cette page.

Les fonctions

Voir sur cette page.

Des exemples

De nombreux exemples sont disponibles sur le forum des utilisateurs de OOo et de LibO. La recherche peut porter sur un terme ou une partie d'un terme. À titre d'exemple, vous pouvez faire une recherche sur bool dans la section du forum consacrée à Base pour visualiser les résultats.