Faq/Calc/141/da

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 141
Jump to: navigation, search

Hvordan bruger jeg Ikonsættet i Betinget formatering?

Vi ønsker grafisk at repræsentere en værdis relation til visse tærskler

Menuen Formater ▸ Betinget formatering lader dig sætte en betingelse af typen Alle celler ▸ Ikonsæt, sådan at du kan antyde tærsklerne med passende ikoner.

Der er flg. ikonsæt til rådighed:

  • 3, 4 eller 5 pile
  • 3, 4 eller 5 grå pile
  • 3 flag
  • 3 trafiklys 1 og 2 (to forskellige designs)
  • 3 symboler (firkant, trekant, cirkel)
  • 3 smileys
  • 3 stjerner
  • 4 cirkler fra rød til sort
  • 4 eller 5 vurderinger
  • 5 kvartaler
  • 5 bokse

Betingelser for visning af hvert ikon specificeres i forhold til en værdi (Værdi), en procentdel af antallet af værdier i området (Procentdel), som en procentdel af områdets værdier (Percentil)[1]eller formel (Formel).


Det følgende eksempel illustrerer anvendelse af 3 pile:

copie d'écran données résultat attendu
Betingede ikoner: forventet resultat

Ikoner i kolonne B repræsenterer positionen af punktet i forhold til kolonnens afrundede gennemsnit, der blev beregnet i B12 med formlen:

=AFRUND(MIDDEL($B$2:$B$10)) 

For tærskler, der refererer til resultatet af en celle (og ikke ikke til en værdi), bruger vi typen Formel:

copie d'écran données résultat attendu
Betingede ikoner: Tærskler beregnet med formel

I kolonne C repræsenterer vi udviklingen af punktet i kolonne B i forhold til den i kolonne A. Er punktet større end, lig med eller mindre end A?

Vi indfører i kolonne C en formel, der beregner forskellen mellem punkterne. Fx:

=B2-A2 

Resultatet er negativt (andet punkt er mindre end det første), lig med (identiske punkter), eller positivt (anset punkt er større end det første).

Tærsklerne kan derfor henvise direkte til en værdi og derfor bruger vi denne type:

copie d'écran données résultat attendu
Betingede ikoner: tærskler med henvisning til en værdi


Noter:

  1. En percentil er enhver af de 99 værdier, som deler de sorterede værdier i 100 lige store dele, sådan at hver del repræsenterer 1/100 af prøvepopulationen. En percentil returnerer værdien for en dataserie gående fra den mindste til den største værdi i et datasæt. For Alfa = 25, er percentilen lig med den første kvartil; Alfa = 50 er MEDIANEN.

Download et eksempel-regneark