Faq/Calc/141/fr

From The Document Foundation Wiki
< Faq‎ | Calc‎ | 141
Jump to: navigation, search

Comment utiliser le formatage conditionnel Jeu d'icônes ?

On souhaite représenter graphiquement la position d'une valeur par rapport à des seuils.

Le menu Format ▸ Formatage conditionnel permet de définir une condition de type Toutes les cellules ▸ Jeu d'icônes permettant d'indiquer les seuils et de choisir le type d'icônes.

Les jeux d'icônes disponibles sont :

  • 3, 4 ou 5 flèches
  • 3, 4 ou 5 flèches grises
  • 3 drapeaux
  • 3 feux de signalisation 1 et 2 (deux graphismes différents)
  • 3 signes (carré, triangle, rond)
  • 3 émoticônes
  • 3 étoiles
  • 4 cercles rouges à noirs
  • 4 ou 5 notes
  • 5 quartiers
  • 5 boîtes

Les conditions d'affichage de chaque icône peuvent être spécifiées par rapport à une valeur (Valeur), à un pourcentage du nombre de valeurs de la plage (Pourcentage), à un pourcentage des valeurs de la plage (Centile[1]) ou à une formule (Formule).

L'exemple suivant illustre comment mettre en œuvre 3 flèches :

copie d'écran données résultat attendu
Icônes conditionnelles : résultat attendu

Les icônes de la colonne B représentent la position de la note par rapport à la moyenne arrondie de la colonne, calculée en B12 par la formule :

=ARRONDI(MOYENNE($B$2:$B$10))

Les seuils faisant référence au résultat d'une cellule (et non directement une valeur) nous utilisons le type Formule :

copie d'écran données résultat attendu
Icônes conditionnelles :seuils calculés par formule

En colonne C nous représentons l'évolution de la note de la colonne B par rapport à celle de la colonne A. La note est-elle supérieure, égale ou inférieure ?

Nous introduisons en colonne C une formule calculant la différence entre les notes. Par exemple en C2 :

=B2-A2

Le résultat sera négatif (la deuxième note est inférieure à la première), égal (notes identiques), ou positif (la deuxième note est supérieure à la première).

Les seuils pourront donc ici faire directement référence à une valeur et nous utilisons donc ce type :

copie d'écran données résultat attendu
Icônes conditionnelles :seuils en référence à une valeur


Notes :

  • Il peut être utile de ne voir apparaître que les icônes sans les valeurs chiffrées pour gagner en lisibilité. Se reporter à cette FAQ
    • Un centile est chacune des 99 valeurs qui divisent les données triées en 100 parts égales, de sorte que chaque partie représente 1/100 de l'échantillon de population. Un centile renvoie la valeur pour une série de données qui va de la plus petite valeur à la plus grande dans une série de données. Pour Alpha = 25, le centile signifie le premier quartile ; Alpha = 50 est la MEDIANE.

    Télécharger un classeur exemple