Neuerungen und Veränderungen in LibreOffice 3.4

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 3.4 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 3.3.

Writer

  • Neues Aussehen: Ein neuer Gradient/Schatten zum Abheben von Writer-Seiten vom Hintergrund mit konfigurierbaren Farben (im Menü Extras ▸ Optionen... ▸ LibreOffice ▸ Darstellung). Zur Demonstration Writer starten und die schön gestalteten Seiten bewundern.
Sébastien Le Ray
Neuer Gradient/Schlagschatten
  • Graphite Smart Font: Die Darstellungsunterstützung für Graphite Smart Font wurde komplett neu geschrieben und nutzt jetzt eine neue, schnellere Graphite-Engine. Sie ist erheblich stabiler und mindestens 10-mal schneller als die bisherige. Existierende Dokumente brauchen nicht geändert zu werden.
Keith Stribley, Martin Hosken - SIL International
  • Farbige Trennlinien: Farbe und Linienstilen werden jetzt auch bei Spalten- und Fussnoten-Trennlinien unterstützt. Das verbessert die Kompatibilität von LibreOffice zu ODF.
Cédric Bosdonnat
Farbige Fußnoten-Trennlinie
  • Griechische Nummerierung: Nummerierungen sind jetzt auch mit griechischen Zeichen möglich.
Pantelis Koukousoulas
Griechische Nummerierung

Calc

  • Neuer Dialog: Der Dialog zum Verschieben/Kopieren von Tabellenblättern (im Menü Bearbeiten ▸ Tabelle ▸ Verschieben/Kopieren...) wurde mit verbesserter Ergonomie neu gestaltet.
Joost Eekhoorn, Christoph Noack
Neuer Dialog zum Verschieben/Kopieren
  • Mehrere Zwischensummen je Tabellenblatt: Über das Menü Daten ▸ Teilergebnisse... kann nun mehr als ein Teilergebnisbereich in einem Tabellenblatt angelegt werden. Zuvor wurde beim Erstellen eines zweiten Teilergebnisses das erste entfernt, wenn sich dieser im selben Tabellenblatt befand.
Kohei Yoshida
  • Mehr Autofilter: Unterstützung von Autofilter je Tabellenblatt: Man kann jetzt für jedes Tabellenblatt Autofilter setzen ohne zuvor benannte Datenbereiche zu erstellen. Bisher hat Calc nur einen Autofilter pro Dokument unterstützt. Daher verschwand ein Autofilter, sobald ein anderer gesetzt wurde, selbst wenn sich dieser in einem anderen Tabellenblatt befand. Es sei denn, es war vorher ein benannter Datenbereich erstellt wordeen.
Markus Mohrhard
  • Externe Referenzen: Erhebliche Überarbeitungen des Programmcodes für die Behandlung externer Referenzen: Dadurch wurden zahlreiche Berechnungsfehler in Formeln behoben, wenn externe Referenzen enthalten waren. Außerdem wurde dadurch die Caching-Performanz gesteigert, besonders wenn große Datenbereiche referenziert werden.
Kohei Yoshida
  • Benannte Bereiche je Tabellenblatt: Zuvor unterstützte Calc nur globale benannte Bereiche. Dadurch waren alle benannten Bereiche im gesamten Dokument sichtbar, nicht nur im aktuellen Tabellenblatt. Seit Calc 3.4 können nun auch benannte Bereiche definiert werden, deren Geltungsbereich auf das aktuelle Tabellenblatt beschränkt ist. Der Dialog zum Festlegen von benannten Bereichen (im Menü Einfügen ▸ Namen ▸ Festlegen...) wurde hierfür verändert.
Kohei Yoshida
  • Korrigierte OLE-Links: OLE-Links zu anderen Excel-Dokumenten werden beim Import eines Excel-Dokuments beibehalten. OLE-Links werden beim Import zu externen Referenzen konvertiert. Zuvor hat Calc OLE-Links ignoriert und Zellen, die OLE-Links enthielten, führten zu einem Fehler beim Import.
Kohei Yoshida

Datenpilot

  • Benannter Bereich als Datenquelle: Mit Version 3.4 ist es nun möglich, einen benannten Bereich als Datenquelle für den Datenpilot zu verwenden. Dadurch können etwa neu hinzugefügte Zeilen im Datenquellbereich bei einer Aktualisierung des Datenpilots automatisch berücksichtigt werden.
Kohei Yoshida
Benannter Bereich als Datenquelle
  • Unterstützung unendlich vieler Felder: Zuvor hat der Datenpilot nur bis zu 8 Spalten-/Reihen- und Datenfelder sowie bis zu 10 Seitenfelder unterstützt. In Version 3.4 wurde diese Beschränkung aufgehoben, sodass theoretisch eine unendliche Anzahl von Felder unterstützt wird.
Kohei Yoshida
  • Mehrere Korrekturen: Die Implementierung des Datenpilots wurde substantiell überarbeitet, um mehrere Regressionen zu beheben, speziell im Zusammenhang mit der Aktualisierung von Datenpilot-Tabellen.
Kohei Yoshida

Impress/Draw

  • HTML-Export: Der HTML-Export wurde verbessert, eine Vorschau-Gallerie der Folien auf der Startseite wurde hinzugefügt.
Julien Nabet, Michael Meeks
Vorschau-Gallerie einer exportierten Impress-Präsentation
  • Überarbeitung der Zeichenfolien: Dadurch wurde die Genauigkeit beim Positionieren und der Größenbestimmen von Zeichenobejekten verbessert.
Caolán McNamara - Red Hat

Filter

  • Flache ODF-Dateien: Der Import- und Exportfilter für Flache ODF-Dateien wurde von Java auf C++ migriert und dadurch enorm beschleunigt.
Peter Jentsch
  • StarOffice Filter: Aller geerbten StarOffice Binär-Format-Filter (von vor 2000) wurden substantiell überarbeitet, sämtlicher Export-Code wurde entfernt. Die Filter sind nun kleiner und nur zum Lesen geeignet. Dadurch wurden auch der Dialog Speichern unter entwirrt.
Pierre-André Jacquod

Oberfläche

  • GUI-Unterstützungen: Grundlegende Unterstützung von Unity und GlobalMenu.
Unity-Unterstützung
  • Bessere GTK+-Themes: Die Integration von GTK+-Themes wurde verbessert, sodass LibreOffice ein natürlicheres Aussehen bekommt. Probleme bei Menütrennern, Verwendung der Alt-Taste und Wechsel-Schaltflächen wurden behoben und viele Details bei der Darstellung von Widgets verbessert.
Lucas Baudin
  • Verbesserte Vorschau von internationalisierten Schriftarten: In der Schriften-Auswahlliste werden Schriftarten, die zur Nutzung mit einer speziellen Schreibweise (etwa Arabisch, Hebräisch, Malayalam u.s.w.) vorgesehen sind, mit einer zusätzlichen Vorschau eines Beispieltextes in der entsprechenden Schriftsprache angezeigt.
Caolán McNamara - Red Hat
  • Natürliche Sortierung: Menüs listen ihre Einträge jetzt in natürlicher Sortierung, d.h. „Überschrift 10“ erscheint nun nach „Überschrift 9“ anstatt nach „Überschrift 1“.
  • Verbesserte AutoKorrektur: Eingabe von „http:“ am Satzanfang wird nicht mehr groß geschrieben. URLs sind jetzt von der AutoKorrektur ausgeschlossen.
Sébastien Le Ray
  • Verbessertes Text-Rendering: Das Text-Rendering wurde unter Linux verbessert. Text wird nun via Cairo mit denselben Zwischenpixel-Optionen wie andere Cairo nutzende Anwendungen gezeichnet. Im Endeffekt wird Text in LibreOffice genau gleich gerendert wie im übrigen Desktop. Zur Verdeutlichung ein Beispielsfoto mit desktopweitem Subpixeling.
Caolán McNamara - Red Hat
  • Bessere Linux-Mauszeiger: Die Anpassung an Linux-Mauszeiger-Themes wurde verbessert.
Kurosawa Takeshi
  • Geänderte Suchleiste: Das Verhalten der Suchleiste wurde an Anwendungen wie Firefox oder Evolution angenähert. Normalerweise versteckt, wird sie am unteren Fensterrand sichtbar, sobald Strg+F gedrückt wird. Sie ist auch größer und kann somit mehr Text enthalten. Für den Dialog Suchen und Ersetzen wird jetzt Strg+Alt+F verwendet.
Jan Holesovsky
  • Verbesserte Einstellungsmöglichkeit: Die Einstellung von Breite und Stilen für Umrandungen in Writer, Calc und Impress wurde getrennt.
Cédric Bosdonnat
  • Neue 3D-Umrandungstypen: Diese wurden hinzugefügt und damit die Kompatibilität zu vielen Dateiformaten verbessert, einschließlich ODF.
Cédric Bosdonnat
  • Farbpaletten: Farbpaletten können nun hinzugefügt und gelöscht werden.
Rob Snelders

Leistung & Geschwindigkeit

  • Besserer Start unter Linux: Der Splashscreen wird nun vor dem Lesen der Anwendungsdaten angezeigt, dadurch erscheint er schneller und der Code ist sauberer.
Michael Meeks
  • Theming vereinfacht: Der Ineffiziente und unnötige BmpColorMode-Ansatz beim Zugänglichkeits-Theming wurde entfernt. Dadurch wurde die Größe der Themes reduziert und die Doppelungen durch das notwendige separate Vorhalten von Hochkontrastsymbolen in einem eigenen Theme vermieden.
Chris Carpenter, Sebastian Spaeth
  • Symbole entfernt: 150 identische Symbole „Fehlendes Symbol“ wurden zur Verschlankung entfernt.
Joachim Trémouroux, Andrew C. E. Dent
  • Bibliotheken: Selten benötigte Textkodierungsfunktionen wurden in eine separate Bibliothek ausgelagert, dadurch konnte ca. 1 MB RAM gespart werden.
  • Fehler behoben: Ein Fehler in der Linux-Schriftartkonfiguration konnte behoben werden, sodass - je nach Anzahl installierter Schriftarten - bis zu 800 KB RAM eingespart werden können.
  • Kleinere Installationsdateien: Die Downloadgröße des Windows-Installers konnte durch Einsatz besserer Kompressionsalgorithmen um mehr als 30 MB reduziert werden.
Kálmán Szalai
  • Weniger Paletten: Es wurden 624 lokalisierte Paletten-Dateien entfernt, stattdessen passiert die Lokalisierung jetzt zur Laufzeit.
Andras Timar

Sonstiges

  • Einfacheres Ändern eines Kennwortes: Die Kennworte von kennwortgeschützten Dokumenten können nun geändert werden, während das Dokument geöffnet ist (im Menü Datei ▸ Eigenschaften ▸ Allgemein ▸ Passwort ändern). Die Schaltfläche ist nur bei kennwortgeschützten Dokumenten aktiv.
Kohei Yoshida

Code-Bereinigungen

  • Internationalisierung: Es wurden tausende Kommentarzeilen vom Deutschen ins Englische übersetzt. Dadurch ist es für die überwiegend interantionale Gemeinschaft nun einfacher, den Code zu verstehen.
  • Löschungen: Es wurden über 5.000 Zeilen nicht verwendeten Codes entfernt.
Kayo Hamid

Lokalisierung

  • Datenpilot-Umbenennung: Umbenennung des Datenpilots zu Pivot-Tabelle in der englischsprachigen Version. Für die deutschsprachige Version bleibt es vorerst beim Datenpiloten.
  • Neue Sprachen: Wörterbücher der Hunspell-Rechtschreibprüfung sind nun für diverse weitere Sprachen in LibreOffice nutzbar.
Andras Timar
  • Neue Oberflächen: Das Gebietsschema für Angolanisches Portugiesisch (pt_AO) wurde hinzugefügt.
Andras Timar