DE/Doku/Allgemein/12 WebseitenErzeugen

From The Document Foundation Wiki
< DE‎ | Doku‎ | Allgemein
Jump to: navigation, search

Einführung

k-j Jochen reisi007, Kü

Dieses Kapitel beschreibt, wie in Writer, Calc, Draw und Impress Folgendes erstellt wird:

  • Erstellen von Hyperlinks innerhalb eines Dokuments und anderer Dokumente wie z. B. Webseiten, PDFs und andere Dateien.
  • Speichern von Dokumenten als Webseiten (HTML-Dokumente).

Bei der Erstellung eines Dokuments, das Sie als Webseite fertigen möchten, müssen Sie Folgendes berücksichtigen:

  • In einem HTML-Dokument sind nur Hyperlinks aktiv (anklickbar). Andere Querverweise von LibreOffice sind keine aktiven Links.
  • Ein Objekt wie z. B. ein Bild wird als separate Datei gespeichert. Wenn das Objekt allerdings in einem Rahmen (z. B. mit einer zugehörigen Beschriftung) gelegt wird, wird es nicht gespeichert und erscheint auch nicht im HTML-Dokument. Vielmehr erscheint der Name des Rahmens.

Relative und absolute Hyperlinks

k-j Jochen

Hyperlinks, die innerhalb einer Datei gespeichert werden, können entweder relativ oder absolut sein.

Ein relativer Hyperlink besagt: Man kommt an die angezeigte Stelle von dem Abschnitt aus, an dem man gerade ist - also aus dem Ordner, in dem das aktuelle Dokument gespeichert ist. Ein absoluter Hyperlink besagt: Man kommt an die angezeigte Stelle, egal wo man gerade ist.

Ein absoluter Link wird nicht mehr funktionieren, wenn das Ziel verschoben wird. Ein relativer Link wird nicht mehr funktionieren, wenn sich die Start- und Zielorte zueinander verändern. Wenn Sie zum Beispiel zwei Tabellen im gleichen Ordner miteinander verknüpft haben und Sie bewegen den gesamten Ordner an einen neuen Ort oder benennen diesen um, wird ein absoluter Hyperlink nicht mehr funktionieren, während ein relativer Hyperlink erhalten bleibt.

Um die Art und Weise zu ändern, wie LibreOffice die Hyperlinks in Ihrer Datei speichert, starten Sie Extras → Optionen → Laden / Speichern → Allgemein und wählen Sie aus, ob die URLs relativ zum Dateisystem oder zum Internet oder beides gespeichert werden sollen.

Calc zeigt immer einen absoluten Hyperlink. Wundern Sie sich nicht darüber nicht: selbst wenn Sie einen relativen Hyperlink gespeichert haben, wird diese "absolute" Zieladresse aktualisiert, wenn Sie die Datei verschieben.

Hinweis
Stellen Sie sicher, dass die Ordnerstruktur auf Ihrem Computer die gleiche wie die Dateistruktur auf dem Webserver ist, wenn Sie Ihre Links relativ zum Dateisystem speichern und die Seiten ins Internet hochladen.
Tipp
Wenn Sie den Mauszeiger auf einem Hyperlink ruhen lassen, zeigt ein Hilfesfenster die absolute Referenz, da LibreOffice intern absolute Pfade verwaltet. Der vollständige Pfad und die Adresse können Sie nur sehen, wenn Sie das Ergebnis des HTML-Exports (speichern Sie die Tabelle als HTML-Datei) durch Laden der HTML-Datei als Text oder durch Öffnen mit einem Texteditor betrachten.

Hyperlinks erstellen

k-j Jochen

Wenn Sie einen Text eingeben, der als Hyperlink verwendet werden kann (z. B. eine Webseitenadresse oder URL), und dann die Leertaste oder die Eingabetaste drücken, erstellt LibreOffice automatisch den Hyperlink und formatiert den Text entsprechend (in der Regel eine Farbe und Unterstreichung). Wenn dies nicht geschieht, können Sie diese Funktion unter Extras → AutoKorrektur-Optionen → Optionen aktivieren. Wählen Sie die Option URL erkennen an.

Wenn Sie nicht möchten, dass LibreOffice eine bestimmten URL in einen Hyperlink konvertiert, wählen Sie Bearbeiten → Rückgängig AutoKorrektur aus der Menüleiste oder drücken Sie Strg + Z unmittelbar nach der Formatierung.

Tipp
Zum Ändern der Farbe von Hyperlinks gehen Sie auf Extras → Optionen... → LibreOffice → Darstellung, blättern Sie zu Unbesuchte Verknüpfungen und / oder Besuchte Verknüpfungen, wählen Sie neue Farben und klicken Sie auf OK.
Achtung
Dies wird die Farbe für alle Hyperlinks in allen Komponenten von LibreOffice ändern.

In Writer und Calc (aber nicht in Draw oder Impress) können Sie auch die Zeichenvorlage Internetlink ändern oder sich eine neue Vorlagen definieren und diese auf ausgewählte Links anwenden.

Sie können auch Links mit dem Navigator oder dem Dialog Hyperlink einfügen und Sie können alle Links mit dem Dialog Hyperlink, wie in diesem Abschnitt beschrieben, ändern.

Navigator verwenden

k-j Jochen

Der einfachste Weg, um einen Hyperlink (Querverweis) in einem anderen Teil desselben Dokuments einzufügen, ist die Verwendung des Navigators:

  1. Öffnen Sie in Ihrem Dokument den Navigator durch Klicken des entsprechenden Symbols Abbildung 1, durch Auswählen von Ansicht → Navigator oder Drücken der Taste F5.
  2. Klicken Sie auf den Pfeil neben dem Symbol Dragmodus und wählen Sie Als Hyperlink einfügen (Abbildung 2).
  3. In der Liste am unteren Rand des Navigators wählen Sie das Dokument mit dem Element, auf das Sie den Querverweis setzen wollen.
  4. In der Symbolleiste des Navigators wählen Sie das Element, das Sie als Hyperlink einfügen wollen.
  5. Ziehen Sie das Element an die Stelle, an der Sie den Hyperlink in das Dokument einügen wollen. Der Name des Elements wird in das Dokument als aktiver Hyperlink eingefügt.
Abbildung 2
Abbildung 2: Tastaturkürzel einrichten

Wenn Sie den Navigator zur Erstellung von Hyperlinks für Objekte (z. B. eine Grafik) verwenden, müssen Sie solchen Objekten einen sinnvollen Namen anstelle des Standardnamens (z. B. „Grafik6“) geben. Oder Sie ändern den resultierenden Linktext mit dem Hyperlinkdialogfeld. Dies wird weiter unten beschreiben.

Sie können den Navigator auch verwenden, um einen Hyperlink von einem Dokument (Quelle) an einem bestimmten Ort in einem anderen Dokument (Ziel) einzufügen. Öffnen Sie den Navigator im Zieldokument und ziehen Sie das Element an der Stelle im Quelldokument, an der Sie den Hyperlink haben wollen.

Hyperlink-Dialog verwenden

k-j Jochen

Um den Dialog Hyperlink anzuzeigen, klicken Sie auf das Symbol Hyperlink Abbildung 3 in der Symbolleiste Standard oder wählen Sie Einfügen → Hyperlink aus dem Menü. Um einen bestehenden Text in einen Link umzuwandeln, markieren Sie diesen vor dem Öffnen des Dialogs.

Abbildung 4
Abbildung 4: Hyperlink-Dialog mit Einstellungen für Internet-Links

Auf der linken Seite wählen Sie eine der vier Kategorien von Hyperlinks:

  • Internet: der Hyperlink verweist auf eine Webadresse - in der Regel beginnend mit "http://".
  • Mail & News: der Hyperlink öffnet eine E-Mail-Nachricht, die an einen bestimmten Empfänger voradressiert ist.
  • Dokument: der Hyperlink verweist auf ein anderes Dokument oder an eine andere Stelle im aktuellen Dokument.
  • Neues Dokument: der Hyperlink erstellt ein neues Dokument.

Der obere rechte Teil des Dialogs ändert sich entsprechend der Wahl der Hyperlinkkategorie im linken Fenster. Eine vollständige Beschreibung aller Optionen und deren Wechselwirkungen würde den Rahmen dieses Kapitels sprengen. Hier ist eine Zusammenfassung der häufigsten Möglichkeiten.

Für einen Internet-Hyperlink wählen Sie die Art des Hyperlinks (Web, FTP oder Telnet) und geben Sie die gewünschte Web-Adresse (URL) ein.

Für einen Mail- und News-Hyperlink geben Sie an, ob es sich um einen Mail- oder News-Link handelt, die Adresse des Empfängers und - für eine E-Mail - auch den Betreff.

Für ein Dokument-Hyperlink geben Sie den Dokumentpfad ein (die Schaltfläche Datei öffnen öffnet den Dateimanager) oder lassen Sie dieses Feld leer, wenn Sie zu einem Ziel im selben Dokument verknüpfen möchten. Wahlweise können Sie das Sprungziel im Dokument festlegen (z. B. eine bestimmte Folie). Klicken Sie auf die Schaltfläche Sprungziel im Dokument, um den Navigator zu öffnen, in dem Sie das Ziel auswählen können. Falls Sie den Namen des Ziels kennen, können Sie diesen direkt in das Feld eingeben.

Für einen Neues Dokument-Hyperlink geben Sie an, ob das neu erstellte Dokument sofort erstellt und bearbeitet oder nur erstellt und später bearbeitet werden soll. Geben Sie den Dateinamen ein und wählen Sie die Art des Dokuments (z. B. Text oder Tabellenkalkulation). Klicken Sie auf die Schaltfläche Pfad auswählen, um den Dateimanager zu öffnen und den Speicherort der Datei zu wählen.

Der Abschnitt Weitere Einstellungen im unteren rechten Teil des Dialogs ist bei allen Hyperlink-Kategorien gleich. Allerdings haben einige Einträge einen größeren Einfluss auf einige Arten von Links.

  • Setzen Sie den Wert von Frame, um zu bestimmen, wie der Hyperlink wird geöffnet. Dies gilt für Dokumente, die in einem Web-Browser geöffnet werden.
  • Form gibt an, ob der Link als Text oder als Schaltfläche dargestellt wird. Abbildung 5 zeigt einen Link, der als Schaltfläche formatiert ist. Ein Hyperlink-Schaltfläche ist eine Art Formular-Steuerelement. Lesen Sie Kapitel 15 des Writer-Handbuchs für weitere Informationen.
Abbildung 5
Abbildung 5: Ein Hyperlink als Button
  • Text stellt den Text dar, der für den Benutzer sichtbar ist. Wenn Sie hier nichts eingeben, verwendet LibreOffice die vollständige URL oder den vollständigen Pfad als Linktext. Beachten Sie, dass bei Verwendung eines relativen Links und beim Verschieben dieser Datei, dieser Text nicht geändert wird, obwohl das Ziel geändert wird.
  • Name ist nützlich für HTML-Dokumente. Es gibt Text an, der als "name"-Attribut im HTML-Code hinter dem Hyperlink hinzugefügt wird.
  • Schaltfläche Ereignisse Abbildung 6: klicken Sie auf diese Schaltfläche, um den Dialog "Makro zuweisen" zu öffnen, und wählen Sie ein Makro, das ausgeführt werden soll, wenn der Link angeklickt wird. Lesen Sie Kapitel 13 "Einführung in Makros" dieses Handbuchs für weitere Informationen.

Hyperlinks bearbeiten

k-j Jochen

Um eine vorhandene Verknüpfung zu bearbeiten, klicken Sie irgendwo in den Linktext und dann auf das Symbol Hyperlink Abbildung 3 in der Symbolleiste Standard oder wählen Sie Bearbeiten → Hyperlink aus dem Menü. Der Dialog Hyperlink öffnet sich. Nehmen Sie Ihre Änderungen vor und klicken Sie auf Übernehmen. Wenn Sie mehrere Hyperlinks bearbeiten müssen, können Sie das Dialogfeld Hyperlink geöffnet lassen, bis Sie alle Hyperlinks bearbeitet haben. Achten Sie darauf, jedesmal auf Übernehmen zu klicken. Den Dialog beenden Sie mit Schließen.

Das Standardverhalten zur Aktivierung von Hyperlinks innerhalb LibreOffice ist Strg+Klick. Dieses Verhalten kann in Extras → Optionen... → LibreOffice → Sicherheit → Optionen verändert werden, indem Sie die Option Strg beim Klicken halten, um Hyperlinks zu folgen abwählen. Wenn durch Klicken der Links diese aktiviert werden und Sie dies nicht wünschen, überprüfen Sie die Einstellung für diese Seite.

Hyperlinks entfernen

k-j Jochen

Sie können den klickbaren Link des Hyperlinktexts entfernen, sodass nur der Text angezeigt wird, indem Sie mit der rechten Maustaste auf den Link klicken und Standard-Formatierung wählen. Diese Option steht auch im Menü Format zur Verfügung. Sie müssen dann erneut einige Formatierungen vornehmen, damit der Text dem Rest des Dokuments entspricht.

Um den Linktext oder Linkknopf vollständig aus dem Dokument zu löschen, wählen Sie diesen aus und drücken Sie die Rücktaste oder die Entf-Taste.

Writer-Dokumente als Webseite speichern

k-j Jochen

Die HTML-Funktionen von Writer beinhalten das Speichern vorhandener Dokumente im HTML-Format, das Erstellen neuer Dokumente als HTML (hier nicht beschrieben) sowie die Erstellung mehrerer verschiedener Arten von Webseiten mithilfe eines Assistenten.

Die einfachste Möglichkeit, HTML-Dokumente zu erstellen, ist das Erstellen eines Writer-Dokumentes und dieses als Webseite abzuspeichern. Wenn Sie auf Ansicht → Weblayout klicken, erhalten Sie eine gute Vorstellung, wie das Dokument als Webseite aussieht. Allerdings wird Ihnen die Weblayout-Ansicht nicht zeigen, welche Funktionen korrekt oder nicht korrekt im HTML gespeichert werden.

Speichern eines Dokuments als einzelne Webseite

k-j Jochen

Um ein Dokument als einzelne Webseite (HTML-Format) zu speichern, wählen Sie Datei → Speichern unter... und geben Sie HTML-Dokument als Dateityp an.

Hinweis
Writer ersetzt mehrere Leerzeichen im ursprünglichen Dokument nicht mit den HTML-Code für ein geschütztes Leerzeichen. Wenn Sie zusätzliche Leerzeichen in Ihrer HTML-Datei oder Webseite haben möchten, müssen Sie geschützte Leerzeichen in LibreOffice einfügen. Hierfür drücken Sie Strg+Leertaste anstelle der Leertaste.

Aufteilung und Speichern eines Dokuments in mehreren Webseiten

k-j Jochen

Writer kann ein umfangreiches Dokument mit vielen Seiten in mehreren Webseiten (HTML-Dateien) mit einer Inhaltsverzeichnisseite abspeichern.

  1. Entscheiden Sie, welche Überschriften im Dokument auf einer neuen Seite beginnen sollen, und stellen Sie sicher, dass alle Überschriften die gleiche Absatzvorlage (z. B. Überschrift 1) haben.
  2. Wählen Sie Datei → Senden → HTML-Dokument erzeugen.
  3. Im Dialog Name und Pfad geben Sie den Dateinamen ein, unter dem die Seiten gespeichert werden. Geben Sie auch an, welche Absatzvorlage eine neue Seite definiert (wie in Schritt 1 entschieden).
  4. Klicken Sie auf Speichern, um das mehrseitige HTML-Dokument zu erstellen.

Die resultierenden HTML-Dateien entsprechen der Spezifikation HTML 4 Transitional.

Abbildung 7
Abbildung 7: Aus einem Dokument eine Reihe von Webseiten erstellen

Webseite mit einem Assistenten erstellen

k-j Jochen

Mit dem LibreOffice Webseite-Assistenten können Sie verschiedene Arten von Standardwebseiten erstellen.

1) Wählen Sie Datei → Assistenten → Web-Seite.... Auf der ersten Seite des Assistenten wählen Sie Einstellungen für den Webseite-Assistenten aus und klicken Sie auf Weiter. Wenn dies Ihre erste Webseite ist, ist die einzige Wahl "<standard>".

Abbildung 8
Abbildung 8: Web-Assistent – Einleitungsseite

2) Wählen Sie ein Dokument oder suchen Sie nach dem Dokument, das Sie formatieren möchten. Der Titel, die Zusammenfassung und Informationen zum Autor werden aus den Eigenschaften des Dokuments entnommen bzw. bearbeiten Sie die Eigenschaften, wenn Sie Änderungen vornehmen möchten. Klicken Sie auf Weiter.

Abbildung 9
Abbildung 9: Web-Assistent – Auswahl des Dokumentes

3) Wählen Sie ein Layout für die Webseite mit einem Klick auf eine der Layoutboxen. Klicken Sie auf Weiter.

Abbildung 10
Abbildung 10: Web-Assistent – Auswahl des Hauptlayouts

4) Wählen Sie die Informationen, die erscheinen sollen, sowie die Bildschirmauflösung. Klicken Sie auf Weiter.

Abbildung 11
Abbildung 11: Web-Assistent – Anpassen des selektierten Layouts

5) Wählen Sie eine Vorlage für die Seite. Verwenden Sie die Auswahlliste um die verschiedenen Vorlagen und Farbkombinationen zu wählen. Sie können ein Hintergrundbild und einen Symbolsatz aus der Gallery aussuchen. Klicken Sie auf Weiter.

Abbildung 12
Abbildung 12: Web-Assistent – Formatvorlage

6) Geben Sie allgemeine Informationen wie Titel und HTML-Metadaten ein. Klicken Sie auf Weiter.

Abbildung 13
Abbildung 13: Web-Assistent – allgemeine Informationen über die Webseite

7) Wählen Sie den Speicherort der Datei aus. Wenn Sie es wünschen, können Sie an dieser Stelle eine Vorschau der Seite ansehen. Klicken Sie auf Fertigstellen.

Abbildung 14
Abbildung 14: Web-Assistent – Vorschau

Um den dem Dokument zugrunde liegenden HTML-Code anzusehen oder zu bearbeiten, öffnen Sie das Dokument mit LibreOffice und wählen Sie dann Ansicht → HTML Quelltext oder klicken Sie auf das Symbol HTML-Quelltext Abbildung 15 auf der Symbolleiste Standard.

Calc-Tabellen als Webseiten speichern

k-j Jochen

Calc kann Dateien als HTML-Dokumente speichern. Wie für Writer wählen Sie Datei → Speichern unter... und HTML-Dokument als Dateityp oder wählen Sie auf Datei -> Assistenten - > Web-Seite....

Enthält die Datei mehr als ein Blatt, werden die Blätter aufeinanderfolgend in der HTML-Datei dargestellt. Zu jedem Blatt werden am Anfang des Dokuments Links platziert. Calc erlaubt mit dem Dialog Hyperlink auch das Einfügen von Links direkt in der Tabellenkalkulation.

Impress Präsentation als Macromedia Flash-Dateien exportieren

k-j Jochen

Sie können Präsentationen als Dateien im Macromedia Flash-Format exportieren: Wählen Sie Datei → Export... und Macromedia Flash für den Dateityp.

Impress Präsentation als Webseiten speichern

k-j Jochen

Eine Impress Präsentation kann auch als HTML-Dokument (Webseite) abgespeichert werden.

Hinweis
Das Speichern als Webseite (HTML-Format) behält keine Animationen und Folienübergänge bei.

1) Zu Beginn wählen Sie Datei → Export... und HTML-Dokument als Dateityp.

2) Erstellen Sie einen Ordner für die Dateien, geben Sie einen Namen für die resultierende HTML-Datei an und klicken Sie auf Speichern. Der HTML-Export-Assistent wird geöffnet.

Hinweis
Je nach Größe Ihrer Präsentation und Anzahl der Grafiken, die diese enthält, kann die HTML-Export-Funktion viele HTML-, JPG- und GIF-Dateien erstellen. Wenn Sie diese einfach auf Ihrem Desktop und nicht in einen bestimmten Ordner speichern, werden diese HTML-und Grafikdateien auf Ihrem ganzen Desktop verteilt sein. Beachten Sie daher, dass Sie am besten einen Ordner anlegen, um alle Dateien zu erfassen.

3) Wählen Sie das Design für alle Seiten von einem bestehenden Design oder Sie erstellen ein neues Design. Wenn Sie nicht bereits ein Design gespeichert haben, steht Ihnen kein Design zur Verfügung.

Abbildung 16
Abbildung 16: Web-Export-Assistent Impress – Design

4) Klicken Sie auf Weiter, um die Art der zu erstellenden Webseiten zu wählen.

  • Standard HTML-Format: eine Seite für jede Folie. Mit Navigationslinks gelangen Sie von Folie zu Folie.
  • Standard HTML mit Frames: eine Seite mit einer Navigationsleiste auf der linken Seite. Folientitel werden als Navigationslinks genutzt. Klicken Sie auf die Links, um die Seiten im rechten Teil anzuzeigen.
  • Automatisch: eine Seite für jede Folie, wobei jede Seite mit einem Refresh-Meta-Tag versehen ist, sodass ein Browser automatisch von einer Seite auf die nächste wechselt.
  • WebCast: erzeugt eine ASP-oder Perl-Anwendung, um die Folien anzuzeigen. Leider hat LibreOffice noch keine direkte Unterstützung für PHP.
Abbildung 17
Abbildung 17: Web-Export-Assistent Impress – HTML-Format

5) Entscheiden Sie, wie in welchem Format (PNG, GIF oder JPG) die Bilder gespeichert werden sollen und welche Auflösung dafür verwendet werden soll.

Bei der Wahl einer Auflösung überlegen Sie sich, was die Mehrheit der Zuschauer verwenden wird. Wenn Sie eine hohe Auflösung angeben, dann muss ein Betrachter mit einer mitteleren Monitorauflösung seitwärts scrollen, um die gesamte Folie bestrachten zu können. Dies ist möglicherweise nicht erwünscht.

Abbildung 18
Abbildung 18: Web-Export-Assistent Impress – Grafik

6) Wenn Sie im Schritt 4 Titelseite erzeugen angewählt haben, geben Sie die Informationen hierfür auf der nächsten Seite ein. Der Titel enthält den Namen eines Autors, die E-Mail-Adresse und die Homepage sowie weitere Informationen, die Sie angeben können.

Diese Seite des Assistenten wird nicht angezeigt, wenn Titelseite erzeugen nicht angewählt wurde.

Abbildung 19
Abbildung 19: Web-Export-Assistent Impress – Titelinformationen


7) Wählen Sie den Schaltflächenstil aus, der verwendet werden soll, um von einer Seite zur anderen zu gelangen. Wenn Sie keine Schaltflächenstil auswählen, erstellt LibreOffice einen Text-Navigator.

Abbildung 20
Abbildung 20: Web-Export-Assistent Impress – Auswahl der Navigationsvorlagen

8) Wählen Sie das Farbschema für Ihre Webseite. Zur Auswahl stehen das Farbschema aus dem Dokument, ein auf Browser Farben basierendes Schema sowie ein komplett vom Benutzer definiertes Schema. Sie können ein neues Schema speichern, sodass es auf der ersten Seite des HTML-Export-Assistenten angezeigt wird.

Abbildung 21
Abbildung 21: Web-Export-Assistent Impress – Farbschema

9) Klicken Sie auf Fertigstellen, um die HTML-Dateien zu generieren. Wenn Sie mit Hilfe des Assistenten ein neues Design erzeugt haben, erscheint ein kleiner Dialog. Wenn Sie dieses Design wieder verwenden wollen, können Sie ihm einen Namen geben und speichern. Andernfalls klicken Sie auf Nicht speichern.

Abbildung 22
Abbildung 22: Web-Export-Assistent Impress – Dialog für den Namen eines neuen Designs

Draw Dokumente als Webseite speichern

k-j Jochen [[User:Eskroni|Sigrid]

Das Exportieren von Zeichnungen aus Draw erfolgt über Datei → Export. Wählen Sie beim Abspeichern HTML-Dokument als Dateityp.

Bei Verwendung des Assistenten können Sie jederzeit eine Webseite erstellen, indem Sie auf die Schaltfläche Erstellen klicken.