DE/Doku/Allgemein/B OpenDocument

From The Document Foundation Wiki
< DE‎ | Doku‎ | Allgemein
Jump to: navigation, search


Einführung

Sigrid k-j Jochen

LibreOffice ist ein Bürosoftware-Paket, das kompatibel zu vielen anderen Office-Paketen ist. LibreOffice ist für unterschiedliche Betriebssysteme erhältlich. Es ist OpenSource-Software und kann daher kostenlos heruntergeladen, benutzt und weitergegeben werden. Wenn LibreOffice noch neu für Sie ist, erhalten Sie in diesem Anhang einen Überblick über die Geschichte, die Community und die technischen Spezifikationen von LibreOffice.

Die Geschichte von LibreOffice

Sigrid k-j Jochen

Das OpenOffice.org Projekt begann, als Sun Microsystems den Quellcode (die "Blaupausen" oder auch den "Bauplan") für die StarOffice (R) Software am 13. Oktober 2000 veröffentlichte. Die erste Version von OpenOffice wurde am 30. April 2002 veröffentlicht. Am 26. Januar 2010 wurde Sun Microsystems von Oracle übernommen.

Größere Änderungen wurden in der Version 2.0 (Oktober 2005) und in der Version 3.0 (Oktober 2008) vorgenommen. Seit Einführung der Version 2.0 unterstützt OpenOffice.org den offenen Dokumenten-Standard OASIS OpenDocument als das native Dateiformat.

Am 28. September 2010 hat die Gemeinschaft der Freiwilligen (die Community), die OpenOffice.org mit entwickeln und unterstützen, einen Wechsel in der Projektstruktur bekannt gegeben. Nach 10 Jahren erfolgreicher Zusammearbeit mit Sun Microsystems als Gründer und Hauptsponsor, startete das Projekt eine unabhängige Stiftung (engl. Foundation) mit dem Namen "The Document Foundation", um das Versprechen der Unabhängigkeit einzulösen, das schon in den Gründungsdokumenten festgehalten war. Diese Stiftung soll der Grundstein für ein Ökosystem sein, bei dem Einzelpersonen und Organisationen (Firmen) beitragen und von dem Vorhandensein einer wirklich freien Bürosoftware profitieren können.

Die Freigabe von LibreOffice 3.3 erfolgte im Frühjahr 2011 und stellt die erste Version dar, die von der neu gegründeten The Document Foundation erstellt wurde (TDF). Mehr über The Document Foundation können Sie unter https://www.documentfoundation.org/ erfahren.

Die LibreOffice Community

Sigrid k-j Jochen

Die Ziele von The Document Foundation sind:

  • Entwicklung der OpenOffice.org Community innerhalb einer neuen, offenen, unabhängigen und meritokratischen Organisationsstruktur.
  • Gründung einer unabhängigen Stiftung, um so am besten die Werte unserer Beitragenden, Benutzer und Unterstützer zu sichern und eine effektive, effiziente, transparente und alle umfassende Gemeinschaft zu schaffen.
  • Schutz der bisherigen Investitionen, indem auf dem bisher Erreichten der ersten Dekade aufgebaut und zur Mitarbeit ermuntert wird sowie die Aktivitäten von der Community für die Community koordiniert werden.

Die Unterstützer der Foundation sind unter anderem namhafte Firmen wie beispielsweise Canonical, The GNOME Foundation, Google, Novell und Red Hat. Zusätzlich haben mehr als 450.000 Leute aus nahezu jedem Teil der Welt sich diesem Projekt angeschlossen. Das ist die Essenz einer "Open Source" Community.

Mit der Open Source Lizenz ist LibreOffice ein Schlüsselfaktor in dem Projekt, eine Bürosoftware, die für jeden jederzeit und an jedem Ort erhältlich ist, zur kommerziellen und privaten Nutzung zur Verfügung zu stellen. Die Software wurde in viele Sprachen übersetzt und läuft auf allen wichtigen Betriebssystemen. Neue Funktionen können über sogenannte Extensions hinzugefügt werden.

Die LibreOffice Community lädt Beitragende in allen Gebieten ein - also zum Beispiel Übersetzer, Software-Entwickler, Grafiker, Autoren für technische Dokumentation, Editoren, Spender und Endbenutzer-Unterstützung. Je nach Ihren Interessen oder Fähigkeiten finden Sie sicher einen Platz innerhalb der LibreOffice-Community. Die Community arbeitet international in allen Zeitzonen und in verschiedenen Sprachen. Die Koordination erfolgt mittels Internet über www.libreoffice.org und www.documentfoundation.org.

Wie ist LibreOffice lizensiert?

Sigrid k-j Jochen

LibreOffice steht unter der "Lesser General Public Licence (LGPL)", die auch von der Open Source Initiative (OSI) anerkannt ist.

Der Text der LGPL-Lizenz ist über die Webseite der The Document Foundation erhältlich: https://www.documentfoundation.org/lgpl/

Was ist “Open Source”?

Sigrid k-j Jochen

Die vier essenziellen Rechte für Open Source Software sind in der General Public License (GPL) der Free Software Foundation festgeschrieben.

  • Das Recht, die Software für jeden Zweck zu benutzen.
  • Die Freiheit, die Software weiterzugeben - entweder kostenfrei oder gegen eine Gebühr.
  • Zugang zu dem Quellcode der Software (dem "Bauplan").
  • Das Recht, jeden Teil des Quellcodes zu modifizieren oder Teile davon in anderen Programmen zu verwenden.

Die Idee hinter Open Source Software ist sehr einfach: Wenn Programmierer den Quellcode für eine Software lesen, weitergeben und verändern können, entwickelt sich die Software weiter. Programmierer verbessern den Quellcode, führen Anpassungen aus oder beseitigen Fehler.

Um mehr über Freie und Open Source Software zu erfahren, besuchen Sie die folgenden Webseiten:

Open Source Initiative (OSI): http://www.opensource.org

Free Software Foundation (FSF): http://www.gnu.org

Was sind "Offene Standards"?

Sigrid k-j Jochen

Ein offener Standard bietet Ihnen die Möglichkeit etwas zu tun, das unabhängig von einem Hersteller oder Verkäufer ist. Dies ermöglicht es, dass konkurrierende Software-Programme die gleichen Dateiformate verwenden. HTML, XML und ODF sind Beispiele für offene Standards für Dokumente.

Ein offener Standard erfüllt die folgenden Anforderungen:

  • Er ist gut dokumentiert mit der kompletten Spezifikation für alle zugänglich - entweder kostenlos oder gegen eine geringe Gebühr.
  • Er kann frei kopiert, weitergegeben und benutzt werden. Das geistige Eigentum an dem Standard ist unwiderruflich und ohne Lizenzgebühren frei erhältlich.
  • Er ist standardisiert und wird in einem unabhängigen, offenen Forum unter Verwendung eines offenen Prozesses gewartet (eine "Standard Organisation").

Was ist ein OpenDocument?

Sigrid Jochen Erhardt

OpenDocument (ODF) ist ein XML-basiertes Dokumentenformat für Büro-Dokumente (Texte, Tabellenkalkulationen, Zeichnungen, Präsentationen und mehr), das von OASIS (http://www.oasis-open.org/who/) - einer unabhängigen, internationalen Standard Gruppe - entwickelt worden ist.

Im Gegensatz zu anderen Dateiformaten ist ODF ein offener Standard. Es ist für die Öffentlichkeit zugänglich, lizenzgebührenfrei und hat auch keine anderen legalen oder sonstigen Restriktionen. Daher sind ODF-Dateien nicht an eine bestimmte Bürosoftware gebunden und jeder, der möchte, kann ein Programm erstellen, das diese Dateiformate lesen und verarbeiten kann. Aus diesem Grund steigt die Akzeptanz für ODF als das bevorzugte Dateiformat bei Regierungsstellen, Schulen und anderen Firmen, die nicht von einem einzigen Softwarehersteller abhängig sein wollen.

LibreOffice speichert standardmäßig im OpenDocument Format. LibreOffice verwendet Version 1.2 des OpenDocument-Standards. LibreOffice kann weiterhin viele weitere Dateiformate lesen und auch in vielen anderen Formaten speichern. Für weitere Details lesen Sie den Abschnitt "Dateiformate, die LibreOffice öffnen kann" auf Seite XYZ, "Dateiformate, in denen LibreOffice speichern kann" auf Seite XYZ und "Export in andere Formate" auf Seite XYZ.

OpenDocument Dateinamen-Erweiterungen

Sigrid Jochen Erhardt

Die häufigsten Dateinamen-Erweiterungen für OpenDocument-Dokumente sind:

  • *.odt für Textverarbeitungs-Dokumente
  • *.ods für Tabellenkalkulationen
  • *.odp für Präsentationen
  • *.odb für Datenbanken
  • *.odg für Grafiken (Vektorgrafik-Zeichnungen)
  • *.odf für Formeln (Mathematische Gleichungen)

Häufig gestellte Fragen

Sigrid Jochen Erhardt
Kann ich LibreOffice an jeden weitergeben?
Ja.
Auf wie vielen Computern kann ich es installieren?
Auf so vielen wie Sie wollen.
Kann ich es verkaufen?
Ja.
Kann ich LibreOffice in meiner Firma einsetzen?
Ja.
Ist LibreOffice in meiner Sprache erhältlich?
LibreOffice wurde in mehr als 40 Sprachen übersetzt - unter anderem auch in die Deutsche Sprache. Zusätzlich gibt es mehr als 70 Rechtschreib-, Trennungs- und Thesaurus-Wörterbücher für Sprachen und Dialekte, die keine lokalisierte Programmoberfläche haben. Die Wörterbücher erhalten Sie über die LibreOffice-Webseite unter http://www.libreoffice.org oder über http://extensions.services.openoffice.org/en/dictionaries .
Wie schaffen Sie es, dass LibreOffice kostenlos ist?
LibreOffice wird von Freiwilligen entwickelt und gewartet. Zusätzlich bekommen wir auch die Unterstützung von mehreren Firmen und Organisationen.
Was mache ich, wenn ich technischen Support benötige?
Lesen Sie den Abschnitt "Wie Sie Hilfe erhalten" in Kapitel 1 (Einführung in LibreOffice).
Wer besitzt die Software?
  • Niemand. Allerdings vertritt "The Document Foundation" die Anliegen von LibreOffice.
Heißt das, dass jemand die Software wegnehmen kann?
Nein. Die Lizenzen, unter denen LibreOffice entwickelt und weitergegeben wird, können nicht zurückgenommen werden.
Ich schreibe ein Software-Programm. Kann ich Code von LibreOffice in meinem Programm verwenden?
Ja, Sie können Code von LibreOffice verwenden. Sie müssen allerdings die Vorgaben der LGPL-Lizenz beachten. Lesen Sie die Lizenz hier: https://www.documentfoundation.org/lgpl/
Wieso benötige ich Java um LibreOffice zu verwenden? Ist es in Java geschrieben?
LibreOffice wurde nicht in Java geschrieben, sondern in C++. Java ist eine von mehreren Programmiersprachen die benutzt werden kann, um die Funktionalität der Software zu erweitern. Das Java JDK/JRE wird nur für wenige Features benötigt wie zum Beispiel für die HSQLDB relationale Datenbank.
Anmerkung: Java ist kostenfrei erhältlich. Wenn Sie Java nicht benutzen wollen, so können Sie trotzdem fast alle Funktionen von LibreOffice verwenden.
Wie kann ich zu LibreOffice beitragen?
Sie können zu der Entwicklung von LibreOffice auf viele Arten beitragen - und Sie müssen dafür noch nicht einmal ein Programmierer sein. Lesen Sie mehr dazu auf dieser Webseite: https://www.documentfoundation.org/contribution/
Wo ist der Haken?
Es gibt keinen. Lesen Sie die Lizenz hier: https://www.documentfoundation.org/lgpl/

Dateiformate, die LibreOffice öffnen kann

k-j Jochen Erhardt

LibreOffice kann neben den OpenDocument-Formaten eine große Auswahl an Dateiformaten öffnen.

Text-Formate, die geöffnet werden können

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.odt, .ott, .oth und .odm) kann Writer die Formate, die von OpenOffice.org 1.x verwendet wurden (.sxw, .stw und .sxg) sowie die folgenden Formate lesen:

  • Microsoft Word 6.0/95/97/2000/XP) (.doc und .dot)
  • Microsoft Word 2003 XML (.xml)
  • Microsoft Word 2007 XML (.docx, .docm, .dotx, .dotm)
  • Microsoft WinWord 5 (.doc)
  • WordPerfect Document (.wpd)
  • WPS 2000/Office 1.0 (.wps)
  • Rich Text Format (.rtf)
  • Text CSV (.csv and .txt)
  • StarWriter formats (.sdw, .sgl, .vor)
  • DocBook (.xml)
  • Unified Office Format text (.uot, .uof)
  • Ichitaro 8/9/10/11 (.jtd und .jtt)
  • Hangul WP 97 (.hwp)
  • T602 Document (.602, .txt)
  • AportisDoc (Palm) (.pdb)
  • Pocket Word (.psw)
  • HTML Document (.htm und .html)

Die meisten dieser Dateitypen werden von LibreOffice automatisch erkannt, so dass Sie die Dateien öffnen können, ohne die Dateiart vorher explizit festzulegen.

Wenn Sie eine .htm oder .html Datei öffnen, passt LibreOffice die Writer-Oberfläche für die Arbeit mit diesen Datei-Formaten an.

Tabellen-Formate die geöffnet werden können

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.ods und .ots) kann Calc die Formate die von OpenOffice.org 1.x verwendet wurden (.sxc und .stc) sowie die folgenden Tabellenformate öffnen:

  • Microsoft Excel 97/2000/XP (.xls, .xlw und .xlt)
  • Microsoft Excel 4.x–5.0/95 (.xls, .xlw und .xlt)
  • Microsoft Excel 2003 XML (.xml)
  • Microsoft Excel 2007 XML (.xlsx, .xlsm, .xlts, .xltm)
  • Microsoft Excel 2007 binary (.xlsb)
  • Lotus 1-2-3 (.wk1, .wks und .123)
  • Data Interchange Format (.dif)
  • Rich Text Format (.rtf)
  • Text CSV (.csv und .txt)
  • StarCalc formats (.sdc und .vor)
  • dBASE (.dbf)
  • SYLK (.slk)
  • Unified Office Format spreadsheet (.uos, .uof)
  • HTML Document (.htm und .html Dateien - einschließlich Webseiten-Abfragen)
  • Pocket Excel (pxl)
  • Quattro Pro 6.0 (.wb2)

Präsentationsformate die geöffnet werden können

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.odp, .odg und .otp) kann Impress auch die Formate, die von OpenOffice.org 1.x verwendet wurden (.sxi und .sti) sowie die folgenden Formate öffnen:

  • Microsoft PowerPoint 97/2000/XP (.ppt und .pot)
  • Microsoft PowerPoint 2007 (.pptx, .pptm, .potx, .potm)
  • StarDraw and StarImpress (.sda, .sdd, .sdp und .vor)
  • Unified Office Format presentation (.uop und .uof)
  • CGM – Computer Graphics Metafile (.cgm)

Hinweis:

  • pdf-Dokumente (Portable Document Format) werden in LibreOffice standardmäßig mit Draw geöffnet.

Grafik-Formate die geöffnet werden können

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.odg und .otg) kann Draw auch die Formate, die von OpenOffice.org 1.x verwendet wurden (.sxd und .std) sowie die folgenden Grafik-Formate öffnen: BMP, JPEG, JPG, PCX, PSD, SGV, WMF, DXF, MET, PGM RAS, SVM, XBM, EMF, PBM, PLT, SDA, TGA, XPM, EPS, PCD, PNG, SDD, TIF, TIFF, GIF, PCT, PPM, SGF und VOR.

Hinweis:

  • pdf-Dokumente (Portable Document Format) werden in LibreOffice standardmäßig mit Draw geöffnet.

Formel-Dateien die geöffnet werden können

Sigrid Jochen Erhardt

Zusätzlich zu dem OpenDocument-Format (.odf) kann Math auch das von OpenOffice.org 1.x verwendete Format (.sxm), StarMath (.smf) und MathML (.mml) öffnen.

Wenn Sie ein Word-Dokument öffnen, das ein eingebettetes Formel-Editor-Objekt enthält und Sie unter Extras -> Optionen -> Laden/Speichern -> Mircrosoft Office die Option MathType zu LibreOffice Math oder umgekehrt aktiviert haben, wird das Objekt automatisch in ein LibreOffice Math-Objekt umgewandelt.

Datei-Formate in denen LibreOffice speichern kann

Sigrid Jochen Erhardt

Das Speichern im OpenDocument-Format garantiert die korrekte Darstellung der Datei, wenn dies an eine andere Person weitergegeben wird oder wenn die Datei mit einer späteren Version von LibreOffice geöffnet wird. Es wird empfohlen, dass Sie ODF als Standard-Format für die Speicherung von Dateien verwenden. Sie können aber auch Dateien in anderen Formaten abspeichern, wenn Sie das wünschen.

Tipp
Wenn Sie ein Dokument weitergeben, das vom Empfänger nicht weiter bearbeitet werden soll, ist es die beste Option, dass Sie das Dokument in eine PDF-Datei exportieren. LibreOffice bietet Ihnen einen einfachen Weg um ein Dokument in ein PDF umzuwandeln. Genaueres hierzu finden Sie in Kapitel 10, Drucken, Exportieren und E-Mailen in diesem Handbuch.

Speichern von Text-Dokumenten

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.odt und .ott) kann Writer auch in diesen Formaten speichern:

  • OpenOffice.org 1.x Text Dokument (.sxw)
  • OpenOffice.org 1.x Text Dokument Vorlage (.stw)
  • Microsoft Word 6.0, 95, and 97/2000/XP (.doc)
  • Microsoft Word 2003 XML (.xml)
  • Microsoft Word 2007 (.docx)
  • Office Open XML Text (.docx)
  • Rich Text Format (.rtf)
  • StarWriter 3.0, 4.0 und 5.0 (.sdw)
  • StarWriter 3.0, 4.0 und 5.0 Vorlage (.vor)
  • Text (.txt)
  • Text Encoded (.txt)
  • Unified Office Format text (.uot und .uof)
  • HTML Dokument (OpenOffice.org Writer) (.html und .htm)
  • DocBook (.xml)
  • AportisDoc (Palm) (.pdb)
  • Pocket Word (.psw)

Die Unterstützung von Verschlüsselungstechnologien innerhalb des Microsoft Word 97/2000/XP Filters ermöglicht es Ihnen, passwortgeschützte Microsoft Word Dokumente abzuspeichern.

Hinweis
Das .rtf Format ist ist ein gebräuchliches Format um Textdateien zwischen verschiedenen Anwendungen auszutauschen. Allerdings kommt es häufig vor, dass vorgenommene Formatierungen oder eingefügte Bilder verloren gehen. Aus diesem Grund sollten andere Formate verwendet werden.

Speichern von Tabellen-Dokumenten

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.ods und .ots) kann Calc in den folgenden Formaten speichern:

  • OpenOffice.org 1.x Tabellendokument (.sxc)
  • OpenOffice.org 1.x Tabellendokument Vorlage (.stc)
  • Microsoft Excel 97/2000/XP (.xls und .xlw)
  • Microsoft Excel 97/2000/XP Vorlage (.xlt)
  • Microsoft Excel 5.0 and 95 (.xls und .xlw)
  • Microsoft Excel 2003 XML (.xml)
  • Microsoft Excel 2007 (.xlsx)
  • Office Open XML Tabellendokument (.xlsx)
  • Data Interchange Format (.dif)
  • dBase (.dbf)
  • SYLK (.slk)
  • Text CSV (.csv und .txt)
  • StarCalc 3.0, 4.0, and 5.0 Formate (.sdc und .vor)
  • Unified Office Format Tabellendokument (.uos)
  • HTML Document (OpenOffice.org Calc) (.html und .htm)
  • Pocket Excel (.pxl)
Hinweis
Die Java Laufzeit Umgebung (JRE) wird benötigt, wenn Sie die Filter für die mobilen Geräte für AportisDoc (Palm), Pocket Word und Pocket Excel verwenden wollen.

Speichern von Präsentationen

Sigrid Jochen Erhardt

Zusätzlich zu den OpenDocument-Formaten (.odp, .otp, .fodp und .odg) kann Impress in diesen Formaten speichern:

  • OpenOffice.org 1.x Präsentation (.sxi)
  • OpenOffice.org 1.x Präsentation Vorlage (.sti)
  • Microsoft PowerPoint 97/2000/XP (.ppt)
  • Microsoft PowerPoint 97/2000/XP Vorlage (.pot)
  • Microsoft PowerPoint 2007 (.pptx und .potm)
  • Office Open XML Präsentation (.pptx, .potm und .ppsx)
  • StarDraw, StarImpress (.sda, .sdd und .vor)
  • Unified Office Format Präsentation (.uop)

Impress erlaubt es Ihnen, auch Ihre Präsentation in das MacroMedia Flash-Format zu exportieren und in jedes Grafikformat, das für Draw aufgelistet wird.

Speichern von Zeichnungen

Sigrid Jochen Erhardt

Draw kann nur in den OpenDocument-Zeichnungsformaten (.odg und .otg) speichern sowie in den von OpenOffice.org 1.x benutzten Formaten (.sxd und .std) und den StarDraw-Formaten (.sda, .sdd und .vor).

Allerdings kann Draw Dateien in die folgenden Grafik-Formate exportieren: BMP, EMF, EPS, GIF, JPEG, MET, PBM, PCT, PGM, PNG, PPM, RAS, SVG, SVM, TIFF, WMF und XPM.

Speichern von Writer/Web-Dokumenten

Sigrid Jochen Erhardt

Writer/Web kann in den folgenden Formaten speichern:

  • HTML Document (.html und .htm), as HTML 4.0 Transitional
  • OpenOffice.org 1.0 HTML Template (.stw)
  • OpenOffice.org 2.x HTML Template (.oth)
  • StarWriter/Web 4.0 and 5.0 (.vor)
  • Text (LibreOffice Writer/Web) (.txt)
  • Text Encoded (LibreOffice Writer/Web) (.txt)

Export in andere Formate

Sigrid Jochen Erhardt

LibreOffice benutzt den Begriff "Export" für Datei-Operationen, die einen Wechsel des Datei-Typs beinhalten. Falls Sie den Datei-Typ, den Sie suchen, nicht im "Speichern unter..."-Menü finden, schauen Sie unter "Export" für weitere Datei-Typen nach.

Um in eines dieser Formate zu exportieren, wählen Sie Datei -> Export. Im Export-Dialog geben Sie einen Dateinamen für das exportierte Dokument an, wählen das gewünschte Format in der Export-Format-Liste aus und anschießend klicken Sie auf die "Export"-Schaltfläche.