DE/Doku/Draw/01 IntroducingDraw

From The Document Foundation Wiki
< DE‎ | Doku‎ | Draw
Jump to: navigation, search

Hier gibt es die englischen Originale als ODT | PDF

Hier gibt es die Version für OOo 2.x als odt: https://www.odfauthors.org/libreoffice/deutsch/Archiv_alte_OOo_Dokumente/draw/dh1_einfuehrung_in_draw.odt/view


Seite gesperrt Florian Reisinger


== Introduction==

k-j (Name) (Name) (Name)

Draw is a vector graphics drawing tool, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, and polygons rather than as a collection of pixels (points on the screen). This permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

Draw’s functionality is extensive, and even though it was not designed to rival high-end graphics applications, it possesses significantly more functionality than the drawing tools that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

The Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file management or the way the LibreOffice environment works, are mentioned only briefly; they are covered in more detail in the Getting Started guide.

The Draw workplace

k-j (Name) (Name) (Name)

The main components of the Draw interface are shown in Figure 1.

The large area in the center of the window is where you make the drawings. You can surround the drawing area with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences. Therefore, your setup may look different. For example, many users put the main Drawing toolbar on the left-hand side of the workspace—not at the bottom, as shown here.

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for presentations. The Pages pane, on the left side of the Draw window in Figure 1 gives an overview of the pages that you create. If the Pages pane is not visible on your setup, you can enable it from the View menu (View > Page Pane). To make changes to the page order, just drag and drop one or more pages.

In Draw 3, the maximum size of a drawing page is 300 cm by 300 cm.

[[File:|thumb|Figure 1: Initial Draw window]]

[[File:|thumb|Figure 2: Rulers show the size of the selected object]]Rulers

k-j (Name) (Name) (Name)

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, you can enable them by selecting them from the View menu (View > Ruler).

The rulers show the size of a selected object on the page (see the gray double lines, highlighted in Figure 2). When no object is selected, they show the location of the mouse pointer, which helps to position drawing objects more accurately.

[[File:|thumb|Figure 3: Rulers units]]You can also use the rulers to manage object handles and guide lines, making it easier to position objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse.

To modify the units of measurement of the rulers (which you can define independently), right-click on the desired ruler, as illustrated for the horizontal ruler in Figure 3.

Status bar

k-j (Name) (Name) (Name)

The Status bar is located at the bottom of the Draw window and includes several Draw-specific fields, as identified in Figures 4 and 5.

[[File:|thumb|Figure 4: Left end of Draw status bar]]

[[File:|thumb|Figure 5: Right end of Draw status bar]]

The Information field shows which action is being carried out, or which object type is selected.

The Position field shows different information, depending on whether objects are currently selected or not:

  • When no object is selected, the left number pair shows the current position (in X,Y Cartesian coordinates) of the mouse cursor.
  • While an object is being resized with the mouse, the right number pair shows the size of the object (width and height).

Note

The sizes are given in the current measurement unit (not to be confused with the ruler units). This unit is defined in Tools > Options > LibreOffice Draw > General, where you can also change the scale of the page. Another way to change the scale is to double-click on the number shown in the status bar.

  • If an object is selected, the left number pair shows the X,Y coordinates of the upper-left corner, and the right number pair displays the size of the object, as seen in Figure 4. These numbers do not relate to the object itself, but to the selection outline, which is the smallest possible rectangle that can contain the visible part or parts of the object; see also Chapter 3, Working with Objects and Object Points.
  • When an object is selected, a double-click on this field opens the Position and Size dialog, which is described in detail in Chapter 4, Changing Object Attributes.

In the Indicator field, an asterisk (*) is shown whenever any change is made to the document but not yet saved to disk.

If you wish to digitally sign the document, a double-click or right-click in the Signature field brings up the signature box. Note that a document must be saved at least once before it can be signed. After it is signed, an indicator is present in this field.

The Slide field shows the sequence number for the current drawing page, in addition to the total number of pages that you created so far. This is useful when your drawing has a number of pages. If you select an object, the field enclosed by parentheses shows the layer in which the object resides within the drawing. In the example of Figure 5, the object is on the Layout layer of Slide 1, and there is a total number of one slide, so far.

The Page style field shows which template is being used.

The vertical bar in the middle of the Zoom slider represents a zoom factor of 100%. To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Double-clicking on the zoom level percent to open the Zoom & View Layout dialog.

Toolbars

k-j (Name) (Name) (Name)

You can display or hide the various Draw toolbars, according to your needs. To display or hide a toolbar, click View > Toolbars. On the menu that appears, choose which toolbars you want to display.

You can also select the icons that you wish to appear on the toolbars. To change the visible icons on any toolbar, click the arrow at the right-hand end of that toolbar and choose Visible Buttons from the drop-down menu. Visible icons are indicated by an outline around the icon. Click on icons to hide or show them on the toolbar.

[[File:|thumb|Figure 6: Selection of visible toolbar icons]]

The tools available in the various toolbars are explained in the following sections.

Standard toolbar

k-j (Name) (Name) (Name)

The Standard toolbar is the same for all LibreOffice components and is not described in detail here.

[[File:|thumb|Figure 7: Standard toolbar]]

Drawing toolbar

k-j (Name) (Name) (Name)

The Drawing toolbar is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes and for organizing them on the page. It is described in detail in Chapter 2, Drawing Basic Shapes.

[[File:|thumb|Figure 8: Drawing toolbar]]

Line and Filling toolbar

k-j (Name) (Name) (Name)

The Line and Filling toolbar lets you modify the main properties of a drawing object: the icons and pull-down lists vary, according to the type of object selected. For example, to change the thickness of a line with the spinner, hover the mouse over the spinner and click the up or down arrow to achieve the desired thickness.

[[File:|thumb|Figure 9: Line and Filling toolbar]]

In the example above, the available functions enable you to change the color, style, and width of the line drawn or the fill color, style, and other properties of an object. The object must first be selected with a mouse click. If the selected object is a text frame, the buttons for line style and fill color are changed to Invisible by default. You can change them to something else if you want.

Text Formatting toolbar

k-j (Name) (Name) (Name)

When text is selected, the Line and Filling toolbar changes to the Text Formatting toolbar, which is very similar to the Formatting toolbar in Writer. A more detailed explanation of the buttons on this toolbar can be found in Chapter 4, Changing Object Attributes.

[[File:|thumb|Figure 10: Text Formatting toolbar]]

Color bar

k-j (Name) (Name) (Name)

To display the Color bar, use View > Toolbars > Color Bar. The toolbar then appears at the bottom of the workspace and displays the current color palette.

[[File:|thumb|Figure 11: Color bar]]

This toolbar lets you rapidly choose the color of the various objects (lines, areas, and 3D effects) in your drawing. The first box in the panel corresponds to transparency (no color).

Choosing a color palette

k-j (Name) (Name) (Name)

You can access several specialized color palettes in Draw, as well as change individual colors to your own taste. This is done using the Area dialog, reached by choosing Format > Area, or the pouring can icon on the Line and Filling toolbar (Figure 9).

On the Area dialog, choose the Colors tab (Figure 12).

To load another palette, click on the Load Color List button (circled). The file selector dialog asks you to choose one of the standard LibreOffice palettes (files bearing the file extension*.soc). For example, web.soc is a color palette that is particularly adapted to creating drawings that are going to appear in Web pages. These colors will display correctly on workstations with screens capable of at least 256 colors.

A more detailed description of color palettes and their options can be found in Chapter 8, Tips and Tricks.

.[[File:|thumb|Figure 12. Changing the color palette]]

Options toolbar

k-j (Name) (Name) (Name)

The Options toolbar lets you activate or deactivate various drawing aids. The Options Bar is not one of the toolbars displayed by default. To display it, select View > Toolbars > Options.

[[File:|thumb|Figure 13: Options toolbar]]

The options are described in the table below and in greater detail in other chapters of the Draw Guide.

Table 1: Functions on the Options toolbar

Icon

Function

[[File:]]

Rotation mode after clicking object

[[File:]]

Display (or hide) the grid

[[File:]]

Display (or hide) the guides

[[File:]]

Display (or hide) guides when moving

[[File:]]

Snap to grid

[[File:]]

Snap to guides

[[File:]]

Snap to page margins

[[File:]]

Snap to object borders

[[File:]]

Snap to object points

[[File:]]

Allow quick editing

[[File:]]

Select text area only

[[File:]]

Double-click to edit text

[[File:]]

Simple handles

[[File:]]

Large handles

[[File:]]

Modify object with attributes

[[File:]]

Exit all groups

Drawing grid and guides

k-j (Name) (Name) (Name)

Draw offers a grid as a drawing aid. The grid can be turned on or off by clicking on the Grid icon on the Options toolbar. The points of the grid displayed on the screen are not shown on the printed drawing. The color, spacing, and resolution of the grid points can be individually chosen for each axis. This is described in more detail in Chapter 8, Tips and Tricks, in the section titled “Configuring the grid”.

Guides are special “helper lines” that can be turned on or off by clicking on the Guides icon on the Options toolbar. Draw offers a “Snap” function, with which you can place drawings exactly on these guides or on a grid point, a page margin, or a border or point of another object. All snap functions are described in detail in Chapter 8, Tips and Tricks.

Showing the position of the object while moving it makes positioning the object much easier. If the Guides function is activated, pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These lines extend to the edges of the drawing area. This function is also described in detail in Chapter 8.

Floating and moving toolbars

k-j (Name) (Name) (Name)

Many toolbar icons are marked with a small arrow. The arrow indicates that this icon has additional tools. Click the arrow to display the full set of tools (see Figure 14). You can “tear off” this tool set so it becomes a floating toolbar. Click the area at the bottom of the toolset, drag it across the screen to a location you want, and then release the mouse button.

To dock a floating toolbar to the top or side of the Draw workspace, Ctrl+click on the title of the toolbar. To float a docked toolbar, click on its handle and drag it off the side of the workspace (see Figure 15). The floating-toolbar capability is common to all components of LibreOffice.

[[File:|thumb|Figure 14: An arrow next to an icon indicates additional functions]]

Note

When a toolset is made into a floating toolbar, the icon on the existing toolbar remains in the toolbar and always shows the last command you used. This means that the icon you see on your screen may differ from the icon shown in this Guide.

[[File:|thumb|Figure 15: Moving a docked toolbar]]

Tip

When you double-click on an icon on a floating toolbar, the command corresponding to that icon will run. You can then repeat this action as often as you like. To exit from this mode, press the Esc key or click on another icon (for example [[File:]]). This may not work for every icon on every toolbar.

Customizing toolbars

k-j (Name) (Name) (Name)

You can customize toolbars in several ways. To show or hide icons defined for a toolbar, see Figure 6 on page 8.

To add functions to a toolbar, move tools between toolbars, or create new toolbars., choose View > Toolbars > Customize, select the Toolbars tab (Figure 16) and the toolbar you want to change, and then select the desired buttons for that toolbar.

[[File:|thumb|Figure 16: Customizing a toolbar]]

Each toolbar has a different list of functions. For details, see Chapter 14, Customizing LibreOffice, in the Getting Started guide. That chapter also describes how to customize menus.

Quick printing

k-j (Name) (Name) (Name)

Click the Print File Directly icon [[File:]] to send the entire document to the default printer defined for your computer.

Note

You can change the action of the Print File Directly icon to send the document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Controlling printing

k-j (Name) (Name) (Name)

For more control over printing, use the Print dialog (File > Print or Ctrl+P).

Note

The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice – Print and Tools > Options > LibreOffice Draw – Print.

[[File:|thumb|Figure 17. The Print dialog]]

The Print dialog has four tabs, from which you can choose a range of options, as described in the following sections.

Selecting general printing options

k-j (Name) (Name) (Name)

On the General tab of the Print dialog, you can choose:

  • The printer (from the printers available)
  • Which pages to print, the number of copies to print, and whether to collate multiple copies (Range and copies section)

Select the Properties button to display a dialog where you can choose portrait or landscape orientation, which paper tray to use, and the paper size to print on.

On the Options tab of the Print dialog (Figure 18) you can set a number of other, lesser used, options for printing.

[[File:|thumb|Figure 18: General print options]]

Printing multiple pages on a single sheet of paper

k-j (Name) (Name) (Name)

You can print multiple pages of a document on one sheet of paper. To do this:

  1. In the Print dialog, select the Page Layout tab.
  2. In the Layout section, select from the drop-down list the number of pages to print per sheet. The preview panel on the left of the Print dialog shows how the printed document will look.

When printing more than two pages per sheet, you can choose the order in which they are printing across and down the paper. The two pictures below show the difference.

[[File:]]

[[File:]]

  1. In the Page sides section, select whether to print all pages or only some pages.
  2. Click the Print button.

Selecting pages to print

k-j (Name) (Name) (Name)

In addition to printing a full document, you can choose to print individual pages, ranges of pages, or a selection of a document.

[[File:]]

To print an individual page:

  1. Choose File > Print from the menu bar.
  2. Select the page to print.
    1. In the Ranges and copies section of the Print dialog, select the Pages option.
    2. Enter the number of the page to print.
  3. Click the Print button.

To print a range of pages:

  1. Choose File > Print from the menu bar.
  2. Select the pages to print.
    1. In the Ranges and copies section of the Print dialog, select the Pages option.
    2. Enter the number of the pages to print (for example 1-4 or 1,3,7,11), or any combination of the two, for example: 1-4,5-9,10.
  3. Click the Print button.

To print a selection of a page, or a selection from multiple pages:

  1. In the document, select the section of the page to print.
  2. Choose File > Print from the menu bar.
  3. Choose the Selection option in the Ranges and copies section of the Print dialog.
  4. Click the Print button.

Printing a brochure

k-j (Name) (Name) (Name)

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

Tip

Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

To print a brochure on a single-sided printer:

  1. Choose File > Print.
  2. In the Print dialog, click Properties.
  3. Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures. Click OK to return to the Print dialog.
  4. Select the Page layout tab in the Print dialog (see Figure 19).
  5. Select the Brochure option.
  6. In the Page sides section, select Back sides / left pages option from the Include drop-down list.
  7. Click the Print button.
  8. Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.
  9. On the Print dialog, in the Page sides section, select Front sides / right pages option from the Include drop down box.
  10. Click the Print button.

[[File:|thumb|Figure 19: Setting up to print a brochure]]

Tip

If your printer can print double-sided automatically, choose All pages.

Printing in black and white (on a color printer)

k-j (Name) (Name) (Name)

You may wish to print documents in black and white on a color printer. Several choices are available. Please note that some color printers may print in color regardless of the settings you choose.

To change the printer settings to print in black and white or grayscale:

  1. Choose File > Print to open the Print dialog.
  2. Click Properties to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information.
  3. The choices for color might include black and white or grayscale. Choose the required setting.
  4. Click OK to confirm your choice and return to the Print dialog,
  5. Click the Print button to print the document.

Tip

Grayscale is best if you have any graphics in the document.

To change the LibreOffice settings to print all color text and graphics as grayscale:

  1. Choose Tools > Options > LibreOffice > Print.
  2. Select the Convert colors to grayscale option. Click OK to save the change.
  3. Open the Print dialog (File > Print).
  4. Click the Print button to print the document.

To change the Draw settings to print all color text as black, and all graphics as grayscale:

  1. Choose Tools > Options > LibreOffice Draw > Print.
  2. Under Contents, select the Print text in black option. Click OK to save the change.
  3. Open the Print dialog (File > Print).
  4. Click the Print button to print the document.

Exporting to PDF

k-j (Name) (Name) (Name)

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending the file to someone else to view using Adobe Reader or other PDF viewers.

The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.

Quick export to PDF

k-j (Name) (Name) (Name)

Click the Export Directly as PDF icon [[File:]] to export the entire document using your default PDF settings. You are asked to enter the file name and location for the PDF file, but you do not get a chance to choose a page range, the image compression, or other options.

Controlling PDF content and quality

k-j (Name) (Name) (Name)

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has five pages (General, Initial View, User Interface, Links, and Security). Select the appropriate settings, and then click Export. In the following dialog, enter the location and file name of the PDF to be created, and click Save to export the file. See Chapter 10, Printing, Exporting, Emailing, in the Getting Started book for details.

Exporting to other formats

k-j (Name) (Name) (Name)

LibreOffice uses the term “export” for some file operations involving a change of file type. If you cannot find what you want under File > Save As, look under File > Export as well.

LibreOffice can export files to XHTML. In addition, Draw can export to Adobe Flash (.swf) and a range of image formats.

To export to one of these formats, choose File > Export. On the Export dialog, specify a file name for the exported document, then select the required format in the File format list and click the Export button.

See Chapter 6, Editing Pictures, in this book for more about exporting graphics.

Note

The content of the exported file will depend on the element(s) selected on the page. No selection results in the entire image being exported. For most export formats only the image on the current page will be exported.

Exporting Draw documents as web pages

k-j (Name) (Name) (Name)

To export a multi-page Draw document to a series of web pages, choose File > Export and select HTML Document as the file type. The HTML Export wizard opens. Follow the prompts to creat the web pages. If you wish, the wizard can generate a navigation aid to help in moving from page to page.

E-mailing documents

k-j (Name) (Name) (Name)

LibreOffice provides several ways to send documents quickly and easily as an e-mail ttachment in one of three formats: OpenDocument (LibreOffice’s default format), Microsoft Office formats, or PDF.

Note

Documents can only be sent from the LibreOffice menu if a mail profile has been set up.

To send the current document in OpenDocument format:

  1. Choose File > Send > Document as E-mail. LibreOffice opens your default e-mail program. The document is attached.
  2. In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

If you choose E-mail as PDF, LibreOffice first creates a PDF using your default PDF settings (as when using the Export Directly as PDF toolbar button) and then opens your email program with the PDF file attached.

You can email a document to several recipients. For details, see Chapter 10, Printing, Exporting, Emailing, in the Getting Started book.