Documentation/System Requirements

From The Document Foundation Wiki
Jump to: navigation, search

This page details System Requirements for LibreOffice, the Impress Remote, and other software.

LibreOffice

Windows, Mac, Linux, and Android

System requirements for LibreOffice are available on the main LibreOffice.org website. Official supported by The Document Foundation.

For older operating system version here a table with links to the download archive:

Operating System latest supported LibreOffice version Link to the download archive
Windows 2000 3.6.7.2 x86
Windows XP 5.4.7.2 32bit, 64bit
Windows Vista 5.4.7.2 32bit, 64bit
Mac OS X 10.5 PPC 3.6.7.2 PPC, please read also the next section!
Mac OS X 10.5 Intel 3.6.7.2 32bit
Mac OS X 10.6 4.3.7.2 32bit, 64 bit
Mac OS X 10.7 4.3.7.2 32bit, 64 bit
Mac OS X 10.8 5.4.7.2 64bit
Mac OS X 10.9

LibreOffice on other OSes

macOS 10.5 PowerPC (PPC)

Alpha builds (prebuild and build instructions) for macOS 10.5 PowerPC by Douglas Mencken are available at osuosl.org.

FreeBSD

LibreOffice runs on FreeBSD and is available as package in the standard FreeBSD repositories. This is the suggested way to install LibreOffice on FreeBSD. There is no other community-supplied LibreOffice installer provided.

OpenBSD

See package information here.

NetBSD

See package information in pkgsrc.

Haiku

See information on the port in the announcement on the Haiku forum "LibreOffice is now available for Haiku".

Solaris & OpenIndiana Hipster

Amiga

Linux based

Linux powered Amiga can run LibreOffice see this forum thread.

AmigaOS

Only announced, see this press release and this press release.

LibreOffice Viewer for Android

Impress Remote