LibreOffice 4.4: Release Notes

From The Document Foundation Wiki
Jump to: navigation, search

Contents

About this page

This is the page with our 4.4 release notes. It should be final now the 4.4 version itself has been released. However, might you spot some missing information, then we would appreciate to hear from you. Thanks in advance for your help!


Writer

Master Document Templates

Writer has long had Master Documents. A master document lets you manage large documents, such as a book with many chapters. The master document can be seen as a container for individual LibreOffice Writer files. LibreOffice 4.4 introduces Master Document Templates. These Master Document Templates can be added to the Template Manager and creating a new document based on a Master Document Template creates a Master Document with the same initial content as the Template it is based upon. (Caolán McNamara, Red Hat)

Shapes can have a TextBox

Writer shapes can now have a Textbox, meaning that it's possible to have complex Writer content and full drawinglayer geometry for a shape at the same time. tdf#70942 blog entry (Miklós Vajna, Collabora)

Table in the shape text and shape with rounded corners.

Improvements to Track Changes

  • The “Accept Change” and “Reject Change” commands now automatically jump to the next change. tdf#83953 (Samuel Mehrbrodt)
  • Inclusion of new buttons in the Track Changes toolbar, along with a new set of icons. tdf#83955, tdf#84405 (Yousuf Philips)
New icons for the Changes toolbar
  • The keyboard shortcut Ctrl+⇧ Shift+E has been associated with the recording of track changes. tdf#86183 (Yousuf Philips)

Style dropdown

The style dropdown now has a split menu to edit or update the selected style. tdf#62081 (Szymon Kłos and Samuel Mehrbrodt)

Split Menu for Style Dropdown.

Line numbering easier to apply for headers and footers

Line numbering for Headers and Footers (using the proper Header/Footer paragraph style) can now be enabled in the same location where the line numbering is set in Tools ▸ Line Numbering, in addition to the already existing method in the style dialog. tdf#84504 (Charu Tyagi, Ericsson)

Line Numbering of header/footer.

Status bar improvements

  • Page number in the statusbar are more easily understood when page number styles are used. tdf#80617 (Yousuf Philips and Samuel Mehrbrodt)
Before (on the left) and after (on the right) side-by-side of how the statusbar page numbers have improved.
  • Spacing between elements was improved to work better in low-resolution screens and small windows and double-clicking in the blank statusbar field no longer opens the 'Fields' dialog. tdf#86018 (Yousuf Philips and Samuel Mehrbrodt)
  • Click behaviour was unified so that left-click results in an action or dialog appearing and right-click results in the display of a context menu. tdf#82707 (Yousuf Philips and Samuel Mehrbrodt)
  • Tooltips were added to all elements of the statusbar. tdf#82708 (Yousuf Philips and Samuel Mehrbrodt)
  • Word and character count now have thousand separators. tdf#83308 (Yousuf Philips and Matthew J. Francis)

Toolbar improvements

The “Standard” and “Formatting” toolbars were reorganized by removing uncommonly used commands and replacing them with frequent features, in order to reduce the need for users to hunt through menus or customize toolbars. Additional buttons have been added to the toolbars, but are hidden by default and can be enabled by using the “Customize” option. tdf#81475 (Yousuf Philips and Samuel Mehrbrodt)

Before (on the top) and after (on the bottom) side-by-side of how the toolbars have been improved.

Navigator bookmarks

Bookmarks in Navigator can be named using any character that is accepted in HTML anchor names. Specifically, LibreOffice now accepts period (.) and colon (:). tdf#56116 (Brij Mohan Lal Srivastava)

AutoCorrect improvements

Dash replacement between numbers, wildcard patterns in the default Autocorrect lists and new middle autocorrect wildcard patterns, also in Impress, Calc and Draw (László Németh):

  • Improved “Replace dashes” autocorrect feature: double dashes between numbers are replaced with en dash (–) instead of em dash (—), according to the orthography of ranges of values (years, page numbers etc.), for example, 1:15--2:15 p.m., for ages 3--5, pp. 38--55, President Jimmy Carter (1977--81) will be replaced with 1:15–2:15 p.m., for ages 3–5, pp. 38–55, President Jimmy Carter (1977–81) (See also Dash Wikipedia logo v3.svg), tdf#62923
  • Simplified input of special symbols by default autocorrect patterns:
    • Trademark, copyright, registered symbols: don’t need to type and delete spaces before the default (tm), (C), (R) autocorrect patterns any more: LibreOffice(tm) will be replaced with LibreOffice™. tdf#81571
    • Arrows: don’t need to type spaces around the default “ASCII arrow” autocorrect patterns (->, <-): A->B->CA→B→C.
    • Subscript/superscript characters (in French and Hungarian default autocorrect patterns): TeX-like input for Unicode subscript/superscript characters: cm^2cm², H_2OH₂O, H^+H⁺. (Note: these characters are usually better typographically, than using a smaller letter size with subscript/superscript character formatting, especially with the default Graphite font of LibreOffice, Linux Libertine G.) [French (Olivier R.) and Hungarian].
  • Middle Autocorrect wildcard patterns: Autocorrect wildcard patterns (text.* and .*text) introduced in LibreOffice 4.2.x allowed autocorrect replacements of arbitrary suffixes and prefixes. Now in LibreOffice 4.4 it is possible to add .*text.*-like patterns to correct common typing errors within words. tdf#55292
For example, a single autocorrect entry with the pattern .*laod.*load will correct all words containing that specific letter sequence:
uplaoding → uploading
uplaoded → uploaded
downlaoding → downloading
downlaoded → downloaded
...
Moreover the .*text.* pattern can be used to type special characters as well, e.g. for poor man’s f-ligature replacements:
.*fi.* -> fi (U-FB01)
.*fl.* -> fl (U-FB02)
(Note: some Graphite and OpenType fonts have automatic f-ligature replacement in LibreOffice).

Calc

See also: GUI: Tab changes

Statistics Wizard (alternative to Excel's Add-in "Analysis ToolPak")

In Statistics Wizard in Data ▸ Statistics:

  • Added Quartile in Descriptive statistics. tdf#81801 (Tomaž Vajngerl, Collabora)
  • Added z-test. tdf#74669 (Tomaž Vajngerl, Collabora)
  • Added Chi square test. tdf#76868 (Tomaž Vajngerl, Collabora)

Direct conversion of formulas into static values

A new feature was added to convert formula cells into static values (via the menu Tools ▸ Cell Contents ▸ Formula to Value). Previously, you would need to cut the cells and paste them back into place to have the same outcome. (Kohei Yoshida, Collabora)

Formula engine

  • Added AGGREGATE spreadsheet function for Excel interoperability. tdf#73148 (Winfried Donkers and Eike Rathke)

Toolbar improvements

The “Standard” and “Formatting” toolbars were reorganized by removing uncommonly used commands and replacing them with frequent features, in order to reduce the need for users to hunt through menus or customize toolbars. Additional buttons have been added to the toolbars, but are hidden by default and can be enabled by using the toolbar right-click context menu “Customize Toolbar...” option or Tools ▸ Customize.... tdf#85594 (Yousuf Philips)

Before (on the top) and after (on the bottom) side-by-side of how the toolbars have been improved.

Sheet context menu

The right-click context menu that appear for managing sheets now has icons for sheet operations. tdf#86476 (Yousuf Philips)

Impress and Draw

See also: GUI: Tab changes

Text of Master View Object Previews

  • In Slide Master view, the text of the presentation object previews is now read-only. Changing the text of these previews has never affected the objects based on the styles that the presentation object preview. To add or hide a level to the outline numbering preview, now you can right-click on the last line to display a menu to add/hide another level. (Caolán McNamara, Red Hat)
Hide/show outline levels from the context menu.
  • Toggling bullets on and off in slide master view in the outline preview via "Bullets On/Off" now truly toggles on/off the bullets of the Outline styles. In the past this only affected the preview itself, leaving the outline styles unchanged. Now it correctly affects outline levels in the normal view. (Caolán McNamara, Red Hat)

Select and toggle off master elements directly via Delete

In Slide Master view, master elements which Impress allows the user to remove via View ▸ Master ▸ Master elements can now be removed by direct deletion of the matching placeholder in the Master View preview. In other words, to remove a footer, header, slide number or date/time, select the corresponding box in Master View and press Delete. (Caolán McNamara, Red Hat)

Select and toggle off master elements directly via Delete

OpenGL transitions

  • Implemented and enabled for Windows. (Markus Mohrhard, Collabora)
  • Improved implementation based on new OpenGL framework in vcl for Linux, Windows and OS X. (Markus Mohrhard, Collabora)

Page Title field

New field: Page Title in Insert ▸ Field ▸ Page Title. tdf#47302 (Jennifer Liebel)

Inherit current style of cells when inserting New row/column in table

When we have a table in impress, have modified a cell style and then add a new row or column it now inherits the style of the current row/column for the new one instead of using default values. tdf#60712 (Hideki Ikeda)

Password for editing

It is now possible to save an Impress/Draw file read-only and require a password to modify it. tdf#63483 (Katarína Behrens)

Printing: use specified paper size

Draw now uses the paper size specified in page formatting with printing. tdf#63905 (Eilidh McAdam)

Zoom Mode button

Creation of a new zoom mode button that is able to zoom in, zoom out and pan with the use of Ctrl and ⇧ Shift. tdf#55903 tdf#83572 (Maxim Monastirsky and Yousuf Philips)

Toolbar improvements

The default toolbars were reorganized to bring frequent used features to the toolbars. tdf#84909 (Yousuf Philips)

Before (on the top) and after (on the bottom) side-by-side of how the impress toolbars have been improved.

Menubar improvements

The View menu was reorganized to better unify its items similar to Writer and Calc. tdf#86209 (Yousuf Philips)

Math

Color support

New colors supported by Math.

Core

Included fonts

LibreOffice 4.4 adds the libre-licensed Caladea and Carlito fonts (Huerta Tipográfica). Caladea and Carlito have the same metrics and proportions as Microsoft’s Cambria and Calibri, respectively, so they can be used as drop-in replacements. (András Tímár, Collabora)

Digitally signed PDF export

PDF's generated by LibreOffice can now be digital signed directly from LibreOffice during the export. It works on Windows, OS X, and Linux, and on Windows, the built-in certificate functionality is used to store your certificates for signing. (Gökçen Eraslan - GSoC 2012, Markus Wernig - Wilhelm Tux, fund raising, Tor Lillqvist - Collabora)

Selecting a certificate for signing on Windows.
The Digital Signatures tab of the PDF export dialog.

Drawing objects

You can move only the point next to the rectangle in "line callout" drawings, with ⇧ Shift key pressed. (Matúš Kukan, Collabora)

Technical Dictionary

Various updates have been made to the technical dictionary. New Ubuntu and Debian release names have been added, as well as more Operating System names. Additionally, Obsolete Ubuntu release names (before Ubuntu 10.04 LTS) were removed from the technical dictionary.

LibreOfficeKit

Impress supports tiled rendering Wikipedia logo v3.svg for improved performance when navigating documents in mobile devices. (Andrzej Hunt, GSoC 2014)

Help content

Code quality

Translation of German comments

Many more source code comments have been translated into English. (Daniel Sikeler; Christian M. Heller; Tobias Madl; Thomas Viehmann; Philipp Riemer; Michael Jaumann; Laurent Balland-Poirier; Chris Sherlock; Philipp Weissenbacher; and Jennifer Liebel)

Coverity

Improved code quality based on the Coverity scan analysis.

Results based on the Coverity scan analysis results. (Data available after registration)

Refactoring

Refactored large parts of Writer code, split the large classes into smaller interfaces. (Valentin Kettner, GSoC 2014)

Filters

See also: Document Liberation libraries

Media file formats

More media file types are now accessible from Insert ▸ Audio/Video: Real Audio (.ra), Real Media (.rm), Digital Video (.dv), Audio Codec (.ac3), Ogg Opus (.opus), Advanced Systems (.asf), MPEG Audio (.m4a). tdf#82994 (Daniel Sikeler and Caolán McNamara)

New import filters

  • Draw can now import Adobe PageMaker files (v. 6-7), via libpagemaker. (Anurag Kanungo, GSoC 2014)
Sample document opened in PageMaker 7.0
Sample document opened in LibreOffice 4.4
  • Both Writer and Draw can import files from MacDraw, MacDraw II and RagTime for Mac (v. 2-3), via libmwaw. (Alonso Laurent; Fridrich Štrba and David Tardon)
  • Writer can now import Sony BroadBand eBook (LRF) files, via libe-book. (David Tardon)
Sample e-book opened in LibreOffice.

Connection to SharePoint and OneDrive

  • It is possible to connect to SharePoint 2010/2013 directly from LibreOffice. blog entry (Mihai Varga, GSoC 2014)
Versioning
Check-out
Check-in
Complete check-in
  • It is possible to connect to OneDrive directly from LibreOffice. blog entry (Mihai Varga, GSoC 2014) tdf#62437
Server setup
Authentication
File picking
Check-out

Improved OOXML support

  • Metadata is now imported from PPTX. (Miklós Vajna, Collabora)
  • Custom wrap polygon is now exported to DOCX. (Miklós Vajna, Collabora)
  • Support for bitmaps when exporting cropped images to DOCX. (Miklós Vajna, Collabora)

Improved Visio support

  • Metadata is now imported from VSDX. tdf#86664 (Miklós Vajna, Collabora)
  • Metadata is now imported from VSD. tdf#86729 (Miklós Vajna, Collabora)

Improved Table of Contents in HTML export

It is possible to export CSS2 dot leaders by enabling Print layout in Options ▸ Load/Save ▸ HTML Compatibility, and selecting the HTML Document file type in the Save As dialog of Writer. (László Németh)
Tested in Firefox 32, Google Chrome 39, Internet Explorer 11.

Old HTML Table of Contents.
New HTML Table of Contents with CSS2 dot leaders.

Document thumbnails

Thumbnails are now compressed to PNG-8 which takes much less space than PNG-24 without much quality degradation. Typically the thumbnails compress to about 35% of the size of thumbnail from a document saved with LibreOffice 4.3. tdf#62104 (Tomaž Vajngerl, Collabora)

Improved MS Publisher support

  • Embedded fonts are now imported. (David Tardon)
  • Tables are now imported. (David Tardon)
  • Metadata is now imported. (Miklós Vajna, Collabora)

Improved Abiword support

  • Text language is now correctly set. (David Tardon)
  • Globally defined writing mode is now used. (David Tardon)
  • Headings are now recognized. (David Tardon)
  • Metadata is now imported. (David Tardon)

Improved MS Works Spreadsheet support

  • An old Lotus LICS character encoding is now recognized and converted. (Laurent Alonso)

Improved FictionBook support

  • Text language is now set (provided the input file specifies it correctly). (David Tardon)
  • Headings are now imported. (David Tardon)

GUI

Dialogs conversion to WidgetLayout finished

LibreOffice 4.0 introduced an infrastructure to build user interface dialogs and windows with the XML-based .ui format of GtkBuilder/Glade. All the original dialogs and tabs (.src-based) are now converted to this new format. blog entry (Caolán McNamara, Red Hat; Palenik Mihály, GSoC 2014; Szymon Kłos, GSoC 2014; and many more heroes)

Sifr as the default icon theme on OS X

LibreOffice 4.4 now defaults to the Sifr icon theme on OS X.

Sifr icon theme on OS X.

Changes to rulers

  • Rulers have smaller numbers and are now hidden by default. (Jan Holešovský, Collabora)
LO 4.4 rulers (on the right) have a more discrete, less distracting appearance.
  • Rulers can be turned on or off by using the key combination Ctrl+⇧ Shift+R. tdf#87042 (Mattias Põldaru)
  • Writer now hides the vertical ruler by default, though a user can re-enable it in Tools ▸ Options ▸ LibreOffice Writer ▸ View. tdf#87923 (Jan Holešovský, Collabora)

Start Center

Templates now appear directly in the Start Center and can be picked from there. (Efe Gürkan Yalaman, GSoC 2014; and Jan Holešovský, Collabora)

Templates in the Start Center.

New default templates

New templates have been created, and included in the default installation (Alexander Wilms, Edmund Laugasson, Jun NOGATA, Michael Kovarik, Péter Szathmáry, Zirk)

The new templates in the Start Center.

New color selector

  • Shows recently used document colours
  • Support for different color palettes and for .gpl GIMP palette format
  • Allows to directly open the color picker and choose another colour

(Krisztian Pinter, GSoC 2014; Tomaž Vajngerl, Collabora; Maxim Monastirsky; and Adolfo Jayme Barrientos)

The new color selector facilitates access to custom colors and avoids the need for hunting in the menus.

Reworked paragraph line spacing dropdown

The paragraph line spacing dropdown that was present only in the sidebar has been reworked so that it can be used in the main toolbar too, and was added there. tdf#83076 (Jan Holešovský, Collabora; Yousuf Philips)

The reworked line spacing dropdown in action.

Bullet and Numbering dropdown

The “Bullets” and “Numbering” toolbar buttons now have drop-down menus so it easier to change the list style without opening the lists dialog. tdf#85804 (Maxim Monastirsky; Yousuf Philips)

New list dropdown in action.

Sidebar changes

The Sidebar is still receiving progressive improvements from our community developers over the initial code import from Symphony:

  • It has now been enabled by default in Writer, in addition to Impress (where it was enabled since 4.2). Also, the Sidebar now combines the functionalities of the old “Gallery” and “Styles & Formatting” floating panels, removing a lot of UI redundancy. tdf#73151 (Samuel Mehrbrodt)
  • Tabs icons now also work as a toggle to open/close sidebar decks. tdf#67627 (Thomas Arnhold)
  • The sidebar drop down menu now has a 'Close Sidebar' entry. tdf#85937 (Samuel Mehrbrodt)
  • Sidebar open by default in Writer, Calc and Draw showing just the tab icons. tdf#85935 (Jan Holešovský, Collabora)
  • Style tabs have new icons. (Miroslav Mazel)
New icons for Style tabs

Context menu changes

  • Cut, Copy and Paste actions are now at the top of the context menu. tdf#71770 tdf#84293 (Jeffrey Stedfast, Xamarin; Yousuf Philips)
  • Writer now has the ability to access the Paste Special dialog via the context menu, reaching feature parity with Calc. tdf#62947 (Babu Vincent; Yousuf Philips)
  • Font, Font size and Text alignment formatting options have been removed from the context menu: according to statistics were widely unused and their removal reduces visual clutter. tdf#81132 (Yousuf Philips and Samuel Mehrbrodt)
Cut, copy and paste moved at the top of contextual menu
Paste special is now available via the context menu
Removed some unused formatting options.
  • Writer now has an option to change the currently selected image to another graphic via the context menu, reaching feature parity with Impress and Draw. tdf#82496 (Jennifer Liebel)
Change Picture via the context menu.

Edit / Read-only mode

LibreOffice will now display an infobar to indicate visibly when a document is being opened in read-only mode. This infobar replaces the “Edit file” icon in the main toolbar, as its labeling and usage patterns proved confusing for users. Activation and deactivation of read-only mode is also available from within the menu Edit ▸ Edit Mode or through the keyboard shortcut Ctrl+⇧ Shift+M. tdf#80538 tdf#80536 (Yousuf Philips, Samuel Mehrbrodt and Joren De Cuyper)

The infobar provides clearer guidance to users in this use case.

Tab changes

  • Sheet tabs (Calc) and layer tabs (Draw) were moved to an independent row and are no longer displayed next to the horizontal scrollbar. As many visual styles under Linux (in addition to the default OS X configuration) use very thin scrollbars, these rendered the tabs too small to be clickable and, most importantly, readable. tdf#36772 (Tomaž Vajngerl, Collabora and Samuel Mehrbrodt)
  • The tabs have an updated, flatter look. (Tomaž Vajngerl, Collabora)
Before.
After.

Firefox Themes

  • New browser for Firefox themes with search and preview. (Rachit Gupta, GSoC 2014)
The new dialog to search and apply Firefox themes.
  • Firefox themes now apply also to bottom toolbars. tdf#59299 (Michael Jaumann, LHM)
Firefox themes now apply both to top and bottom toolbars.

Image scaling

Images are now scaled proportionally by default in Calc and Impress/Draw as they were already in Writer. tdf#83808 (Samuel Mehrbrodt)

Simplification of Special Character dialog

Special characters are now added to an editable field so special characters can be inserted/removed at the location of the cursor in the field. tdf#64302 tdf#85907 (Szymon Kłos; Adolfo Jayme Barrientos)

Simplified special character dialog with input field.

Icon improvements

  • New and improved icons have been added to the Tango, Sifr, and Oxygen icon themes. tdf#75256 tdf#75359 (Mirek Mazel; Yousuf Philips; Matthias Freund; Alexander Wilms; and Adolfo Jayme Barrientos)
  • Large icons are shown by default on Windows, as they are on Linux and Mac OS. tdf#82309 (Jan Holešovský, Collabora; and Yousuf Philips)

Locale in About dialog

The About dialog now informs the user about the locale Wikipedia logo v3.svg they are currently using. tdf#85432 (Brij Mohan Lal Srivastava)

The locale information, provided below the build ID, can be useful to debug some language-related issues.

UI text improvements

See: Documentation/RecentStringChanges#4.4

Localization

New languages/locales with locale data

Available as default document language and for locale specific formatting.

  • Added Catalan Valencian [ca-ES-valencia] locale data. tdf#83292 (Andras Timar)

Improved language tools (spell-check dictionaries, thesaurus, hyphenation patterns)

  • Portuguese spell-check dictionary updated.
  • French spell-check dictionary updated. (Olivier R.)
  • Slovenian thesaurus updated. (Martin Srebotnjak)
  • Russian proof-reading rules (Lightproof) updated. (Yakov Reztsov)
  • Spanish AutoCorrect patterns include more common misspellings and many typographical rules were added. (Adolfo Jayme Barrientos)

Performance

  • Loading large autocorrect lists is at least twice as fast now, because the lists are parsed in a thread by the fastparser and repeated parsing of unchanged files is avoided. tdf#79761 (Daniel Sikeler)
  • Redundant image swap out / in has been significantly cleaned up avoiding wasteful image load/save. (Tamas Zolnai, Collabora)
  • FastSerializer classes used by all OpenXML export are very significantly faster and more efficient, reducing syscall thrash. (Matus Kukan, Collabora)
  • JPEG-Turbo - we now use and bundle this library which provides in excess of a 2x performance improvement for loading and de-compressing JPEG images (Matúš Kukan, Collabora)
  • Mail merge in Writer should be now significantly faster when processing a large number of records (Luboš Luňák, Collabora)

Scripting / Basic

  • It's now possible to export a Basic library from an Excel document. tdf#60904 (Caolán McNamara, Red Hat)
  • Changed the value returned from GetSolarVersion. Before this change the returned value was one number for version major, minor and micro. So, for version 4.4.0, the returned value was 440. Now we're using two decimals for version major, two for version minor and one for version micro. The new format is 40400, for version 4.4.0. tdf#60689 (Marcos Paulo de Souza)
  • Add an (un-published: be careful) processEventsToIdle() method to the com.sun.star.awt.Toolkit service - calling this causes all pending rendering to be completed. (Michael Meeks, Collabora)

Access2Base updated

The bundled Access2Base Basic library is upgraded to version 1.2.0. (Jean-Pierre Ledure)

  • All the methods which can meaningfully be used without a database connection (error handling, dialogs manipulations, status bar and window handling, commands launch...) have been reviewed to become executable before any OpenConnection call.
  • A CloseConnection method has been added to free resources.
  • To pass values from one open document to another, use the TempVars collection of TempVar objects.
  • New properties added for forms and subforms: OrderBy and OrderByOn.
  • The ApplyFilter and SetOrderBy actions are now applicable on table or query datasheets, and on forms or subforms as well.
  • The GoTorecord method has been extended to table and query datasheets.

Details here

Feature removal / deprecation

The feature to embed LibreOffice in certain web browsers via the deprecated NPAPI Wikipedia logo v3.svg (enabled through the Internet ▸ Browser Plug-in ▸ Display documents in browser option) has been removed. (Bryan Quigley, blog)

API changes

Removed configuration options

C++ UNO language binding and URE libraries

  • Add default value for Context param in UNO C++ exception class constructors which makes it possible to use UNO exceptions with less code verbosity.

OSL macro clean-up

IReference and ReferenceObject

  • ReferenceObject in include/salhelper/refobj.hxx no longer extends IReference.
  • IReference has been removed from include/rtl/ref.hxx, it is no longer in use.

Java UNO language binding

  • Add extra constructors for UNO Java exception classes that take a "Throwable cause" parameter, allowing us to store the original cause when rethrowing exceptions.

Java Office Bean

UNO API changes

The following UNO interfaces and services were changed:

Platform compatibility

Windows

  • Known Issue: there are problems with running the Windows release on older CPUs that lack support for SSE2 instructions, see tdf#82430. Affected CPUs include Intel Pentium III and older, and all AMD 32-bit CPUs (Athlon XP and older).

OS X

  • LibreOffice 4.4 requires OS X 10.8 or later. The binary packages provided are 64-bit only.
  • Known Issue: LibreOffice Language packs are not presently signed. They will fail Gatekeeper security checks and cause rejection of the LibreOffice install. Workaround is to launch the signed 4.4.x LibreOffice installation one time after installation. And only then install the Language pack with <Ctrl>+Open Gatekeeper override. tdf#89561, tdf#84352.