Neuerungen und Veränderungen in LibreOffice 4.4

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 4.4 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 4.3.

Writer

  • Dokumentvorlagen für Globaldokumente: Mit LibreOffice 4.4 werden Globaldokument-Dokumentvorlagen eingeführt. Diese Vorlagen können wie gehabt zu den Dokumentvorlagen hinzugefügt und neue Globaldokumente mit demselben Anfangsinhalt auf Grundlage dieser Vorlagen erstellt werden (bisher war nur der Umweg über das Abspeichern einer Writer-Datei als Globaldokument möglich).
Caolán McNamara - Red Hat
  • Textfelder in Writer-Formen: Writer-Formen besitzen nun Textfelder (anstatt der einfachen Texteingabe-Felder wie bisher), wordurch es nun möglich ist, komplexen Writer-Inhalt und volle Zeichnungsunterstützung zugleich für Formen zu verwenden (tdf#70942).
Miklós Vajna - Collabora
Tabelle innerhalb einer Form.
  • Verbesserung bei der Aufzeichnung von Änderungen: „Änderungen übernehmen“ und „Änderungen ablehnen“ springen nun automatisch zur nächsten Änderung (tdf#83953).
Samuel Mehrbrodt
  • Symbolleiste Änderungen: Es wurden neue Schaltflächen zur Symbolleiste hinzugefügt sowie neue Symbole hierfür erstellt (tdf#83955, tdf#84405).
Yousuf Philips
Neue Symbole der Symbolleiste Änderungen.
  • Umbenennung des Menüeintrags Änderungen: Der Menüeintrag unter Bearbeiten ▸ Änderungen wurde in Änderungen verfolgen umbenannt (tdf#85046).
Yousuf Philips
  • Tastenkombination für Änderungen aufzeichnen: Die Tastenkombination Strg+⇧ Umschalt+E wurde mit dem Befehl Änderungen aufzeichnen verknüpft (tdf#86183).
Yousuf Philips
  • Aufklappmenü Vorlage: Die Einträge im Aufklappmenü Vorlage besitzen jetzt Auswahlmenüs, über die die ausgewählte Vorlage bearbeitet oder aktualisiert werden kann (tdf#62081).
Szymon Kłos, Samuel Mehrbrodt
Auswahlmenü im Aufklappmenü Vorlage.
  • Zeilennummerierung für Kopf- und Fußzeilen: Die Zeilennummerierung für Kopf- und Fußzeilen kann nun (unter Verwendung der festgelegten Absatzvorlage für Kopf-/Fußzeilen) im gleichen Dialog aktiviert werden, in dem auch die Zeilennummerierung eingestellt wird: Extras ▸ Zeilennummerierung.... Dies funktioniert alternativ zur bereits bestehenden Möglichkeit über die Verwendung der entsprechenden Vorlage im Dialog Vorlagen (tdf#84504).
Charu Tyagi - Ericsson
Zeilennummerierung für Kopf- und Fußzeilen.
  • Verbesserungen an der Statusleiste:
  • Die Seitenzählung in der Statusleiste ist nun aussagekräftiger, wenn verschiedene Vorlagen für Seitenzählungen verwendet werden (tdf#80617).
Yousuf Philips, Samuel Mehrbrodt
Neue Seitenzählung in der Statusleiste
Links: vorher - Rechts: neu.
  • Die Abstände zwischen den Elementen der Statusleiste werden bei geringen Auflösungen und kleinen Fenstern nun besser verteilt; ein Doppelklick in einen leeren Bereich öffnet zukünftig nicht mehr den Dialog Felder (tdf#86018).
Yousuf Philips, Samuel Mehrbrodt
  • Das Klickverhalten wurde vereinheitlicht, sodass Linksklicks nun eine Aktion ausführen oder einen Dialog öffnen und Rechtsklicks ein Kontextmenü öffnen (tdf#82707).
Yousuf Philips, Samuel Mehrbrodt
  • Kurzinfos sind nun für alle Elemente der Statusleiste verfügbar (tdf#82708).
Yousuf Philips, Samuel Mehrbrodt
  • Die Werte der Wort- und Zeichenanzahl in einem Dokument werden nun mit einen Tausenderpunkt dargestellt (tdf#83308).
Yousuf Philips, Matthew J. Francis
  • Verbesserungen der Symbolleisten:
  • Die Symbolleisten Standard und Format wurden neu organisiert, wobei selten benutzte durch häufiger verwendete Funktionen ersetzt wurden, um für Benutzer, die ihre Symbolleisten nicht selber anpassen, die Notwendigkeit, sich durch Menüs zu klicken, zu reduzieren. Weitere nützliche Funktionen wurden hinzugefügt, sind aber standardmäßig deaktiviert und können mittels Kontextmenü der Symbolleiste und Symbolleiste anpassen... oder über das Menü Extras ▸ Anpassen... ▸ Symbolleiste leicht aktiviert werden (tdf#81475).
Yousuf Philips, Samuel Mehrbrodt
Symbolleisten: vorher (oben) und jetzt (unten).
  • Textmarken im Navigator: Bei der Benennung von Textmarken können im Navigator jetzt alle Zeichen verwendet werden, die auch als HTML-Anker zulässig sind. Insbesondere sind in LibreOffice jetzt auch Punkte . und Doppelpunkte : zulässig (tdf#56116).
Brij Mohan Lal Srivastava
  • Verbesserugen bei der AutoKorrektur:
László Németh
  • Bindestriche zwischen Zahlen werden durch die neue Funktion „Bindestriche ersetzen“ nun geeignet ersetzt: Doppelte Bindestriche zwischen Zahlen werden nun, ensprechend der Rechtschreibung für Wertebereiche (Jahre, Seitennummern usw.), durch Halbgeviertstriche (–) anstelle von Geviertstrichen (—) ersetzt, z.B.:
  • 1:15--2:15 Uhr → 1:15–2:15 Uhr
  • 3--5 Jahre → 3–5 Jahre
  • S. 38--55 → S. 38–55
  • 1933--45 → 1933–45
  • Sonderzeichen werden nun standardmäßig durch die AutoKorrektur ersetzt:
  • Zeichen für unregistrierte Warennamen (tm), registrierte Warennamen (R) und Copyright (C) werden nun auch ersetzt, wenn keine Leerzeichen vorher dem Ausdruck geschrieben werden (tdf#81571).
  • Symbole für Pfeile (-> oder <-) benötigen keine Leerzeichen drumherum mehr, um ersetzt zu werden, z.B.: A->B->C → A→B→C.
  • Platzhalter bei der AutoKorrektur (Text.* und .*text), welche in LibreOffice 4.2 eingeführt wurden, erlauben die Ersetzung von Wortanfängen und -enden. In LibreOffice 4.4 ist es nun auch möglich, Platzhalter der Art .*text*. zu verwenden, um Tippfehler in der Mitte eines Wortes zu korrigieren (tdf#55292).
Somit kann ein einzelner AutoKorrektur-Eintrag .*cih.* -> ich alle Wörter korrigieren, die diese Zeichenfolge besitzen, z.B.:
  • cih -> ich
  • nciht -> nicht
  • verncihten -> vernichten
  • rcihtig -> richtig
Darüber hinaus kann die AutoKorrektur somit verwendet werden, um bestimmte Zeichenfolgen durch gängige Sonderzeichen zu ersetzen, wie sie in einigen Sprachen vorkommen, z.B.:
  • .*fi.* -> fi (U-FB01)
  • .*fl.* -> fl (U-FB02)

Calc

  • Neue Statistik-Funktionen: Bei den Statistiken (eine Alternative zu Excels Add-in "Analyse-Funktionen") im Menü unter Daten ▸ Statistiken wurden Funktionen ergänzt:
Tomaž Vajngerl - Collabora
  • Bei der Funktion Beschreibende Statistik wurden Quartile ergänzt (tdf#81801).
  • Die Funktion Z-Test wurde neue hinzugefügt (tdf#74669).
  • Die Funktion Chi-Quadrat-Test wurde neu hinzugefügt (tdf#76868).
  • Konvertierung von Formelergebnissen in statische Werte: Eine neue Funktion ermöglicht es, Formelergbnisse nun direkt in statische Werte umzuwandeln. Zu finden ist die Funktion im Menü Extras ▸ Zellinhalte ▸ Formel in Wert. Zuvor war es nötig, die Zellen auszuschneiden und nur die Werte einzufügen, um dasselbe Ergebnis zu erzielen.
Kohei Yoshida - Collabora
  • Neue Funktion: Die Funktion AGGREGATE wurde zur Kompatibilität mit MS-Excel hinzugefügt (tdf#73148).
Winfried Donkers, Eike Rathke
  • Symbolleisten neu organisiert: In den Symbolleisten Standard und Format wurden selten genutzte Befehle durch häufiger verwendete Funktionen ersetzt, um die Notwendigkeit, sich durch Menüs zu klicken, zu verringern. Weitere Funktionen wurden zu den Symbolleisten hinzugefügt, sind aber standardmäßig ausgeblendet, diese können bei Bedarf schnell mittels Kontextmenü der Symbolleiste und Symbolleiste anpassen... oder über das Menü Extras ▸ Anpassen... aktiviert werden (tdf#85594).
Yousuf Philips
Symbolleisten vorher (oben) und nachher (unten) im Vergleich.
  • Symbole für Kontextmenü der Tabellenblätter: Das Kontextmenü der Tabellenblätter hat nun Symbole für die aufgeführten Funktionen (tdf#86476).
Yousuf Philips

Impress und Draw

  • Texte in der Masteransicht: In der Masteransicht ist der Textinhalt der Objektvorschauen nun schreibgeschützt. Die Änderung der Texte hat nie einen Einfluss auf die Objekte besessen, die die jeweilige Vorlage verwenden. Um Gliederungsebenen ein- oder auszublenden, können Sie nun einen Rechtsklick auf die letzte Zeile ausführen und über das Kontextmenü diese Änderung durchführen.
Caolán McNamara - Red Hat
Gliederungsebenen über das Kontextmenü ein- oder ausblenden.
  • Masterelemente direkt löschen: In der Masteransicht können Elemente, die zuvor nur über Ansicht ▸ Master ▸ Masterelemente... gelöscht werden konnten, nun direkt gelöscht werden, indem der betreffende Platzhalter gelöscht wird. Sie können jetzt also einfach <Datum/Uhrzeit>, <Fußzeile> oder <Foliennummer> in der Masteransicht auswählen und die Taste Entf drücken.
Caolán McNamara - Red Hat
Masterelemente direkt löschen.
  • Aufzählungszeichen: Ein Klick auf die Schaltfläche „Aufzählungszeichen an/aus“ bei ausgewählter Gliederungsebene in der Masteransicht schaltet nun korrekterweise auch die Aufzählungszeichen in der Normalansicht an oder aus. Bisher war hiervon nur die Vorschau in der Masteransicht betroffen, nicht aber die Gliederungsvorlage und somit auch nicht die spätere Darstellung der auf dieser Vorlage basierenden Inhalte.
Caolán McNamara - Red Hat
  • OpenGL-Übergänge:
  • Für Windows wurden OpenGL-Übergänge implementiert und aktiviert.
Markus Mohrhard - Collabora
  • Die Umsetzung des OpenGL-Frameworks in VLC wurde für Linux, Windows und OS X verbessert.
Markus Mohrhard - Collabora
  • Neuer Feldbefehl Seitentitel: Der Feldbefehl Seitentitel wurde ins Menü unter Einfügen ▸ Feldbefehl ▸ Seitentitel neu aufgenommen (tdf#47302).
Jennifer Liebel
  • Korrektur bei Tabellenformaten: Wenn einer Tabelle in Impress ein anderes Format zugewiesen wurde und nun Zeilen/Spalten eingefügt werden, so wird jetzt auch das neue Format in diesen Zeilen/Spalten verwendet, anstatt des Standardformats wie bisher (tdf#60712).
Hideki Ikeda
  • Schreibschutz-Kennwort: Es ist nun möglich, ein Impress/Draw-Dokument schreibgeschützt so zu speichern, dass ein Kennwort für die Bearbeitung benötigt wird (tdf#63483).
Katarína Behrens
  • Drucken in der eingestellten Papiergröße: Draw benutzt nun die Seitengröße beim Drucken, die in den Seiteneinstellungen eingestellt ist (tdf#63905).
Eilidh McAdam
  • Schaltfläche zum Zoomen: Eine neue Schaltfläche Zoom-Modus ermöglicht nun das Zoomen mittels der Tasten Strg und ⇑ Umschalt (tdf#55903, tdf#83572).
Maxim Monastirsky, Yousuf Philips
  • Symbolleisten neu organisiert: In die Symbolleisten Standard wurden häufig verwendete Funktionen neu aufgenommen (tdf#84909).
Yousuf Philips
  • Menü Ansicht neu organisiert: Das Menü Ansicht wurde umgeordnet, um ein einheitliches Aussehen mit Writer und Calc zu erzielen (tdf#86209).
Yousuf Philips

Math

  • Farbunterstützung erweitert:
  • Math unterstützt nun die 16 HTML-Grundfarben.
Regina Henschel
  • Die neuen Farben können einfach über die Seitenleiste eingefügt werden.
Marcos Paulo de Souza
Neue Farben in der Seitenleiste.

Kern

  • PDF-Export mit digitaler Signatur: Mit LibreOffice generierte PDFs können nun beim Export aus LibreOffice heraus direkt digital signiert werden. Es funktioniert unter Windows, OS X und Linux, wobei in Windows dazu die eingebaute Zertifizierungsfunktion verwendet wird, um die Zertifikate für die Unterschrift zu speichern.
Gökçen Eraslan - GSoC 2012, Markus Wernig - Wilhelm Tux, Tor Lillqvist - Collabora
Auswahl eines Zertifikats zum Unterzeichnen unter Windows.
Das Register Digitale Unterschrift im Dialog PDF-Export.
  • Neue Schriftarten: Ab LibreOffice 4.4 werden die Schriftarten Caladea und Carlito (Huerta Tipográfica) mit ausgeliefert. Diese haben dieselben Metriken und Proportionen wie die Schriftarten Cambria und Calibri von Microsoft, können also als direkter Ersatz für diese verwendet werden.
András Tímár - Collabora
  • Verbesserung bei Zeichenobjekten: Der Ansatzpunkt für Linien bei Zeichenobjekten Legende mit Linie lässt sich jetzt mit gedrückter Taste ⇑ Umschalt verschieben.
Matúš Kukan - Collabora
  • Technisches Wörterbuch: Verschiedene Updates.
  • Mobile Geräte: Impress unterstützt das ausschnittsweise Rendern auf mobilen Geräten, was die Leistung beim Navigieren durch Dokumente schont.
Andrzej Hunt - GSoC 2014

Hilfe-Inhalte

  • Direkter Zugriff auf die Hilfe: Mehrere Dialoge in Calc haben Schaltflächen zum direkten Aufruf der zugehörigen Hilfe erhalten:
Olivier Hallot - EDX
  • Der Dialog im Menü unter Bearbeiten ▸ Ausfüllen ▸ Zufallsszahlen... (tdf#80453).
  • Die Dialoge im Menü unter Daten ▸ Statistiken (tdf#80338).
  • Hilfeeinträge für Calc-Funktionen: Für mehrere Calc-Funktionen wurden fehlende Hilfeseiten erstellt und/oder der direkte Zugriff auf die entsprechende Hilfeseite ergänzt.
Olivier Hallot - EDX
  • Meta-Issue (tdf#80430).
  • LOGNORM.VERT, LOGNORM.INV, NORM.VERT, NORM.INV, NORM.S.VERT und NORM.S.INV (tdf#80432).
  • T.VERT, T.VERT.2S, T.VERT.RE, T.INV, T.INV.2S und T.TEST (tdf#80433).
  • MODUS.EINF, MODUS.VIELF, NEGBINOM.VERT und G.TEST (tdf#80436).
  • UNTERGRENZE.GENAU, OBERGRENZE.GENAU und ISO.OBERGRENZE (tdf#80438).
  • GAUSSF.GENAU und GAUSSFKOMPL.GENAU (tdf#80440).
  • LINKSB, LÄNGEB, TEILB und RECHTSB (tdf#80442).
  • KOVARIANZ.P und KOVARIANZ.S (tdf#80443).
  • STABW.N und STABW.S (tdf#80444).
  • VAR.P und VAR.S (tdf#80445).
  • BETA.VERT und BETA.INV (tdf#80446).
  • BINOM.VERT und BINOM.INV (tdf#80447).
  • KONFIDENZ.NORM und KONFIDENZ.T (tdf#80449).
  • F.VERT, F.VERT.RE, F.INV, F.INV.RE und F.TEST (tdf#80450).
  • EXPON.VERT, HYPGEOM.VERT, POISSON.VERT und WEIBULL.VERT (tdf#80451).
  • CHIQU.VERT, CHIQU.VERT.RE, CHIQU.INV, CHIQU.INV.RE und CHIQU.TEST (tdf#80452).
  • ZAHLWERT (tdf#80656).

Code quality

  • Deutsche Kommentare übersetzt: Sehr viele (historisch bedingte) deutsche Kommentare im Quellcode wurden ins Englische übersetzt.
Daniel Sikeler, Christian M. Heller, Tobias Madl, Thomas Viehmann, Philipp Riemer, Michael Jaumann, Laurent Balland-Poirier, Chris Sherlock, Philipp Weissenbacher, Jennifer Liebel
  • Writer-Verbesserungen: Große Teile des Writer-Codes wurden überarbeitet, wobei große Klassen in kleinere unterteilt wurden.
Valentin Kettner - GSoC 2014
  • Coverity-Scan: Die Code-Qualität wurde, basierend auf der Coverity-Scananalyse, weiter verbessert.
Ergebnisse der Coverity-Scananalyse.

Filter

  • Neue Medientypen: Über den Dialog Audio oder Video einfügen im Menü unter Einfügen ▸ Medien ▸ Audio oder Video... lassen sich neue Medientypen einfügen: Real Audio (.ra), Real Media (.rm), Digital Video (.dv), Audio Codec (.ac3), Ogg Opus (.opus), Advanced Systems (.asf), MPEG Audio (.m4a) (tdf#82994).
Daniel Sikeler, Caolán McNamara
  • Adobe PageMaker: Draw kann nun über libpagemaker Adobe PageMaker-Dateien (Version 6 und 7) importieren.
Anurag Kanungo - GSoC 2014
Beispieldokument, mit PageMaker 7.0 geöffnet.
Beispieldokument, mit LibreOffice 4.4 geöffnet.
  • Neue Mac-Filter: Über libmwaw können Writer und Draw nun Dateien öffnen, die mit MacDraw, MacDraw II oder RagTime für Mac erstellt wurden.
Alonso Laurent, Fridrich Štrba, David Tardon
  • Import von BroadBand E-Books (LRF): Writer kann über libe-book nun Sony BroadBand E-Book-Dateien (LRF) importieren.
David Tardon
Beispiel eines E-Books, geöffnet mit LibreOffice.
  • Verbesserte OOXML-Unterstützung:
Miklós Vajna - Collabora
  • Metadaten werden nun aus PPTX importiert.
  • Benutzerdefinierte Vielecke werden nun auch nach DOCX exportiert.
  • Die Unterstützung für zugeschnittene Bitmaps wurde zum Export nach DOCX hinzugefügt.
  • Verbesserte Visio-Unterstützung:
Miklós Vajna - Collabora
  • Die Metadaten aus VSD werden nun importiert (tdf#86729).
  • Die Metadaten aus VSDX werden nun importiert (tdf#86664).
  • Inhaltsverzeichnisse beim HTML-Export: Es ist nun möglich, Inhaltsverzeichnisse mit CSS2 Füllzeichen beim HTML-Export zu versehen, indem in den Einstellungen im Menü unter Extras ▸ Optionen... ▸ Laden/Speichern ▸ HTML-Kompatibilität die Option Drucklayout aktiviert wird und anschließend über den Befehl Datei ▸ Speichern unter... und Auswahl des Dokumenttyps HTML Dokument (Writer) (.html) das Dokument exportiert wird.
László Németh
  • Mit Firefox 32, Google Chrome 39 und Internet Explorer 11 getestet.
Bisheriges Inhaltsverzeichnis.
Neues Inhaltsverzeichnis mit CSS2 Füllzeichen.

Vorschaubilder für Dokumente: Vorschaubilder werden nun in PNG-8 komprimiert. Dies verbraucht weniger Speicher als PNG-24, ohne nennenswerte Qualitätseinbußen. Dabei werden die Vorschaubilder auf ca. 35% der vorherigen Größe eines Vorschaubildes komprimiert (tdf#62104).

Tomaž Vajngerl - Collabora
  • Verbesserte Unterstützung von MS Publisher:
  • Eingebettete Schriftarten werden nun importiert.
David Tardon
  • Tabellen werden nun importiert.
David Tardon
  • Metadaten werden nun importiert.
Miklós Vajna - Collabora

Verbesserte Unterstützung von Abiword:

  • Die Textsprache wird nun korrekt gesetzt.
  • Die global festgelegte Schreibrichtung wird nun verwendet.
  • Überschriften werden nun erkannt.
  • Metadaten werden nun importiert.
David Tardon

Verbesserte Unterstützung von MS Works Tabellendokumenten: Eine älterer Lotus LICS-Zeichensatz wird nun erkannt und korrekt konvertiert.

Laurent Alonso

Verbesserte Unterstützung von FictionBook:

  • Die Textsprache wird nun gesetzt (sofern sie in der Datei richtig angegeben ist).
  • Überschriften werden nun importiert.
David Tardon
  • Verbindungen mit SharePoint und OneDrive:
  • Es ist nun möglich, direkt aus LibreOffice mit SharePoint 2010/2013 zu verbinden.
Mihai Varga - GSoC 2014
Version auswählen.
Dokument austragen.
Dokument eintragen.
Eintragung erfolgreich.
  • Ebenso ist es möglich, direkt aus LibreOffice mit OneDrive zu verbinden (tdf#62437).
Mihai Varga - GSoC 2014
Servereinstellung.
Authentifizierung.
Dateiauswahl.
Dokument austragen.

GUI

  • Änderungen an den Linealen in Writer: Die Lineale in Writer haben nun kleinere Zahlen und sind standardmäßig ausgeschalten.
Jan Holešovský - Collabora
Die Lineale in LO 4.4 (rechts) haben ein unauffälligeres Erscheinungsbild als bisher (links).
  • Tastenkombination fürs Ein-/Ausblenden der Lineale: Lineale können über die Tastenkombination Strg+⇧ Umschalt+R ein- und ausgeblendet werden (tdf#87042).
Mattias Põldaru
  • Vorlagen im Startcenter: Vorlagen werden nun direkt im Startcenter angezeigt und können von dort aus geöffnet werden.
Efe Gürkan YALAMAN - GSoC 2014, Jan Holešovský - Collabora
Vorlagen im Startcenter.
  • Neue Dokumentvorlagen: Neue Dokumentvorlagen wurden gestaltet und stehen in der Standardinstallation zur Verfügung.
Alexander Wilms, Edmund Laugasson, Jun NOGATA, Michael Kovarik, Péter Szathmáry, Zirk
Neue Vorlagen im Startcenter.
  • Neue Farbauswahl:
  • Zuletzt verwendete Farben werden jetzt aufgelistet.
  • Es wurde eine Auswahlmöglichkeit für verschiedene Farbpaletten implementiert.
  • GIMP Farbpaletten (.gpl) werden nun ebenfalls unterstützt.
  • Eine Farbpipette ermöglicht die direkte Auswahl und Verwendung einer anderen Farbe.
Krisztian Pinter - GSoC 2014, Tomaž Vajngerl - Collabora; Maxim Monastirsky, Adolfo Jayme Barrientos
Die neue Farbauswahl mit Auswahlmöglichkeit für Farbpaletten und eine Farbpipette.
  • Aufklappmenü für Zeilenabstand überarbeitet: Das Aufklappmenü für den Zeilenabstand aus der Seitenleiste wurde überarbeitet und der Symbolleiste hinzugefügt (tdf#83076).
Jan Holesovsky - Collabora, Yousuf Philips
Aufklappmenü Zeilenabstand.
  • Aufklappmenüs ergänzt: Für die Symbole Aufzählungen und Nummerierungszeichen wurden den Symbolleisten Aufklappmenüs hinzugefügt, um die Notwendigkeit, die vollwertigen Dialoge zu öffnen, zu verringern (tdf#85804).
Maxim Monastirsky, Yousuf Philips
Neues Aufklappmenü Aufzählungen.
  • Änderungen an der Seitenleiste: Die Seitenleiste hat weitere Verbesserungen durch die Community erhalten (über den anfänglichen Import von Symphony hinaus).
  • Nach Impress (in LibreOffice 4.2) wurde die Seitenleiste nun auch in Writer standardmäßig aktiviert. Außerdem beinhaltet sie nun allein die Funktionen der alten Gallery und des Dialogs Formatvorlagen, wodurch viel doppelter Code entfernt werden konnte (tdf#73151).
Samuel Mehrbrodt
  • Die Symbole der Register funktionieren nun auch, um die Seitenleiste wieder zu schließen und nicht mehr nur zu öffnen (tdf#67627).
Thomas Arnhold
  • Das Aufklappmenü der Seitenleiste hat jetzt einen Eintrag "Seitenleiste schließen" (tdf#85937).
Samuel Mehrbrodt
  • Die Seitenleiste öffnet sich in Writer, Calc und Draw standardmäßig nun so, dass nur die Symbole der Register anzeigt werden (tdf#85935).
Jan Holešovský - Collabora
  • Es wurde eine Schaltfläche zum ein-/ausblenden der Seitenleiste hinzugefügt (tdf#83527).
Tomaž Vajngerl
  • Die Register der Seitenleiste haben neue Symbole bekommen.
Miroslav Mazel
Neue Symbole der Seitenleiste.
  • Neue Symbole: Zu den Symbolsätzen Tango, Sifr und Oxygen wurden neue Symbole hinzugefügt und bestehende Symbole überarbeitet (tdf#75256, tdf#75359).
Mirek Mazel, Yousuf Philips, Matthias Freund, Alexander Wilms, Adolfo Jayme Barrientos
Jan Holešovský - Collabora, Yousuf Philips
  • Standard-Symbolsatz unter OS X: Unter OS X ist der Symbolsatz Sifr jetzt als Standard vorausgewählt.
Symbolsatz Sifr unter OS X.
  • Symbolleisten-Standard: Standardmäßig werden jetzt auch unter Windows große Symbole angezeigt, wie es unter Linux und Mac OS bereits der Fall war (tdf#82309).
  • Dialog Info zu LibreOffice: Der Dialog Info zu LibreOffice zeigt jetzt auch das verwendete Gebietsschema an (tdf#85432).
Brij Mohan Lal Srivastava
Dialog Info zu LibreOffice mit Gebietsschema unterhalb der Build-ID.
  • Dialogumwandlung abgeschlossen: Wie in LibreOffice 4.0 begonnen, wurden nach und nach die Dialoge in LibreOffice auf das XML-basierte Format von GtkBuilder/Glade übertragen. Diese Umwandlung ist jetzt abgeschlossen und sämtliche Dialoge sind konvertiert.
Caolán McNamara - Red Hat, Palenik Mihály - GSoC 2014; Szymon Kłos - GSoC 2014, u. v. a.
  • Änderungen an Kontextmenüs:
  • Die Einträge Ausschneiden, Kopieren und Einfügen stehen im Kontextmenü nun an oberster Stelle (tdf#71770, tdf#84293).
Jeffrey Stedfast - Xamarin, Yousuf Philips
  • In Writer kann über das Kontextmenü auf den Dialog Inhalte einfügen sowie spezielle Einfügeoptionen direkt zugegriffen werden, wie es auch in Calc bereits zuvor möglich war (tdf#62947).
Babu Vincent, Yousuf Philips
  • Die Einträge Schrift, Größe und Ausrichtung wurden aus dem Kontextmenü entfernt; gemäß Statistiken wurden sie nahezu gar nicht verwendet und ihre Entfernung verringert die optische Unordnung (tdf#81132).
Yousuf Philips, Samuel Mehrbrodt
Ausschneiden, Kopieren und Einfügen stehen nun im Kontextmenü ganz oben.
Einfügeoptionen sind nun über das Kontextmenü verfügbar.
Einige nicht benutzte Formatierungsoptionen wurden entfernt.
  • Writer hat nun einen Kontextmenü-Eintrag, über den ein ausgewähltes Bild direkt durch ein anderes ausgetauscht werden kann, wie es in Impress und Draw bereits zuvor möglich war (tdf#82496).
Jennifer Liebel
Bild übers Kontextmenü ändern.
  • Schreibschutz: LibreOffice blendet nun eine Infoleiste ein, um sichtbar anzuzeigen, dass ein Dokument schreibgeschützt geöffnet wurde. Diese Infoleiste ersetzt das Symbol Bearbeitungsmodus in der Symbolleiste Standard, deren Bezeichnung und Benutzung viele Anwender eher verwirrt hat. Über das Menü Bearbeiten ▸ Bearbeitungsmodus und die Tastenkombination Strg+⇑ Umschalt+M ist die Aktivierung und Deaktivierung des Schreibschutzes auch weiterhin möglich (tdf#80538, tdf#80536).
Yousuf Philips, Samuel Mehrbrodt, Joren De Cuyper
Die neue Infoleiste.
  • Änderungen an Registern:
  • Die Register für Tabellenblätter in Calc und für Zeichenebenen in Draw wurden in eine eigene Zeile verschoben und sind nicht länger in einer Zeile mit den Bildlaufleisten. Einige Fensterstile unter Linux sowie der Standard-Fensterstil unter OS X verwenden sehr schmale Bildlaufleisten, sodass die Register teilweise zu schmal zum Klicken und nicht mehr lesbar waren (tdf#36772).
Tomaž Vajngerl - Collabora, Samuel Mehrbrodt
  • Die Register haben ein neues, flacheres Aussehen bekommen.
Tomaž Vajngerl - Collabora
Vorher.
Nachher.
  • Firefox-Themen:
  • Ein Dialog zum Suchen von Firefox-Themen inklusive einer Vorschaufunktion wurden neu geschaffen.
Rachit Gupta - GSoC 2014
Der neue Dialog zum Suchen von Firefox-Themen.
  • Firefox-Themen werden nun auch auf Symbolleisten am unteren Bildschirmrand angewandt (tdf#59299).
Michael Jaumann - LHM
Firefox-Themen in allen Symbolleisten.
  • Ändern der Bildgröße: In Calc und Impress/Draw wurde das Standardverhalten so geändert, dass beim Ändern der Bildgröße mit der Maus nun das Seitenverhältnisses beibehalten wird, wie in Writer bereits zuvor geändert (tdf#83808).
Samuel Mehrbrodt
  • Verbesserter Dialog Sonderzeichen: Sonderzeichen werden jetzt in ein editierbares Feld eingefügt, in dem das Einfügen/Löschen von Zeichen an der Cursorposition möglich ist (tdf#64302, tdf#85907).
Szymon Kłos, Adolfo Jayme Barrientos
Verbesserter Dialog Sonderzeichen.

Lokalisierung

  • Neue Sprache: Katalanisch (Valencia) [ca-ES-valencia] wurde zur Sprachliste und zu den sprachspezifischen Einstellungen hinzugefügt (tdf#83292).
Andras Timar
  • Wörterbücher: Es wurden für mehrere Sprachen Wörterbücher, Theasurus und/oder Silbentrennung aktualisiert, u.a.:
  • portugiesisch
  • französisch
  • slowenisch
  • russisch
  • spanisch

Leistung

  • Schnellere AutoKorrektur-Listen: Das Laden großer AutoKorrektur-Listen erfolgt jetzt mindestens doppelt so schnell wie zuvor, da die Listen nun gebündelt geladen werden und das Laden unveränderter Dateien vermieden wird (tdf#79761).
Daniel Sikeler
  • Optimierter Umgang mit dem Bildspeicher: Überflüssiges Leeren/Füllen des Bildspeichers wurde deutlich verringert und so das überflüssige Laden/Speichern von Bildern vermindert.
Tamas Zolnai - Collabora
  • Schnellerer OpenXML-Export: FastSerializer-Klassen, wie sie bei jedem OpenXML-Export verwendet werden, sind deutlich schneller und effizienter geworden und unnötige Systemaufrufe wurden verringert.
Matúš Kukan - Collabora
  • Schnellere JPEG-Verarbeitung: Es wird jetzt eine schnellere Bibliothek für JPEG-Bilder verwendet, wodurch eine Halbierung der Zeit zum Laden und Dekomprimieren von JPEG-Bildern erreicht werden konnte.
Matúš Kukan - Collabora
  • Schnellerer Seriendruck: Der Seriendruck in Writer sollte jetzt bei einer großen Zahl an Datensätzen deutlich schneller erfolgen.
Luboš Luňák - Collabora

Skriptsprachen/Basic

  • Basic-Bibliotheken: Es ist nun möglich, Basic-Bibliotheken aus Excel-Dokumenten zu exportieren (tdf#60904).
Caolán McNamara - Red Hat
  • Geänderte Versionsangabe: Der Wert, der bei der Abfrage der Versionsangabe zurückgeliefert wird, wurde geändert. Bisher wurde eine Zahlenfolge mit je einer Ziffer für Haupt-, Neben- und Unterversion zurückgegeben, also 440 für die Version 4.4.0. Nun werden für Haupt- und Nebenversion je zwei Ziffern, für die Unterversion weiterhin eine Ziffer zurückgegeben, also 04040 für die Version 4.4.0 (tdf#60689).
Marcos Paulo de Souza
  • Neue Methode: Eine neue Methode processEventToIdle() (noch nicht veröffentlicht, seien Sie vorsichtigt) wurde dem Service com.sun.star.awt.Toolkit hinzugefügt. Ein Aufruf dieser bewirkt, dass alle noch ausstehenden Rechnungen erst zuende geführt werden.
Michael Meeks - Collabora
  • Access2Base aktualisiert: Die mitgelieferte Access2Base Basic-Bibliothek wurde auf die Version 1.2.0 aktualisiert.
Jean-Pierre Ledure
  • Alle Methoden, die sinnvoll ohne Verbindung zu einer Datenbank verwendet werden können (Fehlermeldungen, Dialoge, Statusleiste, Fensteranpassungen, Befehlseingaben), wurden ermittelt und werden nun vor dem Datenbankzugriff ausgeführt.
  • Eine CloseConnection-Methode wurde hinzugefügt, um Resourcen einzusparen.
  • Um Werte von einem geöffneten Dokument zu einem anderen zu übertragen, kann die TempVar-Sammlung von TempVar-Objekten verwendet werden.
  • Neue Eigenschaften wurden Formen und Unterformen hinzugefügt: OrderBy und OrderByOn.
  • Die Aktionen ApplyFilter und SetOrderBy sind nun auf Tabellen und Abfragen ebenso wie auf Formen und Unterformen anwendbar.
  • Die Methode GoTorecord wurde auf Tabellen und Abfragen erweitert.
  • Details gibt es hier (englisch).

Entfernte/Herabgestufte Features

  • Entfernte Funktion: Die Funktion, um LibreOffice mittels des veralteten NPAPI (aktivierbar über Extras ▸ Optionen... ▸ Internet ▸ Browser-PlugIn ▸ Dokumente in Browser anzeigen) in Webbrowser einzubetten, wurde entfernt.
Bryan Quigley

Plattformkompatibilität

  • Kompatibilität für MAC OS X: LibreOffice 4.4 benötigt OS X 10.8 oder höher. Die Binärpakete beinhalten nur 64-bit-Versionen.