LibreOffice 4.4 Release Notes

From The Document Foundation Wiki
Jump to: navigation, search

Writer

Plantillas para documento maestro

Writer ha tenido desde hace tiempo Master Documents un sistema de archivo maestro que permite manejar documentos grandes, como es un libro de muchos capitulos. El documento maestro puede ser visto como un contenedor de pequeños documentos de LibreOffice Writer. LibreOffice 4.4 introduce Plantillas de documento maestro. Estas plantillas pueden ser agregadas al administrador de plantillas y crear nuevos documentos utilizando estilos y formatos definidos por el usuario, creando uniformidad en sus documentos. (Caolán McNamara, Red Hat)

Las figuras pueden contener un cuadro de texto

Ahora es posible que las figuras contengan cuadros de texto con contenido elaborado, siguiendo la geometría de la figura. tdf#70942 blog entry (Miklós Vajna)

Tabla y texto dentro de una figura con esquinas redondeadas.

Mejoras para el control de cambios

  • Los comandos “Aceptar mdificaciones” y “Rechazar modificaciones” se realizan en el siguiente cambio. tdf#83953 (Samuel Mehrbrodt)
  • Se incluyen nuevos botones en la barra de herramientas de Control de cambios, con un nuevo conjunto de iconos. tdf#83955, tdf#84405 (Yousuf Philips)
Nuevos iconos en la barra de herramientas de control de cambios
  • El submenú para control de cambios en el menú Editar ha sido renombrado de "Modificar" a "Control de cambios". tdf#85046 (Yousuf Philips)
  • La combinación de teclas Ctrl+⇧ Shift+E ha sido asociada con la grabación de control de cambios. tdf#86183 (Yousuf Philips)

Lista de estilos en la barra de herramientas

Ha sido mejorada para poder modificar o actualizar los estilos desde la misma, sin necesidad de abrir el estilista. tdf#62081 (Szymon Kłos and Samuel Mehrbrodt)

Menú dentro de la lista de estilos en la barra de herramientas.

Numeración de lineas sencillo de aplicar para todos los párrafos

Ahora puede ser activada la numeración de líneas en varios cuadros de diálogo, además del método ya conocido dentro del menú Herramientas. tdf#84504 (Charu Tyagi, Ericsson)

Numeración de líneas en encabezado, pie de página.

Mejoras en la barra de estado

  • Es más fácil de entender la numeración cuando se están utilizando estilos. tdf#80617 (Yousuf Philips and Samuel Mehrbrodt)
Antes (a la izquierda) y después (a la derecha) de como la numeración a mejorado.
  • El espacio entre los elementos ha sido mejorado para trabajar en pantallas de baja resolución, y que al hacer doble clic en campos vacíos no abra el cuadro de diálogo de 'Campos'. tdf#86018 (Yousuf Philips and Samuel Mehrbrodt)
  • El clic izquierdo abre un cuadro de diálogo o realiza una acción, y el clic derecho abre el menú contextual. tdf#82707 (Yousuf Philips and Samuel Mehrbrodt)
  • Las Tooltips han sido incorporadas a todos los elementos de la barra de estado. tdf#82708 (Yousuf Philips and Samuel Mehrbrodt)

Mejoras en las barras de herramientas

  • Las barras de herramientas de Formato y Estandard han sido reorganizadas, cambiando de posición botones, ocultando aquellos de poco uso o agregando algunos de uso frecuente. Se pueden mostrar los ocultos desde la opción "Personalizar" del menú "Herramientas". tdf#81475 (Yousuf Philips and Samuel Mehrbrodt)
Antes (arriba) y después (abajo) se puede ver la nueva distribución de los botones.
  • Desde la barra de herramientas Estándar se puede modificar el espacio entre líneas. tdf#83076 (Jan Holešovský, Collabora and Yousuf Philips)
  • Nuevos menús para “Símbolos” and “Numeración” fueron agregados para evitar abrir sus cuadros de diálogo. tdf#85804 (Maxim Monastirsky and Yousuf Philips)

Calc

Ver también: GUI: Pestañas

Conversión de formulas en valores estáticos

Está nueva características se usa con Herramientas ▸ Contenido de celdas ▸ Formulas a valores. Anteriormente se tenía que cortar la celda y desde Pegado especial se pegaban los valores. (Kohei Yoshida, Collabora)

Formulas

  • Se incorpora AGGREGATE para la interoperabilidad con Excel. tdf#73148 (Winfried Donkers and Eike Rathke)

Mejoras a la barra de herramientas

  • Las barras de herramientas de Formato y Estándar han sido reorganizadas, cambiando de posición botones, ocultando aquellos de poco uso o agregando algunos de uso frecuente. Se pueden mostrar los ocultos desde la opción "Personalizar" del menú "Herramientas". tdf#85594 (Yousuf Philips)

Impress y Draw

Ver también: GUI: Pestañas

Text of Master View Object Previews

  • In Slide Master view, the text of the presentation object previews is now read-only. Changing the text of these previews has never affected the objects based on the styles that the presentation object preview. To add or hide a level to the outline numbering preview, now you can right-click on the last line to display a menu to add/hide another level. (Caolán McNamara, Red Hat)
Hide/show outline levels from the context menu.
  • Toggling bullets on and off in slide master view in the outline preview via "Bullets On/Off" now truly toggles on/off the bullets of the Outline styles. In the past this only affected the preview itself, leaving the outline styles unchanged. Now it correctly affects outline levels in the normal view. (Caolán McNamara, Red Hat)

Select and toggle off master elements directly via Delete

In Slide Master view, master elements which Impress allows the user to remove via View ▸ Master ▸ Master elements can now be removed by direct deletion of the matching placeholder in the Master View preview. In other words, to remove a footer, header, slide number or date/time, select the corresponding box in Master View and press Delete. (Caolán McNamara, Red Hat)

Select and toggle off master elements directly via Delete

Transiciones OpenGL

  • Implementación y activación para Windows. (Markus Mohrhard, Collabora)
  • Implementación mejorada usando el nuevo OpenGL framework en vcl para Linux, Windows y OS X. (Markus Mohrhard, Collabora)

Campo de título de la página

Nuevo campo: Título de la página en Insertar ▸ Campo ▸ Titulo de la página. tdf#47302 (Jennifer Liebel)

Heredar el estilo actual de las celdas cuando se agrega una Nueva fila/columna en la tabla

Cuando tenemos una tabla en Impress y se modificado el estilo de la celda y luego se añadió una fila o columna esta hereda el estilo de la fila/columna actual en lugar de utilizar los valores por defecto. tdf#60712 (Hideki Ikeda)

Contraseña para edición

Ahora se puede guardar los archivos de Impress/Draw con contraseña para abrirlos como solo lectura, o escribir la contraseña para modificarlos. tdf#63483 (Katarína Behrens)

Text background color

Draw supports background color for text in frames and captions. blog entry (Matteo Campanelli, GSoC 2014)

Text in boxes and captions can have colored backgrounds.

Impresión: Utilizar el tamaño de papel del usuario

Draw ahora usa el tamaño de papel especificado en el menu Formato - Página cuando imprime. tdf#63905 (Eilidh McAdam)

Botón de escala de vista

Se creo un nuevo botón para cambiar la escala de vista que hace acercamientos, alejamientos o pantalla con las teclas Ctrl y ⇧ Shift. tdf#55903 tdf#83572 (Maxim Monastirsky and Yousuf Philips)

Mejoras a la barra de herramientas

  • Las barras de herramientas han sido reorganizadas para que las funciones mas frecuentes estén disponibles. tdf#84909 (Yousuf Philips)

Menubar improvements

  • The View menu was reorganized to better unify its items similar to Writer and Calc. tdf#86209 (Yousuf Philips)