Frequently asked questions - General

From The Document Foundation Wiki
< Faq‎ | General
Jump to navigation Jump to search
This page is a translated version of the page Faq/General/116 and the translation is 0% complete.
Outdated translations are marked like this.
Other languages:
English • ‎dansk • ‎español • ‎français • ‎italiano • ‎čeština

If, when you type a word with a spelling mistake, it is not underlined by a red wave, here are the things to check by order. It can result from an issue with the general configuration or from the document formatting.

Note: under macOS, the menu Tools used in this page is to be replaced by Preferences.

Remember that the language where the cursor is located is displayed in the status bar, bottom of the LibreOffice window: Status bar

General configuration

  • Slovník musí být nainstalovaný pro váš jazyk. Instalace se provádí pomocí rozšíření, jak je vysvětleno v tomto textu.. Aby bylo možné slovník používat, musíte úplně zavřít LibreOffice, včetně rychlého spouštění. Výchozí slovník pro váš jazyk je nainstalovaný.
  • Zkontrolujte, že se slovník úspěšně nainstaloval:
    • V nabídce přejděte na volbu Nástroje ▸ Možnosti ▸ Jazykové nastavení ▸ Pomůcky pro psaní a v části Uživatelem definované slovníky byste měli vidět svůj slovník. Vyberte jej a klikněte na tlačítko Edit.

Check that the dictionary is installed:

  • Go to the menu Tools ▸ Options ▸ Language Settings ▸ Languages ▸ Writing Aids
  • Make sure that the feature is enabled (in the Options section bottom right of the dialog): Check spelling as you type must be checked (this option is also directly accessible in the Standard toolbar or with Tools ▸ Automatic Spell Checking or with ⇧ Shift+F7).
  • Click the Edit... button (top right of the dialog).
Writing Aids section
  • V rozbalovací nabídce Jazyk, zvolte Váš_jazyk, kterému musí předcházet ikona A (až do verze 5.X se používala ikona ABC).
  • V modulu Pravopis, musí být slovník zaškrtnutý (ve výchozím nastavení je to Hunspell SpellChecker).


  • Zkontrolujte, že je povolena tato funkce:
    • V nabídce Nástroje ▸ Možnosti ▸ Jazyková nastavení ▸ Pomůcky pro psaní v části Možnosti musí být zaškrtnuta volba Kontrolovat pravopis během psaní (tato možnost je přímo dostupná ze standardní nástrojové lišty).
  • Zkontrolujte, že jako výchozí jazyk je nastaven ten váš: v nabídce Nástroje ▸ Možnosti ▸ Jazyková nastavení ▸ Jazyky​​ ▸ Výchozí jazyky pro dokumenty ▸ Západní hledejte Váš_jazyk.


Pokud k tomu dochází pouze v některých dokumentech nebo po provedení předchozích kontrol

  • Ověřte, že jazyk odstavce v aktuálním dokumentu je právě ten váš a máte nastaven Výchozí styl
    • Ve Writeru, zobrazte stisknutím klávesy F11 v postranní liště okno Styly, ve kterém zvolte Styly odstavce. Na Výchozí styl klikněte pravým tlačítkem myši a zvolte Upravit.
  • V Calcu zvolte nabídku Formát ▸ Buňky ▸ Písmo ▸ Jazyk.
  • V Impress nebo Draw pak zvolte nabídku Formát ▸ Znak ▸ Písmo ▸ Jazyk.

In Impress or Draw, display the Styles window with F11 or the menu View ▸ Styles, in the Drawing Styles list, right click the Default Drawing Style then Modify and check the language in the Font tab.


At character level

The previous configuration may still have no effect on the language displayed in the status bar. Meaning that another formatting layer remains.

In Writer, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.

  • Note that in Writer:
    • A character style may have been applied, with a different language setting, it will override the paragraph style setting. Thus, in the Styles panel, click the Character Styles button and check the entry highlighted. If different from Default Character Style, then check the font properties of that character style.
    • A direct formatting may have been applied on top of that. Check the language displayed in the status bar, bottom of the Writer window. Click it and select Reset to Default Language.

In Calc, go to the menu Format ▸ Cells... and in the Fonts tab, check the Language field.

In Impress or Draw, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.


Pokud nic z toho nefunguje

Tento tip by vás mohl zachránit:

  • Změňte výchozí jazyk na nějaký jiný, než váš a pak jej změňte zpět na váš:
    • V nabídce Nástroje ▸ Možnosti ▸ Jazyková nastavení ▸ Jazyky ▸ Výchozí jazyk pro dokumenty ▸ Západní nastavte jiný jazyk, než váš.
    • Nastavení potvrďte a úplně zavřete LibreOffice, včetně rychlého spouštění.
    • Restartujte LibreOffice a opět otevřete nabídku Nástroje ▸ Možnosti ▸ Jazyková nastavení ▸ Jazyky ▸ Výchozí jazyk pro dokumenty ▸ Západní, kde tentokrát nastavte Váš_jazyk.
    • Nastavení potvrďte a úplně zavřete LibreOffice, včetně rychlého spouštění.

Changing the default language to another one, then changing back to the desired language per following steps may help:

  • Go to the menu Tools ▸ Options ▸ Language Settings ▸ Languages​​ and in the section Default language for Documents, Western field, specify a different language than your language.
  • Confirm and close LibreOffice completely, including the quick starter.
  • Restart LibreOffice, open that same menu again and select Your_language.
  • Confirm and close LibreOffice completely, including the quick starter.
  • Restart LibreOffice and check if the language is correct.


Last chance

Try to reset your LibreOffice user profile to go back to factory settings. Rename it so that you can retrieve parts of your customization if needed.