Faq/General/116

From The Document Foundation Wiki
< Faq‎ | General
Jump to navigation Jump to search
This page is a translated version of the page Faq/General/116 and the translation is 5% complete.
Outdated translations are marked like this.
Other languages:
English • ‎dansk • ‎español • ‎français • ‎italiano • ‎čeština

Si lorsque vous tapez un mot avec une faute d’orthographe, celui-ci n’est pas souligné d’un liseré rouge, voici les points à vérifier dans l’ordre :

Note: under macOS, the menu Tools used in this page is to be replaced by Preferences.

Remember that the language where the cursor is located is displayed in the status bar, bottom of the LibreOffice window: Status bar

  • Un dictionnaire français doit être installé. L’installation se fait par une extension comme expliqué à cette question. N’oubliez pas de quitter totalement LibreOffice, démarrage rapide compris, pour que le nouveau dictionnaire soit pris en compte. Par défaut le dictionnaire français est installé.
  • Vérifiez que le dictionnaire est bien installé :
    • menu Outils ▸ Options ▸ Paramètres linguistiques ▸ Linguistique ▸ Modules de langue disponibles, cliquez sur le bouton Éditer.

Check that the dictionary is installed:

  • Go to the menu Tools ▸ Options ▸ Language Settings ▸ Languages ▸ Writing Aids
  • Make sure that the feature is enabled (in the Options section bottom right of the dialog): Check spelling as you type must be checked (this option is also directly accessible in the Standard toolbar or with Tools ▸ Automatic Spell Checking or with ⇧ Shift+F7).
  • Click the Edit... button (top right of the dialog).
Writing Aids section
capture d’écran de la boite de dialogue correspondante Options, Paramètres linguistiques, Linguistique
  • dans la boite déroulante de Langue, sélectionnez Français, qui doit être précédé de l’icône ABC.
  • dans le module Orthographe un dictionnaire doit être coché (par défaut Hunspell (fr)).


capture d’écran de la boite de dialogue correspondante Éditer les modules
  • Vérifiez que la fonctionnalité est cochée :
    • Dans le menu Outils ▸ Options ▸ Paramètres linguistiques ▸ Linguistique ▸ Options ▸ Vérifier l’orthographe au cours de la frappe doit être cochée (cette option est directement accessible dans la barre de boutons Normal).
  • Vérifiez que la langue par défaut est bien le français : menu Outils ▸ Options ▸ Paramètres linguistiques ▸ Langues ▸ Langue par défaut pour les documents ▸ Occidental, indiquez Français.


capture d’écran de la boite de dialogue correspondante Options, Paramètres linguistiques, Langues

Si cela ne se passe que dans certains documents, ou que les vérifications précédentes ont été faites

  • Vérifiez que la langue du paragraphe est bien le français dans le texte courant, ainsi que dans le Style Standard :
    • sous Writer, affichez le Styliste par F11, dans les Styles de Paragraphe, faire un clique droit sur Standard puis Modifier :
  • sous Calc, menu Format ▸ Cellule ▸ Police ▸ Langue ;
  • sous Impress ou Draw, menu Format ▸ Caractères ▸ Police ▸ Langue.

In Impress or Draw, display the Styles window with F11 or the menu View ▸ Styles, in the Drawing Styles list, right click the Default Drawing Style then Modify and check the language in the Font tab.


At character level

The previous configuration may still have no effect on the language displayed in the status bar. Meaning that another formatting layer remains.

In Writer, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.

  • Note that in Writer:
    • A character style may have been applied, with a different language setting, it will override the paragraph style setting. Thus, in the Styles panel, click the Character Styles button and check the entry highlighted. If different from Default Character Style, then check the font properties of that character style.
    • A direct formatting may have been applied on top of that. Check the language displayed in the status bar, bottom of the Writer window. Click it and select Reset to Default Language.

In Calc, go to the menu Format ▸ Cells... and in the Fonts tab, check the Language field.

In Impress or Draw, go to the menu Format ▸ Character... and in the Fonts tab, check the Language field.


capture d’écran de la boite de dialogue correspondante Style de paragraphe Standard, onglet Police, liste déroulante Langue

Si tout cela ne marche pas

Une astuce pourra peut-être vous sauver :

  • Modifiez la langue par défaut pour une autre que le Français, puis remettez le Français :
    • Dans le menu Outils ▸ Options ▸ Paramètres linguistiques ▸ Langues ▸ Langue par défaut pour les documents ▸ Occidental, indiquez une autre langue que Français.
    • Validez et fermez complètement LibreOffice, démarrage rapide compris.
    • Relancez LibreOffice et dans le menu Outils ▸ Options ▸ Paramètres linguistiques ▸ Langues ▸ Langue par défaut pour les documents ▸ Occidental, indiquez Français.
    • Validez et fermez complètement LibreOffice, démarrage rapide compris.


Last chance

Try to reset your LibreOffice user profile to go back to factory settings. Rename it so that you can retrieve parts of your customization if needed.