Neuerungen und Veränderungen in LibreOffice 5.2

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 5.2 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 5.1.

Writer

  • Neue Zeichenformen gefüllte Kurven: In den Symbolleisten wurden Formen für gefüllte(s) Kurve/Freihandlinie/Polygon/Polygon (45°) ergänzt. Diese waren vorher nur in Draw verfügbar (tdf#89646).
Gülşah Köse
  • Symbolleiste Änderungen verfolgen einfacher ein-/ausblenden: Der Symbolleiste Standard wurde eine Schaltfläche zum Ein-/Ausblenden der Symbolleiste Änderungen verfolgen hinzugefügt (tdf#90187).
Gülşah Köse
Schaltfläche zum Ein-/Ausblenden.
  • Gemeinsame Schaltfläche für Kurven: Die Symbole für Kurven in der Symbolleiste Standard wurden in einem Symbol Kurve zusammengefasst und in ein Aufklappmenü für die vier Kurven und die vier neuen gefüllten Kurven (s.o. - Kü) umgewandelt (tdf#89646, tdf#90505).
Gülşah Köse
Neues Aufklappmenü Kurve.
  • Geändertes Tastenkürzel für Datenquellen: Das Tastenkürzel zum Aufrufen von Datenquellen wurde von F4 in Strg+⇧ Umschalt+F4 geändert und mit dem in Calc vereinheitlicht (tdf#97906).
Yousuf Philips
  • Neue Symbolleiste Standard (einfacher Modus): Eine neue Symbolleiste Standard (einfacher Modus) wurde hinzugefügt, welche die wichtigsten Funktionen der beiden Symbolleisten Standard und Formatierungen enthält und anstelle dieser beiden verwendet werden kann, um Platz am oberen Bildschirmrand einzusparen (tdf#92218).
Yousuf Philips
Symbolleiste Standard (einfacher Modus) in Writer.
  • Optimierte Symbolleisten Es wurden weitere Optimierungen an den Hauptsymbolleisten vorgenommen (tdf#91781).
Yousuf Philips
  • Filterfunktion für Querverweise hinzugefügt: Im Menü unter Einfügen ▸ Feldbefehl ▸ Weitere Feldbefehle... wurde im Register Querverweise ein Filter hinzugefügt. Sie können dort ein paar Buchstaben eingeben und erhalten eine gefilterte Auswahl angezeigt (tdf#32364).
Akshay Deep
Register Querverweis mit gefilterter Anzeige.
  • Überarbeiteter Dialog Lesezeichen (tdf#90855):
  • Der Dialog im Menü unter Einfügen ▸ Lesezeichen... wurde modernisiert.
Jakub Trzebiatowski, Yousuf Philips
Neuer Dialog Lesezeichen.
  • Neue Lesezeichen werden automatisch nach dem Schema „Lesezeichen N“ benannt.
  • Zum Lesezeichen wird nun ein Text angezeigt; je nach Situation der folgende Text, die Auswahl oder der vorangehende Text.

Calc

  • Zugriff auf Bedingte Formatierung: Alle Schaltflächen zur bedingten Formatierung wurden in einer Schaltfläche Bedingte Formatierung mit Aufklappliste gruppiert (tdf#86567).
Maxim Monastirsky
  • Neuer Befehl zum Fixieren: Es wurde eine einfache Möglichkeit zum Fixieren der ersten Spalte oder ersten Zeile einer Tabelle im Menü unter Ansicht ▸ Zellen fixieren hinzugefügt (tdf#91013).
Gülşah Köse, Maxim Monastirsky, Yousuf Philips
  • Schaltfläche mehrzeilige Eingabezeile angepasst: Die Schaltfläche zum Ausklappen der mehrzeiligen Eingabezeile hat nun auf allen Systemen dieselbe Größe - diese wurde auf einigen Systemen zuvor sehr klein dargestellt (tdf#99701).
Samuel Mehrbrodt - CIB
  • Geänderte Tastenkombinationen:
  • Die Tastenkombination ⇧ Umschalt+Eingabetaste erzeugt in der mehrzeiligen Eingabezeile nun einen Zeilenumbruch anstatt wie bisher die Eingabe abzuschließen und die Markierung eine Zelle nach oben zu bewegen (tdf#63994).
Samuel Mehrbrodt - CIB
  • Die Tastenkombination ⇧ Umschalt+F4 zum Umschalten zwischen relativen und absoluten Bezügen wurde aufgrund der Doppelbelegung mit F4 entfernt, bleibt aber bei veralteten Tastenkombinationen aus OpenOffice.org weiterhin verfügbar (tdf#97906).
Dennis Francis, Yousuf Philips
  • Die Tastenkombination zum Auswählen einer ganzen Spalte wurde von Strg+⇧ Umschalt+Leertaste in Strg+Leertaste geändert (tdf#96969).
Yousuf Philips
  • Die Tastenkombinationen Strg+Komma (,) zum Einfügen des Datums und Strg+⇧ Umschalt+Komma (,) zum Einfügen der Zeit sind nun für viele europäische Tastatur-Layouts verfügbar (tdf#88027).
Yousuf Philips
  • Neue Option zum Löschen von Rahmen: Im Dialog Zellen formatieren wurde eine Option hinzugefügt, um auch Rahmen benachbarter Zellen zu löschen (tdf#34449).
Dennis Francis
Neue Option im Dialog Zellen formatieren.
Links: Ergebnis beim Löschen ohne aktivierte Option.
Rechts: Ergebnis bei aktivierter Option.
  • Neue Symbolleiste Standard (einfacher Modus): Eine neue Symbolleiste Standard (einfacher Modus) wurde hinzugefügt, welche die wichtigsten Funktionen der beiden Symbolleisten Standard und Formatierungen enthält und anstelle dieser beiden verwendet werden kann, um Platz am oberen Bildschirmrand einzusparen (tdf#92218).
Yousuf Philips
Symbolleiste Standard (einfacher Modus) in Calc.
  • Neue Zeichenformen gefüllte Kurven: In der Symbolleiste Zeichnung wurden Formen für gefüllte(s) Kurve/Freihandlinie/Polygon/Polygon (45°) ergänzt. Diese waren vorher nur in Draw verfügbar (tdf#89646).
Gülşah Köse
  • Zellfunktionen der Statusleiste: In der Statusleiste können nun mehrere Funktionen für ausgewählte Zellen gleichzeitig aktiviert werden (tdf#42629).
Dennis Francis, Dag Wieers
Gleichzeitig ausgewählte Funktionen Anzahl und Summe.
  • Symbole erweitert:
  • Das Symbol Währung in Symbolleisten wurde um eine Aufklappliste ergänzt, aus der die gewünschte Währung ausgewählt werden kann (tdf#82641).
Mohammed Abdul Azeem, Michael Meeks
Aufklappliste Währung.
  • Das Symbol Zeilen/Spalten fixieren in Symbolleisten wurde um eine Aufklappliste ergänzt, aus der Erste Zeile fixieren und Erste Spalte fixieren ausgewählt werden kann (tdf#91013).
Gülşah Köse, Maxim Monastirsky
Aufklappliste Zeilen/Spalten fixieren.
  • Die Symbole für Kurven in Symbolleisten wurden in einer Schaltfläche Kurve zusammengefasst und um eine Aufklappliste einschließlich der neuen Zeichenfunktionen (s.o. - Kü) ergänzt (tdf#90505).
Gülşah Köse
Neue Aufklappliste in der Symbolleiste Zeichnung.
  • Infotexte für Funktionen: Die Infotexte für Funktionen wurden um Beschreibungen ergänzt (tdf#95878).
Keigo Kawamura
Der Infotext gibt die Syntax an und beschreibt das Argument.

Funktionen

  • Neue Funktionen:
  • Die Funktion SUBTRAKTION subtrahiert Zahlen, ohne kleine Rundungsungenauigkeiten auszugleichen (tdf#71459).
Eike Rathke - Red Hat
  • =SUBTRAKTION(a;b;c) ist dasselbe wie =a-b-c mit dem Unterschied, dass der Operator - kleine Rundungsungenauigkeiten ausgleicht, die aufgrund der Tatsache entstehen, dass nicht jede Dezimalzahl eindeutig durch eine Gleitkommazahl abgebildet werden kann, und so Null als Ergebnis liefert. SUBTRAKTION verwendet den Standard IEEE 754, der durch das Betriebssystem zur Verfügung gestellt wird. Z. B. ergibt =0,3-0,2-0,1 0 wohingegen =SUBTRAKTION(0,3;0,2;0,1) 2,7755575615689€-17 ergibt.
Hinweis: Um dieses Ergebnis zu bekommen, muss im Menü unter Extras ▸ Optionen... ▸ LibreOffice Calc ▸ Berechnen die Option Stellen für Standardformat begrenzen deaktiviert sein.
  • Diese Funktion kann verwendet werden, um zu überprüfen, ob das Ergebnis exakt einer vorgegebenen Zahl entspricht, z. B. ob =SUBTRAKTION(Ergebnis,Zahl) gleich 0,0 ist.
  • Die Funktion PROGNOSE.EXP ist ein Satz von Funktionen für Vorhersagen, welche die dreifache oder doppelte exponentielle Glättung verwenden und periodische Effekte berücksichtigen (tdf#94635).
Winfried Donkers
  • Es wird das Holt-Winters-Verfahren verwendet. Additive und subtraktive Methode unterstützen beide die dreifache exponentielle Glättung.
  • Der Satz umfasst die Funktionen PROGNOSE.EXP.ADD(*), PROGNOSE.EXP.MULT, PROGNOSE.EXP.SAISONAL(*), PROGNOSE.EXP.VOR.ADD(*), PROGNOSE.EXP.VOR.MULT, PROGNOSE.EXP.STAT.ADD(*), PROGNOSE.EXP.STAT.MULT.
Die mit (*) gekennzeichneten Funktionen sind kompatibel mit MS Excel 2016.
Beispiel für eine Vorhersage mit 95% Vertrauensintervall.
  • Die Funktion TEXTKETTE ist eine Erweiterung der Funktion VERKETTEN, die auch Bereiche, Spalten und Bezüge als Argumente erlaubt (tdf#97831).
Winfried Donkers
  • Die Funktion ist kompatibel mit der Funktion TEXTKETTE aus MS Excel 2016.
  • Die Funktion VERBINDEN verbindet mehrere Zeichenfolgen zu einer Zeichenfolge, wobei jeweils ein Trennzeichen dazwischen eingefügt wird (tdf#97831).
Winfried Donkers
  • VERBINDEN erlaubt dieselben Argumente wie TEXTKETTE und hat ein zusätzliches Argument, mit dem das Trennzeichen zwischen den Zeichenfolgen festgelegt wird.
  • Die Funktion ist kompatibel mit der Funktion TEXTJOIN aus MS Excel 2016.
  • Die Funktion WENNS fasst mehrere Funktionen WENN in einer zusammen (tdf#97831).
Winfried Donkers
  • WENNS funktioniert nach dem Prinzip „Wenn A, dann B, sonst wenn C, dann D, sonst …“.
  • Die Funktion ist kompatibel mit der Funktion WENNS in MS Excel 2016.
  • Die Funktion SCHALTER wählt aus mehreren Bedingungen das erste zutreffende Ergebnis aus (tdf#97831).
Winfried Donkers
  • SCHALTER vergleicht einen Ausdruck mit 1 bis n Werten und gibt das Ergebnis zurück, welches zum ersten Wert gehört, der mit dem Ausdruck übereinstimmt.
  • Die Funktion ist kompatibel mit der Funktion SWITCH in MS Excel 2016.
  • Funktionen MINWENNS und MAXWENNS (tdf#97831).
Winfried Donkers
  • Diese Statistikfunktionen arbeiten wie SUMMEWENNS und MITTELWERTWENNS, liefern aber den kleinsten bzw. größten Wert des zugehörigen Bereichs.
  • Die Funktionen sind kompatibel mit den Funktionen MINWENNS und MAXWENNS in MS Excel 2016.
  • Geänderte Funktion:
  • Die Funktion WOCHENTAG unterstützt zusätzliche Werte für das Argument Art (tdf#100396).
Eike Rathke - Red Hat - Inc.
  • Für die Kompatibilität zu anderen Tabellenkalkulations-Implementierungen sind die folgenden neuen Werte für das zweite Argument Art zulässig und geben Werte zwischen 1 und 7 zurück:
  • 11: Montag 1 bis Sonntag 7.
  • 12: Dienstag 1 bis Montag 7.
  • 13: Mittwoch 1 bis Dienstag 7.
  • 14: Donnerstag 1 bis Mittwoch 7.
  • 15: Freitag 1 bis Donnerstag 7.
  • 16: Samstag 1 bis Freitag 7.
  • 17: Sonntag 1 bis Samstag 7.
  • In vorherigen Versionen waren für das Argument Art alle ganzen Zahlen zulässig, wobei alle Zahlen, die nicht 1, 2 oder 3 waren, wie 3 gehandhabt wurden, also Werte mit Montag = 0 ergaben. Nun ergeben alle Werte, die nicht 1, 2, 3, 11, 12, 13, 14, 15, 16 oder 17 sind, einen Fehler.
  • Platzhalter in Formeln: Grundlegende Platzhalter, wie sie aus anderen Tabellenkalkulationen schon bekannt sind, können nun auch in Formelausdrücken verwendet werden.
Eike Rathke - Red Hat - Inc.
Zulässige Platzhalter sind:
  • * (Sternchen) findet alle Zeichenfolgen, einschließlich leerer Folgen.
  • ? (Fragezeichen) findet jedes beliebige (aber genau ein) Zeichen.
  • ~ (Tilde) hebt die besondere Bedeutung des folgenden Zeichens (Sternchen, Fragezeichen oder Tilde) auf.
Vergleichen Sie tdf#72196 und die entsprechenden Abschnitte in ODF 1.2 table:use-wildcards (englisch) und OpenFormula Host-Defined Behaviors (englisch).
Platzhalter werden in allen Funktionen unterstützt, die bereits reguläre Ausdrücke unterstützen. Dies sind: alle Datenbankfunktionen DBMITTELWERT, DBANZAHL, DBANZAHL2, DBAUSZUG, DBMAX, DBMIN, DBPRODUKT, DBSTDABW, DBSTDABWN, DBSUMME, DBVARIANZ, DBVARIANZEN sowie die Funktionen ZÄHLENWENN, ZÄHLENWENNS, WVERWEIS, VERWEIS, VERGLEICH, SVERWEIS, SUMMEWENN, SUMMEWENNS, MITTELWERTWENN, MITTELWERTWENNS und SUCHEN.
Folglich wurden im Menü unter Extras ▸ Optionen... ▸ LibreOffice Calc ▸ Berechnen die Einstellungen erweitert, sodass jetzt gruppierte Optionsfelder mit den Optionen Platzhalter in Formeln ermöglichen, Reguläre Ausdrücke in Formeln ermöglichen und Keine Platzhalter oder regulären Ausdrücke in Formeln existieren.
  • Bezug zu Bereichen mit Namen: Es ist nun möglich, über das Menü Einfügen ▸ Namen festgelegte lokale Namen einer Tabelle in Formeln einer anderen Tabelle zu verwenden (tdf#96915).
Eike Rathke - Red Hat - Inc.
Wenn z. B. in Tabelle1 ein Bereich mit LokalerBereich benannt wurde, kann dieser in Tabelle2 mittels =SUMME(Tabelle1.LokalerBereich) verwendet werden, wobei die üblichen Beschränkungen bei der Benennung von Tabellen gelten, sodass z. B. Tabellennamen, die Leerzeichen enthalten, in einfachen Anführungszeichen eingeschlossen werden müssen, wie in =SUMME('Tabelle 1'.LokalerBereich).
  • Kopieren von Bereichen mit Namen: Wenn ganze Tabellen kopiert werden, werden über das Menü Einfügen ▸ Namen festgelegte lokale Namen sowie Bezüge zu Namen als neue lokale Namen in die neue Tabelle kopiert (tdf#75372).
Eike Rathke - Red Hat - Inc.
Beispiel eines Dokuments mit einer Tabelle Tabelle1 mit festgelegten Namen
Name Bereich oder Ausdruck Geltungsbereich
Global $Tabelle1.$A$1 Dokument (global)
Global_global Global*10 Dokument (global)
Global_lokal Lokal*20 Dokument (global)
Lokal $Tabelle1.$A$2 Tabelle1
Lokal_global Global*30 Tabelle1
Lokal_lokal Local*40 Tabelle1
und Formelzellen, welche die Namen Global_global, Global_lokal, Lokal_global und Lokal_lokal verwenden.
Das Kopieren von Tabelle1 in eine neue Tabelle NeueTabelle führt zu (Dialog Namen verwalten von NeueTabelle):
Name Bereich oder Ausdruck Geltungsbereich
Global $Tabelle1.$A$1 Dokument (global)
Global $NeueTabelle.$A$1 NeueTabelle
Global_global Global*10 Dokument (global)
Global_global Global*10 NeueTabelle
Global_lokal Tabelle1.Lokal*20 Dokument (global)
Global_lokal Lokal*20 NeueTabelle
Lokal $Tabelle1.$A$2 Tabelle1
Lokal $NeueTabelle.$A$2 NeueTabelle
Lokal_global Global*30 Tabelle1
Lokal_global Global*30 NeueTabelle
Lokal_lokal Tabelle1.Lokal*40 Tabelle1
Lokal_lokal Lokal*40 NeueTabelle
Somit funktionieren die Formeln auch weiterhin und die Namen verweisen wie erwartet auf die kopierten Zellen.

Impress & Draw

  • Seitenleiste:
  • Die Liste mit Effekten für Benutzerdefinierte Übergänge wurde in die Seitenleiste integriert (tdf#87813).
Rishabh Kumar - GSoC 2015, Yousuf Philips
  • Die Liste mit Benutzerdefinierten Animationen ist detailreicher, was auf einen Blick zu erkennen ist (tdf#87812).
Akshay Deep, Yousuf Philips
  • Die Aufklapplisten mit Voreinstellungen wurden durch Kombinationsfelder mit veränderbaren Werten ersetzt (tdf#98037).
Akshay Deep
  • Schnellerer Zugriff auf Folieneigenschaften über einen neuen Bereich Folienhintergrund im Register Eigenschaften (tdf#89466).
Rishabh Kumar, GSoC 2015, Katarina Behrens, Susobhan Ghosh, Yousuf Philips
Neuer Bereich Folienhintergrund.
  • Optimierte Symbolleisten Es wurden weitere Optimierungen an den Hauptsymbolleisten vorgenommen (tdf#91857).
Yousuf Philips
  • Zeichenfunktionen ein-/ausblenden: Ein Symbol zum Ein-/Ausblenden der Symbolleiste Zeichnung wurde für Impress/Draw ergänzt (tdf#89540).
Gülşah Köse
Symbol zum Ein-/Ausblenden in Draw.
Symbol zum Ein-/Ausblenden in Impress.

Chart

  • Darstellung von Trendliniengleichungen:
  • Die Darstellung von Trendliniengleichungen bei polynomischen Trendlinien wurde verbessert:
Laurent BP
  • Bisher: f(x) = 2x^2 - x + 1.
  • Neu: f(x) = 2x² − x + 1.
  • Trendliniengleichungen werden nun umgebrochen, wenn sie länger sind, als das Diagramm breit ist (tdf#94004).
Laurent BP
Verzerrtes Diagramm (vor LibO 5.2).
Umgebrochene Trendliniengleichung (LibO 5.2).
  • Verbesserte logarithmische Skalierung: Für das Minimum bei automatischer Skalierung der Y-Achse einer logarithmischen Skala wird nicht mehr maximal 1 erzwungen (tdf#96871).
Laurent BP

Document signing

  • Dokument-Signaturen:
  • Es werden nun Signatur-Beschreibungen unterstützt.
Miklos Vajna - Collabora
Neue Signatur-Beschreibungen.
  • Die Unterstützung zum Lesen von SHA-256 Hashes wurde ODF-Dokumenten hinzugefügt (tdf#76142).
Miklos Vajna - Collabora
  • Die Unterstützung für den Import und Export von OOXML-Signaturen wurde hinzugefügt.
Miklos Vajna - Collabora

Kern

  • Tastenkürzel:
  • Für Windows wurde Alt+F12 dem Dialog im Menü unter Extras ▸ Optionen... neu zugeordnet.
Yousuf Philips
  • Für Mac OS wurden Befehl+G dem Befehl Nächsten finden, Befehl+Doppelpunkt (:) dem Dialog Rechtschreibprüfung und Befehl+Strg+F dem Befehl Vollbild neu zugeordnet.
Yousuf Philips
  • Hilfe für LibreOffice: Viele Hilfeseiten wurden aktualisiert.
Adolfo Jayme Barrientos, Stanislav Horáček, Eike Rathke, Maxim Monastirsky, Yousuf Philips, Olivier Hallot
  • Programmabstürze: Die von der TDF herausgegebenen Versionen für Windows und Linux erzeugen nun beim Absturz Fehlerberichte mit einer serverbasierten Fehleranalyse.

Filter

  • Import von DOCX und RTF: Der Import von verknüpften Grafiken wurde verbessert (tdf#59699).
Miklos Vajna - Collabora
  • Unterstützung für Microsoft Word für DOS: Dateien aus Microsoft Word für DOS können nun über libwps importiert werden.
Sean Young
  • Import von SVG: Es wurden einige Verbesserungen beim Einfügen von SVG-Bildern übers Menü Einfügen ▸ Bild... vorgenommen.
Xisco Faulí
  • Import von EFM:
  • Gepunktete und gestrichelte Linien werden nun korrekt angezeigt.
Chris Sherlock
  • Linienenden und Linenecken werden nun korrekt importiert.
Stephan van den Akker
  • Export in JPEG: Der DPI-Wert wird nun korrekt berücksichtigt.
Chris Sherlock

Oberfläche

  • Größenänderung von Objekten: Bei Videos, Diagrammen und OLE-Objekten wird das Seitenverhältnis bei Größenänderungen nun auch standardmäßig beibehalten (tdf#97919).
Samuel Mehrbrodt - CIB
  • Beim Ziehen einer Ecke bleibt das Seitenverhältnis erhalten, beim Ziehen einer Seite wird das Seitenverhältnis verändert (tdf#84953).
  • Zeichenabstand: Es wurden Vereinfachungen beim Zeichenabstand vorgenommen (tdf#89953).
Samuel Mehrbrodt - CIB, Oliver Specht - CIB
  • Zuvor: Es mussten positive Werte wahlweise für gesperrt oder schmal angegeben werden.
  • Neu: Es müssen nun positive Werte (für gesperrt) und negative Werte (für schmal) eingegeben werden.
  • Symbol Speichern: Dem Auswahlmenü neben dem Symbol Speichern wurde der Eintrag Als Vorlage speichern... hinzugefügt (tdf#99926).
Samuel Mehrbrodt - CIB
  • gtk3:
Caolán McNamara - Red Hat
  • Die Menüleisten in LibreOffice sind nun echte gtk3-Menüleisten und nicht länger vlc-Menüs, die wie gtk3-Menüs aussehen.
  • Ebenso sind Tooltipps, Popovers und Kontextmenüs nun echte gtk3-Elemente.
  • Startcenter: Eine neue Experteneinstellung wurde ergänzt, um die Vorschau von zuletzt verwendeten Dokumenten im Startcenter zu deaktivieren (tdf#74834).
Pierre Sauter
  • Windows: Unter Windows ist es möglich, das Tastaturlayout aus der Anwendung heraus zu wechseln. Dies ist nun auch mit LibreOffice möglich (tdf#98924).
Juergen Funk - CIB
  • Kontextmenüs anpassbar: Der Dialog im Menü unter Extras ▸ Anpassen... hat nun ein neues Register Kontextmenüs, in dem die Kontextmenüs angepasst werden können (tdf#93837).
Maxim Monastirsky
  • Dialog Suchen & Ersetzen:
  • Es wurde eine Schaltfläche Vorherigen suchen ergänzt (tdf#98417).
Akshay Deep, Yousuf Philips
  • Der Dialog Suchen & Ersetzen hat ein neues, breiteres Layout erhalten (tdf#98539).
Akshay Deep, Yousuf Philips
Dialog Suchen & Ersetzen in der einfachen Ansicht.
Dialog Suchen und Ersetzen in der erweiterten Ansicht.
  • In Datei drucken: Dem Dialog Drucken wurde der Liste mit Druckern der Eintrag In Datei drucken... hinzugefügt (tdf#94097).
Katarina Behrens - CIB
  • Basic-Editor: Die Register im Basic-Editor wurden in eine eigene Zeile verschoben, um nicht von der Höhe der Bildlaufleiste abhängig zu sein (tdf#96683).
Samuel Mehrbrodt - CIB
  • JVM-Startparameter: Es wurde eine Möglichkeit ergänzt, die voreingestellten JVM-Startparameter anzupassen (tdf#97425).
Akshay Deep
  • Dialog Webdatei:
  • Es wurde eine Symbolansicht sowie Schaltflächen zum Umschalten der Ansichten hinzugefügt.
Szymon Kłos, Yousuf Philips, Heiko Tietze
Dialog Webdatei in der Symbolansicht.
  • Die Zwei-Faktor-Authentifizierung (2FA) von Google Drive wird nun unterstützt (tdf#87938).
Szymon Kłos
PIN-Abfrage für Google Drive.
  • Überarbeiteter Vorlagen-Manager: Der Vorlagen-Manager wurde grundlegend überarbeitet. Dieser Blog-Eintrag (englisch) beschreibt die Neuerungen ausführlich.
Akshay Deep - GSoC 2016, Yousuf Philips, Samuel Mehrbrodt
Template Manager layout
  • Alle Funktionen, die nichts mit der Navigation, Auswahl oder Suche von Vorlagen zu tun haben, wurden in ein Kontextmenü gepackt.
  • Am unteren Rand wurden Funktionen zum Durchsuchen ergänzt.
  • Am oberen Rand sind Funktionen um Filtern untergebracht.

Lokalisierung

  • Neue Sprachen: Folgende Sprachen wurden neu hinzugefügt:
Eike Rathke - Red Hat - Inc.
Im-jabber.svg

Unser Ziel ist es, so viele Sprachen wie möglich zu unterstützen. Wir möchten allen dafür danken, dass sie freiwillig Ihre Zeit und Kraft in die Übersetzung von LibreOffice investieren und damit helfen, ihre Muttersprache zu erhalten.

  • Portugiesische AutoKorrektur: Die AutoKorrektur für Portugiesisch (pt-PT) wurde erweitert (tdf#97439).
Marco A. G. Pinto, Olivier Hallot, Raimundo Moura
  • Tschechischer Thesaurus: Für die tschechische Sprache wurde ein Thesaurus neu erstellt.
Jan Holešovský
Im-jabber.svg

Wenn Sie eine seltene Sprache sprechen und uns bei unserem Ziel, freie Software für möglichst jeden Menschen auf dem Planeten zur Verfügung zu stellen, helfen möchten, stoßen Sie zu uns: zum Übersetzungsprojekt.

Entfernte / herabgestufte Funktionen

  • NPAPI entfernt: Die Unterstützung für NPAPI-Plugins (englisch) (vor allem Adobe Flash) in Dokumenten wurde nun entfernt.
  • Warnung vor ActiveX: Die Unterstützung für ActiveX ist veraltet und könnte in einer der zukünftigen Version entfernt werden. Falls diese Änderung Ihre Windows-Anwendung negativ beeinflussen sollte, schicken Sie bitte eine E-Mail an die development-Liste mit Ihrem Anwendungsfall und Ihrem Plan für die zukünftige Verwendung von ActiveX. Wir sind besonders an Rückmeldungen interessiert, wenn Sie ActiveX zur Einbettung von LibreOffice in Ihre Anwendung verwenden.
  • perftune.ini: Die Unterstützung für die undokumentierten perftune.ini-Flags FastPipeCommunication und QuickstartPreloadConfiguration wurde entfernt.
  • Impress:
  • Die Funktion zur Anzeige des Navigators während Präsentationen wurde entfernt (tdf#96414).
  • Die Schaltfläche Stift und ihr zugehöriger Befehl uno:NavigatorPen wurden vom Navigator entfernt.
Bryan Quigley