Neuerungen und Veränderungen in LibreOffice 5.1

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 5.1 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 5.0.

Writer

  • Kurzvideo: Ein kurzer Einblick in die neuen Funktionen von LibreOffice Writer 5.1 (in Englisch).
YouTube-Video (englisch)
  • Seitensprung in Druckvorschau: Der Druckvorschau wurde ein Eingabefeld hinzugefügt, in das die gewünschte Seite eingegeben werden kann, zu der gesprungen werden soll (tdf#80657).
Gülşah Köse
Druckvorschau in Writer.
  • Verbessertes Verhalten: Der Dialog Rechtschreibung und Grammatik wird nun nicht mehr automatisch geschlossen, nachdem die Rechtschreibprüfung abgeschlossen ist (tdf#79312).
Marek Dolezel
  • Schusterjungen- und Hurenkinderregelung: Die Schusterjungen- und Hurenkinderregelung zum Textfluss in Absätzen sind jetzt in neuen Dokumenten voreingestellt aktiviert (tdf#89714).
SIL
  • Verbesserte Darstellung: Eine neue Option zum Ausblenden von Seitenzwischenräumen in der Ansicht Drucklayout wurde dem Menü unter Ansicht ▸ Zwischenraum verbergen hinzugefügt (tdf#39080).
Ashod Nakashian - Collabora
  • Schaltfläche für Umrandungen: Der Symbolleiste Formatierungen wurde eine Schaltfläche mit Auswahlmenü für Umrandungen hinzugefügt (standardmäßig verborgen) (tdf#95403).
Maxim Monastirsky
  • Weniger Verwirrung bei Serienbriefen: Bei Serienbriefen auf Grundlage einer Calc-Tabelle wird der Datensatz jetzt direkt in das Writer-Dokument eingebettet, anstatt wie bisher in einer neuen Datenbank gespeichert.
Miklos Vajna - Collabora
YouTube-Video (englisch)

Calc

  • Kurzvideo: Ein kurzer Einblick in die neuen Funktionen von LibreOffice Calc 5.1 (in Englisch).
YouTube-Video (englisch)
  • Kontextmenü von Tabellenblättern: Das Kontextmenü der Tabellenblätter wurde neu geordnet.
Yousuf Philips
  • Verbesserung am Funktions-Assistenten: Der Funktions-Assistent zeigt nun im Abschnitt Struktur des Registers Struktur die Werte von Parametern und Ergebnissen an.
Benjamin Ni
Neue Ansicht im Abschnitt Struktur.
  • Neue Statistikfunktion: Im Menü unter Daten ▸ Statistiken wurde ein neuer Menüpunkt Regression... hinzugefügt, über den sich ein Dialog für lineare, logarithmische und potentielle Regression öffnen lässt.
Tomaz Vajngerl - Collabora
Dialog für Regressionen; erreichbar übers Menü Daten ▸ Statistiken ▸ Regression....
  • Geändertes Tastenkürzel: Das Tastenkürzel für Datenquellen wurden in Strg+⇧ Umschalt+F4 geändert und F4 wurde dem Umschalten von Zellbezügen zugewiesen (tdf#59418).
Dennis Francis
  • PNG-Export: Der Export von Bildern im PNG-Format wurde in Calc ergänzt, wie in Writer und Impress bereits vorhanden.
Miklos Vajna - Collabora
PNG-Export in Calc.
  • Verbesserung beim Zeilen/Spalten einfügen: Es wurden dem Kontextmenü von Zeilen der Befehl Zeilen unterhalb einfügen und dem Kontextmenü von Spalten der Befehl Spalten rechts einfügen hinzugefügt. (tdf#90882)
Philippe Jung
  • Verbesserte Suche: Die Symbolleiste Suchen und der Dialog Suchen & Ersetzen haben eine zusätzliche Option Nach formatierten Zeichenketten suchen erhalten (tdf#48456).
Durch Aktivieren dieser Option kann man jetzt z. B. nach "1.234" suchen und findet alle Zellen, die mit Tausendertrennzeichen formatiert sind. Zuvor bestand nur die Möglichkeit, nach "1234" zu suchen, um diese Zellen zu finden, was Probleme bereitete, wenn z. B. formatierte Zellen kopiert und in die Symbolleiste Suchen oder den Dialog Suchen und Ersetzen eingefügt wurde.
Dennis Francis
Neue Option Nach formatierten Zeichenketten suchen (s. o. - Kü).
  • Funktion INDIREKT: Die Kompatibilität zu veralteten OOo-Dokumenten und zu Excel wurde verbessert (tdf#92256, tdf#93688).
Katarina Behrens - CIB
  • Benutzerdefinierte Dezimalzeichen: Benutzerdefinierte Fragezeichen als Dezimalzeichen (wie z. B. 0,???), um die Ausrichtung als Dezimalzahl zu erhalten, ohne dass die Nullen dargestellt werden, werden nun im ODF-Format gespeichert (tdf#40517).
Laurent BP

Formeln

  • Verbesserungen bei strukturierten Tabellenbezügen (tdf#85063)
Eike Rathke - Red Hat
  • Die folgenden Einschränkungen bei strukturierten Tabellenbezügen wurden behoben:
  • Es müssen keine Spaltennamen mit Zellinhalt in den Tabellenköpfen mehr vorliegen; Tabellenkopf-freie Tabellen werden nun unterstützt.
  • Hierfür werden für Datenbereiche ohne oder mit leerem Tabellenkopf interne Namen festgelegt: Spalte1, Spalte2, usw.
  • Interne Namen aus OOXML-Tabellendokumenten werden nun importiert und funktionieren auch weiterhin für Funktionen.
  • Beim Speichern als OOXML werden nun auch strukturierte Tabellenbezüge verwendet (und nicht mehr in die A1-Schreibweise überführt) und der Tabellenkontext beibehalten.
  • Beim Speichern als OOXML werden festgelegte Datenbereiche nun als <table>-Elemente exportiert.
  • Beim Ändern der Zellinhalte von Tabellenköpfen werden nun auch die internen Spaltennamen aktualisiert.
  • Wenn der Zellinhalt von Tabellenköpfen gelöscht wird, funktionieren Formeln, die Tabellenköpfe als Referenzen verwenden, weiterhin und können auch unter Verwendung der vorherigen Namen weiterhin bearbeitet werden.
  • Wenn der Zellinhalt von Tabellenköpfen kopiert wird, werden die kopierten Spaltennamen intern durchnummeriert. Wenn also z. B. zwei Tabellenköpfe beide Beispiel heißen, werden als interne Spaltennamen Beispiel und Beispiel2 verwendet. Dies wird automatisch für bestehende Formelausdrücke übernommen.
  • Wenn Spalten in eine Tabelle eingefügt werden, werden für leere Tabellenköpfe automatisch nummerierte Spaltennamen, entsprechend ihrer Spaltennummer innerhalb der Tabelle, generiert. Werden z. B. zwei Spalten vor der dritten Spalte einer Tabelle eingefügt, sind die generierten Namen Spalte3 und Spalte4.
  • Wenn solche leeren Tabellenköpfe dann benannt werden, werden die generierten Spaltenköpfe entsprechend aktualisiert.
  • Alle internen Spaltennamen einer Tabelle sind einzigartig, was sich bei der Anzeige existierender Formelausdrücke widerspiegelt.
Eike Rathke
  • Bei Zellbezügen, die mindestens zwei Spalten bzw. Zeilen umfassen und deren Bezug die letzte Spalte (AMJ) bzw. die letzte Zeile (1048576) einschließt, ist die letzte Spalte bzw. Zeile nun fixiert, d. h. beim Einfügen von Spalten bzw. Zeilen wird dieser Bezug beibehalten.
  • Wenn Spalten bzw. Zeilen eingefügt werden, sodass der Bezug aktualisiert und außerhalb des Tabellenbereichs verschoben werden würde, wird der Bezug nun an der letzten Spalte bzw. Zeile fixiert und kein Fehler #REF! mehr erzeugt.
  • Z. B. wird ein Bezug B2:B1048575 beim Einfügen von zwei Zeilen nur auf B2:B1048576 aktualisiert.
  • Die Zeile wird dabei fixiert, auf den Wert 1048576.
  • Ein Bezug wie B1048576:C1048576 hat keinen fixierten Zeilenbezug, da nur eine Zeile referenziert ist.
  • Umsetzung von ODF 1.2-Standards: Die Funktion KALENDERWOCHE entspricht nun strikt der ODF 1.2 Definition, die Funktion ISOKALENDERWOCHE wurde neu eingeführt (tdf#50950).
Winfried Donkers, Eike Rathke
  • Die Funktion KALENDERWOCHE_ADD wurde in KALENDERWOCHE_EXCEL2003 umbenannt, um auf deren Existenz für die Kompatibilität mit Dokumenten, die mit Microsoft Excel 2003 (und früher) erstellt wurden, hinzuweisen.
  • Beim Import von Dokumenten, die mit älteren Microsoft Excel Versionen erstellt wurden, wird die Funktion KALENDERWOCHE automatisch durch KALENDERWOCHE_EXCEL2003 ersetzt.
  • Beim Speichern als ODF oder OOXML wird automatisch KALENDERWOCHE verwendet, wofür ältere Versionen von LibreOffice und OpenOffice.org KALENDERWOCHE_ADD verwendeten.
  • Die Funktion KALENDERWOCHE unterstützt nun alle Argumente als zweiten Parameter, die im ODF-Standard (englisch) festgelegt sind.
  • Die Funktion ISOKALENDERWOCHE wurde nach ODF-Standard (englisch) neu implementiert, um die Kalenderwoche korrekt nach dem Standard ISO 8601 zu berechnen.
  • Die Funktion KALENDERWOCHE_OOO wurde für die Kompatibilität mit älteren Versionen von LibreOffice und OpenOffice.org eingeführt, für Fälle, in denen die Funktion KALENDERWOCHE nicht dem in der Funktion ISOKALENDERWOCHE definierten Standard entspricht. Das ist insbesondere der Fall, wenn das Argument Modus den Wert 1 besitzt, bei dem die alte Funktion KALENDERWOCHE die Kalenderwoche nach ISO 8601 berechnet hat, aber mit Wochenstart am Sonntag anstatt am Montag. Dies wird durch keinen Standard abgebildet.
  • Die Funktion KALENDERWOCHE_OOO wird nicht im Funktions-Assistenten angezeigt, um die versehentliche Verwendung zu verhindern. Sie sollte auch nur verwendet werden, um die Kompatibilität mit äteren Versionen von LibreOffice oder OpenOffice.org sicherzustellen.
  • Derzeit wird diese noch falsch als ISOKALENDERWOCHE mit zwei Parametern gespeichert, um die Kompatibilität zu älteren Versionen von LibreOffice oder OpenOffice.org sicherzustellen.
  • Dieses Fehlverhalten wird in der zukünftigen Version LibreOffice 5.3 korrigiert und die Funktion als KALENDERWOCHE_OOO gespeichert werden, welche die aktuelle Version 5.1 bereits lesen kann.

Impress und Draw

  • Kurzvideo: Ein kurzer Einblick in die neuen Funktionen von LibreOffice Impress und Draw 5.1 (in Englisch).
YouTube-Video (englisch)
  • Einfacheres Navigieren und Sortieren: Befehle zur Navigation und zum Sortieren von Seiten wurden neu hinzugefügt (tdf#91909). englischer Text ergänzt
Philippe Jung, Yousuf Philips
  • Bessere Darstellung des Folienmasters: Die Ansicht Folienmaster wird nun in einer anderen Farbe dargestellt als die Ansicht Normal (tdf#87905).
Katarina Behrens - CIB
  • Bildschirmschoner verhindern: Die Ausführung von Bildschirmschonern unter KDE, XFCE und Mate wird nun während einer Präsentation verhindert.
Andrzej Hunt
  • Impress Ansichten: Es existieren mehrere Ansichten in Impress:
  • Normal - um Seiteninhalte zu bearbeiten.
  • Folienmaster - um Folienvorlagen zu bearbeiten.
  • Notizen - um Notizen zur Präsentation hinzuzufügen.
  • Notizenmaster - um die Notizenvorlage zu bearbeiten.
  • Gliederung - um eine Übersicht der Präsentation zusammenzustellen.
  • Handzettelmaster - um Handzettel zu formatieren.
  • Foliensortierung - um eine individuelle Präsentation zusammenzustellen.
Zuvor war es schwierig, zwischen den Ansichten umzuschalten. Die Register oberhalb des Arbeitsbereichs sprangen beim Wechsel wild hin und her und raubten Platz auf dem Bildschirm. Deshalb wurden nun zwei Schaltflächen hinzugefügt:
  • Mit der einen wird die Sichtbarkeit der Registerleiste umgeschaltet. Diese Schaltfläche ist standardmäßig ausgeblendet. Beim Umschalten wird die neue Ansichten-Auswahl deaktiviert und das vorherige Verhalten wiederhergestellt.
  • Mit der zweiten kann eine der 7 oben genannten Ansichten gewählt werden. Beim Draufklicken werden zwei Bereiche sichtbar: oben befinden sich die 4 normalen Ansichten (zum Bearbeiten der Präsentation), unten die 3 Masteransichten.
Neue Schaltfläche Ansichtenauswahl Genaue Bezeichnung prüfen. - Kü.
  • Folienvorlagen: Die Änderung einer Folienvorlage im Menü unter Folie ▸ Folienvorlage... wirkt sich nun auf alle ausgewählten (Standard-)Folien aus.
Caolán McNamara - Red Hat
  • Neue Menübefehle Breite/Höhe angleichen: Wenn mehrere Objekte ausgewählt sind, werden im Kontextmenü nun die zwei neuen Befehle Formen ▸ Breite angleichen und Formen ▸ Höhe angleichen angezeigt, welche die Breite/Höhe aller ausgewählten Objekte der Breite/Höhe des zuletzt ausgewählten Objekts angleichen.
Caolán McNamara - Red Hat
Neue Befehle im Kontextmenü.
  • Presenter Console: Diese besitzt nun eine Schaltfläche, um die Stoppuhr einer Präsentation neu zu starten, ohne die Präsentation selbst neu starten zu müssen.
Miklos Vajna - Collabora, Andreas Kainz
Schaltfläche zum Zurücksetzen der Stoppuhr.
  • Hintergrundbilder speichern: Im Kontextmenü einer Folie wurde der Befehl Hintergrundbild speichern... hinzugefügt, der den Befehl Hintergrundbild setzen... sinnvoll ergänzt.
Caolán McNamara - Red Hat
Neuer Befehl Hintergrundbild speichern im Kontextmenü.
  • Einstellung von Kontrollpunkten: Das Register Schräg stellen / Eckenradius des Dialogs Position und Größe enthält für Formen mit Kontrollpunkten nun die Möglichkeit zur Einstellung ihrer Werte. Dies erweitert die bereits bestehende Möglichkeit, die gelben Steuergriffe von Formen mit der Maus zu bewegen, um eine Feinsteuerung der einzustellenden Werte.
Caolán McNamara - Red Hat
Einstellungsmöglichkeit im Dialog.
  • OpenGL-Übergänge: Alle OpenGL-Übergänge wurden auf OpenGL 2.1+ portiert, wodurch die Unterstützung für ältere GPUs entfernt werden musste, dafür aber die Verwendung neuerer GPUs verbessert wurde. Vier Übergänge sind neu hinzugekommen, die OpenGL 3.2 oder höher benötigen, das diese neu verfügbaren Funktionen verwendet.
Emmanuel Gil Peyrot - Collabora, Tomaž Vajngerl - Collabora
Neuer Übergang Glitzern.
Neuer Übergang Bienenwabe.
Neuer Übergang Wogen.
Neuer Übergang Wirbel.

Math

  • MathML Import aus Zwischenablage: Math hat einen neuen Menüeintrag Extras ▸ MathML aus Zwischenablage importieren erhalten, über den MathML aus der Zwischenablage in die Formelsyntax von LibreOffice konvertiert wird. MathML-Code kann beispielsweise unter Windows mittels "Math Input Panel" oder über das Kontextmenü einer Formel in einem Webbrowser in die Zwischenablage kopiert werden.
Regina Henschel
Math Input Panel unter Windows.
MathML Quellcode im Browser.
  • MathML und StarMath besitzen einige Unterschiede, sodass ggf. Korrekturen der importierten Formeln nötig sind, meistens werden sie aber korrekt übernommen. Wenn keine Konvertierung nicht möglich ist, passiert nichts.
Import aus MathML
  • Für den Import ist es notwendig, dass ein Element <math> mit dem Attribut xmlns="http://www.w3.org/1998/Math/MathML" existiert.
Ergebnis des Imports von MathML.
  • Automatisches Schließen von Klammern: Diese Funktion ist nun voreingestellt deaktiviert (tdf#43090).

Base

  • Mozab-Treiber entfernt: Der veraltete, auf SeaMonkey basierende und nur unter Windows 32-bit verwendete Mozab-Treiber wurde entfernt. Diese Funktion übernimmt nun der Mork-Treiber, der auch den Zugriff aufs Thunderbird-Adressbuch unterstützt. Die Integration für Outlook und Outlook Express, die der Mozab-Treiber mit unterstützt hat und die nur für Windows 32-bit existierte, geht damit ebenfalls verloren. (Für Windows 64-bit hat es nie einen SeaMonkey Mozab-Treiber gegeben.)

Chart

  • Verbesserungen bei Trendlinien
Laurent BP
  • Exponentielle und potentielle Trendlinien können nun auch negative Werte handhaben (tdf#70673).
  • Bei den Trendliniengleichungen wurden überflüssige 1-en entfernt:
  • Bei Potenzfunktionen: f(x) = x^2 + x +1 statt f(x) = 1x^2 + 1x +1
  • Bei Exponentialfunktionen: f(x) = exp( x ) statt f(x) = exp( 1 x )

Kern

  • Eingabe von Unicode-Zeichen: Einige Windows-Anwendungen wie Word und WordPad erlauben es Benutzern, für beliebige Unicode-Zeichen Hexadezimalcodes einzutippen (z. B. 2026 für ) und mittels Alt+C umzuwandeln. LibreOffice unterstützt diese Funktion nun ebenfalls. (Diese Funktion ergänzt unter Linux/GTK das althergebrachte Vorgehen mittels Strg+⇧ Umschalt+U+Hexadezimalcode.)
SIL
Details:
  • Die Tastenkombination mehrfach gedrückt schaltet zwischen dem Zeichen vor dem Cursor und seinem Hexadezimalcode hin und her.
  • Kombinierte Zeichen werden intelligent behandelt, indem das gesamte Zeichen sofort erweitert wird. (Was sind "kombinierte Zeichen" und wie funktioniert das? - Kü)
  • Eine Markierung ist nicht notwendig, aber falls sie vorliegt, wird die Umwandlung auf diese Zeichen beschränkt. (In Calc, Impress und Draw wird das Endergebnis markiert, nicht jedoch im Writer.)
  • Alle Unicode-12 Zeichen werden unterstützt.
  • Die Funktionalität ist in Writer, Calc, Impress Draw und Math verfügbar.
  • Die zugewiesene Tastenkombination lässt sich anpassen: Der Befehl findet sich im Menü unter Extras ▸ Anpassen... ▸ Tastatur im Bereich Optionen als Funktion Unicode-Schreibweise umschalten. Die Tastenkombination Alt+C befindet sich auf globaler Ebene (oben rechts im Dialog "LibreOffice" ausgewählt).
  • WebDAV Verbesserungen:
  • Der Umgang mit LOCK/UNLOCK bei WebDAV-Verbindungen wurde korrigiert (tdf#82744).
Giuseppe Castagno
  • In Ergänzung zum (nicht standardisierten) vnd.sun.star.webdav-Schema wurde ein (nicht standardisiertes) vnd.sun.star.webdavs-Schema ergänzt (vergleichbar mit http und https).
Stephan Bergmann - Red Hat

Optionen

  • Windows Registry: In Windows wird nun auch die HKEY_CURRENT_USER-Registry-Hirarchie unterstützt, welche benutzerspezifische Konfigurationsmöglichkeiten erlaubt.
Michael Meeks - Collabora

Filter

  • Gnumeric-Import: Der Gnumeric-Import wird jetzt offiziell unterstützt (zuvor nur als experimentelle Funktion verfügbar) (funktioniert nicht unter Windows tdf#94834).
Markus Mohrhard
  • Microsoft Write-Import: Microsoft Write-Dokumente (.wri-Dateien) können nun importiert werden.
Sean Young
  • Apple Keynote 6-Import: Apple Keynote 6-Dateien können nun über libetonyek importiert werden (tdf#88682).
David Tardon - Red Hat
Beispieldokument in Keynote 6.6.
Beispieldokument in LibreOffice 5.1.
  • OpenXML-Filter: Der Export veränderter VBA-Datenströme funktioniert jetzt auch zurück in binäre Microsoft-Dateiformate sowie in OOXML.
Rosemary Sebastian, Markus Mohrhard
  • Es wurde eine zusätzliche Einstellungsmöglichkeit in den Optionen ergänzt, welche diese Funktion erlaubt (Standard) oder zum alten Verhalten (bei dem die Änderungen verworfen werden) zurück wechseln lässt.
  • Folgende Funktionen werden noch nicht (vollständig) unterstützt: geschützte Makros, Makrovorlagen, ActiceX und einige Designer-Funktionen.
  • OOXML-Filter:
  • Der Export von eingebetteten Objekten, einschließlich dem Export von Math-Formeln, funktioniert nun auch in DOCX und PPTX.
Michael Stahl - Red Hat
  • Zahlreiche Verbesserungen der Filter für die Formate DOCX, XLSX, PPTX, VML und drawingML.
  • Microsoft Binärformate: Zahlreiche Verbesserungen der Filter für die Formate DOC, XLS, PPT und ww8.
  • RTF-Filter: Zahlreiche Verbesserungen für den RTF-Filter.
  • MS Visio
Fridrich Strba, Andras Timar - Collabora
  • Das Überschreiben von Linienfarben und von Text durch Ebeneneigenschaften sowie die Sichtbarkeit und/oder Druckbarkeit von Ebenen wurde implementiert (tdf#50309, tdf#68392).
  • Ein falsches Verhalten von überlappendem Text wurde korrigiert (tdf#90154).
  • Grundlegende Schraffuren wurden implementiert (tdf#44552, tdf#76835).
  • Aufzählungen werden nun unterstützt (tdf#92349).
  • Standard Taulatoren und benutzerdefinierte Tabulatoren in den Absatzeigenschaften werden nun unterstützt.
  • Anstelle von Zeilenumbrüchen wird nun ein neuer Absatz erkannt, wenn ein Absatzumbruch vorliegt.
  • Rundungen von Linienecken werden nun grundsätzlich dargestellt (tdf#90603).
  • Der Import von VSDX Farbpaletten wurde korrigiert (tdf#92270).
  • Der Umgang mit Zeichenhintergründen wurde korrigiert (tdf#92270).
  • CorelDRAW: Leere Textzeilen werden nun nicht mehr ausgelassen (tdf#67873).
David Tardon

Oberfläche

  • OpenGL-Status: In den Optionen im Menü unter Extras ▸ Optionen... ▸ LibreOffice ▸ Ansicht wurde eine Information zum OpenGL-Status ergänzt: "Aktueller OpenGL-Status: Aktiviert/Deaktiviert".
Info zum OpenGL-Status.
  • Menüs neu organisiert:
  • Die Hauptmenüs in Writer, Calc und Impress wurden umsortiert, um die Benutzbarkeit zu verbessern, ähnliche Funktionen zu gruppieren und Funktionen, die bisher gefehlt haben, zu ergänzen. Außerdem wurden die Einträge nach der Häufigkeit ihrer Verwendung und nach deren Relevanz neu geordnet.
  • In Writer wurde ein neues Menü Formatvorlagen ergänzt, um einen schnellen Zugriff auf Standard-Formatvorlagen zu haben (tdf#91781).
Yousuf Philips
Neues Hauptmenü Formatvorlagen in Writer.
  • In Calc wurden die Menüs neu organisiert und das Menü Tabelle neu hinzugefügt (tdf#91820).
Yousuf Philips
Neues Hauptmenü Tabelle in Calc.
  • In Impress wurden die Menüs neu organisiert und das Menü Folie neu hinzugefügt (tdf#91857).
Yousuf Philips
Neues Hauptmenü Folie in Impress.
  • Remote-Verbindungen:
  • Im Startcenter sowie im Menü Datei wurden der Eintrag Remote-Datei öffnen (Genaue Bezeichnung prüfen - Kü.) ergänzt, mit dem sich Remote-Verbindungen wie zu Google Drive, OneDrive, SharePoint, usw. herstellen lassen.
Szymon Kłos - GSoC 2015, Yousuf Philips, Heiko Tietze
  • Übers Menü Datei ▸ Auf Remote-Server speichern (Genaue Bezeichnung prüfen - Kü.) können Dateien ebenso als Remote-Dateien gespeichert werden.
Dialog zum Öffnen von Remote-Dateien.
  • Formatvorlagen-Vorschau deaktivieren: Die Experteneinstellungen im Menü unter Extras ▸ Optionen... ▸ LibreOffice ▸ Erweitert ▸ Experteneinstellungen besitzen nun eine Einstellung StylesAndFormatting mit der Eigenschaft Preview, über die sich die Vorschau von Formatvorlagen deaktivieren lässt (tdf#91495).
Tomaž Vajngerl
91495 StylesAndFormatting PreviewInExpertOptions.png
  • GTK unter Linux: Für GTK wurde das Verhalten zum Verbergen von Zugriffstasten umgesetzt (tdf#92630).
Simon Long - Raspberry Pi
  • Sonderzeichen: Sie können nund den Dezimal- oder Headezimal-Code eines Zeichens im Dialog im Menü unter Einfügen ▸ Sonderzeichen... eingeben (tdf#34882).
Steve Hart, Adolfo Jayme Barrientos
  • Verbesserte AutoKorrektur im Kontextmenü: Dem Kontextmenü wurde der Eintrag AutoKorrektur Optionen hinzugefügt. So kann jetzt direkt auf die AutoKorrektur-Ersetzungstabelle zugegriffen werden, wenn keine Vorschläge im Untermenü Immer korrigieren in vorhanden sind.
Yousuf Philips, Samuel Mehrbrodt - CIB
Kontextmenü mit neuem Eintrag AutoKorrektur Optionen.
  • Änderungen an der Seitenleiste
  • Der Status der Seitenleiste und des aktiven Registers wird zwischen den Sitzungen gespeichert (tdf#67770).
Laurent Godard
  • Bei der Verwendung des Mausrades über den Registern der Seitenleiste wird nun zwischen den Registern gewechselt, anstatt im Dokument zu rollen.
Bjoern Michaelsen
  • Der Bereich Fläche wurde überarbeitet (tdf#90078).
Rishabh Kumar, GSoC 2015, Yousuf Philips
Der neu gestaltete Bereich Fläche:
Links: in LibreOffice 5.0;
Rechts: in LibreOffice 5.1.
  • Der Bereich Linie wurde überarbeitet (tdf#89543).
Rishabh Kumar, GSoC 2015, Yousuf Philips, Katarina Behrens - CIB
Der neu gestaltete Bereich Linie:
Links: in LibreOffice 5.0;
Rechts: in LibreOffice 5.1.
  • Neuer Bereich Schatten (Bezeichnung prüfen - Kü.) in den Seitenleisten von Calc, Impress und Draw (tdf#87702).
Rishabh Kumar, GSoC 2015, Yousuf Philips
Neuer Bereich Schatten (s.o. - Kü.) in den Seitenleisten von LibreOffice 5.1.
  • Dem Bereich Umlauf wurden in Writer Elemente für Kontur und Abstände hinzugefügt (tdf#93775).
Rishabh Kumar, GSoC 2015, Yousuf Philips
Der Bereich Umlauf:
Links>/u>: in LibreOffice 5.0;
Rechts: in LibreOffice 5.1.
  • Der Seitenleiste wurden Schaltflächen zum Vergrößern und Verkleinern der Schriftgröße hinzugefügt (tdf#86179).
Maxim Monastirsky
Neue Schaltflächen zum Vergrößern und Verkleinern der Schriftgröße
Oben: Abschnitt Zeichen in Calc 5.0.
Unten: Abschnitt Zeichen in Calc 5.1.
  • Der Seitenleiste wurden Schaltflächen für die Bezugskante bei schräggestelltem Text hinzugefügt (tdf#91802).
Rishabh Kumar GSoC 2015
  • Dem Bereich Eigenschaften in Calc wurde ein Abschnitt für Formatvorlagen hinzugefügt (tdf#73071).
Rishabh Kumar, GSoC 2015, Yousuf Philips, Maxim Monastirsky
  • Der Bereich Folienübergang der Seitenleiste in Impress wurde für eine vereinfachte Auswahl neu gruppiert und in ein Auswahlfeld mit Symbolen geändert (tdf#36946).
Tor Lillqvist - Collabora, Michael Meeks - Collabora, Andreas Kainz, Yousuf Philips
Der Bereich Folienübergang in Impress 5.1.
  • Chart wurde eine Seitenleiste zur Bearbeitung von Diagrammen hinzugefügt.
Markus Mohrhard
  • Diese unterliegt jedoch noch einigen Einschränkungen.
Elemente der neuen Seitenleiste in Chart.
  • Eine Möglichkeit zum Spiegeln ist nun auch in der Seitenleiste von Writer verfügbar.
Samuel Mehrbrodt - CIB
Symbole um Spiegeln in der Seitenleiste von Writer
  • Die Symbole in der Seitenleiste berücksichtigen nun auch RTL- bzw. senkrechte Texteinstellungen und entsprechend vorliegende die Drehung/Spiegelung, wie es in der Symbolleiste der Fall ist.
Samuel Mehrbrodt - CIB
  • Sonderzeichen in der Rechtschreibprüfung: Der Dialog Rechtschreibung hat jetzt eine Symbolleiste mit Schaltflächen, um Inhalte aus der Zwischenablage und Sonderzeichen einzufügen (tdf#95682).
Caolán McNamara - Red Hat, Inc.
Symbolleiste im Dialog Rechtschreibung.

Lokalisierung

  • Neue Sprachen:
  • Es wurden weitere Sprachen zur Rechtschreibprüfung und als Gebietsschemata hinzugefügt:
  • Es wurden Gebietsschemata für Arabisch hinzugefügt: [ar-BH] [ar-IQ] [ar-JO] [ar-LY] [ar-MA] [ar-QA] [ar-SY] [ar-YE] (tdf#95485).
Ghasan Al-Sakkaf, Eike Rathke
  • Wörterbücher und Grammatik:
  • Die deutsche Rechtschreibprüfung in den Varianten für Deutschland (de-DE), Österreich (de-AT) und die Schweiz (de-CH) wurde erheblich erweitert (tdf#96782).
  • Das Rechtschreibwörterbuch enthält nun über 250.000 Wörter; über 20.000 davon sind neu hinzugekommen.
  • Der Thesaurus (Synonymwörterbuch) enthält nun 135.000 Wörter in über 35.000 Wortgruppen; ca. 35.000 Wörter sind neu hinzugekommen.
  • Die Silbentrennung wurde aktualisiert und enthält eine verbesserte Ausnahmenliste.
  • Es wurden für mehrere weitere Sprachen die Wörterbücher aktualisiert, u.a. für Griechisch(tdf#94415), Portugiesisch, Schwedisch, Spanisch und Ungarisch (tdf#95024).
  • Der Thesaurus wurde u.a. für Slowenisch aktualisiert.
  • Ein Thesaurus neu hinzugekommen ist für Guarani.

Leistung

  • Calc:
  • Die Funktion SUMME verwendet nun eine verbesserte Arithmetik und, falls verfügbar, SSE3, was für die Berechnung großer Summen einen Geschwindigkeitszuwachs um den Faktor 5 bedeutet.
Michael Meeks - Collabora, Tomaz Vajngerl - Collabora
  • Für einfache Funktionen wie +, -, *, /, SUMME und PRODUKT wird nun der Formula Group SoftwareInterpreter verwendet, was für die Berechnung umfangreicher Funktionen einen Geschwindigkeitszuwachs um den Faktor 2 bedeutet.
Jan Holesovsky - Collabora

Skriptsprachen

  • Access2Base aktualisiert: Die Basis-Bibliothek für Base ist nun in ihrer neuesten Version 1.4.0 verfügbar.
Die größte Erweiterung hat die Aktion OutputTo erhalten, wodurch es jetzt einfach ist, Daten aus einer Base-Tabelle oder -Abfrage in Calc, Text oder HTML zu exportieren.
Beispiele für den HTML-Export sind auf dieser Seite (englisch) verfügbar.
Jean-Pierre Ledure
  • PyUNO: Zur Vereinfachung hat PyUNO ein Python-ähnlicheres Verhalten bekommen.
  • Vereinfachter Zugriff auf die Online-Dokumentation der API: Es wurde ein Methode eingefügt, über welche auf die Dokumentation jedes UNO-Services zugegriffen werden kann.

Entfernte / herabgestufte Funktionen

  • Bei eingebetteten NPAPI-Plugins (englisch) (vor allem Adobe Flash) wird nun gewarnt, dass diese veraltet sind. Dies funktioniert nicht in allen Umgebungen und die Unterstützung für NPAPI wird im Release 5.2 ganz entfernt.
  • Die Unterstützung für ActiveX ist veraltet und könnte in einer der zukünftigen Version entfernt werden. Falls diese Änderung Ihre Windows-Anwendung negativ beeinflussen sollte, schicken Sie bitte eine E-Mail an die development-Liste mit Ihrem Anwendungsfall und Ihrem Plan für die zukünftige Verwendung von ActiveX. Wir sind besonders an Rückmeldungen interessiert, wenn Sie ActiveX zur Einbettung von LibreOffice in Ihre Anwendung verwenden.

Plattform-Kompatibilität

  • Android: Es wird nun auch flat-ODF unterstützt.
Miklos Vajna - Collabora
Flat-ODF auf Android.
  • Linux: Es wird nun Kernel 2.6.32 oder neuer und glibc 2.12 oder neuer benötigt.
  • OS X:
  • LibreOffice auf OS X muss mindestens einmal gestartet werden, bevor das LanguagePack installiert werden kann (tdf#89657).
  • Es ist die Installation von Oracle Java JDK notwendig, um Base (HSQLDB) und Extensions, die Java benötigen, auzuführen.
  • Die vorherige Möglichkeit, Apple JRE 6 und Oracle JRE 8 parallel installiert zu haben, funktioniert nicht mehr. Die Verwendung von JDK ist nun fest in den Code einprogrammiert (tdf#74877, tdf#94716).