LibreOffice 5.1 Release Notes

From The Document Foundation Wiki
Jump to: navigation, search

About this page

This is an in-progress scratch-pad of notes to build release notes from as and when we release. Please do not list features that are to be shipped already in the 5.0 release! Please do not add wish-list features that you hope will be implemented, but only what actually is implemented already.

What does a good feature look like here:

  • It has a description, and a way for a busy reviewer, to find and play with the feature. Target someone who is extremely busy, and knows little-to-nothing about the product. So if a user interface element is key to the feature, be very explicit about where it is, e. g. Menu ▸ Format ▸ Character ▸ Position [tab] ▸ ‘90 degrees’ paths to the elements you changed. Of course, you know your feature is important, and that everyone should care about the Extensible AutoShapes Properties dialog – but often the guys taking the screenshots and writing the notes do not.
  • It credits the main authors who did the work – just add them in brackets after the feature, where possible.
  • If the feature can be shown off with a sample / test file – particularly for new import-able features, it would be wonderful to have a link to/up-load of a test file that we can use to show that feature off to best effect. That really helps us to make good screenshots to show off the features, and allows reviewers to do their testing.

Thanks in advance for your help filling this out!


Writer

  • El cuadro de diálogo de corrección ortográfica no se cierra automáticamente una vez que se ha completado el proceso. tdf#79312 (Marek Dolezel)
  • El flujo de texto para filas viudas o huerfanas esta activo en los nuevos documentos. tdf#89714 (SIL)
  • Al combinar correspondencia se guarda la definición de la fuente de datos. (Ver esta entrada de blog [1]) (Miklos Vajna)
  • En el menú Ver se agrega la opción Ocultar espacios en blanco. Con esto solo se ve el espacio que tiene texto. tdf#39080 (Ashod Nakashian)
  • Reorganización de los menús, incluyendo la adición de un menú de estilos tdf#91781 (Yousuf Philips)
Nuevo menú de Estilos en Writer
  • Boton de enmarcado disponible en la barra de formato, pero oculto tdf#95403 (Maxim Monastirsky)

Calc

  • Nuevos comandos para agregar filas abajo y columnas a la derecha. (Philippe Jung)
  • El Wizard para formulas muestra los valores de los parámetros y los resultados. (Benjamin Ni) add screenshot
  • La exportación a PNG ha sido agregada, como en Writer e Impress. [Entrada al blog http://vmiklos.hu/blog/calc-png-export.html] (Miklos Vajna)
  • Botón para incrementar y decrementar el tamaño de las letras en la barra lateras de propiedades. tdf#86179 (Maxim Monastirsky)
  • La orientación del texto dentro de la celda cuando se rota ha sido agregado el panel lateral del formato. tdf#91802 (Rishabh Kumar)
  • Opción para buscar formatos usando la barra de búsqueda y el cuadro de diálogo. tdf#48456 (Dennis Francis)
Searchformatted.png
  • Reorganización de los menús, incluyendo el menú Hoja tdf#91820 (Yousuf Philips)
Nuevo menú Hoja en Calc

Motor de Formula

Referencias a tablas estructuradas

tdf#85063 (Eike Rathke)

  • Las siguientes restricciones de referencias a tablas estructuradas que estaban presentes en 5.0 fueron referenciadas:
    • Los nombres de las columnas no están presentes como contenido de celda en el encabezado de la tabla. Las columnas sin encabezado ahora son soportadas.
      • Por esto, para nuevos rangos de base de datos sin encabezado se les generará un nombre de columna interno, por ejemplo: Columna1, Columna2, ...
      • Los nombres internos son importados de la Hoja de cálculo en formato OOXML y continuará la función en las expresiones de las formulas.
    • Al salvar en formato OOXML, las referencias en las tablas estructuradas sera escritas (No se transformará en formato A1) y el contenido de la tabla es mantenido.
    • Al salvar en formato OOXML, el rango definido como base de datos es exportado como elementos <tabla>.
  • Modifying header cell content updates the internal table column names.
    • When deleting header cell content, formulas referring the column name continue to function and are still editable using the previous name.
    • When duplicating header cell content, duplicated column names internally are numbered. For example, having two FooBar header cells the column names will be FooBar and FooBar2. This is automatically reflected in existing formula expressions.
    • When inserting columns within a table, numbered column names are internally generated for empty header cells, starting with the column number within the table. For example, inserting two columns before the third column of a table the generated names are Column3 and Column4.
      • The generated column names are updated if text is entered in such an empty cell.
    • All internal column names are unique within one table, which is reflected when displaying existing formula expressions.

ODF 1.2

Funciones WEEKNUM y WEEKNUM_ADD cumplen con ODF 1.2. tdf#50950

Impress and Draw

  • Navegación en diapositivas y comandos para ordenar han sido agregados. tdf#91909 (Philippe Jung)
  • La vista de diapositivas principal aparece en un color de fondo diferente a la vista normal. tdf#87905 (Katarina Behrens)
  • El protector de pantalla en KDE, XFCE, y Mate son inhabilitados en las presentaciones. (Andrzej Hunt).
  • Reorganización de los menús en Impress, incluyendo el menú Diapositivas tdf#91857 (Yousuf Philips)
Nuevo menú Diapositivas en Impress

Modos de selección en Impress

Distintos modos de selección en Impress:

  • Página para editar el contenido de las diapositivas
  • Página maestra para editar los fondos de las diapositivas
  • Notas para agregar notas
  • Notas Maestra para editar notas de fondo
  • Plan para bosquejar una presentación
  • Manos libres para definir el formato de manos libres
  • Ordenar diapositivas para organizar las diapositivas

It was hard to navigate between Master / non master modes. Tabs above the working area were jumping right and left, consuming screen space.

Ahora, dos barras de herramientas han sido agregadas:

  • one to toggle Tab bar visibility. It is hidden by default. Clicking the toggle disables the new Mode Selection tool and restores the previous behaviour.
  • one to Select the Working mode among the 7 modes listed above. It is divided in two zones: top zone is regular mode (dealing with content of the presentation), bottom zone is the Master mode (dealing with container).
Nuevos modos de selección


Diseño de diapositivas

El cuadro de diálogo Diseño de diapositiva en Diapositivas ▸ Diseño de diapositiva ahora afecta a todas las diapositivas seleccionadas. (Caolán McNamara)

Igualar Ancho/Alto

Cuando multiples objetos son seleccionados, el submenú Figuras del menú contextual ahora soporta igualar el ancho o el alto de los objetos ajustandolos con el tamaño del último objeto seleccionado. (Caolán McNamara)

Equalize.png

Guardar imagen de fondo

Con el menú contextual se puede guardar la imagen de fondo de la diapositiva. (Caolán McNamara)

Save-bg.png

View/Edit Control Points

The Shape Properties dialog for enhanced shapes now lists and enables editing the control points. This is in addition to the preexisting mechanism of selecting with the mouse the yellow control handle of the shape, but enables viewing and fine control over the control values. (Caolán McNamara)

Control-points.png

Presenter Console

Chart

  • Nueva barra lateral para Chart tdf#91063 (Markus Mohrhard, Yousuf Philips, Heiko Tietze)
    • Todavía tiene algunas limitaciones
Nueva sección Elementos para las gráficas en la barra lateral

Líneas de tendencia

  • Líneas de tendencia exponencial y de poder aceptan valores negativos en Y tdf#70673 (Laurent BP)
  • Se mejora el renderizado eliminando algunos 1: (Laurent BP)
    • polinomial: f(x) = 1x^2 + 1x +1 => f(x) = x^2 + x +1
    • exponencial: f(x) = exp( 1 x ) => f(x) = exp( x )

Core

Entrada de caracteres Unicode con Alt+X

Algunas aplicaciones en MS Windows, como Microsoft Word y WordPad, permiten al usuario ingresar caracteres unicode escribiendo un código hexadecimal (Por ejemplo, 2026 para ) y entonces presionar Alt+X (o Alt+C en Aleman). LibreOffice ahora incluye esta funcionalidad. (Nota: Esta característica es equivalente en Linux presionando Ctrl+⇧ Shift+U + código hexadecimal.) tdf#73691 (SIL)

Detalles:

  • Toggles (switches back and forth) between the character before the cursor and its Unicode notation.
  • Intelligently handles combining characters, expanding the entire character immediately.
  • Selection is not necessary, but if used will limit the input to those characters. (Draw/Impress/Calc have the final result selected, but not Writer.)
  • Handles all 16 Unicode planes
  • Available in Writer, Draw, Impress, Calc and Math.
  • Re-assignable keyboard shortcut: Tools ▸ Customize ▸ Keyboard Options Category ▸ Toggle Unicode Notation function. Defaults to Alt+X assigned at the global level.

Mejoras en WebDav

Options / General

  • Soporte de la engrada de registro HKEY_CURRENT_USER Windows que activa politicas de configuración por usuario. (Michael Meeks)

Filtros

  • Exportación de una cadena modificada de VBA a los formatos binarios de Microsoft y OOXML (Rosemary Sebastian, Markus Mohrhard)
    • There is a new configuration value that allows to control whether to use this feature (by default yes) or switch back to the old behavior of discarding or writing back the unchanged stream
    • The following features are not yet (completely) supported: Protected macros, macro sheets, active x and some of the designer features.
  • Gnumeric es oficialmente un formato de importación soportado (No trabaja en MS Windows) (Estuvo soportado de forma experimental por algún tiempo) (Markus Mohrhard)
  • Microsoft Write (Archivos .wri) ahora pueden ser importados, core commit c399caebe35e57d55edc4fcc19a7276a23e2645f (Sean Young)

GUI

  • En el cuadro de diálogo Herramientas ▸ Opciones ▸ LibreOffice ▸ Ver se agregó el estado de OpenGL: Activar o desactivar.
Current status OpenGL.png

Archivos remotos

  • En la pantalla de Inicio y el menú Archivo se agregó la opción Abrir archivos remotos para abrir archivos en recursos remotos como Google Drive, OneDrive, SharePoint, etc.
  • En el menú Archivo se agregó la opción Guardar en servidor remoto para guardar archivos en recursos remotos como Google Drive, OneDrive, SharePoint, etc.
RemoteFilesDialog.png

Barra lateral

  • Se reorganiza las propiedades de Área. tdf#90078 (Rishabh Kumar, Yousuf Philips)
Sección Área en Libreoffice 5.0, A la derecha LibreOffice 5.1
  • Se reorganiza las propiedades de Línea. tdf#89543 (Rishabh Kumar, Yousuf Philips, Katarina Behrens [CIB])
Sección Línea en Libreoffice 5.0, A la derecha LibreOffice 5.1
  • Se agrega una sección para crear sombras enCalc, Impress y Draw. tdf#87702 (Rishabh Kumar, Yousuf Philips)
Nueva sección Sombras en LibreOffice 5.1
To left section Wrap in Libreoffice 5.0, to right - in LibreOffice 5.1

Menú contextual de AutoCorrección

  • Una opción "Opciones de AutoCorrección" se incluye en el menú contextual. Ahora se puede editar las opciones de correccion cuando las sugerencias no cumplan las necesidades. tdf#92341 (Yousuf Philips, Samuel Mehrbrodt [CIB])
Autocorrect context menu.png

Spelling Dialog

  • El cuadro de diálogo de Corrección ahora tiene una barra de herramientas para pegar o insertar especiales. tdf#95682 (Caolán McNamara, Red Hat, Inc.)
Insert-symbol-spell-dialog.png