Notes de version LibreOffice 5.1

From The Document Foundation Wiki
Jump to: navigation, search

Contents

À propos de cette page

Cette page présente les nouveautés de la version LibreOffice 5.1 (notes de version). Bien qu'en principe complète, certaines modifications peuvent ne pas y figurer.

Merci par avance pour votre participation au remplissage de cette page !

Writer

  • Le dialogue de vérification orthographique ne se ferme plus automatiquement quand la vérification est terminée tdf#79312}, tdf#42935 (Marek Dolezel et Samuel Mehrbrodt).
  • Le traitement des veuves et orphelines pour l'enchaînement des paragraphes est maintenant activé par défaut pour les nouveaux documents tdf#89714 (SIL).
  • Publipostage : incorporation de la définition de la source de données dans le document (cf. cette entrée de blog) (en anglais) (Miklos Vajna, Collabora))
  • Ajout de l'option Affichage ▸ Masquer les espaces tdf#39080 (Ashod Nakashian, Collabora))
  • Outil déployable pour les listes de type plan dans la barre d'outils Formatage ; non affiché par défaut tdf#95403 (Maxim Monastirsky).
  • En mode aperçu avant impression, ajout de la possibilité d'introduire le numéro de page dans le champ prévu de la barre d'outils pour atteindre la page demandée. tdf#80657 (Gülşah Köse)
Jumptospecificpage.png

Voir aussi

Calc

  • Nouvelles commandes pour ajouter des lignes en-dessous et des colonnes à droite (Philippe Jung).
  • Le raccourci-clavier affichant les sources de données a été changé pour Ctrl+⇧ Maj+F4 et F4 a été assigné au basculement des références de cellules tdf#59418 (Dennis Francis).
  • L'assistant Fonctions affiche désormais les valeurs et résultats des paramètres dans l'onglet Structure (Benjamin Ni).
Function-Wizard-Structure.png
  • Statistiques : régression linéaire, logarithmique, puissance ; ajout d'un nouveau dialogue pour calculer la régression commit tdf#74667 (Tomaz Vajngerl, Collabora)
Dialogue Données ▸ Statistiques ▸ Régression
  • Réorganisation des menus contextuels de niveau Feuille commit (Yousuf Philips).
  • L'export PNG a été ajouté dans LibreOffice Calc, comme pour Writer et Impress (voir cette entrée de blog) (en anglais) (Miklos Vajna, Collabora).
Nouvel export PNG dans Calc
  • Augmenter & Réduire la taille de police ajoutées au volet latéral tdf#86179 (Maxim Monastirsky).
  • Bord de référence de cellule ajouté à la section alignement du volet latéral tdf#91802 (Rishabh Kumar).
  • Ajout d'une option pour chercher les données telles qu'affichées, tenant compte du formatage. Disponible dans la barre d'outils Rechercher et dans Édition ▸ Rechercher & Remplacer tdf#48456 (Dennis Francis).
Searchformatted.png
  • Fonction INDIRECT : amélioration de la compatibilité avec les documents legacy OOo, amélioration de l'interopérabilité avec Excel tdf#92256, tdf#93688 (Katarina Behrens, CIB)
  • Les formats de nombre personnalisés incluant des points d'interrogation dans la partie décimale (comme 0,???), pour obtenir un alignement décimal sans '0', peuvent maintenant être enregistrés au format ODF tdf#40517 (Laurent BP)

Moteur de Formule

Références des tableaux structurés

tdf#85063 (Eike Rathke, Red Hat)

  • Les restrictions suivantes présentes dans la version 5.0 ont été traitées :
    • Les noms de colonnes ne doivent plus être présents comme contenu dans la ligne d'en-tête de table ; les tables sans en-tête de colonnes sont gérées.
      • Pour cela, des noms internes sont générés pour les nouvelles plages de base de données sans en-tête ou en-tête vide, par exemple Column1, Column2, etc.
      • Les noms internes sont importés des classeurs au format OOXML et continuent de fonctionner dans les formules.
    • Lors de l'enregistrement en OOXML, les références structurées sont maintenant écrites (ne sont plus transformées en notation A1) et le contexte de table est maintenu.
    • Lors de l'enregistrement en OOXML, les plages de bases de données définies sont exportées comme des éléments <table>.
  • Modifier le contenu des cellules d'en-tête met à jour les noms internes des colonnes de la table.
    • Lors de la suppression du contenu des cellules d'en-tête les formules faisant référence au nom de colonne continuent de fonctionner et sont toujours éditables en utilisant le nom précédent.
    • Lors de la duplication du contenu des cellules d'en-tête, les noms internes dupliqués sont numérotés. Par exemple le nom de colonne FooBar générera FooBar et FooBar2. Ceci est automatiquement répercuté dans les formules existantes.
    • Lors de l'insertion de colonnes à l'intérieur d'une table, des noms internes numérotés de colonne sont générés pour les cellules vides, commençant avec le numéro de colonne à l'interieur de la table. Par exemple insérer deux colonnes avant la troisième générera les noms Column3 et Column4.
      • Les noms de colonne générés sont mis à jour si le texte saisi dans une de ces cellules vides.
    • Tous les noms internes de colonne sont uniques à l'intérieur d'une table, ce qui est répercuté lors de l'affichage des formules.

Extrémités fixes des ancres de fin de ligne/colonne

tdf#92779 (Eike Rathke, Red Hat)

  • Pour les références de plage englobant au moins deux colonnes ou lignes, où la référence de fin pointe vers la dernière colonne/ligne, i.e. AMJ ou 1048576, la référence de fin est désormais fixe et n'est pas déplacée lors de l'insertion ou la suppression de colonnes/lignes.
  • Si l'insertion de colonnes/lignes génère un débordement des limites de feuille, la référence est ancrée à la dernière colonne/ligne au lieu de générer une erreur#REF!.
    • Par exemple une référence B2:B1048575 sera transformée en B2:B1048576 lors de l'insertion de deux lignes.
    • La référence de fin est devenu fixe, "collante", soit 1048576 dans l'exemple.
  • Une référence commee B1048576:C1048576 n'a pas d'ancre de fin fixe car une seule ligne est référencée.

Compatibilité ODF 1.2

La fonction NO.SEMAINE est strictement conforme aux définitions des fonctions ODF 1.2 et la fonction ISOWEEKNUM a été ajoutée tdf#50950 (Winfried Donkers + Eike Rathke).

  • Dans l'interface WEEKNUM_ADD a été renommée WEEKNUM_EXCEL2003 pour souligner qu'elle existe pour l'interopérabilité des documents créés avec Microsoft Excel.
    • L'import de tels documents créés avec des versions anciennes de Microsoft Excel associe la fonction WEEKNUM à WEEKNUM_EXCEL2003
    • L'enregistrement en ODF ou OOXML écrit WEEKNUM ; les versions plus anciennes de LibreOffice et OpenOffice.org font le lien avec WEEKNUM_ADD.
    • Pour les nouveaux documents la fonction WEEKNUM devrait être utilisée.
  • WEEKNUM gère désormais tous les arguments du deuxième paramètre tels que définis dans ODF OpenFormula (ODFF), cf. [1]
  • La fonction ISOWEEKNUM a été implémentée pour calculer le numéro de semaine selon la norme ISO 8601, cf. [2]
  • WEEKNUM_OOO fournit la compatibilité avec les versions plus anciennes de LibreOffice et OpenOffice.org pour les cas ne pouvant être mappés à WEEKNUM ou ISOWEEKNUM comme défini dans la norme. En particulier si l'argument mode est à 1 l'ancienne implémentation de la fonction WEEKNUM renvoie un numéro de semaine calculé comme respectant ISO 8601 mais avec la semaine commençant le dimanche au lieu du lundi. Ceci n'est couvert par aucune norme.
    • Non proposé dans l'assistant Fonctions pour prévenir un usage accidentel. À n'utiliser que pour des raisons d’interopérabilité avec des versions plus anciennes.
    • Actuellement toujours enregistré fautivement comme ISOWEEKNUM avec 2 paramètres pour interopérabilité avec les versions plus anciennes.
      • Ceci sera changé dans la future versions 5.3 et la fonction sera enregistrée ORG.LIBREOFFICE.WEEKNUM_OOO, l'actuelle version 5.1 sait déjà lire ceci.

Voir aussi

Impress et Draw

  • Ajout de commandes de navigation et de tri de diapos avec leurs raccourcis-clavier tdf#91909 (Philippe Jung, Yousuf Philips).
  • Affichage des pages maîtresses avec une couleur d'arrière-plan différente du mode normal tdf#87905 (Katarina Behrens, CIB).
  • KDE, XFCE, et Mate ScreenSavers sont désormais inhibités lors de la présentation (Andrzej Hunt).
  • Réorganisation des menus dans Impress, incluant l'ajout d'un menu Diapo tdf#91857 (Yousuf Philips)
Nouveau menu Diapo (Slide) dans Impress

Sélection du mode de travail

Plusieurs modes de travail sont disponibles dans Impress :

  • Normal pour mettre à jour le contenu des diapos
  • Pages maîtresses (masque) pour éditer ces dernières
  • Notes pour rédiger les notes associées aux diapos
  • Masque des notes pour modifier le format des notes
  • Plan pour rédiger les titres et ordonner la présentation
  • Prospectus pour définir un format d'impression
  • Trieuse de diapositives pour organiser la présentation

Il était difficile de naviguer entre les modes Masque et Non-masque. Les onglets au-dessus de la zone de travail diminuaient celle-ci.

Désormais, deux outils ont été ajoutés :

  • un pour basculer la visibilité de la barre d'onglet masquée par défaut. Cliquer sur cet outil désactive le nouvel outil de choix de mode de travail et rétablit le fonctionnement précédent.
  • un pour choisir le mode de travail parmi les 7 listés ci-dessus. Il est divisé en deux zones : en haut le mode de travail "normal" (gérant le contenu de la présentation) et en bas le mode masque (gérant les zones de saisie, la présentation, etc.).
Nouvau mode de sélection


Conception de diapo

Le dialogue de conception affecte désormais toutes les diapos (standard) sélectionnées (Caolán McNamara, Red Hat).

Égalisation Largeur/Hauteur

Lorsque plusieurs objets sont sélectionnés, la commande Formes du menu Contextuel gère l'égalisation Largeur et Hauteur qui les ajuste sur le dernier objet sélectionné (Caolán McNamara, Red Hat).

Equalize.png

Enregistrer l'image d'arrière-plan

Le clic droit sur une diapo permet désormais d'enregistrer l'image d'arrière-plan dans un fichier ; ceci correspond à l'option pré-existante Définir l'image d'arrière-plan (Caolán McNamara, Red Hat).

Save-bg.png

Affichage/Édition des points de contrôle

Le dialogue des propriétés des formes liste et active désormais l'édition des points de contrôle. Ceci est un ajout au mécanisme pré-existant de sélection à la souris, et cela active un contrôle plus précis par la gestion des valeurs (Caolán McNamara, Red Hat).

Control-points.png

Console de Présentation

Il y a désormais un bouton sur la console de présentation pour redémarrer la minuterie du diaporama sans redémarrer le diaporama lui-même (cf. cette entrée de blog) (en anglais) (Miklos Vajna, Collabora, Andreas Kainz).

Presenter-restart.png

Transitions OpenGL

Toutes les transitions OpenGL ont été portées sur OpenGL 2.1+, ce qui retire la prise en charge des très anciens GPUs mais permet une meilleure utilisation des plus modernes. Quatre transitions requérant OpenGL 3.2+ et utilisant ces nouvelles fonctionnalités ont été rajoutées. (Emmanuel Gil Peyrot, Collabora; Tomaž Vajngerl, Collabora)

Glitter
Honeycomb
Ripple
Vortex

Math

  • L'Auto-fermeture est désormais optionnel tdf#43090.

Import MathML depuis le presse-papier

(Regina Henschel)

  • L'outil “Math Input Panel” dans Windows ou le menu contextuel d'une formule dans l'explorateur permet de copier le code source MathML dans le presse-papiers. Le module Math de LibreOffice a un nouvel item Import MathML depuis le presse-papiers dans le menu Outils pour importer de telles sources et les convertir dans la syntaxe StarMath propre à LibreOffice.
Math Input Panel
MathML source dans l'explorateur
  • MathML et StarMath ont quelques différences et de ce fait des corrections sont parfois nécessaires lors de l'import, mais la plupart des formules devraient être correctes. Si une conversion n'est pas possible, rien n'est fait.
Import MathML
  • L'import s'attend à ce qu'un élément <math> existe, qui a un attribut xmlns="http://www.w3.org/1998/Math/MathML".
Résultat d'un import MathML

Base

L'ancien pilote SeaMonkey basé sur mozab n'était utilisé qu'en environnement Windows 32 bits et il est désormais supprimé. Cette fonctionnalité est remplacée par le pilote mork qui gère le carnet d'adresses Thunderbird.

L'ancien pilote SeaMonkey fournissant également l'intégration des carnets d'adresse Outlook et Outlook Express, cette fonctionnalité, limitée à l'environnement Windows 32 bits, est de ce fait perdue pour le moment.

Nota : Windows 64 bits n'a jamais géré l'ancien pilote SeaMonkey.

Diagramme

Courbes de tendance

  • Les courbes de tendance exponentielle et puissance acceptent maintenant des valeurs négatives en ordonnée tdf#70673 (Laurent BP)
  • Amélioration du rendu des équations en supprimant quelques 1 inutiles : (Laurent BP)
    • polynomiale : f(x) = 1x^2 + 1x +1 => f(x) = x^2 + x +1
    • exponentielle : f(x) = exp( 1 x ) => f(x) = exp( x )

Voir aussi

Core

Saisie de caractère Unicode sous la forme Alt+X

Des logiciels Windows, comme Microsoft Word et WordPad, permettent à l'utilisateur de saisir des caractères Unicode en tapant un code hexadecimal (par exemple, 2026 pour ) puis en pressant Alt+X. LibreOffice inclut désormais cette fonctionnalité. (Note : ceci s'ajoute à l'ancien équivalent Linux/GTK Ctrl+⇧ Maj+U+code hexadecimal) tdf#73691 (SIL).

  • Bascule entre le caractère précédent le curseur et sa notation Unicode.
  • Gestion intelligente de la combinasion et expansion immédiate des caractères.
  • La sélection n'est pas nécessaire, mais elle limite l'application à ces caractères. (Draw/Impress/Calc ont le résultat final sélectionné, mais pas Writer.)
  • Gestion des 16 Unicode planes
  • Disponible dans Writer, Draw, Impress, Calc et Math.
  • Raccourcis-clavier personnalisables : Outils ▸ Personnaliser ▸ Clavier ▸ Catégorie:Options ▸ Fonction:Basculer la notation Unicode. Par défaut affecté à Alt+X au niveau global (Alt+C utilisé pour les locales basque/hollandais/galicien/allemand/portugais brésilien et ⌘ Command+⌥ Option+X pour MacOS).

Améliorations WebDav

  • Meilleur support LOCK/UNLOCK tdf#82744 (Giuseppe Castagno)
  • Support de schéma d'URL non-standard (commme https) vnd.sun.star.webdavs en plus du non-standard (http) vnd.sun.star.webdav, commit (Stephan Bergmann, Red Hat)

Options / General

  • Gestion de la ruche de registre Windows HKEY_CURRENT_USER Windows qui permet à chaque utilisateur des politiques de configuration (Michael Meeks, Collabora).

Filtres

Nouveaux filtres d'import

  • L'import du format Gnumeric est désormais officiellement géré (il l'était depuis quelque temps comme fonctionnalité expérimentale) (Markus Mohrhard) (ne fonctionne pas sur Windows, cf. tdf#94834)).
  • Les fichiers Microsoft Write (fichiers .wri) peuvent maintenant être importés, commit (Sean Young).
  • Les fichiers Apple Keynote 6 peuvent maintenant être importés via libetonyek tdf#88682 (David Tardon, Red Hat).
Cliquer pour voir le document ouvert dans Keynote 6.6 →
Cliquer pour voir le document ouvert dans LibreOffice 5.1 →

Améliorations dans le filtre OpenXML

  • Export du flux VBA modifié aux formats binaires et OOXML Microsoft (Rosemary Sebastian, Markus Mohrhard).
    • Nouvelle option de configuration permettant de contrôler s'il faut utiliser cette fonctionnalité (oui par défaut) ou revenir au comportement antérieur.
    • Les fonctionnalités suivantes ne sont pas encore complètement gérées : protection des macros, feuilles macros, active x et quelques fonctionnalités de design.
  • Amélioration de l'export des objets incorporés vers DOCX et PPTX, incluant l'export des formules Math (Michael Stahl, Red Hat)
  • Nombreuses autres améliorations aux filtres import export Microsoft OOXML, aux formats binaires Microsoft Office et au format RTF. Détails :

Améliorations dans le filtre MS Visio

  • Implémentation de la prédominance de couleur de ligne et de texte sur les propriétés de la couche et la visibilité et l'imprimabilité d'une couche tdf#50309, tdf#68392 (Fridrich Strba).
  • Correction de la gestion des pochoirs de texte tdf#90154 (Fridrich Strba)
  • Début d'implémentation du remplissage par hachures tdf#44552, tdf#76835 (Fridrich Strba)
  • Implémentation de la gestion des puces et listes tdf#92349 (Fridrich Strba)
  • Implémentation des tabulations par défaut et personnalisées dans les propriétés des paragraphes (Fridrich Strba)
  • Au lieu d'un saut de ligne, création d'un nouveau paragraphe quand un saut est trouvé (Fridrich Strba)
  • Début d'implémentation de l'émulation de l'arrondissement de ligne (tdf#90603) (Fridrich Strba)
  • Correction import thème couleur VSDX (tdf#92270) (Andras Timar, Collabora)
  • Correction gestion arrière-plan caractère VSDX (tdf#92271) (Andras Timar, Collabora)

Améliorations dans le filtre CorelDRAW

  • Plus de suppression des lignes de texte vides tdf#67873 (David Tardon)

Interface graphique

  • Affichage de l'état courant (Actif / Inactif) de l'option OpenGL dans le dialogue Outils ▸ Options ▸ LibreOffice ▸ Affichage
Current status OpenGL.png

Réorganisation des menus

Les menus principaux de Writer, Calc et Impress ont été réorganisés pour améliorer la convivialité, regrouper les fonctions similaires, ajouter des fonctions qui manquaient et trier les entrées selon leur utilisation et leur importance cf. cette entrée de blog (en anglais).

  • Réorganisation des menus dans Writer, incluant l'ajout d'un menu Styles tdf#91781 (Yousuf Philips)
Nouveau menu Styles dans Writer
  • Réorganisation des menus dans Calc, incluant l'ajout d'un menu Feuille tdf#91820 (Yousuf Philips)
Nouveau menu Feuille dans Calc
  • Réorganisation des menus dans Impress, incluant l'ajout d'un menu Diapo tdf#91857 (Yousuf Philips)
Nouveau menu Diapo (Slide) dans Impress

Fichiers distants

  • L'entrée Ouvrir des fichiers distants a été ajoutée au centre de démarrage et au menu Fichier pour l'ouverture de fichiers sur des ressources telles que Google Drive, OneDrive, SharePoint, etc tdf#86703. Voir cette entrée de blog (en anglais) (Szymon Kłos, GSoC 2015; Yousuf Philips, Heiko Tietze)
  • L'entrée Enregistrer sur serveur distant a été ajoutée au menu Fichier pour l'enregistrement de fichiers sur des ressources telles que Google Drive, OneDrive, SharePoint, etc.
RemoteFilesDialog.png

Volet latéral

  • État du volet latéral et des panneaux préservé entre les sessions tdf#67770 (Laurent Godard)
  • Le défilement avec la molette de la souris sur le volet latéral fait désormais défiler les panneaux du volet et non plus le document dans la fenêtre principale (Bjoern Michaelsen)
  • Ajout de contrôles et réorganisation de la zone Remplissage du panneau Propriétés tdf#90078 (Rishabh Kumar, GSoC 2015 ;Yousuf Philips)
À gauche en version 5.0, à droite en version 5.1
  • Réorganisation du contenu Ligne tdf#89543 (Rishabh Kumar, GSoC 2015 ; Yousuf Philips, Katarina Behrens [CIB]).
À gauche en version 5.0, à droite en version 5.1
  • Création de contrôles Ombre dans Calc, Impress et Draw tdf#87702 (Rishabh Kumar, GSoC 2015 ; Yousuf Philips).
Nouvelle section Ombre
  • Ajout de contrôles Espacement et Contour dans Writer commit tdf#93775 (Rishabh Kumar, GSoC 2015 ; Yousuf Philips).
À gauche en version 5.0, à droite en version 5.1
  • Augmenter & Réduire la taille de police ajoutées au volet latéral dans Calc tdf#86179 (Maxim Monastirsky).
En haut avec la version 5.0, en bas avec la version Calc 5.1
  • Bord de référence de cellule ajouté à la section alignement du volet latéral dans Calc tdf#91802 (Rishabh Kumar, GSoC 2015).
  • Les styles de cellules sont ajoutés au volet Propriétés dans Calc tdf#73071 (Rishabh Kumar, GSoC 2015 ; Yousuf Philips, Maxim Monastirsky).
  • Section Transition du volet latéral modifiée dans Impress tdf#36946 (Tor Lillqvist, Collabora; Michael Meeks, Collabora; Andreas Kainz, Yousuf Philips)(Tor Lillqvist, Collabora, Michael Meeks, Collabora, Andreas Kainz, Yousuf Philips)
Cliquer pour visualiser la section Transition →
  • Nouveau panneau Diagramme dans le volet latéral tdf#91063 (Markus Mohrhard, Yousuf Philips, Heiko Tietze) (encore quelques limitations...).
Nouvelle section pour les diagrammes dans le volet latéral
  • Boutons Refléter Image désormais disponibles également dans Writer (Samuel Mehrbrodt [CIB])
Les images peuvent maintenant être reflétées via le volet latéral dans Writer
  • Les icônes du volet latéral respectent désormais le paramétrage RTL/Texte Vertical à l'instar des barres d'outils tdf#85767 (Samuel Mehrbrodt [CIB]).

AutoCorrection : menu contextuel

  • Une entrée Options d'AutoCorrection a été ajoutée au menu contextuel de vérification orthographique. Les utilisateurs peuvent désormais accéder à la table de remplacement de l'AutoCorrection quand les suggestions du sous-menu Toujours corriger en ne sont pas satisfaisantes tdf#92341 (Yousuf Philips, Samuel Mehrbrodt [CIB]).
Autocorrect context menu.png

Vérification orthographique

  • Le diaogue de vérification orthographique dispose désormais d'une barre d'outils pour coller et insérer des caractères spéciaux tdf#95682 (Caolán McNamara, Red Hat, Inc.).
Insert-symbol-spell-dialog.png

Linux/Gtk

  • Activation auto-accelérateur pour gtk tdf#92630 (Simon Long, Raspberry Pi)

Caractères spéciaux

  • Saisie d'un caractère en décimal ou hexadécimal dans la boîte de dialogue Caractères spéciaux tdf#34882 (Steve Hart; Adolfo Jayme Barrientos)

Localisation

Nouvelles langues/locales avec données de localisation

Disponibles comme langue par défaut pour le document et pour les formatages locaux spécifiques.

  • Ajout Arabic [ar-BH] [ar-IQ] [ar-JO] [ar-LY] [ar-MA] [ar-QA] [ar-SY] [ar-YE] tdf#95485 (Ghasan Al-Sakkaf and Eike Rathke, Red Hat).

Amélioration des outils linguistiques et de la gestion des langues

  • Outils linguistiques pour l'allemand (de-AT, de-CH, de-DE) très largement améliorés tdf#96782.
    • Le dictionnaire orthographique contient désormais environ 250 000 mots. La nouvelle version ajoute plus de 20 000 nouveaux mots.
    • Le thésaurus contient désormais plus de 135 000 mots dans plus de 35 000 groupes. La nouvelle version ajoute environ 35 000 nouveaux mots.
    • Les motifs de césure ont été mis à jour pour une liste d'exceptions améliorée.
  • Mise à jour du thésaurus slovène
  • Nouveau thésaurus Guarani (gug-PY) (Giovanni Caligaris and Olivier Hallot)
  • Mise à jour majeure du dictionnaire hongrois, implémentant la réforme orthographique définie par la 12ème édition des règles de l'orthographe hongroise (par l'Académie des Sciences Hongroise, 2015) (tdf#95024) (László Németh, Collabora).
  • Mise à jour du dictionnaire grec (tdf#94415)
  • Mise à jour du dictionnaire portugais (pt-PT) spell-check dictionary
  • Mise à jour du dictionnaire suédois
  • Mise à jour du dictionnaire espagnol (Ricardo Palomares)

Performance

Calc

  • La fonction SOMME utilise désormais, si présent, l'arithmétique optimisé SSE3, offrant un gain ~5x pour les grandes sommes (Michael Meeks, Collabora, Tomaz Vajngerl, Collabora)
  • Formula Group SoftwareInterpreter utilisé pour les fonctions simples : +, -, *, /, Somme, Produit, offrant un gain 2x pour les grandes opérations (Jan Holesovsky, Collabora)

Scripts Python / Basic

Faciliter l'usage de PyUNO (Matthew J. Francis)

  • Simplification du travail avec des objets UNO en donnant le comportement de listes, dictionnaires et itérateurs aux objets qui implémentent les interfaces de containers UNO.
  • Application d'un comportement personnalisé pour autoriser les objets qui implémentent com::sun::star::table::XCellRange à obtenir les cellules et plages par leur indice.
  • Quand les containers d'objets UNO sont adressés par leur nouveau style, élimine la nécessité de construire manuellement des objets Any pour les éléments contenus qui sont des séquences typées.
  • Autorisation de passer listes et itérateurs là où les méthodes UNO acceptent une séquence.
  • Réduction des exigences d'initialisation des structures UNO pour permettre à certains membres d'être ignorés quand tous les initialiseurs sont passés par nom.

Plus de détails ici

Conférence à Aarhus Présentation (PDF)

Montée de version du paquetage Python

Sur Mac OS X et Linux, le paquetage Python a été monté en version 3.5. En raison de problèmes de compatibilité Visual Studio, les versions Windows utilisent toujours Python 3.3 (David Ostrovsky).

Access2Base mis à jour

Access2Base, la bibliothèque Basic pour les utilisateurs de Base, est maintenant disponible dans sa version 1.4.0 (Jean-Pierre Ledure).

Les améliorations principales concernent l'action OutputTo, qui permet maintenant de facilement exporter les données contenues dans une table ou une requête de Base vers Calc, ou un fichier texte ou des pages HTML. Des exemples de rendu HTML sont disponibles sur le site de documentation.

Accès facile à la documentation en ligne de l'API LibreOffice

Il y a désormais un singleton theServiceDocumenter. Il fournit la méthode showServiceDocs(), qui ouvre la documentation de n'importe quel service UNO passé en paramètre. Ceci favorise le développement rapide, en particulier pour le développement d'extension en Basic ou Python. Une courte vidéo d'une présentation faite à la conférence LibreOffice est disponible, qui évoque à la fois les concepts de base de l'API UNO et comment le nouvel outil aide les développeurs.

Fonctionnalités supprimées / obsolètes

(section également présente dans les notes de version de la 5.2 en attente de retour des utilisateurs).

  • L'incorporation de Plugins NPAPI (principalement Adobe Flash) dans les documents est désormais signalée comme obsolète. Cela ne fonctionnera pas dans tous les environnements et le support de NPAPI peut être supprimé dans le futur.
  • Le support d'ActiveX est considéré obsolète et peut être supprimé dans le futur. Si cette modification vous affecte négativement dans votre application Windows, merci d'écrire par courrier électronique à la liste des développeurs de LibreOffice, en précisant votre cas d'utilisation et vous préparer à abandonner ActiveX. Nous avons absolument besoin de retours des utilisateurs sur les utilisations d'ActiveX pour des composants embarqués dans LibreOffice.

Sous le capot

Voir ce qui a changé. (en anglais).

Changement dans l'API

Removed configuration options

  • Suppression de /org.openoffice.Office.Common/Misc/AlwaysAllowSave. L'enregistrement est maintenant toujour possible. (Maxim Monastirsky) commit

Liaison Java UNO

  • Suppression de la casse obsolète com.sun.star.uno.Union, commit
  • Java UNO bootstrap (com.sun.star.comp.helper.Bootstrap) accepte maintenant des arguments personnalisés en ligne de commande pour bootstrapped soffice tdf#86784 (Katarina Behrens, CIB)
    • Exemple d'utilisation :
List list = Arrays.asList( Bootstrap.getDefaultOptions() );
list.remove("--nologo");
list.remove("--nodefault");
list.add("--invisible");
Bootstrap.bootstrap( list.toArray( new String[list.size()] );
  • Les archives JAR URE et officebean (juh, jurt, ridl, unoil, unoloader, officebean) peuvent être téléversées sur le dépot central Maven et déployées à partir de ce dépot (David Ostrovsky, Katarina & Thorsten Behrens, CIB)

Annulation de publication UNO API

L'interface com.sun.star.tiledrendering.XTiledRenderable fut publiée de manière erronée lors de son introducion dans les versions précédentes. Elle n'est plus plubliée commit

Changements API UNO

  • Les points de données fournissent désormais également le service com.sun.star.drawing.FillProperties (Markus Mohrhard)
    • Tous les objets chart2 devraient désormais gérer les mêmes nom de propriétés pour la propriété FillChart2
    • Les nouveaux noms sont juste des alias vers les anciens de manière à ce qu'ils restent supportés DataPoints
  • Le volet latéral a désormais une API (Laurent Godard)
    • Point d'entrée getSidebar() ajouté à la (toujours non publiée) com.sun.star.frame.XController2 [3]
    • support de la hiérarchie des volets
    • Script exemple de travail pyUno [4]

Les interfaces et services UNO suivants ont été changés :

  • com.sun.star.ui.dialogs.XFilePicker3 commit
  • com.sun.star.awt.XToolkitExperimental commit

Dispatch commands

  • Suppression des commandes dispatch :
    • Impress: .uno:TitleMasterPage. Obsolète depuis 2004 cf. [5] (Philippe Jung) commit

Compatibilité des plates-formes

Android

  • Ajout du support flat ODF entrée de blog (en anglais) (Miklos Vajna, Collabora).
Flat-odf-android.png

OS X

  • Bug répertorié : Sur OS X LibreOffice doit être lancé au moins une fois avant d'installer un paquet de langue tdf#89657
  • LibreOffice sur OS X requiert désormais l'installation d'un Java JDK Oracle pour utiliser Base (HSQLDB) ou toute extension rédigée en Java (par ex. NLPSolver).
Le contournement précédent d'avoir à la fois un JRE 6 Apple et un JRE 8 Oracle n'est plus suffisant. L'utilisation du JDK est maintenant codée en dur, voir tdf#74877, tdf#94716 et commit.


Linux

  • Cent OS 6 : requiert un noyau 2.6.32 ou plus récent, glibc 2.12 ou ultérieure