Neuerungen und Veränderungen in LibreOffice 5.4

From The Document Foundation Wiki
Jump to: navigation, search

Im Folgenden finden Sie eine Auflistung der Neuerungen und Veränderungen der Version 5.4 von LibreOffice. Dies ist eine Fortschreibung der vorangegangenen Neuerungen und Veränderungen der Version 5.3.

Writer

  • RTF-Dokumenteigenschaften: Der RTF-Filter unterstützt nun alle Arten von benutzerdefinierten Dokumenteigenschaften.
Miklos Vajna - Collabora
  • Neuer Befehl Bereich bearbeiten: Dem Kontextmenü wurde ein neuer Befehl Bereich bearbeiten... hinzugefügt, welcher erscheint, wenn der Cursor sich in einem Bereich befindet (tdf#102132).
Gülşah Köse
Befehl Bereich bearbeiten... im Kontextmenü.
  • Neuer Befehl Fuß-/Endnoten: Dem Kontextmenü wurde ein neuer Befehl Fuß-/Endnoten... hinzugefügt, welcher erscheint, wenn der Cursor sich in einer Fuß- oder Endnote befindet (tdf#103258).
Gülşah Köse
Neuer Befehl Fuß-/Endnoten... im Kontextmenü.
  • Neue Symbolleiste Formatierungen (Formatvorlagen): Eine neue Symbolleiste Formatierungen (Formatvorlagen) wurde hinzugefügt, welche die Verwendung von Formatvorlagen fokussiert und über Ansicht ▸ Symbolleisten ▸ Formatierungen (Formatvorlagen) eingeblendet werden kann (tdf#106781).
Yousuf Philips
Neue Symbolleiste Formatierungen (Formatvorlagen).
  • AutoKorrektur erweitert: In der AutoKorrektur wurde die Optionen zum automatischen Ersetzen um kursiv und durchstreichen ergänzt.
Tiago Santos'
Erweiterte AutoKorrektur-Option.
  • AutoText Import: AutoText wird nun bei .dotx- und .dotm- Dokumenten importiert.
Szymon Kłos - Collabora
  • Verbesserung beim Kopieren & Einfügen: Es wurden diverse Verbesserungen beim Export von Aufzählungszeichen und Nummerierung mittels Kopieren & Einfügen vorgenommen.
Jan Holešovský - Collabora
Vergleich der Ergebnisse beim Kopieren & Einfügen von Aufzählungszeichen und Nummerierung.
  • Benutzerdefinierte Wasserzeichen: Es können nun benutzerdefinierte Wasserzeichen über Format ▸ Wasserzeichen... eingefügt werden.
Szymon Kłos - Collabora
Neuer Dialog Wasserzeichen.
  • Zeichenvorlagen übers Kontextmenü: Dem Kontextmenü wurde ein Untermenü mit Formatvorlagen hinzugefügt, das grundlegende Zeichenvorlagen enthält (tdf#102915, tdf#85940).
Yousuf Philips
Neues Untermenü mit Zeichenvorlagen in Writer.

Calc

  • Negative Jahreszahlen: Es werden nun negative Jahreszahlen (BC) bei der Zelleingabe und -darstellung unterstützt:
Eike Rathke - Red Hat (Inc.)
  • Es werden Eingaben im ISO 8601-Format -JJJJ-MM-TT und dem lokalen Gebietsschema entsprechend, wie beispielsweise -J/M/T, M/T/-J oder T.M.-J, unterstützt.
  • Für BC-Daten werden die Jahreszahlen negativ dargestellt, es sei denn ein spezielles Datumsformat enthält einen entsprechenden Äracode, wie beispielsweise G oder GG.
  • Der letzte BC-Tag ist der 31.12.-0001 und der erste AC-Tag der 01.01.0001.
  • Vorherige Versionen konnten bereits mit solchen Daten rechnen, haben aber negative Jahreszahlen nicht dargestellt.
  • Verbesserter CSV-Export: Die CSV-Exporteinstellungen werden nun gespeichert (tdf#55236).
Bernhard Widl - CIB
  • Verbesserte Bedingte Formatierungen: Dem Dialog Bedingte Formatierung wurden Schaltflächen Nach oben und Nach unten hinzugefügt, um die Priorität der Bedingungen zu verändern (tdf#74074).
Manfred Blume - CIB
Neue Schaltflächen zum Verändern der Priorität.
  • Verbesserung bei Kommentaren: Neue Befehle für Zellkommentare wurden hinzugefügt:
Gülşah Köse, Eike Rathke
  • Dem Menü wurde der Befehl Ansicht ▸ Kommentare hinzugefügt, um die Sichtbarkeit aller Kommentare der ausgewählten Tabelle(n) umzuschalten (tdf#107258).
  • Dem Menü unter Tabelle ▸ Kommentare wurde der Befehl Alle Kommentare löschen hinzugefügt, um alle Kommentare der ausgewählten Tabelle(n) gleichzeitig zu löschen (tdf#107143).
  • Die Befehle Alle Kommentare einblenden und Alle Kommentare ausblenden wurden hinzugefügt, um alle Kommentare der ausgewählten Tabelle(n) ein- bzw. auszublenden (tdf#84837).
  • Neue Funktion: Die Funktion RUNDENSIG zum Runden einer Zahl auf eine bestimmte Anzahl von signifikanten Stellen wurde neu hinzugefügt (tdf#90799).
Winfried Donkers
  • Verbesserung bei Genauigkeit wie angezeigt: Die Option Genauigkeit wie angezeigt zur Berechnung arbeitet nun auch mit:
Laurent Balland-Poirier
  • Zellschutz umschalten: Ein neuer Befehl unter Bearbeiten ▸ Zellschutz zum Umschalten des Zellschutzes wurde hinzugefügt, um den Status der ausgewählten Zelle umzuschalten (tdf#95885).
Gülşah Köse
  • Neue Optionen für den Tabellenschutz: Vier neue Optionen zum Tabellenschutz wurden hinzugefügt, um optional das Einfügen und Löschen von Zeilen und Spalten zuzulassen (tdf#43535). Die Optionen Zeilen einfügen und Spalten einfügen erlauben das Einfügen von Zeilen und Spalten auch dann, wenn die Tabelle geschützt ist, wohingegen Zeilen löschen und Spalten löschen das Löschen von Zeilen und Spalten bei eingeschaltetem Schutz erlaubt.
Hinweis: Wenn das Einfügen von Zeilen und Spalten erlaubt ist, können Sie Zeilen und Spalten auch dann einfügen, wenn der Bereich zum Einfügen von Zeilen oder Spalten geschützte Zellen enthält. Diese werden dann hinter die eingefügten Zeilen oder Spalten verschoben. Das Löschen von Zeilen und Spalten ist hingegen nur erlaubt, wenn keine Zellen geschützt sind.
Kohei Yoshida - Collabora
Neue Optionen für den Tabellenschutz.
  • Zellvorlagen übers Menü : Die grundlegenden Zellvorlagen sind nun über Format ▸ Vorlagen erreichbar (tdf#91820).
Yousuf Philips
  • Zahlenformate umschalten: Die Schaltflächen für Prozentwert und Dezimalzahl schalten nun zwischen dem jeweiligen Format und Standard um (tdf#86119).
Gülşah Köse
  • Änderung der Bezugsart: Beim Erstellen von Formeln mittels Auswahl der Zelle oder des Zellbereichs in einer anderen Tabelle, werden nun absolute Zellbezüge anstatt relativer Zellbezüge verwendet (tdf#90799).
Eike Rathke - Red Hat (Inc.)

Impress & Draw

  • Dialog Vervielfältigen: Der Dialog Vervielfältigen, erreichbar über ⇧ Umschalt+F3, wurde verbessert.
Laurent Balland-Poirier
  • Der Drehwinkel erlaubt nun Nachkommastellen (tdf#77816).
  • Die letzten Einstellungen werden nun gespeichert (tdf#104423).
  • Neues Tastaturkürzel: Impress wurde das Tastaturkürzel Strg+M zum Einfügen einer neuen Folie neu zugewiesen (tdf#87674).
Yousuf Philips

Chart

  • Pivot-Diagramme: Es wurden Pivot-Diagramme neu hinzugefügt, die es erlauben, Daten einer Pivot-Tabelle so in Diagrammen zu veranschaulichen, dass nach einer Aktualisierung der Pivot-Tabelle auch die Diagramme aktualisiert werden, obwohl sich die Zellbereiche verschoben haben.
Tomaž Vajngerl - Collabora
Pivot-Diagramm.

Math

  • Neue Befehle im Kontextmenü: Es wurden dem Kontextmenü des Fensters Kommandos die Befehle Ausschneiden, Kopieren und Einfügen hinzugefügt (tdf#106479).
Maxim Monastirsky
Die neuen Befehle des Kontextmenüs.

BASIC

  • Verbesserte Funktion CDateFromIso: Die Laufzeitfunktion CDateFromIso erlaubt nun auch ISO 8601-Zeichenketten mit Separatoren, beispielsweise im Format JJJJ-MM-TT.
Eike Rathke - Red Hat (Inc.)
  • Diese Funktion wurde in Version 5.3.4 zurück portiert.
  • Verbesserte Datumsfunktionen: Die Laufzeitfunktionen CDateFromIso und CDateToIso behandeln nun den vollen Datenbereich des proleptischen Gregorianischen Kalenders, beispielsweise von -32768-01-01 (BC) bis 32767-12-31 (AC).
Eike Rathke - Red Hat (Inc.)
  • Wenn ein Datumswert automatisch in eine Zeichenkette umgewandelt wird, beispielsweise für einen der Befehle Print oder MsgBox, wird der Kalender des jeweiligen Gebietsschemas verwendet und beim Übergangsdatum 15.10.1582 wird ggf. zum Julianischen Kalender gewechselt. Dies kann ein anderes als das erwartete Datum zur Folge haben. Verwenden Sie die Funktion CDateToIso, um solch ein Datum in eine Zeichenkette zu konvertieren, welche den proleptischen Gregorianischen Kalender abbildet.
  • Spezifikation für CDateFromIso:
  • Die Jahresangabe muss entweder zwei Zeichen (es wird nur JJMMTT ohne Separatoren unterstützt) oder mindestens vier Zeichen enthalten. Bei vier Zeichen müssen die führenden Nullen für Zahlen, die betragsmäßig kleiner als 1000 sind, zwingend angegeben werden. Die Jahreszahl kann ein Minus für Jahreszahlen aus der Zeit BC besitzen und die Jahreszahl darf mehr als vier Zeichen haben, wenn sie betragsmäßig größer als 9999 ist. Die Zeichenfolge kann im Bereich von "-327680101" bis "327671231" bzw. "-32768-01-01" bis "32767-12-31" liegen.
  • Ein ungültiges Datum ergibt einen Fehler. Die Jahreszahl 0 ist ungültig, der letzte Tag BC ist -0001-12-31 und der erste Tag AC ist 0001-01-01. Daten vor 1582-10-15 werden im proleptischen Gregorianischen Kalender erwartet.

Programmkern

  • Farbpaletten:
  • Die Standard-Farbpalette wurde aktualisiert (tdf#87538).
Yousuf Philips, Thibaut Brandscheid, Heiko Tietze
  • Die Farbpalette Diagramme wurde neu erstellt, welche Farben für Diagramme enthält (tdf#106534).
Yousuf Philips

Hilfeseiten

  • Schriftgröße: Die Standardgröße des Hilfstextes wurde verringert.
Adolfo Jayme Barrientos
  • Hilfeseiten:
  • Es wurden neue Hilfeseiten für undokumentierte BASIC-Konstanten, VBA-Funktionen und -Anweisungen ergänzt (tdf#84675).
Olivier Hallot
  • Die Hilfeseiten für den Vorlagenmanager wurden aktualisiert.
Gabor Kelemen

Dokument-Signaturen

  • OpenPGP-Schlüssel unter Linux: In Linux können jetzt OpenPGP-Schlüssel zum Verschlüsseln von ODF-Dokumenten verwendet werden (tdf#89037).
Katarína Behrens, Samuel Mehrbrodt, Thorsten Behrens - CIB
  • Verschlüsselungsverfahren: Es wurde die Unterstützung für ECDSA-Schlüssel unter Linux und macOS hinzugefügt.
Miklos Vajna - Collabora
  • Signaturstatus: Der Status einer Signatur wird nun mit farbigen Informationsleisten dargestellt (tdf#105566).
Katarína Behrens, Samuel Mehrbrodt - CIB
Ein Dokument mit einer ungültigen Signatur.

Filter

  • PDF-Filter:
  • LibreOffice verwendet nun pdfium zum Rendern eingefügter PDF-Bilder.
Miklos Vajna - Collabora
  • Unterstützung für verknüpfte und eingebettete Videos beim PDF-Export aus Writer und Impress.
Miklos Vajna - Collabora
  • Korrektur bei XLSX: Der Export der Funktionen UNTERGRENZE/OBERGRENZE in .xlsx wurde korrigiert (tdf#100011).
Eike Rathke, Bartosz Kosiorek
  • Import von ADO rowset XML: Ein Importfilter für ADO rowset XML wurde neu hinzugefügt (tdf#106525).
Mike Kaganski - Collabora
  • Import von IQY: Der Import von Web Querry Dateien (.iqy) wurde neu hinzugefügt (tdf#106359).
Mike Kaganski - Collabora
  • Korrektur bei DOCX: Der Umgang mit Tabellen für Microsoft Word 2013+ wurde korrigiert (Tabellenränder richten sich nun an Rändern aus und der Text wird eingerückt) (tdf#106742).
Vitaliy
  • Verbesserung des Imports von EMF+ Vektorbildern: Der Import für EMF+ Bilder, welche mit ChemDraw erstellt wurden, wird nun unterstützt. EMF+ Vektorbilder werden von .doc-, .docx-, .xls-, xlsx-, ppt- und pptx-Dateiformaten verwendet (tdf#31814).
Bartosz Kosiorek
Testbild in LO 5.3, Beschriftungen und Kreiselemente werden nicht korrekt dargestellt.
Testbild in LO 5.4, Beschriftungen und Kreiselemente werden korrekt platziert, die Unterstützung für Drehungen muss noch implementiert werden.
Referenzbild aus XnView (Wine 1.8.5).
Es wurde die Unterstützung für folgende Formen hinzugefügt:
Mit ChemDraw erstelltes Testbild in LO 5.3, das Bild ist unsichtbar.
Mit ChemDraw erstelltes Testbild in LO 5.4, das Bild wird dargestellt, einige Linien sind noch verschoben.
Referenztestbild in Office 365 (Ubuntu 16.10).

Benutzeroberfläche

  • Einstellung zur Zeilennummerierung: Die Einstellung zur Zeilennummerierung wird nun gespeichert und bleibt jetzt auch nach einem Neustart erhalten (tdf#91913).
Lera Goncharuk
  • Symbolband in Registern: Eine Symbolleiste für den Schnellzugriff wurde für das Symbollband in Registern eingeführt. Der Anwender kann die Symbole unter Extras ▸ Anpassen... ▸ Symbolleisten ▸ Symbolband Schnellzugriff anpassen (tdf#105486).
Szymon Kłos
Symbolleiste Symbolband Schnellzugriff fürs Symbolband in Registern.
  • Umordnung von Menüs: Die Menüeinträge wurden gemäß dem allgemeinen Designkonzept neu angeordnet. Der Eintrag Schließen wurde nach oben in den ersten Abschnitt des Menüs Datei verschoben. Der Eintrag GoToLine wurde vom Menü Ansicht in das Menü Bearbeiten unterhalb des Eintrags Suchen und Ersetzen verschoben.
Lera Goncharuk
  • Themes bei Symbolbändern: Die Symbolbänder unterstützen nun Themes (tdf#105486).
Szymon Kłos
Symbolband mit blauem Theme.

Online

  • Responsives Design: Das Design des Dokument-iframes ist nun responsiv.
Pranav Kant - Collabora
Responsives Design.
  • Nicht druckbare Zeichen: Die Darstellung nicht druckbarer Zeichen in Writer ist nun optional.
  • Änderungsverfolgung: Änderungsverfolgung und -hervorhebung wird in Writer nun unterstützt und dargestellt.
Pranav Kant, Henry Castro - Collabora
  • Anzahl möglicher Zeilen: Die Zahl der verfügbaren Zeilen in Calc wurde auf 10.000 erhöht.
Marco Cecchetti - Collabora
  • Schreibgeschützter Modus: Ein schreibgeschützter Modus wurde für Dokument-iframe ergänzt.
Kant Pranav - Collabora
Schreibgeschützter Modus.
  • Rendern von Glyphen: Es werden nun alle Glyphen im Dialog Zeichen auf dem Server gerendert.
Henry Castro - Collabora
  • Widersprüchliche Änderungen: Es erfolgt nun eine Benachrichtigung bei Rückgängig/Wiederherstellen, wenn die Änderungen widersprüchlich sind.
Henry Castro - Collabora
  • Server-Erreichbarkeit: Der Benutzer wird nun informiert, wenn der Server nicht erreichbar ist oder neu verbunden wird.
Ashod Nakashian - Collabora
  • CTL-Unterstützung: Anfängliche Unterstützung von Eingabemethoden für CTL-Sprachen.
Pranav Kant - Collabora
  • Leistungssteigerung: Die Leistung wurde verbessert, indem die PNG-Kompression und das Senden unveränderter Kacheln an den Client vermieden werden.
Michael Meeks - Collabora; Tor Lillqvist - Collabora
  • Neuer WSD-Kern: Der WSD-Kern wurde grundlegend neu geschrieben, um den Code stark zu vereinfachen sowie das Theading - mittels Verwendung meistens nicht blockierendem E/A -, die Wartung und die Leistung zu verbessern.
Ashod Nakashian, Michael Meeks, Jan Holesovsky - Collabora
  • Kommentare: Die Darstellung von Kommentaren in Writer wurde sprachspezifischen Besonderheiten angepasst und erlaubt nun Animationen.
Henry Castro - Collabora

Neue Sprachen/Lokalisierungen

  • Neue Sprachen für Textauszeichnung:
Eike Rathke - Red Hat (Inc.)
Eike Rathke - Red Hat (Inc.)
  • Kituba (Demokratische Republik Kongo) [ktu-CD].
Eike Rathke - Red Hat (Inc.)
  • Neue Sprachen für die Benutzeroberfläche:
  • Obersorbisch: Ein Großteil der Oberfläche ist nun ins Obersorbische übersetzt. Zudem ist die Oberfläche für LibreOffice Online komplett in Obersorbisch verfügbar.
Michael Wolf
  • Niedersorbisch: Die Übersetzung der Oberfläche ins Niedersorbische wurde begonnen. Die Oberfläche für LibreOffice Online ist komplett in Niedersorbisch verfügbar.
Michael Wolf
Im-jabber.svg

Unser Ziel ist es, so viele Sprachen wie möglich zu unterstützen. Wir möchten allen dafür danken, dass sie freiwillig ihre Zeit und Kraft in die Übersetzung von LibreOffice investieren und damit helfen, ihre Muttersprache zu erhalten.

  • Rechtschreibwörterbücher und Sprachunterstützung:
  • Die Rechtschreibprüfungen für Englisch, Kroatisch, Polnisch und Französisch wurden aktualisiert.
  • Die Thesauri für Polnisch und Französisch wurden aktualisiert.
  • Die Sprachliste stellt nun auch Sprachen mit BCP47-Tags aus Sprachwörterbüchern dar, wenn eine Sprache in der vordefinierten Liste nicht verfügbar ist.
Eike Rathke - Red Hat (Inc.)
  • Diese Einträge werden in geschweiften Klammern dargestellt (beispielsweise {de-IT}) und am Anfang der Liste nach dem Eintrag [Keine] aufgelistet.
  • Der veraltete Sprach-Tag en-GB-oed für das Oxford English Dictionary wurde in en-GB-oxendict korrigiert (tdf#100462).
Eike Rathke - Red Hat (Inc.)
  • en-GB-oxendict wurde bereits in früheren Versionen unterstützt, aber nicht in der vordefinierten Sprachliste angezeigt; beide Sprach-Tags listen nun "Englisch, OED Schreibweise (UK)" auf.
  • In Dokumenten, in denen bisher en-GB-oed verwendet wurde, wird nun en-GB-oxendict verwendet.

 

Im-jabber.svg

Wenn Sie eine seltene Sprache sprechen und uns bei unserem Ziel, freie Software für möglichst jeden Menschen auf dem Planeten zur Verfügung zu stellen, helfen möchten, stoßen Sie zu uns: zum Übersetzungsprojekt.

Skriptsprachen

  • Access2Base aktualisiert: Die Access2Base-Bibliothek für die Benutzung von Base wurde auf die Version 1.7.0 aktualisiert.
Jean-Pierre Ledure
  • Die Ereignisse form, subform, dialog und control können nun dynamisch abgefragt und aktualisiert werden, mit den neuen Eigenschaften On (form-events), On (dialog-events) und On (control-events).
  • Die neue Objektklasse module zusammen mit ihren Eigenschaften und Methoden machen es nun einfach, die Basic-Bibliotheken zu durchsuchen, die in der aktuellen Base-Datei oder der Anwendung verfügbar sind.
Die vollständige Dokumentation ist der Webseite Documentation (englisch) verfügbar.

Entfernte / herabgestufte Funktionen

  • Telepathy Tubes: Die Schnittstelle zu Telepathy Tubes wurde entfernt.
  • TDE': Die Integration für Trinity Desktop Environment (TDE) ist veraltet und wird in der nächsten Version entfernt werden.
  • Symbolstil Oxygen: Der Symbolstil Oxygen ist nicht mehr standardmäßig eingebunden.
  • Schnellstarter für Linux: Der Schnellstarter für Linux ist veraltet und wird in der nächsten Version entfernt werden.
  • Website-Assistent: Der Website-Assistent unter Datei ▸ Assistenten ▸ Website..., welcher einen Satz von Dokumenten mit Inhaltsverzeichnis und veralteten CSS-Formatierungen exportiert, wurde aus Writer entfernt (tdf#99967).
Samuel Mehrbrodt - CIB
  • Hinweis: Der HTML-Export ist hiervon nicht betroffen.
  • PlaceWare: Der Export-Filter für PlaceWare wurde aus Impress entfernt.

Plattformkompatibilität

  • macOS 10.8: Die Unterstützung für macOS Version 10.8 ist veraltet. Die nächste Version wird mindestens macOS 10.9 erfordern.
  • Uwinapi: Die Unterstützung von Uwinapi für Windows wird nicht mehr fortgesetzt.
  • Windows XP und Windows Vista: Windows XP SP3 und Windows Vista SP2 sind beide veraltet. Die Version 5.4 wird die letzte sein, die diese beiden Betriebssystemversionen noch unterstützt.