Překlad uživatelských příruček do češtiny pomocí OmegaT

From The Document Foundation Wiki
Jump to: navigation, search


Překládáme do češtiny uživatelské příručky pro LibreOffice (LibreOffice Online, Math Guide, Calc Guide a Getting Started with LibreOffice), a to s využitím překladatelského softwaru OmegaT. Tato stránka popisuje, jak celý systém překládání zprovoznit a používat.

Jedná se o projekt zajišťovaný dobrovolníky, jehož cílem je poskytnout kvalitní, obsáhlou, pravidelně aktualizovanou a pod otevřenou licencí zveřejněnou příručku zabývající se všemi programy z balíku LibreOffice – taková literatura v češtině zatím chybí.

Gnome-system-help.svg

Zapojte se!
Budeme rádi za jakoukoliv pomoc, a to nejen při překládání – přeložený text je třeba zkontrolovat a také vytvořit obrázky (snímky obrazovky s českým rozhraním a kresby v Draw).

Jak se připojit

Pokud se chcete připojit, přihlaste se do e-mailové konference věnované lokalizaci LibreOffice do češtiny a pošlete mail na její adresu lokalizace (na) cz.libreoffice.org. Dokumentace je zveřejněná pod otevřenou licencí GNU General Public License, verze 3 nebo novější, a Creative Commons Attribution License, verze 4 nebo novější. Ve svém mailu vyjádřete souhlas s publikováním svého překladu pod těmito licencemi.

Použitý software

Používáme programy těchto verzí:

  • LibreOffice >= 6.2.8
  • OmegaT >= 4.3.1

Instalace OmegaT

Stručný návod, jak si nainstalovat CAT program OmegaT

Na stránce http://omegat.org/ postupně zvolíme:

  1. Čeština
  2. Stáhnout OmegaT
  3. Průvodce stažením
  4. Tradiční
  5. Windows nebo Linux nebo macOS
  6. S JRE nebo Bez JRE
  7. Latest
  8. Uložíme soubor s instalací
  • Dále pro Windows: následuje instalace OmegaT: vícekrát kliknout na Ano, Další... Dokončit
  • Dále pro Linux: rozbalit stáhnutý zip soubor, spustit program OmegaT pomocí ./OmegaT; případně nainstalovat OmegaT do /opt/ spuštěním skriptu ./linux-install.sh (poté lze program spouštět příkazem omegat)
  • Nepoužívejte verzi Web Start

Týmový projekt v OmegaT

Týmový projekt umožňuje spolupráci více překladatelů prostřednictvím sdílených souborů překladové paměti a slovníku. Při otevírání projektu se tyto soubory aktualizují z úložiště, během překladu při zavírání se z nich odesílají změny do úložiště.

Projekt je uložený na serveru https://github.com/LibreOffice/OmegaT/tree/master/cs/LOGuides v úložišti typu subversion (SVN).

Člen týmového projektu

  • Odesílá překlady do úložiště na server (automaticky při překladu a zavírání projektu)
  • Je třeba, aby ho napřed přidal stávající člen projektu mezi spolupracovníky na GitHubu.
  • Při stahování je třeba se přihlásit.
  • Adresa projektu s příručkami v češtině: https://github.com/LibreOffice/OmegaT/trunk/cs/LOGuides

Jak získat přístup k úložišti

  • Je potřeba mít vytvořený účet na github.com, takže se zde zaregistrujeme.
  • Poté v e-mailové konferenci lokalizace (na) cz.libreoffice.org požádáme o přidání do týmu.
  • Administrátor přidá uživatele jako člena týmu a GitHub vygeneruje e-mail s "invitation link". Klikneme na link a přijmeme pozvání do týmu.
  • Následně si stáhneme týmový projekt a můžeme začít s překladem.

Stáhnutí projektu

Postup při úvodním stahování týmového projektu z úložiště:

  • Spustíme OmegaT
  • Zvolíme Projekt > Stáhnout týmový projekt. Otevře se okno, ve kterém nastavíme:
  • Klikneme na tlačítko OK, po čase se nás zeptá na přihlašovací jméno a heslo.

Vlevo dole se zobrazí zpráva Stahování projektu.... Projekt se stáhne ze serveru a otevře se okno. V okně můžeme vybrat soubor, na výběr jsou adresáře pojmenované podle názvu příručky:

  • LOXY -- Getting Started With LibreOffice
  • LOOLXY -- LibreOffice Online
  • CGXY -- Calc Guide

XY udává číslo verze LibreOffice, pro kterou byla příručka vytvořena.

Upozornění: Projekt se stáhne jen jednou, pro další práci se otevírá lokální kopie projektu s pomocí Projekt > Otevřít...

Překládání v OmegaT

Předpokládáme, že týmový projekt máme stáhnutý do složky LOGuides.

Typická překladatelská relace

  1. Spustíme program OmegaT.
  2. Otevřeme projekt volbou Projekt ▸ Otevřít. Otevře se dialogové okno správce souborů, ve kterém vybereme složku LOGuides. Můžeme také použít volbu Projekt ▸ Otevřít nedávný projekt.
  3. Následně se otevře okno Soubory projektu, ve kterém soubor pro překlad dvojitým kliknutím zobrazíme v hlavním okně.
  4. Postupně překládáme jednotlivé části - věty, dbáme při tom na zachování značek.
  5. Po skončení překládání zkontrolujeme správnost značek pomocí Nástroje ▸ Zkontrolovat problémy.
  6. Program OmegaT zavřeme pomocí Projekt ▸ Konec.

Na konci práce není třeba nic ukládat (můžeme tak ovšem provést pomocí Projekt ▸ Uložit), neboť OmegaT překládané části průběžně ukládá do překladové paměti. Její obsah se ve stanovených intervalech a při ukončení programu automaticky přenese do úložiště na serveru. Známkou toho je text Týmová synchronizace, který se objeví vlevo dole po zvolení příkazu Projekt ▸ Konec. Commity do gitu jsou vidět zde https://github.com/LibreOffice/OmegaT/commits/master

Poznámka: To, jak často se bude projekt ukládat do úložiště na serveru, můžeme určit v Možnosti ▸ Předvolby ▸ Uložení a výstup. Při každém uložení přibude do úložiště commit s označením Translated by JMENO, kde JMENO lze v OmegaT nastavit v Možnosti ▸ Předvolby ▸ Tým.

Zobrazení přeloženého dokumentu

Při výše uvedeném postupu se s překládaným dokumentem nepracuje přímo. Při otevírání projektu ho OmegaT rozloží na segmenty – věty, se kterými se pracuje. Pokud chceme zobrazit výsledek, zvolíme Projekt ▸ Vytvořit přeložené dokumenty nebo, pokud stačí pouze aktuálně překládaný dokument, použijeme Projekt ▸ Vytvořit aktuálně přeložené dokumenty. Ty najdeme jako soubory ODT v složce LOGuides/target na našem lokálním disku ve složce projektu. Zdrojové soubory, které překládáme, jsou ve složce LOGuides/source, což znamená, že se nikdy nepřepíší. Vytvořené dokumenty se nepřenášejí na server.

Kontrola pravopisu přeloženého dokumentu

Příkazem Projekt ▸ Zapsat cílové soubory se do složky LOGuides/target vygenerují výsledné soubory ve formátu ODT. V nich je jako jazyk textu nastavena angličtina. Aby v LibreOffice fungovala kontrola pravopisu v češtině, změníme jazyk v nabídce Nástroje ▸ Jazyk ▸ Pro celý text ▸ čeština.

Upozornění: Pokud potřebujeme provést úpravy v překladu, neděláme to v přeloženém dokumentu, ale v příslušné části v OmegaT. Jinak se změny nezachovají.

Překlad segmentů textu pomocí OmegaT

OmegaT načítaný soubor rozloží na věty – segmenty, které se postupně překládají. Jakmile program při načítání najde v překladové paměti část přeloženou, zobrazí překlad, jinak zobrazí originál.

Víc se o postupu překládání dočtete v návodě, který je dostupný po spuštění OmegaT.

Překlad prvků GUI pomocí slovníku

Většina řetězců, které se nacházejí v GUI LibreOffice, je uložená v slovníku OmegaT. Pokud text vypadá jako řetězec z GUI (File > Save a podobně), je podtržený modrou čárou. Potom ho kliknutím pravým tlačítkem můžeme z místní nabídky přenést do psaného textu (viz obrázek). Je dobré se sem vždy podívat, abychom zjistili skutečný překlad v GUI, případně se můžeme podívat rovnou do LibreOffice.

Pokud se podtržení modrou barvou nezobrazí, je třeba je aktivovat v Možnosti ▸ Předvolby ▸ Glosář. Podtržení se zobrazí až po přejití na další větu.

Poznámka: Soubor se slovníkem se nachází v adresáři glossary a jeho název odpovídá verzi LibreOffice, které se týká: soubor ui_lo.txt obsahuje řetězce z desktopové verze, soubor ui_lool.txt řetězce z LibreOffice Online.

Aktuální slovník se vytvoří podle tohoto návodu.

Prvky uživatelského rozhraní

OmegaT sk.png

Zabarvení segmentů

Pokud nemáte pracovní část pro překlady zabarvenu jako na obrázku výše, lze to provést s pomocí podnabídek v hlavní nabídce Zobrazit.

Vybrané podnabídky pro zabarvení jsou:

  • Označit přeložené segmenty - zabarví text, který je již přeložen, žlutým podbarvením řádku.
  • Označit nepřeložené segmenty - text, který zbývá pro přeložení, je podbarven modrou barvou.
  • Ukázat zdrojové segmenty - přidá nad všechny, jak přeložené, tak nepřeložené řádky, zeleně podbarvený zdrojový anglický text.

Užitečné klávesové zkratky

Pro práci s OmegaT lze pro urychlení práce používat i klávesové zkratky.

  • ENTER - přeskočí na další položku směrem dolů (jak přeloženou, tak i nepřeloženou).
  • CTRL-U - přejde na další nepřeloženou položku směrem dolů.
  • CTRL-ENTER - přeskočí na minulou položku směrem nahoru (jak přeloženou, tak i nepřeloženou).
  • CTRL-R - přepíše originální [ENG] text překladem z překladové paměti, který je umístěn na prvním místě.

Slovníky pro kontrolu pravopisu

Kontrola pravopisu využívá slovníky umístěné v adresáři, který je zadaný v nastavení OmegaT. Při kontrole se přitom používají slovníky, jejichž název (kód jazyka) se shoduje s kódem jazyka nastaveným v týmovém projektu. Překladatelské projekty příruček mají v projektu nastavený kód jazyka cs, zatímco český slovník, který lze stáhnout v OmegaT (pomocí Předvolby ▸ Kontrola pravopisu ▸ Instalovat nový slovník) má název cs_CZ. Ten se proto v projektu s příručkami neuplatní a kontrola v tom případě nefunguje.

Řešením je:

  • buď přejmenovat stávající soubory se slovníkem na cs.aff a cs.dic (nacházejí se v adresáři uvedeném v poli Adresář se soubory slovníku, např. v Linuxu ve výchozím nastavení jde o ~/.omegat/spelling),
  • nebo nastavit adresář slovníku na adresář, který je součástí projektu, podle následujícího postupu:

Nastavení slovníku z týmového projektu

Týmový projekt obsahuje adresář dictionary s českým slovníkem pro kontrolu pravopisu, který je v rámci projektu sdílen. Poznámka: Adresář dictionary má správně sloužit pro ukládání slovníků s překlady (viz dokumentace OmegaT), jeho použití pro kontrolu pravopisu je nestandardní.

Tento slovník v OmegaT nastavíme následovně:

  1. Zvolíme Možnosti ▸ Předvolby.
  2. Vybereme položku Kontrola pravopisu.
  3. Do pole Adresář se soubory slovníku vybereme pomocí tlačítka Procházet adresář dictionary týmového projektu.
  4. Předvolby uložíme tlačítkem OK.

Značky v překládaném textu

Značkovaný text

Formátování textu a vkládání různých prvků (odkazy, položky indexu a pod.) se v ODT souborech provádí pomocí značek (angl. tags). Značky jsou uzavřené v špičatých závorkách a můžou být párové (<tucne>text</tucne>) a nebo nepárové (<novyradek />). Lomítko označuje koncovou značku, v případě párové značky je za <, v případě nepárové je před >.

Tyto značky je třeba v překládaném textu zachovat. Pokud to neprovedeme, v lepším případě se ztratí formátování, v horším případě bude vytvořený soubor nečitelný.

Překlad segmentů se značkami

OmegaT zobrazuje značky zjednodušeně, např.

Click <f0>OK</f0> to save your settings and close the dialog

Poznámka: OmegaT rozděluje překlady na věty, a tak se může stát, že úvodní značka je v jedné části a koncová v následující.

Vkládání značek

Značky můžeme přímo zapisovat. Jednodušeji je ale vložíme tak, že kurzor umístíme na požadované místo a stiskneme CTRL-T (nebo Upravit > Vložit další chybějící tag). Opakované stisknutí CTRL-T vkládá následující značku.

Poznámka: Může se stát, že značka je umístěná uvnitř slova. V tom případě je vhodné slovo v překladě nerozdělovat, ale celé ho uvést uvnitř anebo mimo pár značek.

Poznámka: U překladů odkazů na obrázek, např. (<t4>Figure 16</t4>), je vhodné ponechat mezi značkami pouze číslo obrázku, tj. (obrázek <t4>16</t4>). V opačném případě bude ve výstupním souboru ODT chybně pouze číslo bez textu „obrázek“.

Kontrola značek

Před ukončením práce je potřebné zkontrolovat správnost značek pomocí Nástroje ▸ Zkontrolovat problémy. Zobrazí se okno se seznamem chybných segmentů. Vlevo je odkaz na číslo a vpravo je typ chyby. Pokud klikneme na Opravit, OmegaT se pokusí chybu opravit. Obvykle jen vloží chybějící značky na konec segmentu; na správnou pozici je potřeba je přesunout ručně. Proto se této možnosti raději vyhněme.

Práci ukončíme až po odstranění všech chybných značek – jinak by se tyto chyby přenesly do úložiště na server.

Styl překládání

Používáme kontrolu pravopisu. Pokud se překlepy nepodtrhávají červeně, je nutné upravit nastavení Možnosti ▸ Předvolby ▸ Kontrola pravopisu (podrobně popsáno výše).

V příručkách uplatňujeme jednotný styl, jehož ukázku si můžeme prohlédnout v některém z přeložených souborů příručky Getting Started.

Základní pravidla:

  • Důsledně používáme terminologii použitou při překládání samotného uživatelského rozhraní programu LibreOffice, případně v překladu jeho nápovědy. Překlad uživatelského rozhraní je v projektu k dispozici jako glosář, překlad nápovědy jako překladová paměť – zobrazují se v pravé části hlavního okna OmegaT. Slovník termínů používaných pro lokalizaci LibreOffice je k dispozici také jako stránka na wiki.
  • Místo 2. osoby množného čísla rozkazovacího způsobu (anglický originál) píšeme postupy v 1. osobě množného čísla oznamovacího způsobu, např. „Dialogové okno zobrazíme volbou Soubor – Otevřít“, nikoliv „Dialogové okno zobrazte volbou Soubor – Otevřít“.

Sjednocené výrazy překladu:

Anglický výraz Varianty překladu Vybraný překlad Popis
associated asociovat / přidružit / příslušný / spojený s spojený s
components programy / části / součásti programy např. Calc, Write atd.
Configuration Menu button tlačítko nabídky Nastavení tlačítko nabídky Nastavení tlačítko v postranní liště
content panel obsah panelu / panel ???
context menu kontextová nabídka / místní nabídka místní nabídka po stisku pr. tl. myši
decks části / součásti / záložky / karty karty
drop-down list rozevírací seznam / rozbalovací seznam / roletový seznam rozbalovací seznam
Leading zeroes uvozující nuly / úvodní nuly / počáteční nuly / vedoucí nuly úvodní nuly nastavení buňky v Calc
menu bar hlavní nabídky / lišta nabídky hlavní nabídky hlavní menu ve vrchní části okna
More Options button tlačítko Další možnosti tlačítko Další možnosti postranní lišta
Open panel(ikona +) otevřít panel otevřít panel v postranní liště atd.
panel title záhlaví panelu záhlaví panelu v postranní liště atd.
sheet tabs části / součásti / záložky / karty karty
spreadsheet sešity / tabulky sešity v Calc
Tabs (panel) panel karet / panel záložek panel karet v postranní liště atd.
title bar záhlaví okna / záhlaví lišty záhlaví okna / záhlaví lišty v okně / v postranní liště
click kliknout, klepnout klepnout

Časté chyby a opomenutí:

  • klávesové zkratky se překládají s mezerou, např. "Ctrl+A" přeložíme jako "Ctrl + A"
  • odkaz na obrázek uprostřed věty malým písmem. Příklad "(Picture ..." přeložíme jako "(obrázek ... "
  • používáme české uvozovky: „v uvozovkách“
  • název dalších příruček není nutné překládat (v češtině zatím neexistují): Více informací se nachází v kapitole 5 - Kombinace více objektů v příručce Draw Guide.

Snímky obrazovky a jiné obrázky

Z postupu práce s programem OmegaT vyplývá, že původní obrázky je třeba nahradit přeloženými už ve zdrojových dokumentech, které se nacházejí ve složce source. Pokud změna obrázku změní stránkování, segment se změněným odkazem je třeba ručně opravit. Je tomu tak proto, že překládané soubory se při jejich vytváření vždy přepisují. Je na to dost času, stačí to provést až těsně před vydáním přeložené kapitoly.

Nastavení LibreOffice

V zásadě je třeba:

  • Nainstalovat si LibreOffice v příslušné verzi, které se příručka týká, ze stránky ke stažení, resp. mít přístup k příslušné verzi LibreOffice Online.
  • U desktopové verze v Nástroje ▸ Možnosti ▸ LibreOffice ▸ Zobrazení nastavit Velikost a styl ikon na Colibre a nastavit Ikony v nabídkách na Zobrazit.
    • Pokud však chceme vyrobit snímky jednotlivých ikon, nastavíme jejich zobrazení na velké (jen pro tento případ, jinak malé).

Tvorba snímků obrazovky a grafiky

Grafiku v jednotlivých souborech nenahrazujeme přímo, ale pro každou kapitolu vytvoříme soubor s obrázky v programu Draw a až z něho obrázky přeneseme do textových souborů (provede administrátor). Tím se zabezpečí lepší přehled a sníží se riziko omylů.

Postup

  • Před začátkem práce je třeba si na stránce se stavem překladu ověřit, co už je hotové anebo na čem se už pracuje.
  • Pro každou kapitolu vytvoříme samostatný soubor s grafikou (pro češtinu prozatím neexistují).
    • například pro kapitolu GS4003-StylesAndTemplates.odt vytvoříme soubor GS4003.odg
  • Do grafického souboru z textového souboru (převedeného ze složky source) zkopírujeme všechnu grafiku – jsou to rastrové obrázky, vektorové se nepoužívají. Nejlépe tak, že větší obrázky umístíme na snímku podle čísla strany (necháme prázdné stránky, pokud je třeba).
  • Vytvoříme odpovídající snímky obrazovky a vložíme je do grafického souboru pod originál (a nebo vedle, pokud jde o malé obrázky, např. ikony).
    • Snažíme se dodržet vzhled a velikost originálu.
    • Pokud je třeba, obrázek ořežeme v externím editoru obrázků.
    • Dáváme pozor na to, abychom nenasnímali (v pozadí) nějaké osobní záležitosti.
  • Doplníme kresby, pokud je třeba.
    • Snažíme se dodržet vzhled a velikost originálu.
  • Soubor pošleme administrátorovi, který ho přidá k ostatním grafickým souborům a grafiku zkopíruje do zdrojových textových dokumentů.

Důležité odkazy