Release Notes 3.6

From The Document Foundation Wiki
Jump to: navigation, search

Nouveautés de LibreOffice 3.6

A propos de cette page

Il s'agit d'un brouillon des travaux en cours, qui servira à construire les notes de version lors de la sortie. Veuillez ne pas lister ici de fonctionnalités déjà incluses dans la version 3.5 ! Merci de ne pas ajouter ici des demandes d'amélioration ou souhaits que vous désireriez voir développés, mais uniquement des fonctionnalités réellement implémentées.

A quoi doit ressembler une bonne fonctionnalité ici :

  • Elle possède une description, ainsi qu'une manière, pour le lecteur novice, de trouver et de jouer avec cette nouvelle fonctionnalité. Visez une personne à moitié endormie, qui ne connait quasiment rien du produit. Ainsi, s'il s'agit d'un nouvel élément de l'interface utilisateur, soyez très explicite sur sa localisation (par exemple, Menu ▸ Format ▸ Caractères ▸ Position[onglet] ▸ "90 degrés" conduit aux éléments modifiés). Bien entendu, vous jugez votre fonctionnalité importante, et pensez que tout le monde devrait être attentif au "dialogue des propriétés des Formes Automatiques extensibles" - mais souvent les types qui prennent les aperçus d'écran et qui écrivent les notes ne le sont pas.
  • Elle crédite les auteurs principaux - ajoutez-les simplement entre parenthèses à la suite de la fonction, si possible.
  • Si la fonctionnalité peut être présentée grâce à un fichier exemple / test - particulièrement pour les nouvelles fonctions d'importation, il serait fantastique d'avoir un lien vers ce fichier de test, utilisable pour mettre en valeur au maximum la fonction. C'est une aide appréciable pour faire de bons aperçus d'écran, et permet aux testeurs de bien faire leurs tests.

Merci par avance pour votre participation au remplissage de cette page !

Writer

Nouvelle option d'espacement dans Writer.
  • L'outil Appliquer le format différencie désormais les attributs de formatage des caractères appliqués au paragraphe de ceux appliqués à une portion de texte à l'intérieur du paragraphe. Ces attributs sont appliqués au paragraphe entier par défaut ; si la touche Ctrl est maintenue lors de la manipulation ces attributs sont appliqués uniquement à la portion de texte sélectionnée (Maxime de Roucy).
  • L'import VML (utilisé dans les anciens fichiers DOCX) gère désormais les lignes, les rotations et les retournements (Miklos Vajna).
  • L'import DOCX gère désormais les champs GetExpression et SetExpression (Miklos Vajna).
  • Gestion des Smart Art lors de l'import (Miklos Vajna).
Smartart-sw.png
Essayez ce document exemple au format DOCX.
Media:smartart.docx
  • Le filtre RTF/DOCX import/export gère désormais le paramètre de zoom (Miklos Vajna).
  • Ctrl+[ diminue et Ctrl+] augmente la taille de police du texte sélectionné cf. tdf#36187 (Cameron Paul).
  • Comptage des mots (tout le document et sélection courante) dans la barre d'état cf. tdf#34772 (Robert Roth) et correction de deux erreurs de comptage cf. tdf#46757, tdf#50141 (Muhammad Haggag).
Sw-word-count-highlight.png
  • Affichage des délimitations du texte en fonction du choix d'affichage des caractères non imprimables tdf#46073 (Cédric Bosdonnat).
  • L'AutoFormat des tableaux mémorise désormais les propriétés suivantes de niveau "tableau" : tdf#31005 (Muhammad Haggag)
  • Saut
  • Conserver avec le paragraphe suivant
  • Répéter le titre
  • Autoriser le fractionnement des tableaux sur plusieurs pages et colonnes
  • Autoriser le fractionnement des lignes sur plusieurs pages et colonnes
  • Fusionner les styles de ligne adjacents
  • Style d'ombre


Assistants Étiquettes / Cartes de visite

  • Ajout des dimensions du "formulaire" (largeur et hauteur de page) au formulaire de définition des étiquettes (onglet Format). Les étiquettes qui ne sont pas centrées sur le formulaire sont désormais créées correctement (Winfried Donkers).
  • Tous les formats prédéfinis 1700+ ont été modifiés pour inclure la taille du formulaire ; les formats obsolètes ont été supprimés (Winfried Donkers).
  • Recalcul de la position de l'étiquette sur le formulaire. Les formats d'étiquettes avec espace entre les étiquettes plus grand que la marge de droite produisent désormais des documents corrects. Les formats utilisateurs personnalisés incluent automatiquement la taille du formulaire (Winfried Donkers).
  • La taille du formulaire peut être saisie/modifiée dans le dialogue de l'assistant (Winfried Donkers).
Ajout de la gestion du format de page.

Calc

  • Ctrl+D remplit vers le bas d'une manière plus habituelle, remplissant avec le contenu de la cellule du dessus si aucune cellule n'est sélectionnée, et remplissant vers le bas les plages de cellules avec des sélections plus grandes (Kohei Yoshida).
  • Nouvelle option permettant de personnaliser le préfixe par défaut pour les nouvelles feuilles (Albert Thuswaldner).
Nouvelle page d'options par défaut pour Calc.
  • Amélioration des performances des tables de pilote. Actualiser une table de pilote devrait être 35-50% plus rapide qu'en version 3.5. En outre, l'empreinte mémoire des tables de pilote est réduite de manière significative (Kohei Yoshida).
  • Possibilité de définir plusieurs fonctions d'agrégation pour un même champ de données en déplaçant autant de fois le même champ dans la zone Champs de données et en lui attribuant des fonctions différentes (auparavant insertion unique du champ et sélection multiple de fonctions par la touche Ctrl.
  • Amélioration des performances à l'ouverture de documents ods comprenant des cellules fusionnées et plages matricielles (Daniel Bankston).
  • Possibilité de fusionner les cellules sélectionnées via le menu contextuel (clic droit dans la sélection) cf. tdf#37210 (Greggory Hernandez).
  • Les feuilles peuvent être masquées et affichées via le menu contextuel des onglets (Noel Power).
  • Message d'erreur amélioré pour les noms de feuille incorrects cf. tdf#45285 (Albert Thuswaldner).
  • Amélioration de l'import des fichiers CSV
    • Gestion des lignes de plus de 64k caractères cf. tdf#48501 (Eike Rathke).
    • Différenciation des messages d'erreur entre "max lignes dépassé" and "max colonnes dépassé" and "max taille cellule dépassé" cf. tdf#48516 (Eike Rathke).
    • Meilleure gestion des fichiers CSV cassés quand le générateur du fichier n'a pas respecté les RFC 4180 règles des séparateurs cf. tdf#48621 (Eike Rathke).
    • Import des nombres en notation scientifique sans avoir à cocher "Détecter les nombre spéciaux" cf.tdf#39716 (Eike Rathke).
    • Meilleurs séparateurs par défaut virgule, point-virgule, tabulation cf. tdf#38088 (Eike Rathke).
  • Export CSV : Ajout d'une option Enregistrer les formules au lieu des valeurs calculées cf. tdf#45664 (Florent Gallaire).
Option export des formules
  • Nouvelle fonction DATEDIF cf. ODF OpenFormula et l'inter-opérabilité avec MS-Excel cf. tdf#44456 (Winfried Donkers, Eike Rathke).
  • Nouvelles fonctions imaginaires : IMTAN, IMSEC, IMCSC, IMCOT, IMSINH, IMCOSH, IMSECH et IMCSCH telles que définies dans le format ODFF OpenFormula cf. tdf#51017 (Regina Henschel).
  • Gestion des champs dans les cellules. Vous pouvez désormais insérer les champs Date, Nom de feuille, et Titre dans les cellules. Pour insérer un champ, passer en mode "modification" de la cellule, cliquer droit sur la cellule, et choisir Insertion champs dans le menu contextuel (Kohei Yoshida).
Insertion de champ dans les cellules.
  • Format xlsx
    • Import : amélioration des performances (Daniel Bankston).
    • Export : gestion du Formatage conditionnel (Markus Mohrhard).
  • Le tri est désormais possible via le menu Autofiltre (Kohei Yoshida).
Option de tri dans le menu Autofiltre.
  • Collage spécial direct par menu contextuel pour : Texte, Nombre ou Formule (Noel Power).
Collage spécial par menu
  • Options de configuration détaillées pour le calcul de formule. Vous pouvez maintenant configurer la syntaxe de référence pour la fonction intégrée INDIRECT. Dans l'avenir, nous pouvons ajouter ici d'autres options de calcul pour permettre aux utilisateurs de configurer les calculs de formule (Kohei Yoshida).
Nouveau groupe Paramétrage du mode de calcul dans la page d'options Formule.
Dialogue pour le paramétrage du calcul.
  • Suppression de la limite de 3 clés de tri cf.tdf#45747 (Albert Thuswaldner).
Dialogue tri avec plusieurs clés de tri (plus de trois).
  • Le nombre de feuilles par défaut sera 1 et non plus 3 cf. tdf#50183 (Stefan Knorr)
Nota : cette option est paramétrable depuis la version 3.5 par Outils ▸ Options ▸ LibreOffice Calc ▸ Par défaut.
  • Gestion des barres d'erreur X dans les diagrammes XY (dispersion) et Barres, import et export vers xls et ods si utilisation du format ODS 1.2 étendu cf. tdf#33773 (Rafael Dominguez).
  • Gestion des barres de données et échelles de couleurs. Import depuis le format xlsx et import/export depuis le format ods ODF1.2 étendu. Attention : quelques limitations subsistent et seront levées dans la version 4.0.0 (Markus Mohrhard).
Échelles de couleur et barres de données dans calc.
  • Formatage conditionnel : Nouveaux dialogues pour gérer les échelles de couleur & barres de données (Design : Stefan Knorr, mise en œuvre : Markus Mohrhard).

Impress / Draw

  • Ajout du format Écran large (16:9) pour les diapositives cf. tdf#42986 (Rob Snelders).
  • Détection correcte du moniteur externe et affichage de la console de présentation sur le moniteur local (Michael Meeks).
  • 10 nouvelles Pages maîtresses (Alexander Wilms, Mateus Machado Luna, Björn Michaelsen).
Nouvelles Pages maîtresses

Math

  • Les dialogues du menu Format (Police, Taille de police, Espacement) et Symboles (Outils ▸ Catalogue) disposent désormais d'un bouton d'aide. Ref: tdf#47860, tdf#47862, tdf#47863, tdf#47864 . (Karan Desai)
Bouton Aide

Base

  • Les bases (embarquées) au format natif HSQL sont désormais compactées lors de l'enregistrement (LibreOffice utilise CHECKPOINT DEFRAG plus seulement CHECKPOINT). L'espace occupé par les enregistrements supprimés est ainsi réellement libéré ; en contrepartie enregistrement / fermeture pourront être significativement plus longs (Lionel Mamane).

Environnement de Développement Intégré (EDI) Basic

  • Catalogue d'objets ancré dans un volet (Bence Tomcsik).
Volet catalogue d'objets ancré

Core

  • Gestion du format de papier "carte postale" japonais dans toutes les applications (Takeshi Abe).
  • Liste des derniers documents utilisés mise à jour lors de : Enregistrer, Enregistrer sous, Tout Enregistrer, Fermer cf. tdf#37775 (Muhammad Haggag).
  • Paramétrage du Support des logiciels d'accessibilité dans le programme d'installation, décoché par défaut cf. tdf#39833 (Andras Timar).
  • Mise à jour possible de documents en lecture seule (Stephan Bergmann). Cf.[1] :
Par exemple lors de la visualisation de pièces jointes à un mail (enregistrées en lecture seule dans un dossier de téléchargement par le courrielleur), permettre à l'utilisateur de les modifier temporairement, et facilement (modification de valeurs dans un tableau, recalcul des formules, etc.) en cliquant sur le bouton "Éditer le fichier" et ne pas avoir à créer de copie du document pour cela.
  • Le bouton "Éditer le fichier" bascule désormais le statut "lecture seule" de la vue du document affiché. Il ne demande plus de créer une copie si le document affiché est physiquement en lecture seule.
  • Quand un document modifié est basculé sur "lecture seule" via le bouton "Éditer le fichier", LibreOffice demande toujours à l'utilisateur d'enregistrer ou ignorer les modifications. Toutefois, si le document affiché est physiquement en lecture seule, choisir d'enregistrer ouvre le dialogue Enregistrer sous et non plus Enregistrer (qui pourrait échouer dans ce cas).
  • Le titre de la fenêtre du document contient désormais "(lecture seule)" si, et seulement si, le document affiché est en lecture seule, ou si le document est physiquement en lecture seule (ou les deux).
  • Ajout de l'algorithme Lanczos pour utiliser et redimensionner les images en remplacement de l'algorithme d'interpolation. Ce changement a amélioré la qualité des images lors de la réduction de résolution de l'export PDF (Tomaž Vajngerl).
  • Enregistrement de macro activable par une option distincte : Outils > Options > LibreOffice > Général > Autoriser l'enregistrement de macros cf. tdf#41865 (Cor Nouws). Ceci permet d'utiliser cette fonctionnalité sans activer les Fonctions expérimentales.
Option Activer l'enregistrement de macro

Filtres

  • Voir également les sections Writer (formats docx, rtf) et Calc (formats texte, xlsx)
  • Filtre d'import pour les documents Corel Draw. Plus de details ici et ici.
terra v16.cdr dans Corel Draw
terra v16.cdr dans Corel Draw
terra v16.cdr dans LibreOffice Draw
  • Fichier > Exporter au format PDF gère l'option Watermark (tatouage numérique) (Andreas Mantke).
PDF export with watermark.png
  • L'export ODF comprend désormais un format ODF 1.2 Extended (compact mode), offrant une meilleure interopérabilité avec les programmes plus anciens utilisant le format Open Document, ceci au prix d'une légère réduction de la conformité à la norme (Thorsten Behrens).

Interface graphique

  • Mise à jour majeure du look sur Windows Vista, Windows 7, et ultérieures : effets 3D supprimés des règles, barre d'état, barres d'outils et application d'un dégradé d'arrière-plan pour les barres d'outils (Mirek Mazel, Stefan Knorr, Jan Holesovsky, Michael Meeks).
LibreOffice 3.5 LibreOffice 3.6
Libreoffice-3.5.png
Libreoffice-3.6.png
Libreoffice-3.5-mac.png
Libreoffice-3.6-mac.png
  • Nouvel écran d'accueil (Splash screen) (Andrea Soragna, Stefan Knorr (astron)).
LibreOffice 3.6.0.3 Splash Screen.png
  • Le dialogue À propos de (accès via Aide ‣ A propos de LibreOffice) a été redessiné pour une présentation améliorée (Andrew Higginson). Il bénéficie d'un nouveau graphisme (Stefan Knorr (astron), basé sur l'écran d'accueil dessiné par Andrea Soragna).
LibreOffice 3.6.0.3 About Box.png
  • Nouveau graphisme pour l'écran de démarrage (Stefan Knorr (astron), basé sur l'écran d'accueil dessiné par Andrea Soragna).
LibreOffice 3.6.0.3 Start Center.png
  • Writer et Calc disposent d'outils Couleur avec bouton menu séparé permettant d'appliquer la dernière couleur utilisée d'un seul clic de souris, sans ouvrir la palette : ceci est disponible pour la police, l'arrière-plan, les bordures et le surlignage (Winfried Donkers).
Split-Colors-writer.png Split-Colors-calc.png
  • Cliquer sur le bouton >> n'affiche plus le menu des options d'une barre d'outils (n'affiche désormais que les outils non visibles), le menu est obtenu par clic droit sur la barre d'outils cf. tdf#38276 (Iain Billett).
Toolbar options menu in 3.6.png
  • Les règles ont été nettoyées et sont plus légères (design par Mirek M., implémentation par Jan Holesovsky).
Updated-rulers.png
  • Gestion de l'environnement de bureau Trinity Desktop Environment (widgets, dialogues ouvrir/enregistrer, carnets d'adresses) (Timothy Pearson & auteurs originaux de l'intégration KDE3).
  • Le choix du dictionnaire n'est plus proposé lorsqu'il n'y a qu'un seul dictionnaire actif lors de la vérification orthographique cf. tdf#40778 (Caolán McNamara & Rob Snelders).
  • La progression du Zoom est désormais géométrique et non plus arithmétique cf. tdf#44173 (Tim Hardeck).
  • Sélection du style d'icônes Tango par défaut sur OS/X (Michael Meeks & UI team).
  • Les thèmes GTK (styles d'icônes) sont maintenant en mesure de rendre le dégradé d'arrière-plan (les captures d'écran utilisent ici le thème oxygène-gtk de LibreOffice) (Ruslan Kabatsayev).
Toolbar-gradient-and-combo-list.png
  • Les thèmes GTK gèrent désormais le rendu de la sélection des onglets (Ruslan Kabatsayev).
Tab-prelight-and-themed-frame.png
  • La thématisation GTK est mise en œuvre pour les lignes et les cadres (Ruslan Kabatsayev).
Options-menu-with-themed-lines.png

Localisation

  • Acceptation des "motifs" de dates incomplètes pour les langues "locales".
Ceci empêche la détection erronée de dates dans Calc et Writer lors de l'import de fichier CSV.
Cf. ce blog (en anglais) pour plus de détails (Eike Rathke).
  • (Disponible depuis la version 3.6.2) Schémas d’acceptation de date dans Outils ▸ Options ▸ Paramètres linguistiques ▸ Langues pour reconnaissance des dates lors de la saisie au clavier, le collage de texte, l’import de fichiers CSV cf. tdf#52240 tdf#52137 tdf#52288 (Eike Rathke).
EditDateAcceptancePatterns.png
  • Ajout de la langue English_Malawi en_MW (Eike Rathke).
  • Ajout de Erzya_Russia myv_RU.
  • Amélioration des outils linguistiques (dictionnaires de vérification orthographique, thésaurus, motifs de césure) cf. Information tirée du référentiel dictionnaire :
    • Mise à jour du correcteur orthographique brésilien et portugais (pt-BR) (Raimundo Moura).
    • Mise à jour du correcteur orthographique suédois
    • Mise à jour du correcteur orthographique et thésaurus français
    • Mise à jour du thésaurus tchèque
    • Outils linguistiques allemands nettement améliorés (de-DE, de-AT, de-CH) avec plus de 30000 nouveaux mots ajoutés au dictionnaire et plus de 7000 nouveaux synonymes ajoutés au thésaurus. Les motifs de césure ont également été améliorés.
    • Améliorations substantielles du vérificateur orthographique et thésaurus Danois
  • L'indication Par défaut pour la langue de l'interface utilisateur s'applique désormais à celle du système d'exploitation (c'était auparavant la langue en cours d'utilisation) tdf#45830 (Rob Snelders).

Performance

  • Amélioration sensible de l'import des documents OLE2 : .doc, .xls, .ppt (Caolan McNamara, Michael Meeks).
  • Amélioration sensible de l'import des documents : .doc/.docx (Michael Meeks, Caolan McNamara).
  • Grands documents, améliorations (Caolan McNamara) lors du :
    • défilement
    • reformatage
    • modifications interactives
  • Grandes listes d'AutoCorrection gérées environ deux fois plus vite (Michael Meeks).
  • Voir aussi Base

Infrastructure

  • Plusieurs modules rendus plus rapides, plus fiables gnumake (David Tardon, Matus Kukan, David Ostrovsky & d'autres).


Les bugs les plus gênants

Les bugs gênants suivants n'ont pas pu être corrigés à temps et seront traités dans les versions correctives normales :

  • (Microsoft Windows seulement) Le pilote ADO (ActiveX Data Objects) est inactif. En conséquence, la procédure par défaut pour se connecter à une base de données MS Access (.mdb et .accdb files) ne fonctionne pas ; correction confirmée en version 3.6.1. Contournement : se connecter via ODBC (ou utiliser une version 3.5.x de LibreOffice). cf. tdf#52615. Résolu en 3.6.1
  • Le bouton "Terminer" de l'assistant Rapport ne fait rien -> impossible de créer un rapport via l'assistant ; corrigé avec la version 3.6.1. Contournement : créer le rapport en mode conception ou avec une version précédente de LibreOffice (le rapport peut ensuite être utilisé et modifié avec LibreOffice 3.6.0). Résolu en 3.6.1.
  • L'export au format DOCX de fichiers contenant des hyperliens dans les notes de bas de pages/de fin ou même une table des matières génère des fichiers corrompus illisibles par d'autres suites bureautiques. cf. tdf#52610. Résolu en 3.6.1
  • (Microsoft Windows seulement) LibreOffice se ferme sans avertissement après l'écran d'accueil. Ceci se produit au premier démarrage après la mise à jour (et généralement quand les extensions bundled (incorporées) ou partagées ont été modifiées). Contournement : redémarrer "manuellement" LibreOffice. cf. tdf#43989. Résolu en 3.6.1
  • Problèmes divers avec les extensions bundled. Ceci inclut, mais n'est pas nécessairement limité aux Issues ci-dessous.
    • Pas de vérification orthographique (la coche “ABC” manque devant les items de la liste fournie par Outils ▸ Options ▸ Paramètres linguistiques ▸ Langues ▸ Langues par défaut pour les documents même pour les langues pour lesquelles le dictionnaire a été installé comme extension incorporée ou via Outils ▸ Gestionnaire d'extensions...).
    • L'option d'AutoCorrection “COrriger la 2e majuscule en DÉbut de mot” ne fonctionne pas.
    • Pages d'options des dictionnaires manquantes (dans Outils ▸ Gestionnaire d'extensions..., choisir une extension dictionnaire bundled comme “English spelling dictionaries, hyphenation rules, thesaurus, and grammar checker” n'affiche pas le bouton “Options...”).
    • Dans certains cas, LibreOffice ne démarre pas du tout. Sur Windows, le logiciel affiche un message d'erreur “InvalidRegistryException”, sur Linux et Mac OS X il affiche un message au sujet d'une unhandled exception to stderr (visible au démarrage de soffice depuis une fenêtre terminal).
Contournement pour ces Issues : supprimer "manuellement" le cache utilisateur des extensions bundled et redémarrer LibreOffice. Comment faire cela dépend du système utilisé.
  • Sur Linux, dans une fenêtre de terminal entrer “rm -rf ~/.config/libreoffice/3/user/extensions”.
  • Sur Mac OS X, dans une fenêtre Terminal entrer “rm -rf ~/Library/Application\ Support/LibreOffice/3/user/extensions”.
  • Sur Microsoft Windows, dans une fenêtre Command Prompt (fenêtre DOS) entrer “rmdir /q /s %appdata%\LibreOffice\3\user\extensions” (nota : nécessaire de démarrer deux fois LibreOffice, voir ci-dessus). cf. tdf#53006. Résolu en 3.6.1
  • Perte des commentaires lors de l'export (enregistrement) des documents tableur au format XLS/XLSX. Corrigé avec la version 3.6.1. Contournement : utiliser une version LibO 3.5.x ou enregistrer au format ODS. cf. tdf#52998. Résolu en 3.6.1
  • L'option d'espacement conditionnel entre paragraphes n'est pas affichée lors de la modification du style (onglet Retraits et espacement).Résolu en 4.2.0

Contournement :

  1. Créer le style (F11), cocher Actualisation automatique.
  2. Appliquer à un paragraphe le style créé.
  3. Formater le paragraphe et cocher "espacement contextuel" (Ne pas ajouter d'espace entre les paragraphes de même style).
  4. Si vous le souhaitez, modifier le style pour décocher Actualisation automatique cf. tdf#53360.