LibreOffice 3.6: Notas da versão

From The Document Foundation Wiki
Jump to: navigation, search

Novidades do LibreOffice 3.6

Sobre esta página

Esta é uma página de rascunho com anotações sobre os desenvolvimentos até a liberação da versão. Não inclua aqui as modificações que já foram implementadas na versão 3.5 ou em outra anterior!

O que deve constar nesta página:

  • Uma descrição, e uma maneira adequada para um revisor encontrar e conferir a nova característica. Considere que pessoas são bastante ocupadas e com conhecimento modesto do produto. Assim, se um elemento da interface do usuário for importante, seja bastante explícito sobre onde encontrá-lo. Por exemplo, caminhos do tipo Menu ▸ Formatar ▸ Caractere ▸ Guia Posição ▸ 90 graus para achar o elemento novo. Claro que você considera sua contribuição importante e todos deveriam estar cientes de sua “caixa de diálogo de Propriedades avançadas das autoformas”, porém nem sempre as pessoas que gravam imagens de tela e que escrevem sobre o LibreOffice entendem exatamente o novo recurso.
  • Dê os créditos aos autores principais, as pessoas que trabalharam na novidade – Coloque seus nomes entre parênteses.
  • Se uma novidade pode ser apresentada com um exemplo ou arquivo de teste – particularmente para arquivos contendo as novidades, será muito bom ter um atalho para carregar um arquivo de teste que possa ser utilizado para mostrar de forma bem clara a nova característica. Isso ajuda muito para gravar imagens da tela para mostrar as novidades, e permite aos revisores fazerem seus próprios testes.

Obrigado por nos ajudar a completar esta página!


Writer

  • O pincel Formatar agora diferencia atributos de formatação automática de caracteres aplicados ao parágrafo daqueles aplicados à parte de texto dentro do parágrafo. Esses atributos de formatação automática de caracteres são passados para o parágrafo inteiro, por padrão; se a tecla Ctrl for pressionada, enquanto o formato é passado, estes atributos são aplicados para a parte do texto selecionado. (Maxime de Roucy)
  • Suporte para não espaçamento entre parágrafos consecutivos de mesmo estilo conhecido por espaçamento contextual. (Miklós Vajna)
Criada uma nova opção de espaçamento entre parágrafos.
  • A importação de VML (usado dentro de arquivos DOCX mais antigos) agora lida com linhas, rotações e viradas de página. (Miklós Vajna)
  • A importação de DOCX agora lida com campos GetExpression e SetExpression. (Miklós Vajna)
  • A importação e a exportação de RTF e DOCX agora lidam com a configuração de ampliação (zoom) do documento. (Miklós Vajna)
  • Pressionando Ctrl com [ ou com ] diminuirá ou aumentará, respectivamente, o tamanho da fonte do texto selecionado. tdf#36187 (Cameron Paul)
  • Contagem de palavras (para o documento inteiro e para a seleção) na barra de status. tdf#34772 (Robert Roth)
Também é exibida no rodapé a contagem de palavras do texto selecionado.
  • Autoformatação de tabelas agora registra as seguintes propriedades da tabela: tdf#31005 (Muhammad Haggag)
  • Quebras
  • Manter com o próximo parágrafo
  • Repetir cabeçalho da tabela
  • Permitir dividir a tabela em várias páginas
  • Permitir a quebra de linhas em várias páginas
  • Mesclar estilos de linhas adjacentes
  • Sombras da tabela
  • Mostrar Limites do texto dependendo da escolha de mostrar caracteres não imprimíveis tdf#46073 (Cédric Bosdonnat).
  • Suporte para importação de Smart Art. (Miklós Vajna) Experimente este documento DOCX (File:Smartart.docx) como exemplo.
Um exemplo de utilização do Smart Art é mostrado.

Etiquetas / Assistente de cartões personalizados

  • Foram estendidas as definições de etiqueta com tamanho do formulário (página, papel). Etiquetas que não estão centralizadas no formulário agora são criadas corretamente. (Winfried Donkers)
  • Todas as mais de 1.700 definições de etiquetas foram modificadas para incluir o tamanho do formulário; as definições obsoletas foram removidas. (Winfried Donkers)
  • Recálculo da posição das etiquetas no formulário. Definições de etiquetas com intervalos entre estas mais largos do que a margem direita agora produzem documentos corretos. Etiquetas definidas pelo usuário são automaticamente estendidas ao tamanho do formulário. (Winfried Donkers)
  • O tamanho do formulário pode ser modificado na caixa de diálogo do assistente. (Winfried Donkers)
Novo formulário permite a modificação do tamanho da etiqueta.

Calc

  • Ctrl+D preenche para baixo em formas mais conhecidas, atribuindo o conteúdo da célula acima, se nenhuma célula estiver selecionada, e preenche múltiplas células com múltiplas seleções. (Kohei Yoshida)
  • Nova opção para especificar um prefixo de nome personalizado da planilha em novos documentos. (Albert Thuswaldner)
Nova guia de opções para criar um prefixo padrão na planilha.
  • O desempenho da tabela dinâmica foi melhorado. A atualização da tabela dinâmica deve ficar até 50% mais rápida do que na versão anterior (3.5). Além disso, o espaço de memória alocado para a tabela dinâmica foi significativamente reduzido. (Kohei Yoshida)
  • Células marcadas agora podem ser unidas através do menu de contexto (botão direito do mouse). tdf#37210 (Greggory Hernandez)
  • As planilhas podem ser escondidas e mostradas na opção do menu de contexto. (Noel Power)
  • Mensagem de erro melhorada para nome inválido de planilha. tdf#45285 (Albert Thuswaldner)
  • Exportar a formatação condicional para XLSX. (Markus Mohrhard)
  • Aprimorada a importação de arquivos CSV.
    • Manipulação de linhas com mais de 64k caracteres. tdf#48501 (Eike Rathke)
    • Mensagens de erro diferenciam entre "máximo de linhas ultrapassado" e "máximo de colunas ultrapassado" e "tamanho máximo de células foi excedido". tdf#48516 (Eike Rathke)
    • Melhor manipulação de arquivos CSV que não seguem a RFC 4180, regras de citação. tdf#48621 (Eike Rathke)
    • Importar números em notação científica sem ter que verificar "importação de números especiais". tdf#39716 (Eike Rathke)
    • Melhor definição para o separador inicial: vírgula (,) ponto e vírgula (;) tabulador (tab). tdf#38088 (Eike Rathke)
  • Adicionada uma opção "Salvar fórmulas de células em vez de valores calculados" ao exportar CSV. tdf#45664 (Florent Gallaire)
Opção para exportar fórmulas (CSV).
  • Nova função DATADIF definida pelo padrão ODF OpenFormula e para interoperabilidade com MS-Excel. tdf#44456 (Winfried Donkers, Eike Rathke)
  • Novas funções para números complexos do padrão OpenFormula IMTAN, IMSEC, IMCOSEC, IMCOT, IMSENH, IMCOSH, IMSECH and IMCOSECH. tdf#51017 (Regina Henschel)
  • Suporte a campos em células. É possível incluir data, nome da planilha e título do documento em células. Para incluir um campo, entre no modo de edição da célula e utilize o menu de contexto incluir campos. (Kohei Yoshida)
Incluir campo nas células.
  • Permite agora classificar dados pelo menu do autofiltro. (Kohei Yoshida)
Opção de classificação no menu do autofiltro.
  • Colagem rápida de texto, valor ou fórmula a partir do menu de contexto da célula. (Noel Power)
Opção no menu de contexto para "Colar somente".
  • Opções de configuração detalhada para cálculos de fórmulas. Pode-se agora configurar a sintaxe das referências para funções internas do tipo INDIRETO. No futuro, poderemos adicionar mais opções de cálculo para permitir que os usuários configurem suas fórmulas em tempo de execução. (Kohei Yoshida)
Nova página de opções de cálculos. Caixa de diálogo para detalhamento das configurações de cálculo.
  • Remoção da limitação de 3 critérios de classificação no Calc. tdf#45747 (Albert Thuswaldner)
Nova caixa de diálogo de classificação permitindo mais de 3 chaves.
  • Número padrão de planilhas em novos documentos será 1 no lugar de 3 – tdf#50183, (Stefan Knorr). Note que desde a versão 3.5 é possível editar este parâmetro em Ferramentas ▸ Opções ▸ LibreOffice Calc ▸ Padrão.
  • Suporte para barras de erros X e gráficos de espalhamentos e de barras, importação e exportação para XLS e ODS utilizando ODF 1.2 Estendido. tdf#33773 (Rafael Dominguez)
  • Suporte para escala de cores e barra de dados. Importação do XLSX e importação/exportação do ODS em ODF 1.2 Estendido. Atenção: persistem algumas limitações que serão consertadas na versão 4.0.0. (Markus Mohrhard)
Nova escala de cores e barra de dados.
  • Novas caixas de diálogo da formatação condicional para suportar as escalas de cores e barra de dados. (Design: Stefan Knorr, Implementação: Markus Mohrhard)

Impress

  • Novo formato "widescreen" (tela de 16:9) para slides do Impress. tdf#42986 (Rob Snelders)
  • Detecta corretamente o monitor de vídeo externo e coloca a console do apresentador no monitor de vídeo local. (Michael Meeks)
  • Dez novos modelos de página mestre. (Alexander Wilms, Mateus Machado Luna, Björn Michaelsen)
Novos modelos.

Math

  • As caixas de diálogo para formato (fonte, tamanho da fonte e espaçamento) e símbolo (Ferramentas ▸ Catálogo) agora possuem botões de ajuda. tdf#47860, tdf#47862, tdf#47863, tdf#47864 (Karan Desai)
Botão de ajuda adicionado em algumas caixas de diálogo.

IDE do Basic

  • Painel para Catálogo de Objetos Encaixados. (Bence Tomcsik)
Catálogo de objetos integrado ao IDE.

Núcleo

  • Suporte a tamanho de cartão postal japonês em todas as aplicações. (Takeshi Abe)
  • Lista dos documentos recentes é atualizada ao Salvar, Salvar Como, Salvar tudo e Fechar. tdf#37775 (Muhammad Haggag)
  • Permite editar documentos somente leitura, conforme a mensagem da correção. (Stephan Bergmann) Por exemplo, ao visualizar anexos de mensagens eletrônicas (que foram armazenados em somente leitura numa pasta pela aplicação de e-mails), seria interessante se o usuário pudesse modificar temporariamente o documento (digamos, trabalhar numa planilha, mudar alguns números e recalcular as fórmulas) ao clicar no botão Editar arquivo sem a obrigação de criar uma cópia para edição e assim:
    • O botão Editar arquivo alterna o status somente leitura da visualização. Não há mais uma pergunta para salvar uma cópia para editar se o documento estiver fisicamente em somente leitura.
    • Quando um documento modificado é alternado para somente leitura pelo botão Editar arquivo, o LibreOffice ainda perguntará para salvar ou descartar as mudanças. Porém se o documento for fisicamente somente leitura, a caixa de diálogo Salvar como será aberta, no lugar da operação Salvar (o que acarretará um erro no documento somente leitura).
    • O título do documento agora mostrará "somente leitura", se e somente se a visualização for somente leitura ou o documento for fisicamente somente leitura (ou ambos).
  • Adicionada a opção Suporte a ferramentas de tecnologias assistenciais no processo de instalação. tdf#39833 (András Timár).
  • Adicionado o algoritmo Lanczos para redimensionamento de imagens e sua utilização no lugar do algoritmo de interpolação. Esta mudança aumenta a qualidade das imagens quando ocorre a redução da resolução na exportação para PDF. tdf#46378 (Tomaž Vajngerl)
Exemplo de imagens com a qualidade aumentada pelo algoritmo Lanczos.
  • A gravação de macros pode ser ativada em uma opção separada no menu Ferramentas ▸ Opções ▸ Geral ▸ Habilitar gravação de macro. tdf#41865 (Cor Nouws) Isto permite a utilização desta funcionalidade, de forma limitada, não necessitando ativar os recursos experimentais, por estarem ainda instáveis.
Opção para habilitar gravação de macro.

Filtro

  • Filtro de importação para documentos Corel Draw. Mais detalhes podem ser observados nestes artigos de abril e junho.
Arquivo "terra v16.cdr" visualizado no Corel Draw. Arquivo "terra v16.cdr" visualizado no Corel Draw com uma aproximação maior. Arquivo "terra v16.cdr" visualizado no LibreOffice Draw.
  • Exportação de PDF com opção de marca d'água. Acesso pelo menu Arquivo ▸ Exportar para PDF. (Andreas Mantke)
Nova opção de marca d'água para exportação de PDF.
  • A exportação ODF agora vem como ODF 1.2 Estendido (modo de compatibilidade), que fornece uma interoperabilidade melhor com outros usuários de softwares para Open Document Format. Resultará em um menor rigor na aderência ao padrão ODF. (Thorsten Behrens)

Interface do usuário

  • Visual mais limpo da GUI no Windows Vista, 7 ou posterior: foram removidas as bordas 3D nas réguas e nas barras de status; barras de ferramentas estão sem bordas com um fundo gradiente suave para melhor visualização. (Mirek Mazel, Stefan Knorr, Jan Holešovský, Michael Meeks)
LibreOffice 3.5 LibreOffice 3.6
Visual da GUI do LibreOffice 3.5 no Windows 7. Visual da GUI do LibreOffice 3.6 no Windows 7.
Visual da GUI do LibreOffice 3.5 no MacOS X 10.6.8. Visual da GUI do LibreOffice 3.6 no MacOS X 10.6.8.
  • As réguas estão com um visual mais limpo e mais leve. (design de Mirek Mazel, implementado por Jan Holešovský)
Novo visual das réguas.
  • O conjunto de ícones padrão é agora o Tango no OS/X. (Michael Meeks e time da interface do usuário)
  • Nova tela de abertura. (Andrea Soragna, Stefan Knorr – Astron)
Tela de abertura capturada no MacOS X 10.6.8, idioma alemão.
  • A caixa de diálogo Sobre (acesso pelo menu Ajuda ▸ Sobre) foi redesenhada com uma aparência mais limpa (Andrew Higginson) e recebeu uma nova arte. (Stefan Knorr – Astron, baseada na tela de abertura idealizada por Andrea Soragna)
Caixa de diálogo "Sobre" capturada no MacOS X 10.6.8, idioma alemão.
  • Nova arte para a janela inicial de abertura. (Stefan Knorr – Astron, baseada na tela de abertura idealizada por Andrea Soragna)
Janela inicial capturada no MacOS X 10.6.8, idioma alemão.
  • Writer e Calc usam botões separados para cor, tornando-se possível aplicar a última cor utilizada com um clique do mouse para fonte, fundo, borda e realce. (Winfried Donkers)
Possibilidade de aplicar a última cor utilizada no realce. Possibilidade de aplicar a última cor utilizada na fonte.
  • Ao clicar em >>, o botão de expansão não mostrará mais as opções da barra de ferramentas. Estas opções podem ser mostradas pelo menu de contexto (botão direito do mouse) da própria barra de ferramentas. tdf#38276 (Iain Billett)
O botão de expansão mostra somente as opções específicas.
  • Integração e suporte para Trinity Desktop Environment (widgets, diálogos de abrir/salvar, e catálogos de endereços). (Timothy Pearson e time original de integração do KDE3)
  • A escolha do dicionário foi removida quando houver somente um dicionário ativo. tdf#40778 (Caolán McNamara e Rob Snelders)
  • O zoom agora é com progressão geométrica em vez de aritmética. tdf#44173 (Tim Hardeck)
  • Os temas GTK são capazes de exibir gradientes no plano de fundo. As imagens abaixo utilizam o ramo "LibreOffice" do oxygen-gtk. (Ruslan Kabatsayev)
Gradiente no plano de fundo das janelas.
  • Os temas GTK podem agora pré-iluminar as guias das caixas de diálogo. (Ruslan Kabatsayev)
Guias das caixas de diálogo são pré-iluminadas.
  • Os temas GTK agora implementam linhas fixas e quadros. (Ruslan Kabatsayev)
Janela do menu Opções ▸ Ferramentas ▸ Exibir com um gradiente.

Localização (Internacionalização)

  • Implementados padrões de data dependentes de aceitação, conforme a localidade, para a entrada de datas incompletas.
    Isso impede a detecção errônea de datas na entrada de célula e importação de arquivos CSV (Calc e Writer).
    Para mais detalhes, acesse esta página. (Eike Rathke)
  • (Disponível desde a versão 3.6.2) Editar padrões de data de aceitação em Ferramentas ▸ Opções ▸ Configurações de idioma ▸ Idiomas para o reconhecimento da data de entrada do teclado, o texto colado, importação de arquivos CSV etc. tdf#52240 tdf#52137 tdf#52288 (Eike Rathke)
Configuração para a data de aceitação.
  • Adicionada a localidade "Inglês" da República do Malawi (en_MW). (Eike Rathke)
  • Adicionada a localidade "Erzya" da Federação Russa (myv_RU).
  • Melhoria nas ferramentas de idiomas: dicionários para verificação ortográfica, tesauros, regras de hifenização. Informação do repositório de dicionários:
    • Corretor VERO (VERificador Ortográfico) e autocorreção atualizados. (Raimundo Moura)
    • Dicionário ortográfico sueco atualizado.
    • Dicionário ortográfico e tesauro em francês atualizados.
    • Tesauro checo atualizado.
    • Grande melhoria nas ferramentas de idiomas em alemão (de-DE, de-AT, de-CH) com mais de 30.000 novas palavras adicionadas ao dicionário ortográfico alemão e 7.000 novos sinônimos adicionados ao tesauro. A hifenização também foi melhorada.
    • Melhorias importantes para o verificador ortográfico e tesauro em dinamarquês.
  • A localidade padrão passa a ser a localidade do sistema operacional. tdf#45830 (Rob Snelders)

Desempenho

  • Aprimoramento substancial na importação de documentos OLE2: DOC, XLS e PPT. (Caolán McNamara, Michael Meeks)
  • Aprimoramento substancial na importação simples de DOC e DOCX. (Michael Meeks, Caolán McNamara)
  • Aperfeiçoamento na rolagem, redesenho e edição interativa de documentos grandes. (Caolán McNamara)
  • Listas de autocorreção manipuladas com o dobro da velocidade. (Michael Meeks)
  • Aprimoramento na manipulação de tabelas dinâmicas no Calc. A atualização de uma tabela dinâmica deve ser agora entre 35-50% mais rápida que na versão 3.5. Além disso, o consumo de memória da tabela dinâmica foi reduzido substancialmente. (Kohei Yoshida)
  • Aprimoramento na importação de valores das células de documentos XLSX. (Daniel Bankston)
  • Aprimoramento na manipulação de células mescladas e importação de intervalos de matrizes de documentos ODS. (Daniel Bankston)
  • O mecanismo de bancos de dados embutido (HSQLDB) ficará agora com tamanho menor antes de ser salvo (LibreOffice usa "DEFRAG CHECKPOINT" e não apenas "CHECKPOINT"). O espaço ocupado por registros excluídos será liberado, resultando numa demora de tempo um pouco maior para salvar ou fechar o arquivo.

Infraestrutura

  • Vários módulos convertidos para gnumake: mais rápido e mais confiável. (David Tardon, Matúš Kukan, David Ostrovsky e outros colaboradores)

Falhas indesejáveis

As seguintes falhas não foram corrigidas a tempo do lançamento da versão 3.6.0 e serão resolvidas em versões posteriores:

  • (Somente Microsoft Windows) O driver ADO (ActiveX Data Objects) está inativo. Assim, a forma padrão de conexão com banco de dados MS Access (extensões MDB e ACCDB) não funciona. Uma solução paliativa seria conectar através de ODBC ou usar uma versão LibreOffice 3.5.x. tdf#52615 Já corrigida na versão 3.6.1.
  • O botão "Concluir" do Assistente de Relatórios está inoperante. Não se pode criar relatório através do assistente. Uma solução paliativa seria criar o relatório no modo "edição de projeto" (design) ou criar numa versão anterior do LibreOffice (o relatório pode ser usado e editado na versão atual). Já corrigida na versão 3.6.1.
  • A exportação de arquivos com hipertextos em determinadas notas ou mesmo numa tabela de conteúdo para DOCX estava gerando arquivos corrompidos, os quais não são capazes de serem abertos por outros pacotes de escritório. tdf#52610 Já corrigida na versão 3.6.1.
  • (Somente Microsoft Windows) LibreOffice termina silenciosamente após a abertura da tela inicial. Isso acontece a primeira vez que um usuário inicia o LibreOffice após a atualização e, geralmente, sempre que há alterações em extensões empacotadas ou compartilhadas. Uma solução paliativa é reiniciar o LibreOffice. tdf#43989 Já corrigida na versão 3.6.1.
  • Vários problemas com extensões empacotadas. Uma solução paliativa seria remover o cache de cada usuário para extensões empacotadas e reiniciar LibreOffice. A forma de fazer isso dependerá da plataforma. No Linux, em uma console (janela de terminal) digite rm -rf ~/.config/libreoffice/3/user/extensions. No Mac OS X, em uma console (janela de terminal) digite rm -rf ~/Library/Application\ Support/LibreOffice/3/user/extensions. No Microsoft Windows, em uma console (janela do Prompt de Comando) digite rmdir /q /s "%appdata%\LibreOffice\3\user\extensions" e observe a necessidade de reiniciar o LibreOffice duas vezes, conforme mencionado no item anterior. tdf#53006 Já corrigida na versão 3.6.1.
    • A verificação ortográfica não está funcionando. O sinalizador "ABC" de seleção não está na frente dos itens nas listas em Opções ▸ Configurações de idioma ▸ Idiomas ▸ idiomas padrão para documentos, mesmo para os idiomas nos quais o dicionário seja instalado pela opção Ferramentas ▸ Gerenciador de extensão….
    • A opção de autocorreção Corrigir DUas INiciais MAiúsculas não funciona.
    • As configurações de dicionários embutidos não podem ser alteradas. Em Ferramentas ▸ Gerenciador de extensão…, ao selecionar um dicionário embutido, como Dicionário ortográfico, sinônimos, regras de hifenização e verificação gramatical em inglês, o botão Opções… não é exibido.
    • Em algumas situações, LibreOffice não inicializa completamente. No Windows, ele exibirá uma caixa de erro com “InvalidRegistryException”. Já no Linux e no Mac OS X imprimirá uma mensagem sobre uma exceção não tratada stderr (visível quando se inicia o LibreOffice pelo comando soffice a partir de uma console).
  • Os comentários de célula serão perdidos na exportação ou no salvamento da planilha para os formatos XLS e XLSX. Uma solução paliativa seria usar uma versão LibreOffice 3.5.x ou salvar no formato ODS. tdf#52998 Já corrigida na versão 3.6.1.
  • A opção de espaçamento condicional entre parágrafos não é exibida ao formatar um estilo (guia Recuos e espaçamento). tdf#53360 Já corrigida na versão 4.2.0.
    1. Uma solução paliativa seria:
    2. criar o estilo (F11), marcando a opção "autoatualizar";
    3. aplicar a um parágrafo o estilo criado;
    4. formatar o parágrafo e marcar a opção "espaçamento contextual" (Não adicionar espaços entre parágrafos de mesmo estilo);
    5. se preferir, modificar o estilo desmarcando a opção "autoatualizar".