Notas da versión 3.6

From The Document Foundation Wiki
Jump to: navigation, search

Novidades da LibreOffice 3.6

Sobre esta páxina

Este é un borrador esquemático con anotacións para redactar as notas da versión que se vai publicar. Non inclúa aquí as funcionalidades que xa están implantadas na versión 3.5! Non engada funcionalidades desexadas que lle gustaría ver desenvolvidas senón só o que xa estea implementado.

Que é o que parece ser oportuno nesta páxina:

  • Que teña unha descrición, e dun xeito adecuado para un lector ocupado, para que poida atopar e probar esa nova característica. Agardamos esa persoa moi ocupada e con coñecementos modestos do produto. Así, se un elemento da interface de usuario é importante, sexa moi explícito sobre onde atopalo. Por exemplo, Menú ▸ Formato ▸ Carácter ▸ Posición[lapela] ▸ 90 graos leva ao elemento novo. Claro que vostede considera a súa achega importante e todos deberían ser sabedores do cadro de diálogo "Propiedades avanzadas de autoformatado", pero as persoas que fan capturas de pantalla adoitan e que escriben sobre o LibreOffice non o saben.
  • Que teña a atribución dos créditos aos autores principais do traballo, as persoas que traballaron na novidade - Poña os seus nomes entre parénteses cando sexa posíbel.
  • Que se unha novidade pode ser presentada cun exemplo ou ficheiro de proba - particularmente no caso de novas capacidade de importanción, sería moi interesante ter unha ligazón a/ ou /subir un ficheiro de proba que poida ser utilizado para amosar de forma ben clara a nova característica. Isto axuda moito a facer boas capturas de pantalla para amosar as funcionalidades, e permítelles aos lectores facer as súas propias probas.

Grazas por axudarnos a completar esta páxina

Writer

  • Permite o espazamento contextual espazo contextual. Non engadir espazos entre parágrafos consecutivos que teñen o mesmo estilo (Miklos Vajna)
Nova opción de espazamento do Writer.
  • O pincel de formatar diferencia atributos de formatado automático de caracteres aplicados ao parágrafo daqueles aplicados a unha parte de texto dentro do parágrafo. Estes atributos de formatado automático de caracteres aplícanse ao parágrafo enteiro, de modo predeterminado. Se a tecla Ctrl se preme, mentres que se pasa o formatado, estes atributos aplícanse á parte do texto seleccionado. (Maxime de Roucy)
  • A importación de VML (usado en antigos ficheiros DOCX) agora pode manexar liñas, rotacións e xiros de páxina. (Miklos Vajna)
  • A importación de DOCX agora pode manexar GetExpression e SetExpression. (Miklos Vajna)
  • A importación/exportación de RTF/DOCX agora poden manexar a configuración de zoom. (Miklos Vajna)
  • Ao premer Ctrl con [ or with ] diminuirá ou aumentará, respectivamente, o tamaño do tipo de letra do texto seleccionado. tdf#36187 (Cameron Paul)
  • Conta de palabras (do documento enteiro e da selección) na barra de estado tdf#34772, así como correccións para dous erros de contaxe: tdf#46757, tdf#50141 . (Muhammad Haggag)
Sw-word-count-highlight.png
  • O formato automático de táboas agora grava as seguintes propiedades de táboa: tdf#31005 (Muhammad Haggag)
* As quebras
* Manter unida ao parágrafo seguinte
* Repetir cabeceira da táboa
* Permitir dividir a táboa entre varias páxinas
* Permitir que as filas se dividan entre varias páxinas
* Fusionar estilos de liñas adxacentes
* Sombra da táboa
  • Amosar Límites do texto dependendo da elección verbo de amosar caracteres non imprimíbeis tdf#46073 (Cédric Bosdonnat).
  • Compatibilidade coa importación de 'Smart Art'. (Miklos Vajna)
Smartart-sw.png
Probe con este documento DOCX de exemplo.
Media:smartart.docx

Asistente de Etiquetas / Tarxetas de visita

  • Foron ampliadas as opcións das etiquetas co tamaño do formulario (páxina, papel). As etiquetas que non están centradas no formulario créanse agora correctamente. (Winfried Donkers)
  • Todas as máis de 1.700 opcións de etiquetas foron modificadas para incluír o tamaño do formulario; os axustes obsoletos elimináronse. (Winfried Donkers)
  • Recálculo da posición das etiquetas no formulario. As definicións de etiquetas con intervalos entre estas máis largos que a marxe dereita producen agora documentos correctos. As etiquetas definidas polo usuario amplíanse automaticamente co tamaño do formulario. (Winfried Donkers)
  • O tamaño do formulario (a caixa da etiqueta) pode modificarse na caixa de diálogo do asistente. (Winfried Donkers)
Novo formulario para a modificación do tamaño.

Calc

  • Ctrl+D cobre as celas descendentes de forma máis familiar, atribuíndolle o contido da cela anterior, se ningunha cela está seleccionada, e cobre múltiplas celas con múltiplas seleccións. (Kohei Yoshida)
  • Nova opción para especificar un prefixo de nome personalizado na folla de cálculo para novos documentos. (Albert Thuswaldner)
Nova páxina de opcións predetermiandas en Calc.
  • As celas marcadas poden agora ser fusionadas a través do menú contextual (botón dereito do rato). tdf#37210 (Greggory Hernández)
  • Mensaxe de erro mellorada cando o nome da folla de cálculo non é correcto. tdf#45285 (Albert Thuswaldner)
  • Exportar o formato condicional a XLSX. (Markus Mohrhard)
  • Mellorar a importación de ficheiros CSV.
    • Manipulación de liñas con máis de 64k caracteres. tdf#48501 (Eike Rathke)
    • As mensaxes de erro diferencian entre "máximo de liñas superado" por unha banda "máximo de columnas superado" e "tamaño máximo de células superado". tdf#48516 (Eike Rathke)
    • Mellor manipulación de ficheiros CSV que non seguen a RFC 4180, regras de cita. tdf#48621 (Eike Rathke)
    • Importar números en notación científica sen ter que estabelecer "importación de números especiais". tdf#39716 (Eike Rathke)
    • Mellor opción estabelecida para os separadores iniciais: coma (,) punto e coma (;) tabulador (tab). tdf#38088 (Eike Rathke)
  • Engadida unha opción "Gardar fórmulas de celas no canto de valores calculados" ao exportar CSV. tdf#45664 (Florent Gallaire)
A opción para exportar fórmulas (CSV)
  • Nova función DATADIF definida polo estándar ODF OpenFormula e interoperabilidade con MS-Excel. tdf#44456 (Winfried Donkers, Eike Rathke)
  • Novas funcións para números complexos do estándar OpenFormula IMTAN, IMSEC, IMCOSEC, IMCOT, IMSENH, IMCOSH, IMSECH and IMCOSECH. tdf#51017 (Regina Henschel)
  • Compatibilidade con ítems de campos en celas. Pode introducir 'data, 'nome da folla de cálculo e o 'Título do documento nas celas. Para inserir un campo, acceda ao modo de edición da cela e use o menú contextual 'Inserir campos. (Kohei Yoshida)
Engadir campo nas células.
  • Pódese agora ordenar datos a través do menú de filtro automático. (Kohei Yoshida)
A opción de ordenación no menú do filtro automático.
  • Pegado rápido de texto, valor ou fórmula desde o menú de contexto da cela. (Noel Power)
A opción no menú contextual para "Soamente pegar".
  • Opcións de configuración detallada para cálculos de fórmulas. Pódese agora configurar a sintaxe das referencias para funcións internas de tipo indirecto. No futuro, podemos engadir máis opcións de cálculo que permiten que os usuarios configuren as súas fórmulas en tempo de execución. (Kohei Yoshida)
- Nova páxina de opcións de cálculos. Caixa de diálogo para ampliación das opcións de cálculo.
  • Retirada da limitación de 3 criterios de clasificación no Calc. tdf#45747 (Albert Thuswaldner)
diálogo de ordenación con múltiplas claves (máis de 3).
  • O número estándar de follas de cálculo nos novos documentos será 1 no lugar do 3 - tdf#50183, (Stefan Knorr). Teña en conta que desde a versión 3.5 se pode editar este parámetro en Ferramentas ▸ Opcións ▸ LibreOffice Calc ▸ predeterminado.
  • Capacidade de barras de erros no eixo X e gráficas progresivas e de barras, importación e exportación para xls e ods utilizando ODF 1.2 estendido. tdf#33773 (Rafael Domínguez)
  • Capacidade de escala de cores e barra de datos. Importación do XLSX e importación / exportación do ods en ODF 1.2 estendido. Atención: persisten algunhas limitacións que serán reparadas na versión 4.0.0. (Markus Mohrhard)
Escala de cores e barra de datos no Calc.
  • Novas caixas de diálogo de formato condicional para permitir as escalas de cores e barra de datos. (Deseño: Stefan Knorr, Implementación: Markus Mohrhard)

Impress

  • Novo formato "widescreen" (pantalla de 16:9) para diapositivas de Impress. tdf#42986 (Rob Snelders)
  • Detecta correctamente o monitor de vídeo externo e pon a consola do presentador no monitor de vídeo local. (Michael Meeks)
  • Dez novos modelos de páxina principal. (Alexander Wilms, Mateo Machado Luna, Björn Michaelsen)
Novos modelos.

Math

  • As caixas de diálogo para formato (tipo de letra, tamaño do tipo de letra) e símbolo (Ferramentas ▸ Catálogo) agora teñen botóns de axuda. tdf#47860, tdf#47862, tdf#47863, tdf#47864 (Karan Desai)
Botón de axuda engadido

IDE do Basic

  • Panel para Catálogo de Obxectos ancorados. (Bence Tomcsik)
Panel de obxecto ancorado ao IDE

Núcleo

  • Compatibilidade co tamaño postal xaponés en todos os aplicativos. (Takeshi Abe)
  • Lista de documentos recentes é actualizada ao 'Gardar, Gardar como, Gardar todo e 'Pechar. tdf#37775 (Muhammad Haggag)
  • Permite editar documentos que só permiten lectura (Stephan Bergmann). Interpretando a mensaxe remitida de [1]:
    • Por exemplo, ao ver anexos de mensaxes electrónicas (que foron almacenados como só de lectura nun cartafol do aplicativo de correos), sería interesante que o usuario puidese modificar temporalmente o documento (por exemplo, traballar nunha folla de cálculo, cambiar algúns números e recalcular as fórmulas) facendo clic no botón 'Editar ficheiro' sen a obriga de crear unha copia de edición e así:
      • O botón 'Editar ficheiro' agora só cambia o estado da vista de só permite lectura. Xan non se pregunta se gardar unha copia para editar cando o documento estea fisicamente en modo que só permite lectura.
      • Cando un documento modificado cambia o estado a modo que só permite lectura a través do botón 'Editar ficheiro', LibreOffice aínda preguntará se gardar ou descartar os cambios. Pero se o documento está fisicamente en modo que só permite a lectura, a caixa de diálogo 'Gardar como abrirase, en troques da caixa 'Gardar (o que producirá un erro no documento cando só permite lectura).
      • O título do documento agora amosará "só permite lectura", cando e soamente cando a visualización sexa en modo que só permite ou cando o documento estea fisicamente en modo que só permite lectura (ou ambos).
  • Engadida a opción 'Capacidade de ferramentas de tecnoloxías de asistencia' no proceso de instalación. tdf#39833 (Andras Timar).
  • Engadido o algoritmo Lanczos para redimensionamento de imaxes e a súa utilización no lugar do algoritmo de interpolación. Este cambio aumenta a calidade das imaxes cando se produce a redución da resolución na exportación a PDF. tdf#46378 (Tomaz Vajngerl)
Lanczos Resampling.jpg
  • A gravación de macros pode activarse nunha opción separada no menú Ferramentas ▸ Opcións ▸ Xeral ▸ Activar gravación de macro. tdf#41865 (Cor Nouws) Isto permite a utilización desta función, de forma limitada, sen necesitar activar os recursos experimentais, por estaren aínda inestábeis.
A opción para activar gravación de macro

Filtros

  • Filtro de importación para os documentos Corel Draw. Máis detalles aquí artigo.
-
terra v16.cdr no Corel Draw
terra v16.cdr no Corel Draw
terra v16.cdr no LibreOffice Draw
  • Exportación de PDF con opción de marca de auga. Acceso ao menú Ficheiro ▸ Exportar como PDF. (Andreas Mantke)
PDF export with watermark.png
  • A exportación como ODF agora vén como 'ODF 1.2 Estendido (modo de compatibilidade)', que ofrece unha interoperabilidade mellor con outros usuarios de software do Open Document Format. Chega a cambio do prezo de producir unha menor conformidade co estándar ODF. (Thorsten Behrens)

Interface gráfica de usuario (GUI)

  • Limpeza xeral da GUI de Windows Vista, 7 ou superior: foron eliminadas os bordos 3D nas regras e nas barras de estado; as barras de ferramentas non teñen bordos e teñen un suave fondo gradiente para mellorar a visualización. (Mirek Mazel, Stefan Knorr, Xan Holesovsky, Michael Meeks)
LibreOffice 3.5 LibreOffice 3.6
Libreoffice-3.5.png
Libreoffice-3.6.png
Libreoffice-3.5-mac.png
Libreoffice-3.6-mac.png
  • O conxunto de iconas estándar é agora o Tango no Os / X. (Michael Meeks e equipo UI)
  • As regras son máis "limpas" e máis lixeiras. (Deseño de Mirek M., aplicado por Xan Holesovsky)
Updated-rulers.png
  • O diálogo Sobre foi redeseñado para unha aparencia máis limpa (e máis elegante!). Acceso vía menú Axuda ▸ Sobre. (Andrew Higginson)
Modified-new-about-dialog.png
  • Writer e Calc usan botóns separados para a cor, polo que é posible aplicar a última cor utilizada cun clic do rato sobre a letra, fondo, bordo e cores de realzado. (Winfried Donkers)
Split-Colors-writer.png Split-Colors-calc.png
  • Ao premer >>, o botón de expansión xa non se amosan as opcións da barra de ferramentas. Estas opcións poden ser amosadas polo menú contextual (botón dereito do rato) da propia barra de ferramentas. tdf#38276 (Iain Billett)
Toolbar options menu in 3.6.png
  • Compatibilidade coa integración de Trinity Desktop Environment (trebellos - widgets -, diálogos de abrir / gardar, e axendas de enderezos). (Timothy Pearson e equipo orixinal de integración do KDE3)
En breve teremos unha imaxe ...
  • A elección do dicionario foi eliminada cando haxa só un dicionario activo. tdf#40778 (Caolán McNamara e Rob Snelders)
  • O zoom vai agora con progresión xeométrica en vez de aritmética. tdf#44173 (Tim Hardeck)
  • Os temas GTK son capaces agora de amosar gradientes de fondo. As imaxes seguintes utilizan a ramificación "LibreOffice" do Oxygen-gtk. (Ruslan Kabatsayev)
Toolbar-gradient-and-combo-list.png
  • Os temas GTK poden agora preiluminar as lapelas das caixas de diálogo. (Ruslan Kabatsayev)
Tab-prelight-and-themed-frame.png
  • Os temas GTK aplican agora liñas fixas e marcos. (Ruslan Kabatsayev)
Options-menu-with-themed-lines.png

Localización (Internacionalización)

  • Aplicáronse patróns localizados de data dependentes da súa aceptación, non caso de introducir datas incompletas.

Isto impide a detección de falsos positivos de datas en Calc e na introdución de datos nas celas e na importación de ficheiros CSV. Véxase o artigo para máis detalles. (Eike Rathke)

  • Engadida a localización "Inglés" da República de Malaui (en_MW). (Eike Rathke)
  • Engadida a localización "Erzya" da Federación Rusa (myv_RU).
  • Melloras nas ferramentas de idiomas (dicionarios para a corrección ortográfica, sinónimos, regras de guionización). Información do repositorio de dicionarios:
    • Corrector Vero (corrector ortográfico) actualizado. (Raimundo Moura)
    • Dicionario ortográfico sueco actualizado.
    • Dicionario ortográfico e sinónimos en francés actualizados.
    • Sinónimos checo actualizado.
    • Gran mellora nas ferramentas de idiomas en alemán (de-de, de-AT, de-CH) con máis de 30.000 novas palabras engadidas ao dicionario ortográfico alemán e 7000 novos sinónimos engadidos ao Thesaurus. A guionización tamén foi mellorada. <! - Declaración con base na mesma versión antiga do paquete de idioma e da nova versión do paquete de idioma e foi confirmada nun intercambio de mensaxes electrónicas cos autores do dicionario de corrector ortográfico e do Thesaurus. (Usuario Gerald) ->
  • A opción do idioma locale predeterminada pasa a ser a local do sistema operativo. tdf#45830 (Rob Snelders)

Rendemento

  • Perfeccionamento substancial na importación de documentos OLE2: DOC, xls e PPT. (Caolan McNamara, Michael Meeks)
  • Perfeccionamento substancial na importación simple de DOC e docx. (Michael Meeks, Caolan McNamara)
  • Perfeccionamento na desprazamento, redeseño e edición interactiva de documentos máis voluminosos. (Caolan McNamara)
  • Listas de autocorrección manexadas co dobre da velocidade. (Michael Meeks)
  • Perfeccionamento no manexo de táboas dinámicas no Calc. A actualización dunha táboa dinámica debe ser agora entre 35-50% máis rápido que na versión 3.5. Ademais, o consumo de memoria da táboa dinámica reduciuse substancialmente. (Kohei Yoshida)
  • Perfeccionamento na importación de valores das celas de documentos XLSX. (Daniel Bankston)
  • Perfeccionamento na manipulación de células fusionadas e importación de intervalos de matrices de documentos ods. (Daniel Bankston)
  • O mecanismo de bases de datos incorporado (HSQLDB) quedarán agora cun tamaño menor antes de se gardaren (LibreOffice usa "CHECKPOINT DEFRAG" e non só "CHECKPOINT"). O espazo ocupado polas filas eliminadas será entón realmente liberado, malia que gardar/pechar un ficheiro levará máis tempo. (Lionel Mamane)

Infraestrutura

  • Varios módulos convertidos a un máis rápido e fiábel gnumake. (David Tardon, Matus Kukan, David Ostrovsky e outros colaboradores)