LibreOffice 5.0 Примечания к выпуску

From The Document Foundation Wiki
Jump to: navigation, search

Contents

Writer

Поддержка автозамены специального текста на значки Emoji и иные символы прямо в тексте

Современные операционные системы имеют поддержку Unicode 6, включая значки Emojis и некоторые другие полезные специальные символы. LibreOffice 5 получил новое расширение Автозамены для упрощения ввода значков Emoji и других специальных символов Unicode, используя стандартные словосочетания для вызова Emoji, и другие ключевые слова, окруженные двоеточиями. Например: текст :keyboard: будет заменён на символ ⌨ (U+2328), текст :camera: на 📷 (U+1F4F7), текст :alpha: на α. Полный список замен можно посмотреть, используя пункт меню Сервис ▸ Параметры автозамены… ▸ Замена (только для локали en-US в версии LibreOffice RC):

Диалог Автозамена, в котором показаны вызовы Emoji и символы Unicode Emoji (используйте стандартный шрифт Windows Segoe UI Emoji)

Разделитель двоеточие для функций автозамены в Libreoffice обрабатывается особым образом: при постановке конечного двоеточия слово вместе с двоеточиями будет заменено (ненужно использовать завершающий пробел). Это может быть полезно для пользовательской замены символов в типографии, фонологии и др. Некоторые из них уже есть в настройках автозамены по умолчанию:

:-: → − (минус, U+2212)
:--: → – (n-дефис, U+2013)
:---: → — (m-дефис, U+2014)
:x: → × (знак умножения, U+00D7)
:': → ’ (апостроф, U+2019)
:inch: → ″ знак дюйма (U+2033)

Или замена последовательности:

:alpha::<=::sum::Phi::_i: → α≤∑Φᵢ

Вызовы Emoji будут локализованы к моменту выхода финальной весрии LibreOffice 5.0 (смотрите также).

Предварительный просмотр стилей в Боковой панели

На вкладке Боковой панели "Стили и форматирование" теперь отображается предварительный просмотр стилей. tdf#73071 (Rishabh Kumar)

Слева отображение стилей в боковой панели в версии 4.4, справа - в версии 5.0


Выделение текста совместимое с MS Word

  • Теперь и выделение и затенение текста сохраняются при импорте/экспорте документов в формате Microsoft Word. tdf#64490 (Tamás Zolnai)
  • Добавлена новая настройка совместимости для выбора типа фона текста при экспорте из LibreOffice в форматы Microsoft Office: как подсветка или как затенение. tdf#64490 (Tamás Zolnai)

Чтобы использовать эту настройку, выберите пункт меню Сервис ▸ Параметры ▸ Загрузка/Сохранение ▸ Microsoft Office. Более подробно это описано в этом блоге

Новая настройка для совместимости с Microsoft Office

Обрезка изображения (кадрирование)

Стала доступна функция обрезки (кадрирования) изображения с использованием мыши. Она доступна из контекстного меню изображения, из меню Формат ▸ Изображение ▸ Кадрирование изображения и на панели инструментов "Изображение". tdf#34555 (Philippe Jung)

Доступны следующие операции:

  • перетаскивание отметки по середине границ изображения для обрезки только по вертикали или только по горизонтали,
  • перетаскивание угловой отметки для одновременной обрезки по обеим осям изображения,
  • перетаскивание с зажатой клавишей ⇧ Shift для пропорциональной обрезки изображения относительно изначальных размеров,
  • обрезка сохраняется вовремя изменения размеров изображения,
  • выход из режима обрезки осуществляется по нажатию клавиши Esc или если щелкнуть мышью за пределами изображения.
Обрезка изображения в Writer

Улучшение в расчёте отображаемого номера страницы в строке состояния

В LibreOffice была зафиксирована проблема с неправильным отображением номера страницы в строке состояния при прокрутке документа (жуткое наследие OpenOffice.org). Writer теперь обновляет номер страницы, если на экране отображается не менее 43% от ее размера. tdf#90150 i#80672 (Hamidi Massinissa).

Управление таблицами

  • Вставка строк и столбцов в таблицу теперь зависит от количества предварительно выделенных строк или столбцов, аналогично Calc. tdf#90883 (Philippe Jung)
  • В контекстное меню таблицы добавлены пункты "Вставить строку до", "Вставить строку после", "Вставить столбец слева", "Вставить столбец справа" (относительно текущего положения курсора). tdf#90882 (Philippe Jung, Yousuf Philips)

Улучшения панелей инструментов

Произведено дополнительное улучшение панелей инструментов “Стандартная”, “Форматирование”, “Рисование”, а также контекстных панелей для предоставления пользователям наиболее часто используемых команд. tdf#81475 (Yousuf Philips)

Улучшения импорта документов в формате DOC

До настоящего времени импорт текста с примечаниями был проблематичным , теперь он должен проходить так же хорошо как и в форматах ODT/DOCX/RTF. i#93570 blog entry (Miklós Vajna, Collabora)

Корректрое наложение комментариев при импортировании из DOC.

Улучшение импорта OOXML

Улучшена поддержка для команды arcTo в формах OOXML, описанных при помощи DrawingML. tdf#87448 описание в блоге (Miklós Vajna, Collabora)

Теперь команды drawingML arcto отображаются правильно.

Улучшения при импорте из формата RTF

  • Математические формулы, встроенные в текстовый документ старых форматов (до-2010 для RTF, до-2007 для DOCX), теперь импортируются, как редактируемый объект "математическая формула". Подробности (Miklós Vajna, Collabora)
Объект MathType, встроенный в документ RTF теперь можно редактировать, как объект Math.

Перетаскивание изображений

Стало доступно перетаскивание изображений в Writer в операционной системе Mac OS X. tdf#44621 (Manik Malhotra)

Опциональные метки при сравнении документов

Если Вы не используете случайные числа для повышения точности сравнения документов в повседневной работе, то теперь эту функцию можно отключить в менюСервис ▸ Параметры ▸ LibreOffice Writer ▸ Сравнение. tdf#68183 (Miklós Vajna, Collabora)

Новая функция отключения меток

Calc

  • Для сводных таблиц стало доступно повторение подписей элементов (см.скриншот). Эта возможность доступна, как дополнительная настройка. При создании сводной таблицы дважды щелкните мышью по нужному полю в списке "Поля строк". В открывшемся диалоге "Поле данных" нажмите на кнопку "Параметры". В следующем диалоге отметьте флажком опцию "Повторять подписи элементов". Нажмите OK. tdf#87972 (Deena Francis) Скриншот

Условное форматирование

  • В настройки условного форматирования была добавлена возможность заливки гистограммы сплошным цветом (в добавление к уже существующему градиенту). Сам функционал был доступен ещё начиная с версии 3.6. tdf#87356 (Katarina Behrens)
Градиент слева до версии 5.0, сплошной цвет справа в версии 5.0
  • Гистограмма теперь может быть отображена без самих значений в ячейках. Сам функционал был доступен ещё начиная с версии 3.6. tdf#89199 (Katarina Behrens)
Слева гистограмма со значениями в ячейках, справа - без значений
  • Для гистограммы теперь можно задать минимальную и максимальную длину столбца tdf#90197 (Benjamin Ni and Markus Mohrhard)
Сверху гистограмма с 50% максимальной длиной, снизу - со 100% длиной
  • Исправлен экспорт форматирования для условного форматирования в формат XLSX. (Markus Mohrhard)
  • Доступен импорт гистограмм и цветовых шкал с цветами, настроенными пользователем. tdf#90511 (Markus Mohrhard)
  • Реализован импорт и экспорт произвольного набора значков (включая расширения OOXML в MSO) (без интерфейса!) (Markus Mohrhard)
  • Добавлены новые наборы значков: 3 треугольника, 3 звезды, 5 коробок (Markus Mohrhard)

Научный формат и Числовой формат

(Laurent Balland-Poirier и Eike Rathke)

  • Инженерная запись: tdf#30716
    • включен показатель степени кратный 3 (или другому значению) в формате ##0.00E+00: устанавливает количество цифр (# или 0) до десятичного разделителя.
    • добавлен формат ##0.00E+00 к списку научных форматов в диалоге Формат ▸ Ячейки ▸ Числа ▸ Научный для всех локализаций.
    • для научного формата чисел опция Разделитель тысяч заменена на Инженерная запись. tdf#90258
Новая опция Инженерная запись
  • Общий научный формат теперь содержит 2 цифры (вместо 3) в показателе степени для всех локализаций. tdf#88835
  • Линия тренда теперь содержит 1 цифру в экспоненте (вместо 3). tdf#88835
  • Добавление/удаление десятичных знаков научного формата кнопками: на панели инструментов Большие разрядов/Меньше разрядов tdf#88960; на боковой панели Свойства ▸ Формат чисел ▸ Дробная часть tdf#88999; в диалоговом окне, вызываемого из меню Формат ▸ Ячейки ▸ Числа ▸ Дробная часть. tdf#88999
  • Позволяет задать десятичную часть в формате 0.0##E+00 для научных чисел и 0.0## для обычного числового формата (десятичная часть может содержать несколько 0 и затем несколько #). Этот формат теперь корректно сохраняется в ODF файлах. tdf#90133
  • Знак степени может быть пропущен для положительных степеней в формате 0.00E00 (пропущен знак после E). Этот формат теперь корректно сохраняется в ODF файлах. tdf#90133

Движок формул

Таблицы со структурированными ссылками

Здесь описаны структурированные ссылки для Excel.

  • Таблицы со структурированными ссылками в формулах теперь нормально импортируются из электронных таблиц Excel OOXML.
  • Использование с определёнными диапазонами базы данных, OOXML таблиц (содержат элементы <table>) которых были импортированы.
  • При импорте действуют следующие ограничения:
    • Структурированные ссылки внутри именованных выражений не поддерживаются.
    • Имя столбца должно быть задано в строке-заголовке таблицы; column-header-less tables are not supported.
    • При сохранении в формат ODF или OOXML структурированные ссылки не будут записаны, а вместо этого трансформируются в представление в стиле А1. Ссылки продолжат работать, но контекст таблицы при экспорте будет потерян.
    • Сохранение в OOXML, заданных диапазонов баз данных, не экспортируются как элементы <table>.
    • При сохранении в формат .xls (MS Excel 97-2003) формулы, использующие структурированные ссылки будут утрачены.

tdf#85063 (Eike Rathke)

Новые функции

  • Изменения, связанные с функциями FLOOR и CEILING: tdf#69552 (Winfried Donkers and Eike Rathke)
    • Второй параметр функций FLOOR и CEILING теперь опциональный, как это описано в стандарте OpenFormula (ODFF).
    • Дополнительные функции FLOOR.XCL и CEILING.XCL были введены для ввода двух параметров, оба параметра при этом обязательны. При импорте из документа Microsoft Excel функции FLOOR и CEILING будут импортированы, как FLOOR.XCL и CEILING.XCL
    • Новые функции FLOOR.MATH и CEILING.MATH были добавлены для совместимости с Microsoft Excel.
    • При экспорте в формат Microsoft Excel, функции Calc FLOOR и CEILING будут записаны, как функции Excel FLOOR.MATH и CEILING.MATH, а функции Calc FLOOR.XCL и CEILING.XCL будут записаны, как функции Excel FLOOR и CEILING
  • Добавлена функция ENCODEURL для совместимости с Microsoft Excel. tdf#76870 (Winfried Donkers)
  • Добавлена функция ERROR.TYPE в соответствии со стандартом OpenFormula (ODFF) и для совместимости с Microsoft Excel. (Winfried Donkers)

Ссылки на всю строку или весь столбец, вида 1:1 и A:A

tdf#44419 (Eike Rathke)

  • Теперь можно указать ссылки на целую строку или столбец, используя ссылки вида A:A или 1:1 вместо A1:A1048576 или A1:AMJ1
    • Такие ссылки будут сохранены в виде $1:$1048576 или $A1:$AMJ1 для совместимости с более ранними версиями LibreOffice и другими приложениями для чтения электронных таблиц в формате ODF.
    • При чтении из документа ссылки $1:$1048576 или $A1:$AMJ1 преобразуются в А:А или 1:1 соответсвенно.
      • Обратите внимание, что ссылки на всю строку или весь столбец должны быть абсолютными, чтобы они могли быть преобразованы в ссылки вида A:A или 1:1.
    • Inserting rows/columns to or deleting rows/columns from entire column/row references keeps the anchored other axis' endpoints, in particular inserting rows in a column reference will not produce a #REF! error and deleting rows in a column reference will not move the last referenced row that number of rows up, contrary to the standard A1:A1048576 reference behaviour.
    • Стандартные абсолютные/относительные адреса ячеек также можно использовать, например: A:B, A:$B, $A:B и $A:$B будут действующими и позволят осуществить те же стандартные операции, что и в случае обычных ссылок на ячейки, например: копировать, вставить, заполнить, переместить и другие операции редактирования в электронных таблицах, влияющие на указываемые ячейки в формуле.

Обрезка (кадрирование) изображения, замена изображения на другое, сохранение в графический формат

tdf#34555 (Philippe Jung)

  • Чтобы обрезать изображение с помощью мыши, чтобы сохранить изображение или заменить его другим изображением, используйте пункты меню Формат ▸ Изображение, контекстное меню изображения или инструменты в панели инструментов "Изображение".
  • Эта функциональность такая же, как и в Impress или Writer.
  • Меню Формат было соответствующим образом обновлено:
    • в меню Формат ▸ Объект добавлены пункты "Позиция и размер", "Линия", "Область", "Текст" и "Изменение геометрии",
    • в меню Формат ▸ Изображение добавлены пункты "Кадрирование изображения", "Ссылка на внешние данные", "Заменить изображение", "Сжать изображение", "Сохранить изображение".
Обрезка изображения в Calc

Улучшения панелей инструментов

Были выполнены дополнительные улучшения в панелях инструментов Стандартная и Форматирование, а также в контекстных панелях инструментов для предоставления пользователям наиболее часто используемых команд. tdf#85594 (Yousuf Philips)

Impress и Draw

  • Контекстные меню изображения и графической фигуры были улучшены путем удаления редко использовавшихся элементов. tdf#86614 (Yousuf Philips)
  • Переработан выпадающий инструмент выбора цвета заливки области в Impress и Draw. запись в блоге (Caolán McNamara, Red Hat)
Новый выпадающий инструмент выбора цвета в Draw и Impress
  • Цвет фона текста в текстовом поле Draw/Impress теперь может быть установлен кнопкой на панели инструментов и боковой панели. tdf#88276 (GSoC 2014, Matteo Campanelli) (blog post) (Katarina Behrens, CIB)
Кнопка на панели инструментов для установки цвета фона текста в текстовом поле Draw/Impress

Math

Смотрите также раздел: Удалённые возможности и функциональность

Base

Диаграммы

Линии тренда

  • Настройка Пересечение теперь доступна для экспоненциальных линий тренда. tdf#72361 (Laurent Balland-Poirier)

Ядро

Поддержка протокола Time-Stamp при экспорте в PDF

  • При экспорте в PDF теперь поддерживается протокол Time Stamp. Настройки доступны на вкладке "Цифровая подпись" в диалоге экспорта в PDF tdf#84881 (Tor Lillqvist, Collabora)
Настройки Time-Stamp на вкладке "Цифровая подпись" PDF
Добавление нового источника Time-Stamp

Поддержка Adobe Swatch Exchange (.ase)

  • Поддержка цветовых палитр Adobe Swatch Exchange (.ase). Поддерживаются CMYK, RGB и оттенки серого. Цвета LAB пока не поддерживаются и при импорте заменяются чёрным цветом. (tdf#84002, проспонсировано пользователями LibreOffice через FreedomSponsors.org) (Chris Laplante)

Поддержка невидимого содержимого в электронной почте

  • Добавлена настройка для сохранения невидимого содержимого документа при отправке документа по электронной почте. tdf#87441 (Stephan Bergmann)

Фильтры

Новые фильтры импорта

  • Writer теперь может импортировать файлы Apple Pages (Pages версии '09 или старше), используя libetonyek. (David Tardon)
Образец документа, открытый в Pages '09
Образец документа, открытый в LibreOffice 5.0
  • Calc теперь может импортировать файлы Apple Numbers (Numbers версии '09 и старше), используя libetonyek. (Anurag Kanungo, GSoC 2015)
    • Только для предварительного просмотра. Не пожалейте времени для отчёта об ошибках.
  • Draw теперь может импортировать файлы ClarisDraw и MacDraft (v. 1), используя libmwaw. (Laurent Alonso)
  • Calc теперь может импортировать файлы Lotus 123 (wk3, wk4) и файлы Quattro Pro (wq1, wq2), используя libwps. (Laurent Alonso)

Улучшения в фильтре OOXML

  • Добавлена обработка различий между реализацией OOXML для MSO 2007 и официальными спецификациями. (Markus Mohrhard)
  • Chart streams support MSO 2007 and OOXML conforming input now. (Markus Mohrhard)
  • Chart streams are exported according to OOXML spec and no longer according to MSO 2007 format. (Markus Mohrhard)

Улучшения в фильтре экспорта в формат MediaWiki

Robert Buj произвел следующие улучшения компонентов фильтра экспорта в MediaWiki:

  • Замена <text>&#10;</text> на <value-of select="$NL"/>
Изображение
  • Добавление альтернативного текста в изображение
  • Добавлена поддержка для изображения align with wrap='none'
Абзац
  • Удален тег
  • Добавлена поддержка для цвета фона и цвета шрифта
Таблица
  • Ячейка
    • Использование выравнивания элементов
    • Добавлена поддержка для цвета фона и цвета шрифта
    • Если все ячейки имеют одинаковый стиль, то это указывается в строке
  • Таблица
    • Добавлена поддержка выравнивания и ширины таблицы
  • Строка
    • Исправлено появление новой строки в конце существующей строки
  • Заголовок
    • Treat the header like the row
Текст
  • Добавлена поддержка для цвета фона и цвета шрифта

Улучшения в фильтре импорта Keynote

  • Корректная установка языка текста. (David Tardon)
  • Импорт связей и ссылок. (David Tardon)
  • Исправлен импорт табуляции. (David Tardon)
  • Исправлен импорт простого текстового содержимого ячейки, который ранее игнорировался. (David Tardon)
  • Импорт нескольких свойств форматирования текста и абзаца. (David Tardon)
  • Импорт метаданных документа. (David Tardon)
  • Исправлена опечатка, которая была причиной крахов для всех фигур. (David Tardon)
  • Импорт обрамления таблиц. (Anurag Kanungo)

Улучшения в фильтре импорта MS Works

  • Запрашивается кодировка текста, если она не может быть определена автоматически. tdf#87222 (Laurent Alonso)

Улучшения в фильтре импорта Adobe Freehand

  • Значительно улучшен импорт заливки, линий, внедрённых изображений и встроенного текста. (Fridrich Strba)
  • Исправлено позиционирование видимых объектов на холсте. (Fridrich Strba)
  • Поддержка охватывает форматы от Freehand 3.0 до Freehand 11. (Fridrich Strba)

Интерфейс

Общие изменения в интерфейсе

  • Пользовательский интерфейс Impress был улучшен, чтобы обеспечить больше места для редактирования самого слайда, скрывая при этом контекстные панели инструментов. tdf#87676 tdf#87822 (Yousuf Philips, Philippe Jung)
LibreOffice Impress New UI.png
  • Пользовательский интерфейс Draw был улучшен путем скрытия контекстных панелей инструментов форматирования, совместив панели инструментов различных фигур, чтобы Draw стал походить на другие приложения для рисования. Также была расширена боковая панель, чтобы обеспечить доступ к опциям форматирования. tdf#90090 (Yousuf Philips; Jan Holešovský, Collabora)
LibreOffice Draw New UI.png

Изменения в боковой панели

  • Кнопка скрытия/показа боковой панели сделана более заметной. tdf#83527 (Tomaž Vajngerl)
The previous appearance is shown in the bottom-left corner for comparison.
  • Переделан раздел "Смена слайдов" на боковой панели Impress. tdf#87862 (Katarina Behrens, Rishabh Kumar, Yousuf Philips)
  • Сокращена вкладка "Свойства" в Calc, таким образом, чтобы помещалась по высоте в современные широкоформатные мониторы tdf#90888 (Rishabh Kumar, Yousuf Philips)
  • Реорганизованы кнопки вкладок боковой панели в Impress tdf#87904 (Yousuf Philips)
  • Добавлены кнопки увеличения и уменьшения отступа в соответствующую секцию на вкладке Свойства в Impress и Draw. tdf#91944 (Maxim Monastirsky, Yousuf Philips)
  • Добавлены кнопки структуры на боковую панель в Impress и Draw tdf#87651 (Maxim Monastirsky)

Изменения вкладок листов в Calc/Draw

Следующие изменения были выполнены силами Tomaž Vajngerl (Collabora):

  • Кнопок прокрутки ярлыков осталось две, вместо четырёх. Теперь переход к первому и последнему листу в списке осуществляется при нажатии на соответствующую кнопку при удерживании клавиши Ctrl.
  • У кнопок "Добавить лист", "Предыдущий лист" и "Следующий лист" теперь отсутствует граница.
  • Строка с ярлыками листов теперь может быть прокручена колесом мыши (только, если часть ярлыков не видна). tdf#59471
5.0 Calc tabs.png

Изменения в поддержке HiDPI

Смотрите также: Development/HiDpi
  • Масштабирование значков меню (Tomaž Vajngerl, Collabora)
  • Увеличение размера строки состояния в зависимости от разрешения экрана (Tomaž Vajngerl, Collabora).
  • Масштабирование значка "Добавить лист" возле ярлыков листов в Calc (Tomaž Vajngerl, Collabora).
  • Масштабирование линеек в зависимости от разрешения экрана (Darcy Beurle).
  • Масштабирование индикатора перетаскивания в вышеупомянутой панели вкладок (Tomaž Vajngerl, Collabora).

Улучшения курсора мыши в Windows

  • Из сборки для Windows удалены устаревшие курсоры, которые были жестко прописаны в коде, сделанные еще во времена StarOffice. Вместо них были добавлены современные tdf#53148 tdf#53151 (Rimas Kudelis)

Контекстное меню

  • Переделано контекстное меню изображения. Elaborate on the specific changes! tdf#87185 (Yousuf Philips)
  • Переделано контекстное меню таблицы. Elaborate on the specific changes! tdf#86619 (Yousuf Philips)
  • Из контекстного меню удалены все пункты, относящиеся к "прямому" форматированию, поскольку эти функции доступны на панелях инструментов и в боковой панели. tdf#86606 (Yousuf Philips)
  • Пункты Копировать, Вырезать, Вставить теперь всегда отображаются в контекстном меню. tdf#86850 (Trent MacAlpine)
  • Пункты контекстного меню панели инструментов показываются с маленькими иконками. tdf#91953 (Philippe Jung)
  • Теперь при вызове контекстного меню панелей инструментов в верхней части меню отображается название панели инструментов. tdf#86138 (Philippe Jung)
Контекстное меню панели инструментов

Новая тема значков Breeze

  • Новый набор значков Breeze был добавлен в LibreOffice. (Uri Herrera (Nitrux, S. A.), Andreas Kainz (KDE e. V.), Jonathan Riddell (Kubuntu), Jan Holešovský (Collabora), Yousuf Philips и Andrew Dent).
Панели инструментов Writer
Панели инструментов Calc
Панели инструментов Draw
Панель инструментов Рисование в Draw
Панели инструментов Impress
Выпадающее меню Создать на Стандартной панели инструментов

Обновление набора значков Tango

Новые значки от Alexander Wilms, Adolfo Jayme Barrientos и Yousuf Philips были добавлены в тему Tango.

Обновление набора значков Sifr

Matthias Freund исправил ошибки и добавил новые значки для темы Sifr.

Улучшение для Экспертных настроек

Следующие изменения были сделаны Palenik Mihály:

  • В экспертные настройки добавлен поиск. core commit 3d403f2a
  • Строки таблицы с настройками были раскрашены в два цвета для упрощения поиска и восприятия информации. core commit 148e489e
ExpertConfiguration 5.0+ wSearch.PNG

Локализация

Новая локализация на языке Гуарани

Интерфейс LibreOffice был полностью переведен на Гуарани (avañe’ẽ), родной язык индейцев Парагвая. Отдельное спасибо Giovanni Caligaris (который ведёт эту работу), András Tímar (Collabora), Christian Lohmaier и Eike Rathke (Red Hat).

Новые языки / языковые настройки

Доступны, как язык по умолчанию для документов, и специальные языковые настройки:

  • В список языков и языковых настроек добавлен Церковно-славянский язык [cu-RU]. tdf#90802 (Aleksandr Andreev и Eike Rathke)
  • Добавлены языковые настройки для ньянджа (язык племён Банту) [ny-MW]. tdf#89395 (Eike Rathke)
  • Добавлен венетский язык [vec-IT] в список языков и языковых настроек. tdf#91199 (Eike Rathke, it46.se/localegen data by kinfe)
  • Добавлены языковые настройки для тигринья [ti-ET]. tdf#91849 (Eike Rathke, it46.se/localegen data by veneto.abc)

Обновление утилит проверки правописания

  • Комплект испанских орфографических словарей обновлен до версии 0.8. (Jacobo Aragunde Pérez)
  • Комплект португальских орфографических словарей обновлен до версии 15.4.4.1. (András Tímár)
  • Комплект французских орфографических словарей обновлен до версии 5.3.2. (Olivier R.)
  • Несколько исправлений было сделано в чешских файлах. (Petr Gajdos and Tomáš Chvátal)

Другие языковые инициативы

Мы стремимся поддерживать максимально возможное количество языков. Мы хотели бы поблагодарить следующих людей за добровольный перевод LibreOffice и за их стремление помочь сохранить их родные языки:

  • Чеченский:
  • Кабильский: Hamidi Massinissa
  • Венецианский: Alessandro Mocellin

Производительность

Scripting / Basic

Удалённые возможности и функциональность

  • Наследие StarOffice, устаревшая настройка "Системный шрифт для интерфейса" (в меню Сервис ▸ Параметры ▸ LibreOffice ▸ Вид) была удалена. С этого выпуска LibreOffice всегда будет использовать системный шрифт в своём интерфейсе. tdf#87016 (Julien Nabet и Caolán McNamara (Red Hat)).
  • Удалена старая панель элементов Math в связи с появлением новой в версии 4.1. tdf#68871 (Julien Nabet и Adolfo Jayme Barrientos).
  • Удалена возможность вставлять гиперссылки с протоколами news:// Wikipedia logo v3.svg, IMAP Wikipedia logo v3.svg и POP3 Wikipedia logo v3.svg. (core commit 6d089a4c, core commit 52417882) (Tor Lillqvist (Collabora)).
  • Удалена рудиментарная поддержка протокола Gopher. tdf#89361 (Adolfo Jayme Barrientos).

Изменения API

Связывание C++ UNO и URE библиотек

Будут внесены следующие изменения:

Изменения в UNO API

Следующие интерфейсы и сервисы UNO будут изменены:

Writer

  • Созданы новые команды UNO для вставки в таблицах:
    • InsertColumsBefore : вставляет столбцы до выбранных. Если выбрано более одного столбца, будет вставлено столько столбцов, сколько выбрано.
    • InsertRowsBefore : вставляет строки до выбранных. Если выбрано более одной строки, будет вставлено столько строк, сколько выбрано.
    • InsertColumsAfter : вставляет столбцы после выбранных. Если выбрано более одного столбца, будет вставлено столько столбцов, сколько выбрано.
    • InsertRowsAfter : вставляет строки после выбранных. Если выбрано более одной строки, будет вставлено столько строк, сколько выбрано.
    • Эти команды необходимо предпочесть командам .uno:InsertColumns и .uno:InsertRows. Для совместимости с предыдущими версиями .uno:InsertColumns и .uno:InsertRows эквивалентны .uno:InsertColumnsAfter и .uno:InsertRowsAfter соответсвенно.
  • Следующие команды UNO теперь доступны в Writer:
    • .uno:CompressGraphic
    • .uno:ChangePicture
    • .uno.Crop<c/ode>

Calc

  • Следующие команды UNO теперь доступны в Calc:
    • .uno:ChangePicture
    • .uno:SaveGraphic
    • .uno.Crop

UNO API removals

Следующие интерфейсы и сервисы UNO будут удалены: API:

Совместимость с платформами

Windows

  • Доступна 64-битная сборка LibreOffice для ОС Windows.
    • TDF рекомендует использовать для нее Windows Vista или более позднюю версию (это связано со средой сборки разработчиков, пока windows XP x86-64 не поддерживается!).
    • Доступ к адресным книгам Outlook и Outlook Express пока не поддерживается, до разработки нового драйвера (смотри tdf#56903 и tdf#56905).
    • Недоступен экспериментальный драйвер для баз данных Firebird.
    • Информация по разработке сборки - Development/msvc-x86_64.

Android

  • Доступны самые базовые операции редактирования документов. Более подробно это описано в блоге разработчиков: 1 2 3 4 5 (Miklos Vajna, Tomaz Vajngerl, Siqi Liu, Henry Castro, Kohei Yoshida, Jan Holesovsky - Collabora)
Выделение текста в Writer на Android.
Выделение ячеек в Calc на Android.