LibreOffice 5.0 Release Notes

From The Document Foundation Wiki
Jump to: navigation, search

Contents

Acerca de está página

This is an in-progress scratch-pad of notes to build release notes from as and when we release. Please do not list features that are to be shipped already in the 4.4 release! Please do not add wish-list features that you hope will be implemented, but only what actually is implemented already.

What does a good feature look like here:

  • It has a description, and a way for a busy reviewer, to find and play with the feature. Target someone who is extremely busy, and knows little-to-nothing about the product. So if a user interface element is key to the feature, be very explicit about where it is, e. g. Menu ▸ Format ▸ Character ▸ Position [tab] ▸ ‘90 degrees’ paths to the elements you changed. Of course, you know your feature is important, and that everyone should care about the Extensible AutoShapes Properties dialog – but often the guys taking the screenshots and writing the notes do not.
  • It credits the main authors who did the work – just add them in brackets after the feature, where possible.
  • If the feature can be shown off with a sample / test file – particularly for new import-able features, it would be wonderful to have a link to/up-load of a test file that we can use to show that feature off to best effect. That really helps us to make good screenshots to show off the features, and allows reviewers to do their testing.

Thanks in advance for your help filling this out!


Writer

Soporte para reemplazar Emoji e in-word

Los sistemas operativos modernos cuentan con soporte de Unicode 6 con varios Emojis y caractéres especiales. LibreOffice 5 tiene un nuevo sistema de autocorrección para simplificar el uso de estos Emojis y otros caracteres Unicode usando los shortcodes de facto.
Por ejemplo: Escribiendo en Writer, :teclado: aparecerá ⌨ (U+2328), :alfa: por α. Se puede consultar la lista completa en Herramientas ▸ Opciones de autocorrección… ▸ Reemplazar:

Cuadro de diálogo de autocorrección con los shortnames de Emoji(usando la fuente standard Windows Segoe UI Emoji)

Las palabras encerradas entre dos puntos son manejadas especialmente por la característica de autocorrección de LibreOffice: son reemplazadas inmediatamente sin necesidad de escribir un espacio en blanco. Es muy útil cuando se hacen documentos de topografía, fonología. matemáticas, etc. Algunas de estas palabras son:

:-: → − (signo de resta, U+2212)
:--: → – (n-dash, U+2013) (ver tdf#55292)
:---: → — (guión largo, U+2014) (ver tdf#55292)
:x: → × (signo de multiplicación, U+00D7)
:': → ’ (apostrofo, U+2019)
:pulgada: → ″ pulgada (U+2033)

Ejemplo de reemplazamiento múltiple::

:alfa::<=::sumatoria::Fi::_i: se transforma en α≤∑Φᵢ

Los shortcodes han sido traducidos completa o parcialmente. (László Németh, Collabora and translators of LibreOffice project: Mihail Balabanov (Bulgarian), Joan Montané (Catalan), Mihovil Stanić (Croatian), Stanislav Horáček (Czech), Leif Lodahl (Danish), Kees538 (Dutch), Harri Pitkänen (Finnish), Jean-Baptiste Faure (French), Dimitris Spingos (Greek), László & Réka Németh (Hungarian), Valter Mura (Italian), Ingmārs Dīriņš (Latvian), Kolbjørn Stuestøl (Norwegian Nynorsk), Sérgio Marques (Portuguese), Olivier Hallot (Brazilian Portuguese), Nagy Ákos (Romanian), Bormant (Russian), Miloš Šrámek (Slovak), Martin Srebotnjak (Slovenian), Stuart Swales (British English), Niklas Johansson (Swedish), Necdet Yucel (Turkish) and their contributors, see also more)

La existencia de los caracterés dependerá del tipo de letra (Fuente) que se este utilizando.

Previsualización de los estilos en la barra lateral

El deck de estilos y formatos en la barra lateral ahora previsualiza los estilos para darnos una idea de como se verían en nuestro documento. core commit ca95307638207db5d662059aa61594151a13e927
Esta característica puede ser deshabilitada en la configuración de expertos con la propiedad /org.openoffice.Office.Common/StylesAndFormatting Preview cambiandola a false. (Tomaž Vajngerl, Collabora)

LO 4.4-5.0 Sidebar Style.jpeg

Compatibilidad con el texto marcado en Word

  • El marcado y sombreado de texto es preservado durante la importación / exportación de los documentos de Microsoft Word. tdf#64490 (Tamás Zolnai)
  • Nueva opción de compatibilidad que especifica como exportar el fondo del caracter de LibreOffice a Microsoft Office. tdf#64490 (Tamás Zolnai)
Para usar esta opción ir Herramientas ▸ Opciones ▸ Cargar/Guardar ▸ Microsoft Office. Para mas información ver this blog post
Nueva opción de compatibilidad con Microsoft Office

Recortar una imagen

Ahora es posible recortar una imagen con el ratón. La acción es posible desde el menú contextual, o desde en menú Formato ▸ Imagen ▸ Recortar la imagen y en la barra de herramientas. tdf#34555 (Philippe Jung)

Las mejoras implican:

  • Recortar de forma vertical u horizontal desde los bordes,
  • Recortar desde las esquinas,
  • Recortar con las teclas ⇧ Shift presionadas de forma proporcional.
  • El recortado se mantiene si se cambia el tamaño de la imagen,
  • El modo de recorte se detiene presionando la tecla Esc o se da un clic fuera de la imagen.
Recortando una imagen en Writer

Mejor cálculo del número de página desplegada

Otro detalle heredado de OpenOffice.org causaba que en Writer la barra de estado desplegara un número de página incorrecto cuando se movia la barra de desplazamiento. Ahora ha sido corregido en LibreOffice. Writer actualiza el indicador de página cuando se ve menos del 43% de la página en la pantalla. tdf#90150 i#80672 Gracias a: Hamidi Massinissa.

Manejo de tablas

  • Insertar filas o columnas dependiendo de la selección, similar a Calc. tdf#90883 (Philippe Jung)
  • Capacidad de agregar filas o columnas antes y después de la sección desde el menú contextual. tdf#90882 (Philippe Jung, Yousuf Philips)

Mejora en las barras de herramientas

Mejoras en las barras de herramientas “Estandard”, “Formato”, “Dibujo” y contextuales con las funciones mas frecuentes. tdf#81475 (Yousuf Philips)

Mejoras en archivos DOC

Importación de notas de los formatos binarios DOC con correciones, como se comporta desde formatos ODT/DOCX/RTF. i#93570 [Leer el blog http://vmiklos.hu/blog/perfect-ww8-comment-import.html] (Miklós Vajna, Collabora)

Notas importadas desde archivos DOC.

Mejoras con archivos OOXML

Mejora al soporte del comando arcTo en OOXML de figuras usando drawingML. tdf#87448 [Entrada de blog http://vmiklos.hu/blog/cloud.html] (Miklós Vajna, Collabora)

Comandos arcto drawingML se dibujan correctamente.

Mejoras con archivos RTF

  • Las ecuaciones matemáticas que usan el estilo antigüo (pre-2010 for RTF, pre-2007 for DOCX) embebidas en los archivos RTF ahora son importadas como objetos Math. [Ver entrada de blog http://vmiklos.hu/blog/mathtype-import.html] (Miklós Vajna, Collabora)
Ecuaciones matemáticas embebidas en RTF pueden ser editadas como un objeto Math.

Arrastrar y soltar imagenes

El arrastar y soltar imagenes ahora trabaja en Mac OS X. tdf#44621 (Manik Malhotra)

Deshabilitar RSIDs

En caso de que el RSIDs (Identificador para la comparación de documentos) no se use se puede deshabilitar en Herramientas ▸ Opcioness ▸ LibreOffice Writer ▸ Comparación. tdf#68183 (Miklós Vajna, Collabora)

Opción para deshabilitar el RSIDs

Calc

  • Item labels in Pivot Tables can be repeated now. This is optional. When you create a pivot table, double-click on the desired field in the list "Row fields". In the dialog box "Data Field", then click button "Options". In the next dialog box, select "Repeat item labels". Click OK. tdf#87972 (Deena Francis) Screenshot

Formato condicional

  • Barras de datos con colores solidos. tdf#87356 (Katarina Behrens)
Izquierda: Barras de datos con gradientes, Derecha: Barras de datos con colores solidos
  • Barras de datos sin mostrar los valores. tdf#89199 (Katarina Behrens)
Derecha con valores, izquierda sin valores
  • Largos de las barras con máximos y mínimos. tdf#90197 (Benjamin Ni and Markus Mohrhard)
Arriba: Barra de datos con un largo máximo del 50% max, Abajo: Barra de datos con un largo del 100%
  • Iconos adicionales: 3 triángulos, 3 estrellas, 5 cuadros (Markus Mohrhard)

Mejoras para formato XSLX

  • Exportación de los formatos condicionales. (Markus Mohrhard)
  • Importación de las barras de datos y escalas de colores. tdf#90511 (Markus Mohrhard)
  • Exportación e importación de las definiciones de iconos. (Markus Mohrhard)

Formato Científico y Formato Numérico

(Laurent Balland-Poirier and Eike Rathke)

  • Notación ingenieril: tdf#30716
    • Disponible multiples exponentes de 3 (u otro valor) con formato ##0.00E+00: estableciendo el número de dígitos (# o 0) antes del separador decimal.
    • Se agrega formato ##0.00E+00 a la lista de formato cientifico en la interfaz de usuario de diálogo Format ▸ Cells ▸ Numbers ▸ Scientific para todas las localizaciones.
    • Se reemplaza la casilla de verificación Thousands separator con Engineering notation para formatos cientificos. tdf#90258
Nueva opción de notación ingenieril
  • General format using scientific, and default scientific format, keep 2 minimum digits (instead of 3) in exponent for all localizations. tdf#88835
  • Trend line equation with 1 minimum digit in exponent (instead of 3). tdf#88835
  • Add/remove decimal digits of scientific format: with buttons Add Decimal Place/Delete Decimal Place tdf#88960; with Sidebar: Properties ▸ Number Format ▸ Decimal places tdf#88999; with UI dialog Format ▸ Cells ▸ Numbers ▸ Decimal places. tdf#88999
  • Allow variable decimal with format 0.0##E+00 for scientific numbers and 0.0## for numbers (decimal part can contain some 0 and then some #). This format is now correctly saved in ODF files. tdf#90133
  • Sign of exponent can be skipped for positive exponent with format 0.00E00 (remove sign after E). This format is now correctly saved in ODF files. tdf#90133

Formula engine

Table structured references

tdf#85063 (Eike Rathke)

  • Table structured references in spreadsheet formula expressions are imported from OOXML spreadsheet documents.
  • Usable with defined database ranges, which OOXML tables (content of <table> elements) are imported to.
  • The following restrictions apply:
    • The column names must be present as cell content in the table's header row; column-header-less tables are not supported.
    • Saving to ODF or OOXML, structured references are not written, but transformed to A1 style reference notation instead. The references continue to work, but the table context is lost on export.
    • Saving to OOXML, the defined database ranges are not exported as <table> elements.
    • Saving to binary .xls (Microsoft Excel 97-2003 Format), formulas using table structured references are lost.

New spreadsheet functions

  • Changes related to FLOOR and CEILING spreadsheet functions. tdf#69552 (Winfried Donkers and Eike Rathke)
    • The second parameter of FLOOR and CEILING is now optional, as defined by OpenFormula (ODFF).
    • Additional FLOOR.XCL and CEILING.XCL functions were introduced that expect only two parameters and both parameters have to be specified. When importing Microsoft Excel documents, their old FLOOR and CEILING functions are imported as FLOOR.XCL and CEILING.XCL
    • New functions FLOOR.MATH and CEILING.MATH were added for Microsoft Excel interoperability. tdf#87342 (Winfried Donkers)
    • Exporting to Microsoft Excel file formats, Calc FLOOR and CEILING are written as Excel FLOOR.MATH and CEILING.MATH, and Calc FLOOR.XCL and CEILING.XCL are written as Excel FLOOR and CEILING
  • Added ENCODEURL spreadsheet function for Microsoft Excel interoperability. tdf#76870 (Winfried Donkers)
  • Added ERROR.TYPE spreadsheet function according to OpenFormula (ODFF) and for Microsoft Excel interoperability. (Winfried Donkers)

A:A / 1:1 entire column/row references

tdf#44419 (Eike Rathke)

  • It is now possible to specify references to entire columns or rows using the A:A or 1:1 notation instead of A1:A1048576 or A1:AMJ1
    • Such references will be saved as A$1:A$1048576 or $A1:$AMJ1 to maintain interoperability with earlier releases and other applications reading ODF spreadsheet documents.
    • When reading from a document, A$1:A$1048576 or $A1:$AMJ1 are converted to A:A or 1:1 notation.
      • Note that for entire column references both row anchors have to be either absolute or relative, and for entire row references both column anchors have to be either absolute or relative to have the reference converted into A:A or 1:1 notation. Mixed absolute/relative anchors lead to a full range notation being displayed, e.g. A$1:A1048576 or A1:A$1048576 because Calc assumes the user did that on purpose.
    • Inserting rows/columns to or deleting rows/columns from entire column/row references keeps the anchored other axis' endpoints, in particular inserting rows in a column reference will not produce a #REF! error and deleting rows in a column reference will not move the last referenced row that number of rows up, contrary to the standard A1:A1048576 reference behaviour. For example, with previous versions, =SUM(A1:A1048576) became =SUM(A1:A1048566) after deleting 10 lines from 10 to 20. With Version 5 the formula does not change =SUM(A:A).
    • Standard absolute/relative reference addressing can be used, i.e. A:B, A:$B, $A:B and $A:$B are all valid references and imply the same different reference update mechanisms when copy&paste, fill, move and other spreadsheet editing operations affecting cell formula references are applied.

Crop, change and save an image

tdf#34555 (Philippe Jung)

  • It is now possible from Format ▸ Image menu, from contextual menu and from graphic toolbar, to Crop an Image with the mouse, to Save an image and to Change it by another image from disk. These functionalities behave like in Impress or Writer.
  • Format menu has been updated accordingly, there are now:
    • Format ▸ Object entry with Position and Size, Line, Area, Define Text Attributes and Points
    • Format ▸ Image entry with Crop, Edit with External Tool, Change Image, Compress Image, Save Image.
Cropping an image in Calc

Toolbar improvements

Additional improvements have gone into the “Standard”, “Formatting” and contextual toolbars to provide users with frequently used commands. tdf#85594 (Yousuf Philips)

Impress and Draw

  • Rearrangement of toolbars in Impress Elaborate, this is a vague sentence! tdf#87676 (Yousuf Philips)
  • Rearrangement of toolbars in Draw Elaborate, this is a vague sentence! tdf#90090 (Yousuf Philips)
  • Image and shape context menus were improved by removing less important entries in them. tdf#86614 (Yousuf Philips)
  • Area fill dropdown is now implemented in the color selector in Impress and Draw. Blog entry (Caolán McNamara, Red Hat)
New color selector in Draw and Impress
  • Text background colour in Draw/Impress text boxes (GSoC 2014, Matteo Campanelli) (blog post) can now be set in UI with toolbar or sidebar button. tdf#88276 (Katarina Behrens, CIB)
Toolbar button to set text background colour in Draw/Impress text box

Math

See also: Feature removal / deprecation

Base

Chart

Trendlines

  • Force Intercept option is now also available for exponential trendlines. tdf#72361 (Laurent Balland-Poirier)

Core

PDF export supports Time-Stamp Protocol

  • Export to PDF now supports the Time-Stamp Protocol (IETF standard RFC 3161). The address of a Time-Stamp Authority can be specified in the security settings of PDF options tdf#84881 (Tor Lillqvist, Collabora sponsored by Wilhelm Tux crowd-funding)
Time-Stamp options in PDF digital signatures tab
Adding a new Time-Stamp Authority

Adobe Swatch Exchange (.ase) support

  • Support for reading Adobe Swatch Exchange (.ase) color palettes. Handles CMYK, RGB, and grayscale color models. LAB colors are not yet supported, and are replaced by black during import. (tdf#84002, sponsored by LibreOffice users through FreedomSponsors.org) (Chris Laplante)

Maintaining invisible content in Emails

  • Option added to preserve document invisible content when sending a document by email. tdf#87441 (Stephan Bergmann)

Filters

New import filters

  • Writer can now import Apple Pages files (Pages '09 and older), via libetonyek. (David Tardon)
Sample document opened in Pages '09
Sample document opened in LibreOffice 5.0
  • Calc can now import Apple Numbers files (Numbers '09 and older), via libetonyek. (Anurag Kanungo, GSoC 2015)
    • This is only a preview. It is a loss of time to report bugs.
  • Draw can now import ClarisDraw and MacDraft (v. 1) files, via libmwaw. (Laurent Alonso)
  • Calc can now import Lotus 123 (wk3, wk4) and Quattro Pro files (wq1, wq2), via libwps. (Laurent Alonso)

Improvements in OOXML filter

  • Support for handling differences between OOXML written by MSO 2007 and the specification. (Markus Mohrhard)
  • Chart streams support MSO 2007 and OOXML conforming input now. (Markus Mohrhard)
  • Chart streams are exported according to OOXML spec and no longer according to MSO 2007 format. (Markus Mohrhard)

Improvements in MediaWiki export filter

(Robert Buj)

The following improvements have been made to MediaWiki export:

  • Replace <text>&#10;</text> with <value-of select="$NL"/>
Image
  • Add the alternative text in a image
  • Add support for image align with wrap='none'
Paragraph
  • Replace < center > </ center > tags
  • Add support for background-color and font-color
Table
  • Cell
    • Use align element
    • Add support for background-color and font-color
    • If all cells have the same style then specify that in the row section
  • Table
    • Add support for table align and table width
  • Row
    • Fix new line at the end of the row
  • Header
    • Handle the header like a row
Text
  • Add support for background-color and font-color

Improvements in Keynote import filter

  • Correctly set text language. (David Tardon)
  • Import links. (David Tardon)
  • Fix import of tab stops. (David Tardon)
  • Fix import of simple cell text content, which was ignored previously. (David Tardon)
  • Import more text and paragraph formatting properties. (David Tardon)
  • Import document metadata. (David Tardon)
  • Fix a typo that caused all shapes being dropped from output. (David Tardon)
  • Import table borders. (Anurag Kanungo)

Improvements in MS Works import filter

  • Ask for text encoding if it cannot be determined. tdf#87222 (Laurent Alonso)

Improvements in Freehand import filter

  • Drastically improve import of fills, strokes, embedded images, and embedded text. (Fridrich Strba)
  • Fix positioning of visible objects on the canvas. (Fridrich Strba)
  • Cover formats from Freehand 3.0 to Freehand 11. (Fridrich Strba)

GUI

General UI changes

  • Impress's user interface was improved to provide more space to the slide by hiding the text, shape and image formatting contextual toolbars. tdf#87676 tdf#87822 (Yousuf Philips, Philippe Jung)
LibreOffice Impress New UI.png
  • Draw's user interface was improved by hiding formatting contextual toolbars, aligning the shapes toolbar to the left to resemble other drawing applications, and with an expanded sidebar to provide access to formatting options. tdf#90090 (Yousuf Philips; Jan Holešovský, Collabora)
LibreOffice Draw New UI.png
  • The design of the display-toggling button in pane dividers has been updated to increase its visibility. tdf#83527 (Tomaž Vajngerl)
The previous appearance is shown in the bottom-left corner for comparison.

Sidebar changes

  • Slide Transition tab of the sidebar in Impress was rearranged to take better use of space. tdf#87862 (Katarina Behrens, Rishabh Kumar, Yousuf Philips)
  • Sidebar tabs in Impress were rearranged in this sequence - Properties, Slide Transition, Custom Animation, Master Slides. tdf#87904 (Yousuf Philips)
  • Sections of the Properties tab in Calc were reorganized to remove unnecessary features and make it fit on smaller screen resolutions. tdf#90888 (Rishabh Kumar, Yousuf Philips)
  • Addition of increase and decrease indent buttons to the indent section in Impress and Draw. tdf#91944 (Maxim Monastirsky, Yousuf Philips)
  • Addition of outline buttons to the sidebar in Impress and Draw tdf#87651 (Maxim Monastirsky)

Improvements in Calc/Draw sheet tab controls

The following changes were made by Tomaž Vajngerl (Collabora):

  • The scroll buttons in Calc have been reduced to two: First and Last are removed, and Previous and Next can assume the functions of First and Last when pressing the Ctrl key while clicking
  • The Add Sheet and Previous and Next buttons are displayed without borders.
  • The Add Sheet button is now in the left, so that users can click it repeatedly without chasing its changing position.
  • It is now possible to scroll the sheet tabs with the mouse wheel if the number of tabs overflows the bar’s space. tdf#59471
5.0 Calc tabs.png

HiDPI changes

See also: Development/HiDpi
  • Scale menu icons (Tomaž Vajngerl, Collabora).
  • Multiply status bar width depending on DPI scale factor (Tomaž Vajngerl, Collabora) .
  • Scale "add Sheet" button for Calc tabs (Tomaž Vajngerl, Collabora).
  • Scale drag-and-drop indicators in the aforementioned tab bar (Tomaž Vajngerl, Collabora).
  • Scale rulers according to DPI scale factor (Darcy Beurle).

Mouse cursor improvements in Windows

  • Many hardcoded cursors, drawn back in the StarOffice era to support now-obsolete Windows versions, were dropped in favor of native cursors, which have a more modern look. tdf#53148 tdf#53151 (Rimas Kudelis)

Context menus

  • Rearrangement of the image context menu. Elaborate on the specific changes! tdf#87185 (Yousuf Philips)
  • Rearrangement of the table context menu. Elaborate on the specific changes! tdf#86619 (Yousuf Philips)
  • All direct formatting entries were removed, as they are readily available in toolbars and the Sidebar. tdf#86606 (Yousuf Philips)
  • Clipboard functions (Cut, Copy, Paste) are always visible. tdf#86850 (Trent MacAlpine)
  • Toolbar's context menu entries appear with small icons. tdf#91953 (Philippe Jung)
  • Toolbar’s context menus display the name of the corresponding toolbar. tdf#86138 (Philippe Jung)
Toolbar context menu

New icon theme by KDE, Breeze

  • A new icon set, Breeze, has been added to LibreOffice. Thanks to: Uri Herrera (Nitrux, S. A.), Andreas Kainz (KDE e. V.), Jonathan Riddell (Kubuntu), Jan Holešovský (Collabora), Yousuf Philips, and Andrew Dent.
Default Writer toolbar
Default Calc toolbar
Default Draw toolbar
Drawing toolbar in Draw
Default Impress toolbar
Drop-down menu New on Standard toolbar

Updates to the Tango icon set

New icons by Alexander Wilms, Adolfo Jayme Barrientos and Yousuf Philips have been integrated into the main Tango theme. There are now fewer gaps, in which old-style Industrial icons were displayed.

Updates to the Sifr icon set

Matthias Freund has fixed bugs and increased icon coverage for Sifr.

Expert Configuration usability improvements

The following changes were made by Palenik Mihály:

ExpertConfiguration 5.0+ wSearch.PNG

User settings - location of the user profile

The user profile will be in the same location as your previous version of LibreOffice. That is for example:

C:\Users\<username>\AppData\Roaming\LibreOffice\4\user or /home/<username>/.config/libreoffice/4/user .

This takes away the need to automatically migrate an existing user profile with the installation of the new version. See commit and minutes of the ESC and tdf#93057.

Localization

A brand new Guarani localization

LibreOffice’s user interface has been completely translated into Guarani (avañe’ẽ), the native language of the Paraguayan people. This groundbreaking work confirms the innovation pace of the LibreOffice project towards facilitating the use of technology for as many people as possible, which is one of the ethos of The Document Foundation. Special thanks go to Giovanni Caligaris (who is leading this effort), András Tímar (Collabora), Christian Lohmaier, and Eike Rathke (Red Hat).

New languages/locales with locale data

Available as default document language and for locale specific formatting.

  • Added Church Slavic [cu-RU] to language list and locale data. tdf#90802 (Aleksandr Andreev and Eike Rathke)
  • Added Nyanja [ny-MW] locale data. tdf#89395 (Eike Rathke)
  • Added Venetian [vec-IT] to language list and locale data. tdf#91199 (Eike Rathke, it46.se/localegen data by veneto.abc)
  • Added Tigrigna (Ethiopia) [ti-ET] locale data. tdf#91849 (Eike Rathke, it46.se/localegen data by kinfe)

Updated language proofing tools

  • The bundled Spanish spelling dictionary pack is updated to version 0.8. (Jacobo Aragunde Pérez)
  • The bundled Portuguese spelling dictionary pack is updated to version 15.4.4.1. (András Tímár)
  • The bundled French spelling dictionary pack is updated to version 5.3.2. (Olivier R.)
  • Several fixes were made to the Czech affix files. (Petr Gajdos and Tomáš Chvátal)
  • The bundled Slovenian dictionary pack is updated with the updated thesaurus. (Martin Srebotnjak)

Other language initiatives

We aim to support as many languages as possible. We would like to thank the following people for volunteering to translate LibreOffice and help preserving their native tongues:

  • Chechen:
  • Kabyle: Hamidi Massinissa
  • Venetian: Alessandro Mocellin
If you speak an endangered language and want to help us to achieve our goals of providing libre tools to every person on the planet, please join us.

Performance

Scripting / Basic

Feature removal / deprecation

  • The obsolete, StarOffice-inherited option “Use system font for user interface” was removed. LibreOffice will always use the system’s font to display its user interface elements. tdf#87016 Thanks to: Julien Nabet and Caolán McNamara (Red Hat).
  • Since the introduction of a new “Elements” docked pane in Math (in version 4.1), it was intended that it would replace the old, OOo-inherited “toolbox”, or floating pane, which was difficult to use and had visual problems in certain UI configurations (such as dark themes). This old element has finally been removed, thus streamlining the UI by removing redundancy. tdf#68871 Thanks to: Julien Nabet and Adolfo Jayme Barrientos.
  • The ability to insert hyperlinks in the NNTP⁠Wikipedia logo v3.svg, IMAP⁠Wikipedia logo v3.svg and POP3⁠Wikipedia logo v3.svg protocols was removed. (core commit 6d089a4c, core commit 52417882) Thanks to: Tor Lillqvist (Collabora).
  • Vestigial Gopher⁠Wikipedia logo v3.svg support was dropped as well. tdf#89361 Thanks to: Adolfo Jayme Barrientos.

API changes

Configuration changes

C++ UNO language binding and URE libraries

The following changes were done to the C++ UNO language binding and URE libraries:

UNO API changes

The following UNO interfaces and services were changed:

Writer

  • New Dispatch commands were created for Inserting in tables:
    • InsertColumsBefore : insert columns before the selected columns. If more than one column is selected, insert as many columns as selected.
    • InsertRowsBefore : insert rows before the selected rows. If more than one row is selected, insert as many rows as selected.
    • InsertColumsAfter : insert columns after the selected columns. If more than one column is selected, insert as many columns as selected.
    • InsertRowsAfter : insert rows after the selected rows. If more than one row is selected, insert as many rows as selected.
    • These commands should be now prefered to uno:InsertColumns and .uno:InsertRows. For compatibility with previous versions, in writer uno:InsertColumns and .uno:InsertRows are equivalent to uno:InsertColumnsAfter and .uno:InsertRowsAfter
  • The following Dispatch commands are now available in Writer:
    • .uno:CompressGraphic
    • .uno:ChangePicture
    • .uno.Crop

Calc

  • The following Dispatch commands are now available in Calc:
    • .uno:ChangePicture
    • .uno:SaveGraphic
    • .uno.Crop

UNO API removals

The following UNO interfaces and services were removed from the API:

Other changes

  • an undocumented .link bootstrap variable feature was removed commit

Platform compatibility

Windows

  • A native, 64-bit Windows build is now available.
    • TDF release builds require Windows Vista or later.
    • Outlook and Outlook Express address book access will not be supported until a new maintainable driver is implemented (see tdf#56903 and tdf#56905).
    • The experimental Firebird database driver is not yet available.
    • For development information, look at Development/msvc-x86_64.

Android

  • Added basic editing capabilities. blog entry 1 2 3 4 5 (Miklos Vajna, Tomaz Vajngerl, Siqi Liu, Henry Castro, Kohei Yoshida, Jan Holesovsky - Collabora, sponsored by The Document Foundation and our generous donors)
Selecting Writer text on Android.
Selecting Calc cells on Android.