LibreOffice 6.1: Note di rilascio

From The Document Foundation Wiki
Jump to: navigation, search

Contents

Riguardo a questa pagina

This is the page with our 6.1 release notes. It should be final now that the 6.1 version itself has been released. However, if you spot any missing or incorrect information, then please let us know. Thanks in advance for your help!


Writer

Generale

  • Gli aiuti in linea sulle modifiche tracciate sono opzionali ora (Strumenti ▸ Opzioni ▸ Writer ▸ Visualizza) e non vengono visualizzati quando Visualizza ▸ Rintraccia le modifiche è disattivato; il comando UNO .uno: ShowInlineTooltips ("Aiuto in linea") disponibile per la personalizzazione tdf#114523 (Heiko Tietze, Michael Stahl)
  • Gli stili di elenco di base sono stati aggiunti al sotto-menu Stili nel menu di scelta rapida. tdf#85940 (Yousuf Philips)
  • Aggiungi l'opzione Inserisci numero di pagina ai menu di intestazione e piè di pagina. tdf#92685 (Gülşah Köse, Pardus)
Inserisci l'opzione numero di pagina nel menu dell'intestazione
  • Permette di rimuovere l'intera sequenza di varianza ideografica con un ← Backspace. tdf#113481 (Mark Hung)
  • Supporta il formato di testo verticale ruby comunemente utilizzato nel cinese tradizionale. tdf#35301 (Mark Hung)
  • Consente l'esportazione di testo ruby ​​in formato docx. tdf#115258 (Mark Hung)
  • Esporta commenti con testo da destra a sinistra in .doc correttamente per MS Word. tdf#45999 (Mark Hung)
  • Corregge il testo inverso del segno di interruzione di colonna in una pagina RTL. tdf#84522 (Mark Hung)
  • La finestra di dialogo "Numerazione capitolo" ora consente le intestazioni su più righe per i capitoli consentendo un'interruzione di riga come separatore tra un numero di capitolo e il suo nome. In questo caso selezionate la scheda Posizione e nell'elenco a discesa Numerazione seguita da selezionate la variante Nuova linea. tdf#112384 (Nithin Kumar Padavu)
  • Modifica tracciati DOCX: gestisci muoviDa e muoviA tdf#104797 (László Németh, NISZ)
Result of Cut+Paste in Word, Writer 6.0 and Writer 6.1
  • Prestazioni notevolmente migliorate nella conversione tra documenti ODT e XHTML post del blog (Miklos Vajna, Collabora)
Improved ODT <-> prestazioni sulla conversione in XHTML.

Linee di firma

È ora possibile generare una linea di firma usando dal menu Inserisci ▸ Linea di firma. tdf#83877 (Samuel Mehrbrodt, CIB)

Inserisci linea di firma
Linea di firma generato

Dopodiché, potete anche firmare la linea della firma usando un certificato digitale.

Linea di firma stampata
Linea di firma valida
Linea di firma non valida

Impostazioni localizzate

Due impostazioni specifiche di Writer che dovrebbero avere valori localizzati non funzionavano esattamente come previsto in passato:

  • Strumenti ▸ Opzioni ▸ Writer  ▸ Generale ▸ Impostazioni ▸ Tab stop deve essere impostato su 7,4 mm per il cinese (locale e “zh-CN”) e su 12,5 mm per tutte le altre localizzazioni.
  • Strumenti ▸ Opzioni ▸ Writer  ▸ Didascalia automatica ▸ Ordine didascalia deve essere impostato come predefinito su “Numerazione prima” per ungherese (locale “hu”) e per “Categoria prima” per tutte le altre localizzazioni.

Questo problema è stato ora risolto raccomandato, raccomandato), ma potreste ancora vedere valori imprevisti se avete modificato queste impostazioni manualmente in passato, o anche se avete semplicemente continuato a utilizzare un'installazione utente preesistente. In entrambi i casi, si prega di verificare se queste impostazioni hanno valori appropriati per voi e modificarle se necessario nella finestra di dialogo Strumenti. (Stephan Bergmann)

Esportazione in EPUB

  • migliorato supporto per collegamenti, supporto per tabelle, supporto immagini e inclusione di font post del blog (Miklos Vajna, Collabora)
  • supporto per le immagini di copertina, supporto migliorato dei metadati, supporto per le note a piè di pagina e le immagini, supporto per l'impaginazione fissa post del blog (Miklos Vajna, Collabora)
Interfaccia utente per il supporto migliorato dei metadati.
  • supporta la scrittura verticale esportando la modalità di scrittura nello stile di pagina come stili del corpo CSS. tdf#115623 (Mark Hung)
  • esporta il testo ruby. tdf#116822 (Mark Hung)

Stampa unione

  • Ora i campi di stampa unione nascondono il paragrafo per i record di dati con campi rilevanti vuoti (tdf#35798; post del blog) (Mike Kaganski, Collabora)
  • La barra di strumenti Stampa unione ora viene automaticamente visualizzata per i file che contengono campi di unione (tdf#115386) (Mike Kaganski, Collabora)

Nuovi stili di numerazione dei capitoli "spelling out"

  • Indicatori ordinali (1 °, 2 °, 3 ° ...), cardinali (Uno, Due, Secondo ...) e numeri ordinali (Primo, Secondo, Terzo ...) tdf#117171 (László Németh, FSF.hu Foundation, Hungary):
    • Localizzato in più di 30 lingue, utilizzando libnumbertext
    • Esportazione/importazione DOCX dei nuovi stili di numerazione dei capitoli
    • Funziona anche con i campi sequenza e numero pagina (solo in OpenDocument)
Il nuovo stile di numerazione nella finestra Sturmenti ▸ Numerazione capitolo...

Calc

Gestione

La possibilità di salvare un file Calc in formato Excel 2003 XML è stata spostata dal menu File ▸ Salva al menu {{bc|File|Esporta}. Il formato XML di Excel 2003 viene selezionato da un elenco di formati disponibili nella finestra di dialogo Salva come.

Immagini

La gestione delle immagini in Calc è stata notevolmente migliorata (Samuel Mehrbrodt, CIB)

  • Le immagini ancorate alle celle Calc possono ora essere ordinate. tdf#98931
Calc-image-sort.gif
  • I tipi di ancoraggio sono stati rielaborati tdf#114552. Ci sono ora tre scelte:
    • Ancora su cella -> l'immagine si sposta solo con la cella (nuova)
    • Ancora su cella (ridimensiona con cella) -> l'immagine si sposta e si ridimensiona con la cella
    • Ancora alla pagina -> indipendente da qualsiasi cella
  • Quando ridimensionate le immagini con la cella, vengono ora considerate le proporzioni. Funziona solo quando l'immagine si adatta alla sua cella. Se è più grande della cella, la cella iniziale e quella finale vengono sempre mantenute.
  • Le immagini inserite sono di nuovo ancorate alla cella per impostazione predefinita. Di default si muovono solo con la cella e non si ridimensionano.
  • C'è un'opzione per impostare il tipo di ancoraggio dell'immagine nella finestra di dialogo Inserisci immagine. tdf#86739
86739-anchor.jpg.jpg
  • Aggiunta l'opzione per adattare le immagini nella loro cella. Questo ovviamente funziona solo con le immagini ancorate alle celle. tdf#116108
  • Quando si copia /incolla le celle, le immagini ancorate alle celle vengono ora copiate con la cella tdf#116510

Interfaccia utente

  • Ora, quando il cursore si trova sull'ultima cella non protetta della colonna in un foglio protetto e si sposta con il tasto Invio, ritorna alla prima cella non protetta della colonna successiva. Questo funziona anche nella direzione opposta se viene utilizzato il tasto ⇧ Maiusc. tdf#68290 (Lera Goncharuk)
  • Personalizzazione del colore evidenziato tdf#116241 post del blog (Szymon Kłos, Collabora)
Modalità e personalizzazione dei valori evidenziati

Menu contestuale

  • Nuovo comando "Gestisci nome" UNO che funziona se il cursore si trova in un intervallo denominato, è stato creato e aggiunto nel menu contestuale. tdf#108989 (Gülşah Köse, Pardus)
  • Il nuovo comando UNO "Convalida dati" che funziona se il cursore si trova in un campo ha un attributo di convalida ed è stato creato e aggiunto nel menu contestuale. tdf#108989 (Gülşah Köse, Pardus)
  • Il nuovo comando UNO "Formattazione condizionale" che funziona se il cursore si trova in un campo ha una condizione ed è stato creato e aggiunto nel menu contestuale. tdf#87357 (Gülşah Köse, Pardus)
  • Aggiunto il menu contestuale nel campo di immissione della barra della formula tdf#57000 (Maxim Monastirsky)
  • La finestra di dialogo unisci celle mostra ora le immagini di supporto tdf#106544 (Heiko Tietze)
    Finestra di dialogo unisci celle

Dati

Il collegamento a dati esterni supporta CSV

  • Foglio ▸ Collegamento a dati esterni supporta i file di testo/CSV per inserire il loro contenuto come dati e aggiornamenti. tdf#114995 (Eike Rathke (Red Hat, Inc.))

Valutazione formula parallela sulla CPU

  • Compilazione di formule parallele sulla CPU conferenza (Dennis Francis, Luboš Luňák, Michael Meeks, Tor Lillqvist - Collabora)
Benefici delle prestazioni della compilazione parallela delle formule

Prestazioni di VLOOKUP

  • La funzione VLOOKUP() è ora molto più veloce in alcuni casi tdf#115490 (Dennis Francis - Collabora)
I vantaggi prestazionali del lavoro di VLOOKUP

Impress e Draw

  • I menu di Draw sono stati riorganizzati e con l'aggiunta di un nuovo menu Pagina. tdf#95827 (Yousuf Philips)
  • Corregge l'ordine errato tra parentesi e parentesi nel paragrafo da destra a sinistra in Impress, giudicando la direzione di scrittura del testo dal paragrafo invece del solo contenuto. tdf#60533 (Mark Hung)
  • Nuovi stili di disegno e ripulitura degli stili legacy tdf#117455 (Kompilainenn, Heiko Tietze)
Nuovi stili di disegno

Base

  • I driver/ponti ODBC, JDBC e Firebird SDBC precedentemente applicati sostituivano i parametri denominati (per ODBC e JDBC: se abilitati) a "tutti" i comandi SQL, compresi quelli che erano codificati nella GUI come "esegui direttamente il comando SQL", in tal modo non mantiene il comando SQL esattamente come digitato. La sostituzione dei parametri con nome ora viene applicata solo alle query SQL generate da un albero di analisi SQL di LibreOffice, lasciando i comandi "esegui direttamente il comando SQL" completamente intatti.
  • HSQLDB incorporato è deprecato, sebbene sia ancora disponibile in questa versione.
    • Supporto completo del motore Firebird incorporato ora disponibile in modalità sperimentale.tdf#116968, tdf#117081 (Tamas Bunth - Collabora)
    • HSQLDB ha mantenuto il valore predefinito per i nuovi file. Base con questa versione, però, ora quando la modalità sperimentale è abilitata, Firebird diventa predefinito.
    • Le persone sono incoraggiate a migrare i file di base utilizzando HSQLDB incorporato in Firebird incorporato o per continuare a utilizzare HSQLDB a lungo termine, i dati devono essere migrati su un server HSQLDB esterno.
      • Per aiutare gli utenti con questa attività, in questa versione viene introdotto un HSQLDB incorporato per l'assistente di migrazione di Firebird incorporato. L'assistente di migrazione non utilizza il motore HSQLDB e sarà disponibile nelle versioni di LibreOffice anche dopo la rimozione completa del supporto HSQLDB incorporato. Questo include:
        • Supporto per la lettura dello schema HSQLDB quando HSQLDB non è disponibile post del blog (Tamas Bunth - Collabora, finanziato dai donatori di TDF)
        • Supporto per la lettura di dati HSQLDB quando HSQLDB non è disponibile post del blog (Tamas Bunth - Collabora, finanziato dai donatori di TDF)
        • Varie correzioni di azione supplementare al backend firebird e al lettore che analizza i dati da file ODB basati su hsqldb -libreoffice-database-migration / blog post (Tamas Bunth - Collabora, finanziato dai donatori di TDF)
  • Libreria di base Access2Base aggiornata (Jean-Pierre Ledure)
    • traduzione tedesca (Gisbert Friege)
    • supporto di eventi di dialogo e database, moduli con più origini dati, apostrofi nei nomi di tabelle
  • (6.1.3) I moduli (anche in altre applicazioni di LibreOffice) ora applicano la proprietà "Inserimento richiesto". Purtroppo, questo era anche di impostazione predefinita, quindi tutti i moduli creati nelle versioni 6.1.3 o precedenti devono essere aggiornati per non richiedere inserimento dove non dovrebbero.

Chart

Math

BASIC

  • Macro VBA: aggiunto supporto XLSX a Workbooks.Open tdf#118153 (Balázs Varga, NISZ)

Core / Generale

Immagini

  • Ora, Calc, Draw, Impress chiedono agli utenti se vogliono applicare la rotazione EXIF​​ quando le immagini vengono inserite o sostituite come fa attualmente Writer. Questo si applica solo alle immagini con orientamento 3, 6 e 8. tdf#116438 (himajin100000)
  • Aggiunta la nuova opzione per esperti: "AddReplacementImages" per controllare durante l'esportazione se aggiungere o meno immagini di fallback tdf#115005 (Serge Krot, CIB)

Rielaborazione della gestione delle immagini

  • Miglioramento della gestione del ciclo di vita post del blog (Tomaz Vajngerl - Collabora, finanziato dai donatori di TDF)
  • Privazione dell'accesso alle immagini incorporate tramite URL post del blog (Tomaz Vajngerl - Collabora, finanziato dai donatori di TDF)
  • Un nuovo gestore grafico molto migliorato post del blog (Tomaz Vajngerl - Collabora, finanziato dai donatori di TDF)
  • Caricamento a richiesta di immagini da formati binari OOXML e MSO post del blog (Miklos Vajna - Collabora, finanziato dai donatori di TDF)
Caricamento lento delle immagini dai formati binari OOXML/MSO.

Font

  • Nuovo ordine predefinito per i caratteri cinesi tradizionali e semplificati. tdf#114768 (Yousuf Philips)

Comandi per .UNO

  • Il caso del ciclo include ora il caso della frase tdf#116315 (Heiko Tietze)
  • È stato introdotto il comando .uno: ShowInlineTooltips per consentire la personalizzazione delle descrizioni in linea (vedere le modifiche per Writer) tdf#114523 (Heiko Tietze, Michael Stahl)

Firma del documento

  • Aggiunto supporto per la firma (non solo la verifica) dei documenti ODF con ECDSA chiavi su GNU-Linux e macOS tdf#109180 (Miklos Vajna - Collabora)

Configurazione centrale dei dati utente

  • Migliorato il backend di configurazione LDAP esistente post del blog e implementato un nuovo backend di configurazione specifico per Windows post del blog per consentire una configurazione efficiente dei dati utente nei domini AD usando criteri di gruppo (Mike Kaganski - Collabora)

Guida di LibreOffice

Nuova guida

  • Le pagine della Guida in linea ora contengono file collaterali per supportare la descrizione testuale di una funzione (Olivier Hallot)
File collaterali
  • Diversi miglioramenti nell'impaginazione della pagina in linea (Adolfo Jayme Barrientos, Ilmari Lauhakangas, Olivier Hallot)
  • Nuova interfaccia utente di guida completamente traducibile tdf#115685 (Olivier Hallot)
  • Le icone di default sono ora Colibre (A. Kainz)
  • Miglioramenti nel processo di gbuild per la Guida (S. Bergman)

Contenuti della guida

  • Nuove pagine di aiuto per Pivot Charts (Olivier Hallot, dopo Tomaž Vajngerl)
  • Pagine di aiuto su Esportare in EPUB (Olivier Hallot, dopo Miklos Vajna)
  • Molte correzioni nei contenuti della guida (Sophia Schröder, Adolfo Jayme Barrientos, Stanislav Horáček, Gabor Kelemen, Caolán McNamara, Dennis Roczek, A. Gelmini ...)
  • Aggiunti screenshot per le pagine di aiuto Math (Olivier Hallot)

Filtri

Miglioramenti all'importazione XML di Excel 2003

Il filtro di importazione per il formato XML di Excel 2003 è stato revisionato e il precedente filtro basato su XSLT è stato sostituito da quello fornito dalla libreria orcus. (Kohei Yoshida)

Filtro SVG

Sostituito SVGFilter esistente usando SVGIO. raccomandato (Armin Le Grand)

GUI (Interfaccia grafica utente)

  • Immagini di sfondo nella finestra di dialogo Galleria e Area riempimento completamente riviste tdf#114817 (Andreas Kainz, Heiko Tietze)
    Nuovi sfondi Areafill
Questa modifica spezza i documenti con i "collegamenti relativi" alla galleria, cosa possibile qualche tempo fa. Gli utenti interessati possono installare le immagini di sfondo legacy per estensione (https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds).
  • Nuova palette standard RYB, basata sulla teoria degli anelli di colore Itten RYB che fornisce i primari rosso, giallo, blu; secondari arancioni, verdi, viola; terziari oro, mattone, magenta, indaco, alzavola, calce. Tutti i valori RGB sono stati generati in modo algoritmico (cubo tensoriale di Gossett e di Eddy) per tonalità di colore, tinte (30%, 45%, 60%, 75% aggiunta di bianco) e tonalità (20%, 40%, 60%, 80% aagunti di nero) tdf#114719 (Heiko Tietze, V Stuart Foote).
Tavolozza standard RYB
  • Nuova serie di gradienti predefiniti tdf#114006 (Andreas Kainz, Heiko Tietze).
Gradienti
  • La finestra di dialogo "Inserisci tabella" presenta ora un elenco di stili di tabella invece del pulsante Formattazione automatica tdf#113558 (Furkan Tokac)
  • Tolte le descrizioni dei comandi nelle tabelle rimosse ("Regola colonna/riga della tabella", "Seleziona intera tabella/riga/colonna") tdf#116297 (Heiko Tietze)
  • Funzione per modificare tabelle in 3 secondi rimossa, liberando i tasti di scelta rapida Alt+Canc e Alt+Insert tdf#116452 (Heiko Tietze)
  • Nuova serie di icone per le applicazioni. (Andreas Kainz)
  • Le diverse implementazioni di Notebookbar ottengono molti miglioramenti dell'interfaccia utente e nel bugfixing solo in modalità sperimentale, ma l'interfaccia utente è stabile per una versione iniziale (Kshitij Pathania, Szymon Kłos, Andreas Kainz).
    NotebookBar.png

Tema delle icone

  • Colibre introdotto come predefinito in Windows tdf#90194 (Andreas Kainz, Heiko Tietze)
    Colibre il nuovo tema dell'icona di LibreOffice
  • Colibre ottiene supporto per icone a 32px (Andreas Kainz)
    Le icone di Colibre sono disponibili in 16px, 24px e 32px
  • Elementary è ora il tema delle icone di default sugli ambienti desktop basati su Gnome tdf#116695 (Heiko Tietze)
    Elementary come predefinito sui desktop basati su Gnome
  • Il tema ad alto contrasto ora è Sifr tdf#75398. Tema ad alto contrasto elevato disponibile come extension. (Heiko Tietze)
  • Temi delle icone Industrial e Oxygen sono stati rimossi a causa di manutenzione mancante e supporto SVG (reso disponibile come estensione). (Heiko Tietze)
  • Aggiunto il tema dell'icona Karasa Jaga, originariamente creato per Sundara OS, fortemente ispirato (e derivato) dal tema dell'icona dell'Oxygen (ora non più mantenuta) tdf#117342. (Rizal Muttaqin)
Karasa Jaga

Start Center

Windows

  • Ora il messaggio "JRE Required" per Windows contiene informazioni su bitness del JRE richiesto tdf#115002 (Lera Goncharuk)
  • Le finestre di dialogo ora utilizzano interfacce native GTK3 su Linux. post del blog (Caolán McNamara)

Menu

Configurazione

  • Ctrl/⌘ Cmd+Tab ↹ e ⇧ Shift+Ctrl/⌘ Cmd+Tab ↹ possono essere usate come scorciatoie ora e sono stati assegnati al foglio successivo/precedente in Calc tdf#86404 (Heiko Tietze)
  • Ctrl+F5 è assegnato alla voce di menu Visualizza ▸ Barra laterale tdf#86404 (Heiko Tietze)
  • I collegamenti per la formattazione dei numeri in Calc (decimale, scientifico, data ...) sono ora ⇧ Shift+⌃ Ctrl+1..⇧ Shift+⌃ Ctrl+6 su macOS (erano prima ⌘ Cmd) tdf#78777 (Heiko Tietze)
  • Personalizzazione di MOD3 è ora possibile su macOS col tasto ⌃ Ctrl. tdf#34704 (Heiko Tietze)
  • La descrizione mostra in modo corretto il simbolo per MOD3 (⌃) tdf#117033 (Heiko Tietze)

  • Ora è ancora più semplice personalizzare le barre degli strumenti e i menu di livello superiore in base ai tuoi gusti, grazie al pulsante/menu di marcia appena aggiunto della finestra di dialogo Personalizza (Strumenti ▸ Personalizza...). tdf#114260 (Muhammet Kara, Pardus)
  • Con il nuovo menu a forma di ingranaggio sulla barra degli strumenti e le schede Menu, ora potete;
    • rinominare le barre degli strumenti e i menu personalizzati e i sottomenu standard raccomandato
    • spostare e riorganizzare i menu di livello superiore, raccomandato
    • guardare lo stile di visualizzazione attuale delle barre degli strumenti e modificarlo con un solo clic. raccomandato
  • I pulsanti più e meno, che vi consentono di aggiungere o rimuovere menu e barre degli strumenti di livello superiore, sono disponibili anche come opzioni del nuovo menu, riducendo la confusione sull'interfaccia utente.
Menu Gear per un menu personalizzato
Menu Gear per una barra degli strumenti personalizzata

Editor di base

  • Ora c'è una ricerca ripetuta per scorciatoia tdf#94498 (Lera Goncharuk)

Online

Generale

  • Implementazione e notevole miglioramento dell'IME per le lingue asiatiche (Pranav Kant - Collabora)
  • Gestione degli eventi di chiavi e mouse migliorata per evitare possibili blocchi (Pranav Kant - Collabora)
  • Sfarfallio del dialogo ridotto (Pranav Kant - Collabora)
  • Miglioramento della sessione di arresto e amp; risparmio (Ashod Nakashian - Collabora)
  • Rielaborato il framework l10n per ridurre la duplicazione tra le varianti Online e Desktop (Jan Holesovsky - Collabora)

Miglioramenti della sicurezza

  • La console dell'amministratore può autenticarsi tramite PAM (Andras Timar - Collabora)
  • Supporta la crittografia della chiave pubblica HTTP (Pranav Kant - Collabora)

GUI

  • Esposto varie finestre di dialogo nel nucleo di LibreOffice al browser. Alcune schermate.
  • Implementazione della creazione di grafici (in tutti i Writer, Calc, Impress) (Marco Cecchetti, Pranav Kant - Collabora)
  • Controllo ortografico del menu contestuale (Jan Holesovsky, Henry Castro, Marco Cecchetti - Collabora)

Prestazioni

Writer

  • Seguenti dialoghi che arricchiscono l'esperienza di editing dell'utente (Pranav Kant, Jan Holesovsky, Henry Castro - Collabora)
    • Trova e Sostituisci (la finestra di dialogo precedente scritta in JS è stata rimossa)
    • Modifica stile
    • Finestra di dialogo Collegamento ipertestuale
    • Finestra di dialogo dei caratteri speciali (la finestra di dialogo precedente scritta in JS è stata rimossa)
    • Voce di indice
    • Personaggio
    • Paragrafo
    • Punteggiatura e Numerazione
    • Finestra di dialogo delle proprietà della tabella
    • Finestra di dialogo Ortografia e grammatica
    • Finestra di dialogo Conteggio parole
    • Gestione del tracciamento delle modifiche
    • Inserisci intestazione e piè di pagina
    • Formattazione della colonna

Calc

  • Varie finestre di dialogo sono state esposte (Marco Cecchetti, Henry Castro, Pranav Kant - Collabora)
    • Possibilità di aggiungere il filtro automatico
    • Possibilità di filtrare gli oggetti tramite il popup del filtro automatico
    • La finestra di dialogo Formato cella è disponibile
    • Funzionalità di ordinamento
    • Supporto per le schede nascoste in Calc
    • Supporto per la modifica della serie di dati grafici
    • Convalida dei dati

Raggruppamento di colonne/righe

In questa nuova versione è possibile comprimere o espandere qualsiasi gruppo di colonne o righe con un semplice clic (Marco Cecchetti - Collabora)

Collabora-Online-Calc-Grouping-01.png

I gruppi sono organizzati in livelli e un'intestazione livelli (per gruppi di colonne e di righe) è disponibile nell'angolo in alto a sinistra della struttura. Facendo clic su una voce di intestazione livelli, i gruppi appartenenti al livello relativo vengono compressi o espansi del tutto (Marco Cecchetti - Collabora)

Collabora-Online-Calc-Grouping-02.png

Impress

  • Vengono aggiunte le seguenti finestre di dialogo a forma di oggetto e forma (Pranav Kant, Jan Holesovsky - Collabora)
    • Posizione e Taglia
    • Finestra di dialogo di linea
    • Finestra di dialogo dell'area

Localizzazione

Nuovo modificatore NatNum "spell out"

  • NatNum12 nei codici di formato definito dall'utente di Calc e Writer:tdf#115007 (Mike Kaganski, Collabora; László Németh, FSF.hu Foundation, Hungary; Eike Rathke, Red Hat, Inc.)
    • Per compitare i numeri in vari formati di numero, valuta e data, utilizzare il modificatore [NatNum12] con gli argomenti scelti all'inizio di un codice formato numerico definito dall'utente.
    • Ad esempio, [NatNum12 USD] 0 il codice di formattazione formatta i valori delle celle (o i campi numerici) 0, 1, 2 come “zero dollari” (plurale in inglese), “un dollaro americano”, “due dollari americani” etc.
    • Basato su libnumbertext, vedi le lingue e le funzioni native supportate (scegli "aiuto" come formato ortografico) in online demo.
    • L'utilizzo di NatNum12 può sostituire NUMBERTEXT / MONEYTEXT estensione di LibreOffice. Entrambi generalizzano la funzione di foglio di calcolo BAHTTEXT, una funzione di Microsoft Excel per il numero del nome del numero tailandese e la conversione di valuta, standardizzata da ECMA-376 e ISO / IEC 29 500:2008 Formato Office Open XML.
    • Dettagli ed esempi nella guida di LibreOffice

Nuove lingue / locali con dati locali


Altre lingue nella lista delle lingue

  • Arabo malese [ms-Arab-MY] e [ms-Arab-BN], entrambi CTL. (Eike Rathke (Red Hat, Inc.))
  • Juǀ’hoan [ktz-NA] e Naro [nhr-BW]. (Eike Rathke (Red Hat, Inc.))

Incorporazione di altre lingue

  • Traduzione della nuovissima interfaccia utente in frisone (fy). Complimenti al nostro traduttore volontario, Berend Ytsma, per aver intrapreso questo sforzo.
  • Traduzione della nuovissima interfaccia utente in alto sorabo (hsb). Complimenti al nostro traduttore volontario, Michael Wolf, per aver intrapreso questo sforzo.
  • Traduzione della nuovissima interfaccia utente in tamaziɣt /Kabyle (kab). Complimenti al nostro team di traduttori volontari, Belkacem Mohammed, Yasin Bouklif, Yazid Bouhamam, Merzouk Ouchenem, Nabil Semɛun, Slimane Amiri e altri, per aver intrapreso questo sforzo.
Im-jabber.svg

Se parlate una lingua in via di estinzione e volete aiutarci a raggiungere il nostro obiettivo di fornire strumenti gratuiti per ogni singola persona sulla Terra, per favore unisciti a noi.

Miglioramenti agli strumenti di correzione e supporto linguistico

  • Arabo. Il dizionario ortografico è stato aggiornato alla versione 3.5. (Ayaspell e Yousuf Philips)
  • Croato. Il dizionario ortografico è stato aggiornato alla versione 2.1.1.
  • Inglese (GB). Il dizionario ortografico è stato aggiornato alla versione 2018-05-01.
  • Greco. Il correttore automatico, se la parola termina con il carattere greco σ (sigma) o ς (sigma finale), aggiunge anche le eccezioni di correzione automatica alle comuni abbreviazioni greche. tdf#116387 (László Németh)
  • Ungherese. Il dizionario ortografico è stato aggiornato alla versione v1.7. Le regole per il controllo grammaticale ungherese sono state migliorate (v1.6.4). (László Németh, FSF.hu Foundation, Hungary)
  • Indonesiano. È stato aggiunto un dizionario dei sinonimi e ortografia in lingua indonesiana.
  • Coreano. I dati per la funzione di conversione Hangul/Hanja sono stati aggiornati per completezza e accuratezza. (DaeHyun Sung)
  • Spagnolo. Il dizionario ortografico è stato aggiornato alla versione 2.3

Rimozione di funzionalità/deprecazione

Generale

Linux Quickstarter è stato rimosso.

Temi delle icone

  • I seguenti temi di icone sono stati rimossi:
    • Galaxy (al suo posto usate Tango)
    • Industrial
    • Oxygen

Compatibilità della piattaforma

Mac

  • Varie correzioni specifiche per macOS: post del blog (Tor Lillqvist - Collabora)
    • Uso migliorato di vari tipi di carattere di terze parti
    • Correzioni per le notifiche delle modifiche ai parametri dello schermo
    • Miglioramento nell'inserimento di video nelle presentazioni di Impress

Windows

Linux

Modifiche alle API

Modifiche di configurazione

  • Quando proprietà localizzata, nillable non ha valore per una locale richiesta, né un codice "en-US", "en", e "" valore di ritorno, ora viene restituito nil invece di un valore per alcune impostazioni locali non correlate. raccomandato Vedere tdf#121412 per come questo può influenzare le estensioni .oxt che non prevedono i valori di fallback del "Titolo" nei loro file Addons.xcu file.

Modfiche all'API UNO

  • Quando si carica un documento tramite XComponent::loadComponentFromURL, Le finestre di dialogo (come la finestra di dialogo "Abilita macro") verranno visualizzate se il documento è visibile all'utente. (Samuel Mehrbrodt, CIB) tdf#118238
  • La macro SAL_CALL_ELLIPSE non utilizzata è stata rimossa da sal/types.h , raccomandato
  • Il parametro quantum_cache_max di rtl_arena_create (che in genere veniva specificato come zero nelle chiamate a tale funzione) non viene più considerato dall'implementazione e deve sempre essere specificato come zero nelle chiamate . raccomandato

Modifiche SDK