Hidden Functions in Draw

From The Document Foundation Wiki
Jump to navigation Jump to search
Other languages:
Deutsch • ‎English • ‎dansk

This page is in Work!

Foreword

This video series is based on the presentation of 'Hidden Gems in Draw/Impress' by ARMIN LE GRAND.

The videos "Draw - Hidden Features" link to this page, which contains further information.

This series of video shows hidden functions in Draw and how these are applied under version 5.2.

Copied description in Wiki: Videos/Hidden_Gems_In_Draw

Objects - basic

Objects are divided into three property areas.

  1. . the shape of the object, which can only be created or changed by drawing. The geometric data for different shapes of objects are therefore stored inside objects.
  2. . the dimensions for width, height and angle of objects.
  3. . the appearance of objects (colours, line width, filling). You can define it as direct formatting (this is not recommended) or as formatting with styles (recommended).

The property areas 2. and 3. can be set together if the objects have been selected beforehand.

Links to Videos "Draw - Hidden Features" (in German [DE])

Video 1 - Colours and colour bar

Video 2 - Colors on objects

Video 3 - Select and deselect objects and arrow keys

Video 4 - Objects arrangement and alignment

Video 5 - Edit and convert objects - create and change gallery shapes

Video 6 - Copy objects - standard shapes

Video 7 - Merge, subtract and cut objects

Video 1

Link to the Video (in German [DE]):

Video 1 - Colours and colour bar

Colors and Palette

Palette at the bottom
Colour Palette, floating, large

You open Draw and call up the color bar or color palette.

You open the color bar by selecting the menu, View ▸ Toolbars ▸ Color bar, select.

The color bar will be displayed in a rectangle at the bottom of the document window.

The rectangle has an overlapping line with an "Arrow-down" symbol.

This can be used to hide or show the color bar.

If you move the mouse pointer over this line, a double arrow appears.

This line can be moved upwards (become larger) or downwards by dragging with left mouse button.

Floating the Color Bar

If you work with colors frequently, you can grab the gray panel with the left mouse button and pull it upwards, so that the color bar, now called "color palette", floats.

The color palette can be enlarged by dragging the bottom edge.

You can place the color palette at the top, next to the document.

This allows fast color selection.

To re-dock the color palette, hold the Ctrl and double-click the gray area of the color palette window.

The Color Palette window will be docked back to the document window.

- To the top -

Video 2

Slide 1, Red Oval selected

Link to the Video (in German [DE]):

Video 2 - Colors on objects

Colors on Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg".

Now let's color the objects.

In slide 1, select the object "red oval".

When you click on a color in the color palette with the left mouse button, the object takes on the selected color.

When you right-click on a color in the color palette, the border (outline) of the object takes on the selected color.

Alternatively, the fill color and the border color can be selected by using "drag and drop", i.e. dragging the color from the color palette, and placing it on the object or on the border.

The fill color and the line color can also be selected transparently.

 Note 
To enlarge a selection in Draw to fit the entire window, press the / key on the numeric keypad.

- To the top -

Video 3

Link to the Video (in German [DE]):

Video 3 - Select and deselect objects and arrow keys.

Slide 2
Slide 3
Slide 6

Select and Deselect Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg".

Now let's select the objects.

There are several ways to select items.

Click on the slide 2 on the left.

Use the left mouse button to click on an single object.

You can select multiple objects by holding the left mouse button.

Use Ctrl + A to select all objects.

Click the slide 3 on the left.

With the Tab ↹ key the next object is selected.

Use the ⇧ Shift and Tab ↹ keys to select the previous object.

Click the slide 6 on the left.

With Alt and left mouse click, you can select several arbitrary objects as a group.

You are now deselecting objects.

With ⇧ Shift and left mouse click, You can select and deselect individual objects, if several are selected.

Arrow buttons

Use the arrow keys to move objects.

The arrow keys move the object by one tenth of a grid square (depending on your configuration settings).

Using the arrow keys in combination with the ⇧ Shift moves an object by one grid square (depending on your settings).

Using the arrow keys in combination with the Alt key will move one pixel.

You can also use the arrow keys to increase or decrease the size of an object.

Press Ctrl + Tab ↹ twice.

The upper middle blue dot will flash.

Now you can use the up-arrow key to increase the oval size and down-arrow to decrease it.

Press Ctrl + Tab ↹ again, and another blue dot will flash.

- To the top -

Video 4

Toolbar "Standard"
Slide 9

Link to the Video (in German [DE]):

Video 4 - Objects arrangement and alignment

Arranging Objects

Change the arrangement of objects.

Arrangement refers to the location within the layer system, i.e., which object is located over which.

Now let's try to change the arrangement of objects.

Click on slide 9.

In the "Standard" toolbar, the icons "Arrangement", sequence: "To the front", "To the back", "All the way to the front" and "All the way to the back".

Click on an object, e.g. the circle.

In the "Standard" toolbar, you select the black arrow for the "Arrangement" icon.

Now you have the possibility to change a previously selected object in the arrangement.

A selected object can be placed "All the way forward", "To the front", "To the back" and "All the way back".

You drag the menu down to make it float.

Now you can play through the individual arrangements.

Aligning Objects

You will now align objects in their position.

To align objects in their position within a layer, a check mark must be set in the Tools ▸ Options ▸ Grid menu.

Snapping of objects to snap lines can be found in the Tools ▸ Options ▸ Grid menu, where the value of the snap range, e.g. 20 pixels, may be adjusted.

Click on the slide 6.

In the Standard toolbar, find the Align button and open the menu by clicking the triangle beside the button.

Again, you can float the menu by dragging the handle in the bottom of the menu.

Now you have the possibility to align objects.

The functions in the Align menu in sequence are: "Left", "Centered", "Right", "Top", "Middle" and "Bottom".

You can now execute the individual alignments.

For a single selected object, the orientation refers to the page (slide).

For several selected objects, the orientation is relative to the other objects.

Slide 6: Objects alignment

Aligning Objects to Snap Lines

You can also align to snap lines.

By holding down the left mouse button on the ruler, you can pull down a snap line.

Any number of lines, horizontal and vertical, can be pulled down.

You can also add snap lines using the Insert ▸ Insert Snap Point/Line… in the Insert menu.

A dialog will appear "New snap object" with the selection options, "Point", "Vertical", or "Horizontal", and the specification of the position.

Right clicking on the snap line you can select to Edit Snap Line… or Delete Snap Line.

In the View menu there is an item Snap Lines.

You can Display Snap Lines, Snap to Snap Lines, and Snap Lines to Front.

If the snap lines are not visible, they will have no effect.

Now you can drag objects with the mouse, and they will snap to the nearest snap line when you drop them.

Snap lines can also be pushed back onto the ruler.

- To the top -

Video 5

Link to the Video (in German [DE]):

Video 5 - Edit and convert objects - create and change gallery shapes

Example: Curve
Example: Curve with help lines
Toolbar: Edit points
Example: Curve with all help lines

Edit and Convert Objects

Edit Objects

Open LibreOffice Draw and open the reference work file "Draw-Objects.odg".

Draw a Curve

You now want to draw a curve.

Click on the slide 5.

If the "Curve" icon 2017 HB LO Symbol Kurve.png is not visible on the "Drawing" toolbar, select View ▸ Toolbar ▸ Customize… from the menu.

In the "Customize" dialog, you select "Drawing" from the "Toolbar" menu.

For "Toolbar content" | "Commands", scroll down, and check "Curve", then click OK.

Now you can use the Curve button.

Click the "Curve" icon, then click with the left mouse button on the slide, and drag to create a curve.

Then click with the left mouse button on the slide and drag a line.

You release the mouse button and move the mouse to deform the stretch, as a curve.

With the further sequence: click-hold-drag, release and form a curve, the curve can be continued at will.

When the curve has the desired shape, double-click to complete the curve, see example curve on the right.

Draw a Curve With Help Lines

The curve can be edited further.

Select the curve by clicking on it.

Then click the "Edit points" icon or the F8 key.

Hold ⇧ Shift and left-click the mouse; a tangent line with two end points will appear.

By manipulating the ends of the tangent, you can further deform the curve.

Add Points

You can also add points to the curve.

Select from the View ▸ Toolbar ▸ Edit Points menu.

In the toolbar "Edit Points", click on "Insert Point" 2017 HB LO Symbol Punkte einfügen.png.

Then click on the curve where you want the new point to be placed.

Delete Points

You can also delete points from the curve.

For this purpose the corresponding point must be clicked.

Click on the point, then click on "Edit Points", then select "Delete points" 2017 HB LO Symbol Punkte löschen.png in the toolbar.

Split the Curve

A curve can also be split up.

Select the point at the desired location, or set and select a new point.

After that the toolbar "Edit points", the "Split curve" symbol 2017 HB LO Symbol Kurve auftrennen.png was chosen.

Display all points with help lines

When the curve is selected, hold and drag the left mouse button to assign a rectangular range covering the entire curve.

It will display all the points with their help lines.

Points - other functions

If you click on a point with the curve selected, additional functions can be selected, including "Corner Point", "Smooth Transition", and "Symmetrical Transition" 2017 HB LO Symbole Es GÜ SÜ.png.

Close the curve (Bezier)

You can also close the curve.

When the curve is selected, click on the "close Bezier" icon 2017 HB LO Symbol Bezier schliessen.png to close the curve.

Further explanations on Bézier Curves

Here are some further explanations on Bézier curve:

Dokumentation - Bézierkurven - DE, von Regina Henschel (in German)] and

Bézier curveWikipedia logo v3.svg

Convert Objects

Slide 8
Gallery: User-folder
Slide 2 with 10 copied ellipses
Slide 7

Convert curve

You can also convert objects to other forms.

Click on the curve with the right mouse button.

In the menu, select Convert ▸ To Polygon.

In order to keep an overview, you can watch the status of the object during processing in the lower left corner of the status bar.

Then, if you click the polygon with the right mouse button, you can select Convert ▸ To Curve.

Now you have a curve that has more points than before.

Basic Shapes Transform and Deform

Click on the slide 2.

In the "Drawing" toolbar, Select the circle for standard shapes and draw a circle.

Now click on the circle with the right mouse button, and choose Convert ▸ To curve and you can deform the circle.

Convert Text Symbols

Simple text can also be converted just like curves.

Click on the slide 8.

In the "Standard" toolbar, click the "Text box" 2017 HB LO Symbol Textfeld.png icon and place a text box on the slide.

In the main menu Insert ▸ Special character... you can select the font, e.g. "Webdings".

Write some characters in the text box and select a larger font, e.g. 150 pt.

Right-click on the frame of the text box and select Convert ▸ To curve.

Then right-click the characters and select Ungroup.

Now the individual characters can be deformed, colored, and added to the gallery.

Add text characters to the Gallery

A user folder must be created in the gallery.

When adding to the gallery, proceed as follows:

Click on the text symbol with the left mouse button and hold it until the cursor takes on the following shape 202001 LODEHB Draw-Cursor zum Verschieben.JPG.

Then move it to the Gallery pull.

Create And modify gallery shapes

A user folder must be created in the Gallery.

With "drag and drop" you can drag the converted text symbols into the Gallery.

The Gallery objects can now be added arbitrarily with Add.

- To the top -

Video 6

Link to the Video (in German [DE]):

Video 6 - Copy objects - standard shapes

Copy objects

Click on the slide 2.

You draw any object, for example an ellipse.

Any selected object can be dragged-copied with the left mouse button while holding down the Ctrl key.

The Ctrl key can also be used to copy several selected objects simultaneously.

Alternatively, ⇧ Shift + F3 can be used to specify the number of copies of a selected object.

Press ⇧ Shift + F3.

The dialogue opens "Duplicate".

You enter the desired number of copies.

Here you can also enter the "Displacement", "Magnification" and "Colours" for "Start" and "End".

For "Displacement", "X axis", enter, '-0.50 cm.

For "Start" and "End" select two different colours and click OK.

You have now, for example 10 copies is generated.

With ⇧ Shift + F3, this operation can also be performed with multiple objects.

Basic Forms

Objects can also be inserted quickly.

Click on the slide 7.

On the "Drawing" toolbar, click the black arrow at the right of "Basic shapes" icon.

The selection of the basic shapes is displayed.

The selection with the standard shapes can be dragged with the mouse button held down, floating freely.

With Ctrl and clicking the left mouse button on a shape, this shape with the standard attributes is inserted into the slide.

- To the top -

Video 7

Link to the Video (in German [DE]):

Video 7 - Merge, subtract and cut objects

Merging, subtracting, and cutting objects

Merging
Subtracting
Cutting

Object Merging

Click on the slide 9.

In the drawing toolbar, you can use the Ellipse icon to draw a circle or an ellipse.

Then use the Rectangle to draw a rectangle.

You move the rectangle partially over the circle and select both circle and rectangle.

Now select Modify ▸ Shapes ▸ Merge from the menu.

The circle and rectangle have now merged into a new shape.

Object Subtracting

Following the circle and rectangle example, lay the circle over the rectangle.

Now select Modify ▸ Shapes ▸ Subtract from the menu.

You can repeat this with other shapes.

Object Cutting

Again, you select both the rectangle and the circle.

Now select Modify ▸ Shapes ▸ Intersect from the menu.

The shapes will be cut and only the intersection part will be left.

- To the top -

Connectors

Icon "Connector"
Connector toolbar

Connectors are lines or arrows whose ends automatically snap to a Point on an object.

You connect objects using connectors, which you can select from the Drawing toolbar.

Connectors are useful when drawing organization charts, flowcharts and mind maps.

Both Gallery objects and drawing objects can be connected with connectors to show relationships.

Connect objects with connector

Objects here are Gallery- and Drawing objects.

When you have selected a suitable connector, the cursor becomes a crosshair 73 Draw Cursor für Verbinder.png.

Move the cursor to the Object on an edge where you want to start the connection.

The Object lights up and shows you the possible connection points.

Click a connection point, hold-drag to the next Object where you want the connection to end.

The next Object lights up and the connection points become visible.

Move the cursor to a desired connection point and release the mouse button.

This is how you create all connections.

When objects are moved or rearranged, the connectors remain fixed at the respective Point.

Draw offers a number of different connectors with different shapes of the end points.

Click on the small arrow to the right of the "Connector" icon to open the complete Connector Toolbar.

Change end points of connectors

"Arrow Styles" icon
"Arrow Styles" Selection

You can change the end points of the connectors.

Select a connector.

Select "Properties" in the sidebar.

At Line -> Line go to the small icon "Arrow Style".

Click on the small black arrow next to it and select "Arrow Style" for the connector.

- To the top -

Text box

"Standard" Toolbar
draw the text box
text box with the cursor blinking
cursor changes shape as a double arrow
Context menu text box
Sidebar Properties
8 small squares

You can insert a text box by selecting the "Insert text box" icon 202201 DE02 Symbol Textfeld einfügen.png ( F2 ) in the "Standard" toolbar.

Draw text box (create)

Click on the "Insert text box" icon ( F2 ) and drag open a text box.

The term "draw up" means after you select the icon, the cursor appears as a sight cross 202201 DE03 Visierkreuz.png.

Select the point in the document where you want to start drawing the text box.

Click-hold-drag the cursor to draw the text box.

The dragging goes in any direction.

When the text box has the size you want, release the mouse button.

You will now see the text box with the cursor blinking.

The expanded text box expects you to enter text immediately.

Enter your text.

If you deselect the text box before you have entered text, the text box disappears again.

Deselect text box

You can deselect a text box by clicking next to it or pressing the ESC key.

Text box special features

Unlike in Writer, you can use styles|drawing styles for the text boxes in Draw.

The explanations are given below.

Customize text box

You can resize a text box afterwards.

You can change font, font size and font color.

You can also customize the background color of the text box and the character highlighting.

And you have other options for customizing the text box, see below.

Where are the customizations made for a text box

Right-click on a text box and a context menu appears, where you can select the most common functions.

You have more advanced options in the sidebar at Properties.

The sidebar can be reached via the menu View ▸ Sidebar ( Ctrl + F5 ).

Resize text box

Resize a text box by clicking on the text box so that it is marked.

You can see the marking by the frame, which now shows 8 small squares.

When you hover your mouse over one of these squares, the cursor changes shape as a double arrow.

You can click on it and drag the text field in the shown directions of the cursor, i.e. bigger or smaller.

Change font, size and color

This procedure is also called direct formatting.

In Draw, you have the option of using the Styles|Drawing styles instead of direct formatting (recommended).

For the further descriptions here, we will work uniformly with the sidebar, or refer to it.

In the sidebar|Properties|Characters there are two fields for selecting the font and font size.

Click on the downward pointing arrow next to each field and select the font and font size.

Change color for text and background

This procedure is also called direct formatting.

In Draw, you have the option of using the Styles|Drawing styles instead of direct formatting.

Below the fields for font and font size, there are symbols for character color and character highlighting.

You can now select these for the text.

You can select the background color of the text box in the sidebar|Properties at Area.

For the area you can choose:

  • Without
  • Color
  • Gradient
  • Hatch
  • Bitmap
  • Pattern

Choose the color of the area and possibly the transparency.

Further adjustments for a text box

This procedure is also called direct formatting.

In the sidebar|Properties, you have more customization options when the text box is selected, for:

  • Lists
  • Paragraph
  • Area
  • shadow
  • Line
  • Position and Size

Adjust text box with drawing styles

Drawing Styles
choose "New"
Dialog Graphic Styles
Color of Area

This procedure is also called Formatting with styles or soft formatting.

If you use format styles|drawing styles, you can specify many properties of the text and the text box there.

The advantage of a drawing style is that you can assign the previously entered properties to a text box all at once.

The drawing styles can also be found in the sidebar, but at Styles.

When you draw a new text box, it usually has the drawing style "Standard".

You can see that when the text box is selected in the Sidebar|Styles|Drawing Styles, the drawing style "Standard" is displayed as selected.

Create Drawing Style

If you want to create a drawing style for your text box, right-click on the drawing style "Standard" and select New.

In the following "Drawing Styles" dialog, assign a catchy name for the new drawing style.

In the tabs "Font", "Font Effects", "Highlighting", "Line" and "Area" you adjust the defaults, and if necessary, of course, in all other tabs.

Apply drawing style

Select a text box (it should not have been directly formatted before) and double-click on your new drawing style.

The text box now takes on all the properties that you have specified in this drawing style.

With a double-click you can format all other text boxes.

If you think you would prefer a different color for the area, change the drawing style (right-click and select "Modify") and click OK.

All text fields that have been assigned this drawing style instantly change the color of the area.

By the way, the text boxes do not have to be selected for this.

Rotate text box

You can rotate a text box by clicking the selected text box again.

The 8 small squares are now displayed with dots.

Move the mouse over one of the corner points.

The cursor is now displayed as a three-quarter circle with end arrows.

Click on a point and rotate the text box forwards or backwards.

If you also hold down the ⇧ Shift key, the text box will snap into place in 15° increments.

When you have reached the desired position, click.

Delete direct formatting

Select the text boxes and texts that have direct formatting applied to them.

Then choose Format ▸ Delete Direct Formatting ( Ctrl + M ) from the menu.

- To the top -

Layer functions

Layers are located below the plan window

This discription is based on the LibreOffice online help.

Layers in Draw allow great management even for more complex drawings.

Layers allow you to arrange related elements on a page.

For example, you can divide your drawing details according to whether or not you want them to be printed later.

You can make individual layers invisible if too many details bother you when drawing.

And you can lock layers so you don't accidentally edit objects you didn't want to.

Layers

Drawings in LibreOffice Draw support layers.

 Note 
 The terms ″plane″, ″layer″, ″register″ and ″tab″ are sometimes used analogously.

The layers are located below the plan window.

The areas on a layer that do not contain objects are transparent.

Each layer contains a so-called drawing layer.

The respective layer can be imagined as a transparent foil or drawing surface.

If you place several layers on top of each other, the objects contained in them are displayed (prerequisite: the layer is switched to visible).

 Note 
 Objects in one layer, can cover objects in a layer below.

The three layers "Layout", "Controls" and "Dimension Lines", are always provided in Draw.

The Layout layer is the default workspace.

The Controls layer is for buttons that have been assigned an action and should not be printed.

Deactivate the "Printable" property of the layer.

 Note 
 The objects on the "Controls" layer are always in front of the objects on other layers.

The Dimension Lines layer is used to draw dimension lines.

By changing the layer, you can easily turn these lines on and off to hide or show them.

 Note 
 The default layers cannot be deleted or renamed.

Select Insert Layer to add your own layers.

Select a layer

Select a layer by clicking the tab with the layer name at the bottom.

Stacking order

Except for the Controls layer, which always comes before other layers, layers do not affect the stacking order of objects on a page.

The stacking order of objects on your slide is determined by the order in which you add the objects.

Choose Shape ▸ Arrange from the menu to change the stacking order of objects.

The layers context menu

Layer Context menu

Right-click on the tab of a layer or left-click in the free area next to the last tab of the selected layer to open the layer context menu.

Insert Layer

"Insert Layer" Dialog

In the context menu, select Insert Layer….

The "Insert Layer" dialog opens.

In the "Name" field, type a name for the new layer.

In the "Title" field, you can add a title.

In the "Description" field, write what purpose this layer should serve for you.

Below that, set the "Visible", "Printable" and "Locked" properties of the layer.

Click OK.

The new layer is automatically the active layer.

Modify Layer

"Modify Layer" dialog

Select in the context menu Modify Layer….

The "Modify Layer" dialog opens.

Write the desired modifications in the "Name", "Title" or "Description" fields or change the "Visible", "Printable" and "Locked" properties of the Layer.

Click OK.

The layer automatically remains the active layer.

The layers properties

  • Visible - shows or hides the content of the selected layer.
  • Printable - allows printing the layer or not.
  • Locked - locks the content of the selected layer or not, i.e. editing the layer is possible or not.

Possible representations of the layer labels

The combinations of layers properties leads to different display of layer labels.

Set the properties of a layer via the context menu

Each Layer has a Layer context menu.

Right-click on the layer name to open the menu, or to modify the properties of a layer, click on the tab with the layer name and then choose Format ▸ Layer…. from the menu.

Selecting Modify Layer… brings up the "Modify Layer" dialog.

The properties "Visible", "Printable" and "Locked" can be selected or deselected.

The combination of these three possibilities results in the respective overall state of a layer.

Possible representations of the layer labels - Visible
1. 2. 3.
Visible Visible Visible
Printable Printable Not Printable
Unlocked Locked Unlocked
Possible representations of the layer labels - Hidden
4. 5. 6.
Hidden Hidden Hidden
Printable Printable Not Printable
Unlocked Locked Unlocked

Set properties of layers via keyboard shortcuts

Keyboard shortcuts

The settings of the "Visible", "Printable" and "Locked" properties of the layers can also be changed quickly with keyboard shortcuts without menu selection.

To toggle the layer between Visible / Hidden, press: ⇧ Shift + Click

To toggle the layer between Locked / Unlocked, press: Ctrl + Click

To toggle the layer between Printable / Not printable, press: Ctrl + ⇧ Shift + Click

Delete layer

If you select "Delete Layer", the selected layer will be deleted.

Rename layer

If you select "Rename Layer", the tab label will be selected.

Write the new name of the layer.

You can change the name only of the layers you created yourself.

LibreOffice online help about layers

About Layers

Insert Layers

Modify Layer

Working with Layers

Moving Objects to a Different Layer

- To the top -

Zoom functions under Windows

Zoom functions under Windows

Further Informations

Work files

Draw-Objects.odg

The Gallery LibreOffice 7.0

The_Gallery_LibreOffice 7.0

FAQ/Draw - Gallery

Faq/Draw - Gallery

Documentation / Manuals

Here you will find the Documentation / Manuals:

Documentation / Manuals

Any questions?

For questions on this topic go to:

Ask.LibreOffice

Get Involved

Join us today and help us to make it even better!

Get Involved

LibreOffice is Free Software and is made available free of charge.

Your donation, which is purely optional, supports our worldwide community.

If you like the software, please consider a Donation.

- To the top -