LibreOffice 7.4 Community: Note di rilascio

From The Document Foundation Wiki
Jump to navigation Jump to search
This page is a translated version of the page ReleaseNotes/7.4 and the translation is 100% complete.
Other languages:
Bahasa Indonesia • ‎Deutsch • ‎English • ‎Nederlands • ‎Türkçe • ‎dansk • ‎français • ‎italiano • ‎português do Brasil • ‎slovenščina • ‎čeština • ‎русский • ‎فارسی • ‎中文(中国大陆)‎ • ‎日本語

Contenuto della pagina

Questa è una pagina in continuo aggiornamento nella quale stilare le note di rilascio, man mano che vengono sviluppate. Siete pregati di non elencare funzioni aggiunte già nella precedente versione 7.4! Aggiungete solo le funzionalità che sono realmente già state implementate nel rilascio e non quelle che sperate siano presenti.

Ecco come dovrebbe essere una buona presentazione di una funzionalità:

  • possiede una descrizione e, per aiutare i lettori, spiega dove si trova quella funzione in modo da poterla provare. Immaginate che chi legge sia estremamente occupato e conosca poco o nulla riguardo alla suite. Quindi, se un elemento dell'interfaccia grafica dà accesso a quella funzione, siate molto espliciti nel precisare dove sia, ad esempio il suo percorso nel menu Formato ▸ Carattere ▸ (scheda) Posizione ▸ '90 gradi'.
  • indica i nomi degli autori principali che hanno svolto il lavoro – basta aggiungerli fra parentesi dopo la descrizione della funzionalità, dove possibile;
  • se la funzione può essere presentata con un esempio o un file di prova - in particolare per le nuove funzioni di import - sarebbe ideale inserire un collegamento o caricare un file che la illustri nel modo migliore, aggiungendo delle schermate che ne raffigurino le caratteristiche.

Grazie in anticipo per il vostro contributo!


Writer

Miglioramenti generali

  • La voce del menu Strumenti ▸ Aggiorna ▸ Aggiorna tutto aggiorna l'anteprima di tutti gli oggetti OLE (post sul blog) (Miklos Vajna; Collabora)
  • diversi miglioramenti relativi ai bordi delle tabelle e dei paragrafi al fine di renderli maggiormente compatibili con Word (post sul blog) (Miklos Vajna; Collabora)
  • corretta la generazione degli indici analitico o generale quando la voce crea indice analitico o generale ▸ Per: è impostata su Capitolo nella finestra di dialogo Indice generale, analitico o bibliografia del menu (Inserisci ▸ Indice generale e analitico). Le voci generate iniziano dal livello del capitolo corrente, anziché essere stabilmente connesse al livello 2 come in precedenza tdf#130318 (Andreas Heinisch; Emanuele Gissi, CNVVF)
  • Writer supporta la pulizia delle interruzioni di riga di Word per una maggiore fedeltà dell'impaginazione post sul blog (Miklos Vajna; Collabora)
  • La finestra di dialogo Controllo accesso facilitato (Strumenti ▸ Controllo accesso facilitato...) ora viene elaborata in maniera asincrona core commit 61fed0c4 (Nick Wingate; Collabora)
  • per i documenti caricati in sola lettura, Writer ora permette di visualizzare le modifiche apportate, sia tramite la finestra di dialogo Modifica ▸ Revisioni ▸ Gestisci... sia nella barra laterale. core commit 82e789bf (Michael Stahl, allotropia)
  • il tracciamento della cancellazione e dell'inserimento di note a piè di pagina è visibile nell'area delle note a piè di pagina tdf#85610 (László Németh, NISZ)
Il formato della numerazione delle note a piè di pagina usato per mostrare la loro cancellazione e il loro inserimento
  • tdf#104930 Gestione della proprietà "sospesa" per la linea di base dei caratteri OpenType, questo permette ai testi di dimensioni diverse di allinearsi alla linea di base sospesa. tdf#104930 (Mark Hung)
  • Writer ora supporta nativamente il contenuto dei campi rich text e casella di controllo di Word post sul blog (Miklos Vajna; Collabora)
  • Writer ora supporta nativamente il contenuto dei controlli menu a discesa, figure e data di Word post sul blog (Miklos Vajna; Collabora)
  • la correzione automatica dei marcatori *grassetto*, /corsivo/ ecc. è stata disabilitata per impostazione predefinita tdf#133023 (Heiko Tietze, TDF)
  • Migliorato il posizionamento dei glifi, superando alcuni problemi con le crenature e con lo slittamento indesiderato dei caratteri durante la digitazione tdf#144862 (Caolán McNamara, Red Hat)

Nuove impostazioni tipografiche

Aggiunte nuove impostazioni opzionali per la sillabazione al fine di regolare il flusso di testo a livello di paragrafo. (László Németh)

  • Zona di sillabazione (pensata per limitare la sillabazione, usata specialmente con l'allineamento non giustificato del paragrafo). tdf#149420
  • Lunghezza minima della parola da sillabare tdf#149324
  • Non sillabare l'ultima parola del paragrafo tdf#149248

Nota: queste caratteristiche fanno parte del Livello 4 del Modulo di testo di CSS4, dei software di DTP (Desktop Publishing)Wikipedia logo v3.svg e, nel caso della zona di sillabazione, di OOXML/MSO.

La scheda Flusso di testo della finestra Formato ▸ Paragrafo... contiene nuove opzioni di sillabazione, per la regolazione rapida degli errori della sillabazione automatica e per interoperabilità

Nuova numerazione nel modo Mostra le modifiche

Visualizza la numerazione attuale ed originale degli elementi dell'elenco quando è attivo il modo Mostra le modifiche. tdf#115523 tdf#115524 (László Németh, NISZ)

  • Non usa la numerazione sballata, che contava gli elementi rimossi dall'elenco come se non fossero stati eliminati.
  • Visualizza per primo il numero attuale, seguito dal numero originale racchiuso in parentesi quadre, ad esempio “1.[2.]”.
  • Il numero attuale e quello originale sono visualizzati non solo per gli elementi eliminati ed inseriti, ma anche per quelli seguenti; ad es. per facilitare il riconoscimento delle modifiche ad un testo legale.
  • Per migliorare la visibilità di questi elementi dell'elenco, le numerazioni modificate ed il testo del paragrafo sono separate da uno spazio, non da un tabulatore, questo per evitare elenchi indentati in maniera non corretta.
Il modo Mostra le modifiche visualizza correttamente le modifiche alla numerazione: non conta gli elementi rimossi dall'elenco, visualizza anche i numeri originali di tutti gli elementi dell'elenco la cui numerazione risulta modificata (a sinistra: prima di questa correzione, a destra: dopo questa correzione, Elenco 1: tracciamento dell'eliminazione di un elemento dall'elenco, Elenco 2: tracciamento dell'inserimento di un elemento nell'elenco, Elenco 3: tracciamento sia dell'eliminazione, sia dell'inserimento)

Nuovo correttore ortografico remoto: LanguageTool

  • Writer ora è in grado di beneficiare del controllo ortografico di LanguageTool da remoto attraverso le sue API. Documentazione delle API (grazie ad Adfinis per aver sponsorizzato questa funzionalità) core commit d952df36 (Mert Tümer; Collabora)
In Impostazioni delle lingua in Strumenti ▸ Opzioni aggiunte nuove impostazioni per il controllo ortografico usando le API di LanguageTool.
Il menu contestuale visualizza la parola appropriata dopo aver controllato l'ortografia con le API remote di LanguageTool.

Calc

Miglioramenti generali

  • È stato aggiunto il supporto per i grafici sparkline (post sul blog) (Tomaž Vajngerl, Collabora)
  • Ora Calc supporta ed usa 16384 (post sul blog) . (Luboš Luňák, Collabora)
  • Aggiunte le funzioni CONTA.VALORI, PRODOTTO, DEV.ST, DEV.ST.POP, VAR e VARP al menu a comparsa della somma automatica nella barra della Formula tdf#139602 (Dhiraj Holden)
  • quando usate la finestra di dialogo Collegamento ipertestuale (Ctrl + K) il testo della cella selezionata viene inserito nel campo Testo. Se selezionate un'intera cella con un singolo clic ed inserite un URL usando la finestra di dialogo Collegamento ipertestuale, l'intero contenuto della cella corrispondente sarà sostituito anziché inserire un duplicato o aggiungere l'URL. Se la cella contiene più di un URL o un URL con del testo aggiuntivo, la finestra di dialogo Collegamento ipertestuale all'apertura preimposterà solamente il campo testo. Altrimenti compilerà anche il campo URL. tdf#80043 (Andreas Heinisch)
  • L'altezza della barra della formula ora è memorizzata nel documento. tdf#99708 (Samuel Mehrbrodt, allotropia)
  • Migliorata la finestra di dialogo Sposta o copia foglio: l'etichetta del pulsante OK cambia a seconda del comando scelto (Sposta o Copia). tdf#139464 (Laurent Balland)
  • Un nuovo menu contestuale Duplica Foglio è stato aggiunto ed è accessibile con un clic del pulsante destro del mouse sull'area delle linguette dei fogli. Questo permette la duplicazione veloce (cioè la creazione di una copia) di un foglio esistente. tdf#145745 (Rafael Lima)
  • Espansione automatica della matrice di celle per le formule con espressioni che restituisco una matrice. Per le formule inserite in una cella con espressioni che ovviamente restituiscono una matrice, l'intervallo di celle del risultato viene esteso come se aveste premuto ⇧ Maiusc + Ctrl + Invio per completare la formula matriciale. Il comportamento precedente, che visualizzava solamente una cella corrispondente all'elemento in alto a sinistra, può essere forzato ed ottenuto selezionando una singola cella prima dell'inserimento. tdf#149378 (Eike Rathke, Red Hat)
  • Facilitato l'accesso ad un foglio di un documento contenente molti fogli, tramite la nuova voce di menu Foglio ▸ Naviga ▸ Vai al foglio che richiama la nuova finestra di dialogo per cercare tra il nome dei fogli. tdf#129674 (Laurent Balland)
  • Le colonne/righe nascoste possono avere un indicatore Visualizza ▸ Indicatore righe/colonne nascoste tdf#128258 (Heiko Tietze, TDF)
  • Le opzioni di ordinamento e gli elementi da ordinare sono più facilmente accessibili tdf#131155 tdf#140290 (Heiko Tietze, TDF)
  • Formato dei numeri: migliorata la leggibilità di numeri decimali lunghi attraverso il formato 0.000"-"000"-"000. Il testo incorporato nella parte decimale ora viene salvato e recuperato correttamente nel formato ODS tdf#96723 (Laurent Balland)
  • Durante la digitazione della formula, l'inserimento automatico nella barra della formula ora suggerisce anche i nomi no inglesi delle funzioni e i Nomi delle aree tdf#142031 (Andreas Heinisch)

Prestazioni

  • Migliorate le prestazioni quando molte colonne contengono dati (post sul blog) . (Luboš Luňák, Collabora)
  • Migliorate le prestazioni di funzioni come CONTA.SE, SOMMA.SE e CERCA.VERT, specialmente con dati non ordinati tdf#139444 tdf#144777 tdf#146546 (Luboš Luňák, Collabora)
  • Ricalcolo più veloce in alcuni documenti con molte formule tdf#119083 (Luboš Luňák, Collabora)
  • La velocità di apertura di file CSV molto grandi è stata migliorata tdf#94677 (Luboš Luňák, Collabora)
  • Migliorate le prestazioni del filtro di esportazione in Excel tdf#95346 tdf#117366 tdf#126326 tdf#133749 tdf#140893 (Luboš Luňák, Collabora)
  • Migliorate le prestazioni nel caricamento di fogli elettronici che necessitano di essere ricalcolati core commit c315a2f7 core commit 64cb1d10 (Luboš Luňák, Collabora)

Impress e Draw

  • Introduzione dei temi per i documenti in Impress: testo delle forme post sul blog (Miklos Vajna, Collabora)
  • aggiunto anche il supporto al riempimento delle forme per i temi dei documenti in Impress post sul blog (Miklos Vajna, Collabora)
  • supporto all'uso dello sfondo della diapositiva come riempimento delle forme, per interoperabilità con il formato PPTX (Armin Le Grand, Samuel Mehrbrodt, allotropia) tdf#128150
Forma della diapositiva schema che usa lo sfondo della diapositiva come riempimento - versione 7.3 e 7.4

Base

Grafici

Math

Principali / Generale

Miglioramenti generali

  • Aggiunto il supporto per l'importazione/esportazione di immagini WebP tdf#114532 (Luboš Luňák, Collabora)
    • Fate attenzione che attualmente, il formato WebP non viene convertito in PNG internamente, ciò per assicurare la compatibilità retroattiva dei file dei documenti generati.
  • resa asincrona la finestra di dialogo per assegnare il nome ad un nuovo colore core commit 7741b21f (Nick Wingate, Collabora)
  • La configurazione ora ricorda se i documenti recenti erano stati aperti in sola lettura o come modificabili ed aprendoli tramite File ▸ Documenti recenti o dal Centro di avvio saranno aperti nello stesso modo dell'ultima volta. core commit 404c51f3 (Michael Stahl, allotropia)
  • Aggiunto il supporto per i file EMZ/WMZ tdf#103954 (Paris Oplopoios)

Illuminazione delle forme estruse personalizzate

Miglioramenti all'illuminazione delle forme estruse personalizzate al fine di rendere la visualizzazione maggiormente compatibile con i formati binari di MS Office e di interpretare un numero maggiore di attributi ODF. tdf#145700 (Regina Henschel)

  • L'interpretazione sbagliata della direzione z delle luci è stata corretta. In particolare l'illuminazione centrale dall'osservatore all'oggetto ora funziona. La posizione delle alte luci che si riflettono sulle superfici arrotondate ora è la stessa di MS Office.
  • La voce "Metallo" è stata sostituita dalle voci "Metallo ODF" e "Metallo compatibile con MS" nel sottomenu "Superficie" della barra degli strumenti "Impostazioni 3D". La seconda non è utilizzabile nei file ODF del formato "ODF 1.3". Nell'attuale "Metallo ODF" il colore del riflesso è il grigio come specificato in ODF. Nell'attuale "Metallo compatibile con MS" il colore del riflesso è rispettivamente quello di riempimento della forma o dell'estrusione, analogamente alla visualizzazione di MS Office.
  • Il servizio EnhancedCustomShapeExtrusion delle API è stato esteso con il nuovo attributo MetalType. Questo può assumere il valore MetalODF o MetalMSCompatible. Questo attributo è usato nell'impostazione predefinita per la superficie "Metallo compatibile con MS".
  • L'attributo ODF draw:extrusion-shininess ora viene interpretato. Questo attributo è simile all'impostazione "Intensità del riflesso" nella scheda "Materiale" della finestra di dialogo "Effetti 3D" degli oggetti 3D. L'attributo non ha una sua interfaccia grafica, ma è disponibile attraverso l'attributo Shininess del servizio EnhancedCustomShapeExtrusion delle API.
  • L'attributo ODF draw:extrusion-diffusion ora viene interpretato. Solamente il suo valore predefinito "0%" non è interpretato, in quanto le forme già esistenti non hanno questo attributo impostato e si aspettano un valore del 100%. Per le forme esistenti potete forzare la scrittura dell'attributo nel file disattivando e riattivando l'estrusione. L'attributo è usato nella preimpostazione della superficie "Metallo compatibile con MS". L'attributo non ha una sua interfaccia grafica, ma è disponibile attraverso l'attributo Diffusion del servizio EnhancedCustomShapeExtrusion delle API. Un valore inferiore al 100% riduce la luminosità visualizzata dell'oggetto.
  • Gli attributi ODF draw:extrusion-first-light-harsh e draw:extrusion-second-light-harsh ora vengono interpretati. Le luci sono visualizzate morbide distribuendo, durante l'elaborazione, parte dell'intensità della luce in quattro direzioni attorno alla direzione originale della luce. Le impostazioni predefinite dell'illuminazione nel sottomenu "Illuminazione" nella barra degli strumenti "Impostazioni 3D" prevedono l'attributo compatibile con MS Office. L'attributo non ha una sua interfaccia grafica, ma è disponibile attraverso gli attributi FirstLightHarsh e SecondLightHarsh del servizio EnhancedCustomShapeExtrusion delle API.
  • L'implementazione dell'attributo ODF draw:extrusion-specularity si adatta alla corrispondente proprietà della forma prevista nel formato binario di MS Office. Questo attributo corrisponde all'impostazione "Colore riflesso" nella scheda "Materiale" della finestra "Effetti 3D" degli oggetti tridimensionali. Solamente non vengono usati colori arbitrari, ma unicamente variazioni di grigio. L'attributo non ha una sua interfaccia grafica, ma è disponibile attraverso l'attributo Specularity del servizio EnhancedCustomShapeExtrusion delle API. Un valore pari a "0%" forza la prima luce a non creare riflesso, il che produce una superficie opaca nella visualizzazione dell'oggetto. Questo è usato come impostazione predefinita della superficie "Opaca".

Prestazioni

Guida in linea di LibreOffice

  • Guida in linea per la libreria di scripting ScriptForge (J.P. Ledure, A. Romedenne, R. Lima)

Filtri

Filtri di importazione/esportazione dei file DOCX

  • DOCX: importazione delle caselle di testo (con tabelle, immagini, ecc.) presenti in gruppi di forme tdf#66039 (Attila Bakos, NISZ)

Sblocco con verifica della password della protezione al monitoraggio delle modifiche

Sblocco della protezione al monitoraggio delle modifiche dei documenti DOCX tramite verifica obbligatoria della password tdf#128744 tdf#106843 (László Németh, NISZ)

  • Facendo clic sull'icona Registra modifiche nella barra degli strumenti di Revisione (o su Modifica ▸ Revisioni ▸ Registra) viene richiesta la password di verifica, anziché mostrare solo un avvertimento prima dello sblocco senza password;
  • Nella scheda Sicurezza della finestra di dialogo File ▸ Proprietà..., il pulsante Disattiva protezione accetta la password corretta senza disabilitare la registrazione delle modifiche, anziché rifiutare la password corretta.

Filtri di importazione/esportazione dei file PPTX

  • esportazione di file PPTX: corretta l'esportazione dei file video incorporati tdf#53970 (Tünde Tóth, NISZ)
  • importazione di file PPTX: corretta l'importazione dei file multimediali collegati. I file multimediali collegati venivano importati come immagini nei documenti creati da Impress dopo un'esportazione in formato PPTX. tdf#53970 (Tünde Tóth, NISZ)
  • PPTX: aggiunti dei "punti d'incollaggio" ad alcune forme di base (ellissi, triangolo, triangolo retto, trapezio, parallelogramma, diamante, pentagono, esagono, ettagono, ottagono). Attenzione: l'importazione da file PPTX non importa i connettori attaccati ai punti d'incollaggio – solamente l'esportazione in formato ODP li mantiene utilizzabili per le modifiche per cui sono pensati, come ad es. spostare le forme senza perdere le linee e le frecce a loro collegate. tdf#147459 (Tibor Nagy, NISZ)

Filtro di importazione/esportazione in formato RTF

Esportazione di file PDF

  • Migliorate le opzioni di esportazione in PDF da linea di comando post sul blog (Miklos Vajna, Collabora)
  • I tipi di campo di controllo Numerico, Valuta, Data e Orario sono esportati nei formulari in PDF tdf#105972 (Xisco Fauli, TDF)

Esportazione di file HTML

  • La configurazione della codifica di esportazione (codifica caratteri) è stata eliminata dalle Opzioni|Carica/Salva|Compatibilità HTML, i file HTML ora sono esportati usando sempre UTF-8 come codifica caratteri tdf#148413 (Mike Kaganski, Collabora)

importazione di file EMF/WMF

  • Aggiunto il supporto alle Estremità appuntite nel formato EMF+ tdf#142261 (Bartosz Kosiorek)
  • Aggiunto il supporto ai terminali di linea individuali per il formato EMF+ tdf#143875, tdf#55058 (Bartosz Kosiorek)
  • Corretti i buchi nelle linee creati da LINETO nei formati EMF/WMF tdf#89331 (Bartosz Kosiorek)
  • Aggiunto il supporto ai formati grafici compressi con Z nei formati EMF/WMF (.emz and .wmz file formats) tdf#103954 (Paris Oplopoios)
  • I tipi di variabile sono usati in conformità alla documentazione del formato EMF+ tdf#103859 (Bartosz Kosiorek)
  • Corretta nei file formato EMF+ la visualizzazione dei riempimenti di tipo PathGradient tdf#131506 tdf#143031 (Bartosz Kosiorek)

Importazione di file PDF

  • TIFF: filtro di importazione riscritto usando libtiff al fine di supportare molte più varianti (Caolán McNamara, Red Hat, Inc. e Julien Nabet)
  • Aggiunto il supporto al formato OfficeArtBlip TIFF core commit 8c9e6d3a (Bartosz Kosiorek)

Interfaccia grafica

  • Il Navigatore ora può posizionarsi su una voce quando questa viene selezionata con un singolo clic, senza lasciare il navigatore. Abilitate questa funzione con l'opzione avanzata NavigateOnSelect in org.openoffice.Office.Writer > Navigator tdf#131063 (Jim Raykowski)
  • Migliorata visualizzazione delle miniature nel Centro di avvio tdf#134065, tdf#147998, core commit b70d17b0 (Mike Kaganski, Collabora)
  • Campo di ricerca nel Gestore delle estensioni tdf#126672 (Samuel Mehrbrodt, allotropia)
  • La finestra di dialogo del carattere è stata rimaneggiata in modo che resti di dimensioni compatte quando si attivano delle lingue Asiatiche e/o complesse tdf#139395 e tdf#146928 (Heiko Tietze, TDF)
Tema scuro di LibreOffice in Windows

Tema di icone

  • Il tema di icone Colibre, che è quello predefinito in Windows, ora ha una variante scura che mantiene lo stile di composizione del colore monolineare di Microsoft. tdf#146545 (Rizal Muttaqin)
Tema di icone Colibre scuro

Localizzazione

Nuove lingue/impostazioni locali

Disponibili come lingua predefinita per i documenti e per la specifica formattazione locale.

  • Olandese della Pennsylvania {pdc-US}. tdf#146602 (Peter K. Zacharias, Pennsylvania Dutch Education Corporation; Eike Rathke, Red Hat)
  • Aranese {oc-ES}. tdf#147053 (Javier Torres Fernández; Eike Rathke, Red Hat)
  • Maldiviano {dv-MV}. tdf#148428 (Adam, M. A.; Eike Rathke, Red Hat)
  • Inglese (delle Mauritius) {en-MU}. (Eike Rathke, Red Hat)

Miglioramenti agli strumenti di correzione e supporto linguistico

  • Aggiunto il dizionario ed il correttore ortografico per la lingua Soranî (ckb). commit 1, core commit 5727a12a (jwtiyar nariman; Olivier Hallot, TDF)
  • L'Occitano dal 2018 possiede diversi tipi di varianti per la lingua nei subtag del registro IANA language-subtag-registry. Storicamente LibreOffice usava oc-FR per l'Occitano linguadociano e oc-ES per l'Occitano aranese come tag per la lingua. Questa indicazioni non erano abbastanza specifiche, almeno per l'oc-FR, e ora sono state aumentate come oc-FR-lengadoc e oc-ES-aranes, i precedenti codici oc-FR e oc-ES sono ancora riconosciuti e accettati come alias. LibreOffice 7.3.5 accetterà oc-FR-lengadoc e oc-ES-aranes come alias per oc-FR e oc-ES per futura compatibilità. tdf#147390 (Eike Rathke, Red Hat)
  • Il dizionario del correttore ortografico Danese è stato aggiornato (stavekontrolden.dk)
  • Il dizionario dei sinonimi e contrari dello Sloveno è stato aggiornato (Martin Srebotnjak, OdprtiTezaver).

Scripting

Cartella dei comandi .UNO:command di DispatchHelper

la pagina wiki relativa ai .UNO:Commands del servizio com.sun.star.frame.DispatchHelper è stata aggiornata. Contiene l'elenco di tutti i comandi utilizzabili nella versione 7.4 con i rispettivi argomenti.

Librerie ScriptForge

Una solida ed estensibile collezione di macro e risorse per lo scripting di LibreOffice che possono essere invocate negli script realizzati dagli utenti usando Basic o Python. (Jean-Pierre Ledure)

Le librerie forniscono in totale 26 servizi ognuno dei quali contiene numerosi metodi e proprietà.

Novità in LibreOffice 7.4:

  • Il (nuovo) servizio Menu per descrivere un nuovo menu da visualizzare nella barra dei menu. Il menu può contenere le solite voci, caselle di controllo o di scelta. Ogni voce può essere arricchita con icone e suggerimenti.
  • Il (nuovo) servizio UnitTest, un ambiente di lavoro che permette di impostare casi e insiemi di verifiche sui moduli ed estensioni complessi realizzati in Basic.
  • Il (nuovo) servizio Region, per gestire le impostazioni locali, i fusi orari e l'ora legare. Che ora è a Tokyo quando sono le 12am a Roma? Converte anche i numeri in lettere in qualsiasi lingua.
  • Ottenere l'elenco delle estensioni disponibili e la loro cartella di installazione (servizio filesystem).
  • Eseguire comandi di menu con argomenti (servizi ui e document).
  • Gestire una lingua di ripiego (servizio l10n).
  • Esportare intervalli di fogli come immagini o file PDF (servizio calc).
  • Eliminare righe e colonne da intervalli di fogli in base a filtri espressi come formule (predefinito = Elimina tutte le righe e colonne vuote) (servizio calc).
  • Creare e posizionare una tabella pivot (servizio calc).
  • Ridimensionare e/o centrare finestre di dialogo rispetto ad una finestra di sfondo (servizio dialog).
  • L'intero insieme di servizi (ad eccezione di quelli non applicabili) è resto disponibile per l'uso negli script in Python con sintassi e comportamenti identici a quelli in Basic.

Supporto per VBA

  • Aggiunto il supporto per Application.WindowState, commit (Tomaž Vajngerl, Collabora)
  • Aggiunto il supporto per Application.GetOpenFilename tdf#118246 (Tomaž Vajngerl, Collabora)
  • L'esportazione dei progetti in VBA usa la codifica caratteri rilevata durante l'importazione tdf#75263 (Andreas Heinisch)
  • il metodo VBA Range.Sort estende la selezione da una sola cella ad un intervallo Range.CurrentRegion tdf#149579 (Eike Rathke, Red Hat)
  • Supporto per richiamare un Foglio tramite il suo nome tdf#149325 (Eike Rathke, Red Hat)

Basic

  • Fino alla versione 7.2 di LibreOffice compresa, gli argomenti facoltativi mancanti della procedura erano trattati come un oggetto di tipo Error, con codice errore '448', che nelle espressioni veniva forzato, ad esempio al valore numerico '448' o al valore booleano true, a seconda del contesto dell'espressione. Ora questo genera un errore, come da aspettative tdf#144353. In particolare, espressioni come "if IsMissing(FOO) or FOO" funzionavano "per combinazione", ora non lo fanno più.

Funzionalità rimosse o deprecate

  • il supporto al protocollo FTP è deprecato e sarà rimosso in una delle prossime versioni.
  • Nel SDK (Software Development Kit), gli strumenti idlc e regmerge (che usano il tipo di formato del registro compatibile con vecchie versioni) sono deprecati e saranno rimossi in una delle prossime versioni, sostituiti da unoidl-write (che usa il nuovo tipo di formato del registro introdotto internamente in LibreOffice 4.1). core commit 40f2aee6
  • La funzione in C typelib_setCacheSize è stata deprecata senza una funzione sostitutiva, se viene chiamata non produce alcun effetto. core commit c3e9eb99

Compatibilità piattaforme

Mac

  • Per poter essere eseguito, LibreOffice 7.3 richiede la versione 10.13 o una più recente di macOS.
A causa delle policy di Apple relative alle librerie di funzionalità standard di C++, la versione minima di macOS richiesta in futuro verrà innalzata come segue:
  • rilascio in Febbraio 2023 → 10.14 Mojave
  • rilascio in Agosto 2023 → 10.15 Catalina

Modifiche alle API

  • Il servizio EnhancedCustomShapeExtrusion delle API è stato ampliato con il nuovo attributo MetalType. Questo può avere il valore MetalODF o MetalMSCompatible. L'attributo non è utilizzabile nei file in formato "ODF 1.3". Per il contesto di implementazione vedete Illuminazione delle forme estruse personalizzate.
  • Il servizio SpreadsheetViewSettings ha la nuova proprietà FormulaBarHeight che permette di leggere/impostare l'altezza della barra della formula di Calc. core commit d0cacf09 (Samuel Mehrbrodt, allotropia)

Elenchi di spostamento (Jump List)

In Windows, ora è possibile personalizzare gli elenchi di spostamento (Jump Lists) usando le API UNO. Documentazione. (Samuel Mehrbrodt, allotropia)

Elenco di spostamento (Jump list) personalizzato di Writer

Visualizzatore per Android