How to Report Bugs in LibreOffice

From The Document Foundation Wiki
< QA
Jump to: navigation, search
This page is a translated version of the page QA/BugReport and the translation is 9% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎Deutsch • ‎Ελληνικά • ‎English • ‎español • ‎français • ‎galego • ‎italiano • ‎日本語 • ‎Nederlands • ‎português do Brasil • ‎русский • ‎Türkçe • ‎中文(中国大陆)‎ • ‎中文(简体)‎ • ‎中文(台灣)‎

خطوة رائعة

انت على وشك القيام باسهام كبير في LibreOffice, تقرير العلل الواضح والمتكامل مهم جدا للمطورين فشكرا لك لقيامك بهذه الخطوه. من أجل جعل حياة اللذين يتعاملون مع تقارير العلل اسهل, يوجد لدينا بعض الخطوات البسيطه لمساعدتك. من المهم جدا تقديم العلل التي لم تتعرف من قبل, لاحتمال وجود تقرير مسبق عنها وفي هذه الحاله من الأفضل اضافة المعلومات الاضافيه الهامه الى التقرير لاثرائه, ولعمل هذا ننصحك بزيارة تقارير العلل الأكثر انتشارا في LibreOffice

ويمكن الاستفادة من :

معلومات عامة

هل المشكلة حقاً علَّة ؟

Class of Bugs Where to file the bug
LibreOffice Extensions With the extension author
TDF/LibreOffice Infrastructure (websites, mailing lists, etc.) Redmine
Building LibreOffice Developer mailing list
LibreOffice Unit Tests Developer mailing list

الإبلاغ عن العلل المتعلقة بأوبنتو لينُكس

Confirm that it really is a bug. Most of the time, a bug is something that makes the software behave in a way that a reasonable user would not want it to behave. This includes the software not doing what you want it to do, doing what you never asked it to do, or just plain crashing under normal use. Going behind the scenes, a bug may be something that causes the software to take a lot longer and use a lot more resources doing stuff than it should.

القائمة الحالية للمشاكل المختصة بأوبنتو متوفرة هنا

يجب أن تبلغ عن العلل المختصة بأوبنتو فقط إذا كنت قد ثبَّت LibreOffice من الـPPA المخصص.

اصدار أوبنتو 10.04 واصدار 10.10 لا يدعم LibreOffice
اذا كنت تستعمل اصدار أوبنتو 11.04 او أعلى افتح شاشة الاوامر ( تحت التطبيقات > الملحقات > شاشة الأوامر ) وقم بكتابة الأمر ubuntu-bug libreoffice[ادخال] ثم اتبع الاوامر لتكملة التقرير او استخدم هذا النموذج

تذكر ان تضيف التفاصيل مثل طريقة تثبيت LibreOffice , في اي بيئة عمل تعمل (32-bit or 64-bit) والخطوات لاعادة اصدارالمشكله

للإبلاغ عن علة مختصة بأوبنتو, اضطلع على قائمة المشاكل الحالية, ثم استخدمهذا النموذج وحدد libreoffice أسفلIn what package did you find this bug?. وتذكر أيضاً أن تكتب lo33 كوسم "tag" للبلاغ. 

الإبلاغ عن العلة في FreeDesktop.org كما وُضِحَ أعلاه مفيد أيضاً كي يتم التأكد ما اذا كانت المشكلة موجود في المنبع (وفحصها ثم حلها إن أمكن) لنسخ LibreOffice الأخرى.

    1. If you selected Extended Help: select the appropriate subcomponent, or the [1] at the bottom of the list if you did not find or do not know the appropriate subcomponent.
    2. You will see a list of bugs with that subcomponent. At the bottom of the page, select Edit Search. There, you can modify the search according to your needs.
    3. If you find a bug report that concerns your problem, you can contribute to it. If you don’t find a bug report that concerns your problem, file a new bug report.
  1. If the bug only occurs on Ubuntu or is related to printing, go to #More Information.
  2. After all that, if it does not look like there is a bug report about this issue, follow the instructions at #Submitting a bug.

مالذي تتضمنه في البلاغ

File a separate bug report for each bug you run into, even if the symptoms from a user’s point of view seem identical. Different problems with different roots that appeared in different LibO versions might have to be fixed by different people, for different versions, and at different times. It is impossible to track that in a single bug report.

المعلومات التالية تساعدنا في إعادة إحداث العلة أو تشخيص المشكلة ما قد يساهم في حلها بشكل أسرع:

  • اذ لم تكن لديك خبرة كافية في الإبلاغ عن العلل, فضلاً اقرأتوجيهات كتابة العلل, ستجد الرابط أعلى صفحة التبليغ. 

If you are prompted to sign in, log in with your Bugzilla account.

  • من الأمور المهمة الاختيار الصحيح للمكونات, الاصدار, الحاله الابتدائيه, الخطوره, ومن الأفضل الأخذ بعين الاعتبار تفاصيل تقارير العلل
  • بالاضافه الى الاختيارات المفصله المنسدله التي تتعلق باصدار النظام وهندسته, مثال: openSUSE 11.2 on x86_64, 32-bit Windows 7
    • في لينكس, سطح المكتب, مثال : KDE or GNOME
  • نسخة LibreOffice على سبيل المثال: 3.2.0. نستخرجها من مربع الحوار "Help/About LibreOffice" . واذا كنت تستعمل LibreOffice مسبق البناء , في لينكس يجب ان تخبر بنوع الاصدار لحزمه LibreOffice في نظام ادارة الحزم.

لنظام تشغيل ويندوز اسم الملف الفعلي للمثبت ومن اين تم تحميله.

    • بالاضافه لذلك المعلومات التي تتعلق بالتثبيت و استخدام التعريب ( لغة واجهة المستخدم , مستندات اللغه) من الممكن ان تكون مفيده جدا
    • سواء كان LibreOffice 32 بايت ويستعمل في 64 بايت من نظام لينكس
    • حزم المصدر اذا لم تكن من بناء LibreOffice الرسمي
  • الرجاء المساهمه بشكل ذا معنى ومختصر للمشكله اللتي ترغب بكتابه تقرير عنها.
    • لا: تكسر واجهة المستخدم
    • لكن: قائمة > ملف > حفظ باسم > غير متوفر
  • الخطوات لاعادة كتابه العله, الرجاء الاشاره الى كافة التفاصيل الدقيقه التي من الممكن ان تكون مهمه
    • لا تكتب: "فتح ملف ."
    • لكن: "في انشاء ورقة عمل جديده من نوع LibO, استعمل من القائمه: ملف > فتح > نوع الملف > مستند نصي > قم باختيار اضافة مرفقات > نموذج مستند > نقر مزدوج "
    • قم باضافه شرح وافي ودقيق ومحدد لمشكلتك
      • لا: "تهمل تهمل التنسيق والصياغه "
      • لكن: "انا اقبل xxx بسبب yyy ولكني أرى zzz"
  • تفاصيل اخرى مفيده (صوره للشاشه, نموذج مستند, تتبع معاكس, تتبع). فضلا اذكر ان نموذجط النصي من الممكن ان لا يظهر مشكلتك اذا استعمله بعض المستخدمين بانظمة تشغيل مختلفه, او باعدادت برنامج مختلفه او ماشابه ذلك فقد لا تتوجد المشكله في جميع الاحوال. لذلك صورة الشاشه تكون مفيده جدا في هذه الحالات. غالبا صورة الشاشه تكون مفيده اكثر اذا عدلتها ببرامج التعديل كالرسام وغيره لتضيف بعض الملاحظات او لتحدد مكامن المشكله والنقاط المهمه.
  • المرفقات (نماذج مستندات, ... )
  • اذا كنت تريد ارفاق اكثر من صورة للشاشه عليك جمعهم جميعا في مستند واحد (نسخ / لصق في مستند رسم)ثم قم بارفاقها كملف من صغيه PDF. فضلا قم باضافه شرح مختصر لكل صوره على حده لتوضيح ماذا تعني بها.
  • اذا كنت تريد ارفاق اكثر من مستند (نتائج عدة اختبارات) يجب عليك انشاء مستند ضغط يحتوي على جميع الملفات ثم تقوم بارفاق مستند الضغط
  • اذا كان حجم المرفق كبير جدا لارفاقع في بقزيلا (أكبر من 1 ميغا بايت) يمكنك استعمال صفحة التحميل التجريبيه.

ملاحظه: اذا انشئت صورللشاشات, سوف تساعد المطورين بشكل أكبر اذا حولت واجهة المستخدم الى اللغه الانجليزيه أولا. ويمكنك فعل ذلك عن طريق: أدوات > خيارات > اعدادات اللغه > لغات.

In Component, choose the component.

If you are not sure what component your problem is about, choose the LibreOffice component. Someone will review the bug report later and will choose a more precise component. (For more information about triage, which is reviewing bugs to get the important onces to the top of the list, have a look at "BugTriage".)

If it is an urgent issue (broken parts, regression, etc.), and you are an experienced user who knows the development team, you can assign the bug report to one of the developers listed on the FindTheExpert page.

Details

If there is a Sub-component section, select the subcomponent.

If you don’t know the appropriate subcomponent, go to Components. On that page, click on the appropriate component. Read the descriptions of the all the subcomponents on the page of that component. If you don’t see a suitable subcomponent, click on Extended Help, and read the descriptions of the subcomponents on that page.

Choose the version of the application in which the bug appeared. To check what version of LibreOffice you are using, select Help ▸ About LibreOffice

In Operating system or OS, choose the operating system of the computer you were using when you met the bug.

If there is a Hardware section, fill it in.

If there is a Severity section, ignore it unless you are experienced. Selecting Blocker will not get the bug fixed faster. If you want to know the definitions of the items in the Severity section, see this chart.

You can ignore the section latest known-working version.

Subject

Check in possibly related Bugs table on the bug-reporting page and additionally in the Duplicates Table to see whether the problem really has not been reported yet.

In the Subject section (also known as the Summary):

  • Do not include information already known from the fields.
  • Include the names of subcomponents from Components.
    • Make the subcomponents uppercase.
    • If the subcomponent can be confused with parts of a word (for example, UI is part of the word quit), surround the subcomponent with square brackets.
    • Use at most two subcomponents.
    • Use subcomponents exactly as they appear in the list, but you may integrate them into the subject line sentence like “WIKIHELP [UI] not available in all languages”.
  • Summarize the problem fairly precisely.
    • bad example: “File is broken”
    • better example: “Menu File > Save as not available (greyed out)”
  • Avoid short forms like “doesn’t” or “isn’t” to ease queries for strings in the Summary; instead, use the full form, such as “does not” or “is not”.
  • If the problem written in the report is that LibreOffice crashes or stops responding (“hangs”), add the word CRASH to the Summary, so that these bugs can be located and tracked easily.

Description and attachments

In the Long Description or Description section, give a lengthier, factual description of the problem:

  • list the steps to reproduce the bug;
  • use a numbered list; and
  • state the exact method to make something happen. For example, instead of writing “Open document”, write instead “In new empty LibO Spreadsheet document, use menu File > Open (LibO dialog) > file type “Text documents” > select attached sample document > double click”.

If you’re using a pre-built LibreOffice on Linux, list the exact versions of LibreOffice packages in your package management system. If you’re using Windows, list the exact filename of the installer, and from where it was downloaded.

  • Including information about installed and used localization (UI language, document language) might be useful.
  • Include whether a 32-bit LibreOffice is used on a 64-bit (Linux) system.
  • Include the package source if it’s not the official LibreOffice build.

Write the expected behavior and the actual behavior.

You can include an attachment, such as a screenshot or a sample document. The typical way to take a screenshot is to press the "Print Screen/PrtScn" button on your keyboard. Depending on your operating system, you might have to then open an image editing application (such as Paint on Windows) and do Edit - Paste in it.

  • If you create screenshots, switch the language to English before making the screenshot. You can do so in Tools ▸ Options ▸ Language Settings ▸ Languages.
  • You can make screenshots more useful by adding comments and marking relevant areas with LibreOffice Draw.
  • If you want to attach more than one screenshot, you should collect them all in one document (copy / paste to a LibreOffice Draw document) and attach as a PDF. Please add a short comment to each screenshot to tell what you want to demonstrate with it.
  • If you attach a sample document that exhibits the bug you are reporting, please make the document as minimal as possible. For example, for Writer bugs, the document should ideally have just a single paragraph. To make it easy to find the text from your document in debug tracing, use some very easily recognizable text, like AAAAAAAAAA ₂ ZZZZZZZZZZ for a bug that is triggered by that character.
  • It is preferable to upload attachments individually. However, if you want to attach more than half a dozen documents, create a .zip file containing all documents and attach that .zip.
  • If your attachment is too big to be attached in Bugzilla (bigger than 1 MB) you can use the Experimental upload page.

Status

The only time you should change the status to NEW is, if someone already confirmed the bug elsewhere (Ask, mailing list, some forum). In these cases, provide a link to the discussion with the confirmation.

Submit

Click Submit, and your report will be added to the Bugzilla database.

If Bugzilla seems daunting

If the Bugzilla bug tracking system seems daunting or too hard to understand, you should post your problem here:

Even if you post your problem on those channels, your goal should be to get a good bug report on bugzilla. These channels might help you with that. Note, that reporting problems on social media (Facebook, Twitter etc.) is not productive in general as it will rarely lead to a good bug report ending up in bugzilla (see also: 99 ways to ruin an open source project, top 5).

توفير معلومات اضافيه للمطورين

If nobody has reviewed your report within an appropriate time (24 hours for a critical bug, 14 days for an enhancement request), consider asking someone else to reproduce your bug report on the users@global.libreoffice.org mailing list or IRC channel #libreoffice connect via webchat.

كيفية عمل تتبع عكسي (في ويندوز)

  • Avoid posting “me too” comments which contain no additionally useful information.
    The exception to this is when you comment on a bug that has been UNCONFIRMED so far. In that case, please provide reproduction steps (or confirm the ones given by the original reporter) and move the issue to status NEW. Note that if there are no clear reproduction steps, the issue might quickly move back to NEEDINFO, so finding a good and simple reproduction scenario is essential.
  • Refrain from adding comments along the line of “we have 1000 seats here and only this bug prevents us from migrating”, as it contains no additional information relevant to QA or to the priority of the issue.

اقرا عن كيفية عمل تتبع عكسي عن طريق مقالات WinDbg وشاهد فديو لمجموعة الصور التي تشرح كيف يمكنك ان تستخرج مجموعة من المعلومات للمطورين فضلا تذكر ان تعمل نسخه من النص في المستند الجديد وقم بارفاقها لتقرير العله. هذا سوف يبقي العله مقروئه وسوف يحمي من النتائج الغير مستخدمه في استعلامات البقزيلا.

  • Employ and/or teach your own developers to work on LibreOffice. We are most happy to mentor them: see the developer’s pages.
  • Fund individuals or companies to work on specific issues - see the list of certified developers.
  • Contact The Document Foundation to help you if you have only a small amount of funding, and want to collaborate, coordinate or pool your resources with others in the same situation to fund specific fixes or enhancements.

كيف يمكن عمل تتبع عكسي (في لينكس)

Minimum requirements

  1. OS/LibreOffice version;
  2. enumerated reproducible steps;
  3. simple attachments where appropriate; and
  4. observed/expected results.

التتبع العكسي مفيد في حالة ان التطبيق حدث له خطأ او تجمد , ومن الممكن استعمال الخطوات التاليه:

  1. قم بتحميل حزمة libreoffice*-debuginfo, اذا كانت متوفرة. اذا لم تتوفر, التتبع العكسي يصبح اقل فاعليه, ولكن يبقى مفيد الى حد ما حيث من الممكن ان يوفر بعض المعلومات الاضافيه.
  2. ابدأ المصحح بالاعداد الحقيقيه الثنائيه واعمل على تسجيل المخرجات:
    cd /opt/libreoffice/program
    gdb ./soffice.bin 2>&1 | tee /tmp/gdb.log
  3. داخل المصحح, ابدا التطبيقات:
    run
    هل تحتاج لتحديد الخصائص لأوامر LibreOffice, استخدمrun <options>, مثل. run -writer, او run /path/to/document.odt
  4. اعمل الخطوات لاعادة تشغيل التطبيق بعد حدوث الخطأ او بعد التجمد, وفي حالة التجمد تحتاج للضغط على CTRL-C في gdb للحصول على gdb الأوامر مره أخرى.
  5. القيام بعمل التتبع العكسي:
    backtrace
  6. القيام بعمل التتبع العكسي لجميع المواضيع:
    thread apply all bt
  7. الخروج من المصحح
    quit
  8. ارفاق جميع gdb.log لتقرير العله.
  • tdf#85004 - Writer: Crash when clicking the Reminder icon on the Navigation toolbar
  • tdf#87907 - DIALOG: Page preview in print dialog refreshes when opening print details
  • tdf#74839 - EDITING: Position of connectors connected to a group aren't updated when editing group content

كيفية عمل strace log (في لينكس)

Reports can be less than ideal for a number of reasons. Below are some of the common problems:

في أغلب الحالات, يمكن البدء في التطبيق بهذه الطريقه:

Describing a bug report in paragraphs of text is one of the most common problems. Developers do not have the time to read paragraphs of text. Clear, succinct, enumerated steps are always better.

strace -o /tmp/strace.log -f -tt -s 512 libreoffice

One report should only have a single bug in it. Grouping bugs, or listing a whole list of issues with a single document, is utterly unhelpful. In order to find developers to tackle issues, it is best to give them a single issue to focus on. They are unlikely to take on a bug that has multiple issues listed

بعد ذلك قم بعمل هذه الخطوات لاعاده اصدار المشكله والخروج من التطبيق. الأمر libreoffice من الممكن تبديله /opt/libreoffice/program/soffice خاصة اذا لم يتم تحمل عملية التكامل لسطح المكتب . فضلا اضغط السجل قبل ارفاقه في تقرير العله :

All bug reports should have at minimum:

bzip2 /tmp/strace.log

اذا كان 32 بايت LibreOffice يعمل في نظام تشغيل 64 بايت, يجب عليك تحميل حزمة strace-32bit والبدء في 32 بايت مباشرة:

Adding a lot of extra details that aren’t relevant is another common problem. Examples include:

cd /opt/libreoffice/program

strace32 -o /tmp/strace.log -f -tt -s 512 ./soffice.bin

كيفية عمل valgrind log (في لينكس)

Attachments should be as simple as possible. Take the time to prune your examples to the bare minimum. This helps tremendously in diagnosing problems.

valgrind log مفيد عندما يحصل خطأ في التطبيق او تجمد وعملية التتبع العكسي تكون غير كافيه, يمكنك استعمال الخطوات التاليه:

Do not assume contributors know what you’re talking about. Describe your steps clearly, each step of the way.

More Information