How to Report Bugs in LibreOffice

From The Document Foundation Wiki
< QA
Jump to: navigation, search
This page is a translated version of the page QA/BugReport and the translation is 4% complete.

Outdated translations are marked like this.
Other languages:
العربية • ‎Deutsch • ‎Ελληνικά • ‎English • ‎español • ‎français • ‎galego • ‎italiano • ‎日本語 • ‎Nederlands • ‎português do Brasil • ‎русский • ‎Türkçe • ‎中文(中国大陆)‎ • ‎中文(简体)‎ • ‎中文(台灣)‎

Informations générales

Comment utiliser l'Assistant de soumission de bogue

  1. Cliquer ici et suivez les instructions de l'Assistant
  2. Après avoir sélectionné un composant dans l'Assistant de soumission de bogue une liste avec des bogues déjà rapportés pour le même composant sera affichée. Si la courte description du bogue correspond à votre problème, cliquez sur le lien pour plus de détails. Avec le bouton EditSearch au bas de la page correspondante de Bugzilla vous pouvez modifier la recherche en fonction de vos besoins. Si vous trouvez un rapport existant concernant votre problème, aucun rapport supplémentaire n'est nécessaire, mais peut-être que vous pouvez fournir des informations supplémentaires.
    1. Lorsque vous décrivez votre rapport de bogue, un regard sur Ce qu'il faut inclure dans les rapports de bogues et BugReport Details pourrait être utile.
Class of Bugs Where to file the bug
LibreOffice Extensions With the extension author
TDF/LibreOffice Infrastructure (websites, mailing lists, etc.) Redmine
Building LibreOffice Developer mailing list
LibreOffice Unit Tests Developer mailing list

Before you submit a bug

Confirm that it really is a bug. Most of the time, a bug is something that makes the software behave in a way that a reasonable user would not want it to behave. This includes the software not doing what you want it to do, doing what you never asked it to do, or just plain crashing under normal use. Going behind the scenes, a bug may be something that causes the software to take a lot longer and use a lot more resources doing stuff than it should.

Some glitches might actually be the result of a corrupted user profile. Problems with OpenGL and OpenCL are usually valid bugs. It helps a lot, if you check the effects of the OpenGL and OpenCL settings before writing your bug report.

At a certain point what look like bugs are actually more like feature requests, where we know how the software should work in an ideal world, even though the feature we want hasn't been built yet. Fortunately, you don't have to worry that much about separating bugs from feature requests. If it's something that interferes with normal, valid use of the application, report it as a bug.

It helps a lot if you know your way around LibreOffice, though, so you have a good sense of what normal, valid use is. You don’t want to spend a lot of time reporting what you think are bugs when the issue is that you don’t know how to use a certain feature yet. Consider reading the user documentation, and use the apps a lot so you become familiar with what they normally do.

If you know LibreOffice fairly well and run into something that may be a bug, but may be just something you don’t understand, you can post a question at LibreOffice Users Mailing List or Ask LibreOffice.

But let’s say what you found really does look like a bug. Here’s what to do next:

  1. Take notes so you don’t forget something that was going on around the time the bug appeared. What were you doing, what did you expect to happen, and what actually happened? How did you know something was wrong? Can you reproduce the bad behavior?
  2. Check for similar, existing bug reports:
    1. Go to Components, and select the appropriate component (or subcomponent).
    2. If you selected a component: select the appropriate subcomponent, or Extended Help if you don’t see the subcomponent on that page.
    3. If you selected Extended Help: select the appropriate subcomponent, or the [1] at the bottom of the list if you did not find or do not know the appropriate subcomponent.
    4. You will see a list of bugs with that subcomponent. At the bottom of the page, select Edit Search. There, you can modify the search according to your needs.
    5. If you find a bug report that concerns your problem, you can contribute to it. If you don’t find a bug report that concerns your problem, file a new bug report.
  3. If the bug only occurs on Ubuntu or is related to printing, go to #More Information.
  4. After all that, if it does not look like there is a bug report about this issue, follow the instructions at #Submitting a bug.

Signalement d'un bogue en quelques étapes

File a separate bug report for each bug you run into, even if the symptoms from a user’s point of view seem identical. Different problems with different roots that appeared in different LibO versions might have to be fixed by different people, for different versions, and at different times. It is impossible to track that in a single bug report.

  1. Vérifiez la présence de doublons comme décrit ci-dessus. Pour ce faire, sur BugReport Details un simple clic sur le nom d'un sous-composant ouvre une liste avec les bogues déjà rapportés. Un clic sur ⓘ vous mène à l'aide concernant les sous-composants. Avec Edit Search au bas de la page Bugzilla vous pouvez modifier la recherche en fonction de vos besoins.
  2. Démarrer un nouveau rapport. Sur BugReport Details un simple clic sur la flèche► derrière le sous-composant que vous avez utilisé pour votre requête ouvre une page de rapport de bogues Bugzilla préparée pour vos besoins. (Si vous ne trouvez pas un composant, cliquez sur le lien "for all other problems" ! Ensuite, dans les différentes listes, sélectionnez :
    1. Votre version de LibreOffice.
    2. Votre type de matériel.
    3. Votre système d'exploitation.
    4. Écrivez votre rapport de bogue
    5. Décidez du niveau de gravité. Le laisser tel quel si vous n'avez pas beaucoup d'expérience, le bogue ne sera pas pris en charge rapidement si vous choisissez bloquant (blocker).
  3. Cliquez sur Envoyer ('Submit'), votre rapport sera ajouté à la base de données Bugzilla

En fonction du type, vous pouvez choisir différents composants :

  • Pour les problèmes relatifs au site LibreOffice.org, utilisez le composant WWW.
  • Pour les problèmes généraux relatifs aux applications, utilisez les composants correspondants Writer, Presentation, Spreadsheet, Database, ou Drawing.

If you are prompted to sign in, log in with your Bugzilla account.

Conseils supplémentaires

In Component, choose the component.

Si ce système de rapport de bogue vous impressionne avec toutes ses sélections et ses règles, vous pouvez poser votre problème sur la liste users@fr.libreoffice.org où vous obtiendrez de l'aide. Pour vous abonner à une liste, visitez Besoin d'aide ?!

If it is an urgent issue (broken parts, regression, etc.), and you are an experienced user who knows the development team, you can assign the bug report to one of the developers listed on the FindTheExpert page.

Details

If there is a Sub-component section, select the subcomponent.

If you don’t know the appropriate subcomponent, go to Components. On that page, click on the appropriate component. Read the descriptions of the all the subcomponents on the page of that component. If you don’t see a suitable subcomponent, click on Extended Help, and read the descriptions of the subcomponents on that page.

Choose the version of the application in which the bug appeared. To check what version of LibreOffice you are using, select Help ▸ About LibreOffice

In Operating system or OS, choose the operating system of the computer you were using when you met the bug.

If there is a Hardware section, fill it in.

If there is a Severity section, ignore it unless you are experienced. Selecting Blocker will not get the bug fixed faster. If you want to know the definitions of the items in the Severity section, see this chart.

You can ignore the section latest known-working version.

Subject

Check in possibly related Bugs table on the bug-reporting page and additionally in the Duplicates Table to see whether the problem really has not been reported yet.

In the Subject section (also known as the Summary):

  • Do not include information already known from the fields.
  • Include the names of subcomponents from Components.
    • Make the subcomponents uppercase.
    • If the subcomponent can be confused with parts of a word (for example, UI is part of the word quit), surround the subcomponent with square brackets.
    • Use at most two subcomponents.
    • Use subcomponents exactly as they appear in the list, but you may integrate them into the subject line sentence like “WIKIHELP [UI] not available in all languages”.
  • Summarize the problem fairly precisely.
    • bad example: “File is broken”
    • better example: “Menu File > Save as not available (greyed out)”
  • Avoid short forms like “doesn’t” or “isn’t” to ease queries for strings in the Summary; instead, use the full form, such as “does not” or “is not”.
  • If the problem written in the report is that LibreOffice crashes or stops responding (“hangs”), add the word CRASH to the Summary, so that these bugs can be located and tracked easily.

Description and attachments

In the Long Description or Description section, give a lengthier, factual description of the problem:

  • list the steps to reproduce the bug;
  • use a numbered list; and
  • state the exact method to make something happen. For example, instead of writing “Open document”, write instead “In new empty LibO Spreadsheet document, use menu File > Open (LibO dialog) > file type “Text documents” > select attached sample document > double click”.

If you’re using a pre-built LibreOffice on Linux, list the exact versions of LibreOffice packages in your package management system. If you’re using Windows, list the exact filename of the installer, and from where it was downloaded.

  • Including information about installed and used localization (UI language, document language) might be useful.
  • Include whether a 32-bit LibreOffice is used on a 64-bit (Linux) system.
  • Include the package source if it’s not the official LibreOffice build.

Write the expected behavior and the actual behavior.

You can include an attachment, such as a screenshot or a sample document. The typical way to take a screenshot is to press the "Print Screen/PrtScn" button on your keyboard. Depending on your operating system, you might have to then open an image editing application (such as Paint on Windows) and do Edit - Paste in it.

  • If you create screenshots, switch the language to English before making the screenshot. You can do so in Tools ▸ Options ▸ Language Settings ▸ Languages.
  • You can make screenshots more useful by adding comments and marking relevant areas with LibreOffice Draw.
  • If you want to attach more than one screenshot, you should collect them all in one document (copy / paste to a LibreOffice Draw document) and attach as a PDF. Please add a short comment to each screenshot to tell what you want to demonstrate with it.
  • If you attach a sample document that exhibits the bug you are reporting, please make the document as minimal as possible. For example, for Writer bugs, the document should ideally have just a single paragraph. To make it easy to find the text from your document in debug tracing, use some very easily recognizable text, like AAAAAAAAAA ₂ ZZZZZZZZZZ for a bug that is triggered by that character.
  • It is preferable to upload attachments individually. However, if you want to attach more than half a dozen documents, create a .zip file containing all documents and attach that .zip.
  • If your attachment is too big to be attached in Bugzilla (bigger than 1 MB) you can use the Experimental upload page.

Status

The only time you should change the status to NEW is, if someone already confirmed the bug elsewhere (Ask, mailing list, some forum). In these cases, provide a link to the discussion with the confirmation.

Submit

Click Submit, and your report will be added to the Bugzilla database.

If Bugzilla seems daunting

If the Bugzilla bug tracking system seems daunting or too hard to understand, you should post your problem here:

Even if you post your problem on those channels, your goal should be to get a good bug report on bugzilla. These channels might help you with that. Note, that reporting problems on social media (Facebook, Twitter etc.) is not productive in general as it will rarely lead to a good bug report ending up in bugzilla (see also: 99 ways to ruin an open source project, top 5).

Comment rapporter les problèmes spécifiques à Ubuntu

If nobody has reviewed your report within an appropriate time (24 hours for a critical bug, 14 days for an enhancement request), consider asking someone else to reproduce your bug report on the users@global.libreoffice.org mailing list or IRC channel #libreoffice connect via webchat.

La liste de problèmes connus affectant la version de LibreOffice distribuée officiellement avec Ubuntu se trouve à :

  • Avoid posting “me too” comments which contain no additionally useful information.
    The exception to this is when you comment on a bug that has been UNCONFIRMED so far. In that case, please provide reproduction steps (or confirm the ones given by the original reporter) and move the issue to status NEW. Note that if there are no clear reproduction steps, the issue might quickly move back to NEEDINFO, so finding a good and simple reproduction scenario is essential.
  • Refrain from adding comments along the line of “we have 1000 seats here and only this bug prevents us from migrating”, as it contains no additional information relevant to QA or to the priority of the issue.

Seuls les problèmes spécifiques à la version officielle distribuée par le projet Ubuntu devraient être rapportés suivant ces instructions :

  1. Vérifiez que votre problème n'est pas déjà parmi la liste de problèmes connus
  2. Déclarez le bogue :
    • Si vous utilisez Ubuntu 10.04 LTS ou Ubuntu 10.10, ce formulaire (en anglais) et choisissez libreoffice pour "In what package did you find this bug ?".
    • Si vous utilisez Ubuntu 11.04, ouvrez une fenêtre de terminal (Applications ▸ Accessoires ▸ Terminal) et tapez ubuntu-bug LibreOffice [Entrée], puis suivez les instructions pour compléter le rapport.

Ce que doit inclure un rapport de bogue

Les informations suivantes sont nécessaires pour nous aider à reproduire ou à localiser le problème et donc à fournir le correctif qui pourrait être disponible plus tôt pour vous :

  • Si vous n'avez pas l'expérience des rapports de bogue, vous pouvez lire le bug writing guidelines (en anglais), vous y trouverez un lien en haut de la page Enter Bug !
  • Utilisez correctement la sélection du Composant, de la Version et du Statut initial, des conseils figurent sur BugReport Details.
  • Il y a également des sous-sélections permettant de choisir la version et l'architecture du système : e.g. openSUSE 11.2 on x86_64, 32-bit Windows 7
    • pour Linux, quelle interface : e.g. KDE ou GNOME
  • La version de LibreOffice, par exemple 3.2.0. Vous l'obtenez à partir de la boîte de dialogue "Aide/À propos de LibreOffice". Si vous utilisez une pré-version de LibreOffice, sous Linux, dites les versions exactes des packages LibreOffice utilisés dans votre système de gestion de packages. Pour Windows, le nom de fichier exact de l'installeur et à partir d'où ils ont été téléchargés.
    • Des informations complémentaires concernant les localisation installées et utilisées (langue de l'interface, langue du document) peuvent être utiles
    • si une version 32-bit de LibreOffice est utilisée sur un système 64 bit (Linux)
    • la source du package si ce n'est pas une version officielle de LibreOffice
  • Veuillez indiquer un sommaire significatif pour les problèmes que vous souhaitez reporter :
    • Pas de : "UI cassée"
    • Mais : Menu FichierEnregistrer sous}} non disponible (grisé)
  • Étapes pour reproduire le problème, veuillez noter que chaque petit détail peut être important.
    • Ainsi, n'écrivez pas : "Ouvrir le document"
    • Mais: "Dans une nouvelle feuille de calcul LibO, utilisez le menu Fichier ▸ Ouvrir (boîte de dialogue LibO) ▸ type de fichier "documents Texte" ▸ sélectionnez le document d'exemple attaché ▸ double cliquez
  • tout autre détail utile (e.g. copies d'écran, documents d'exemple, backtrace, strace)

Comme obtenir un journal strace (sous Linux)

Minimum requirements

  1. OS/LibreOffice version;
  2. enumerated reproducible steps;
  3. simple attachments where appropriate; and
  4. observed/expected results.

Dans la plupart des cas, il est suffisant de démarrer l'application de la façon suivante :

strace -o /tmp/strace.log -f -tt -s 512 libreoffice

Puis exécutez les étapes pour reproduire le problème et quittez l'application. Commande libreoffice peut être remplacée par

/opt/libreoffice/program/soffice surtout si vous n'avez pas l'intégration à l'environnement de bureau installée.    

Veuillez compresser le journal avant de l'attacher au rapport de bogue :

bzip2 /tmp/strace.log

Si une version 32-bit de LibreOffice est exécutée sur un système 64-bit, vous devez installer le package strace-32bit et démarrer le binaire 32-bit directement :

cd /opt/libreoffice/program
strace32 -o /tmp/strace.log -f -tt -s 512 ./soffice.bin
  • tdf#85004 - Writer: Crash when clicking the Reminder icon on the Navigation toolbar
  • tdf#87907 - DIALOG: Page preview in print dialog refreshes when opening print details
  • tdf#74839 - EDITING: Position of connectors connected to a group aren't updated when editing group content

Comment obtenir un backtrace (sous Linux)

Reports can be less than ideal for a number of reasons. Below are some of the common problems:

Un backtrace est utile lorsque l'application plante ou gèle. Vous devez suivre les étapes suivantes :

  1. Installez les packages libreoffice*-debuginfo, si disponibles. Si vous ne les avez pas, le backtrace est moins utile mais peut cependant fournir quelques informations.
  2. Démarrez le débogueur avec le binaire réel et journalisez la sortie :
    cd /opt/libreoffice/program
    gdb ./soffice.bin 2>&1 | tee /tmp/gdb.log
  3. À l'intérieur du débogueur, démarrez l'application :
    run
    Si vous devez spécifier des options en ligne de commande LibreOffice, utilisez run <options>, comme par exemple run -writer, ou run /path/to/document.odt
  4. Exécutez les étapes pour reproduire le plantage de l'application ou le gel. Dans le cas du gel, vous devez appuyer sur CTRL+C dans gdb pour avoir de nouveau la ligne de commande gdb.
  5. Produisez le backtrace :
    backtrace
  6. Produisez le backtrace de tous les threads :
    thread apply all bt
  7. Quittez le débogueur
    quit
  8. Attachez tout le gdb.log au rapport de bogue.

Describing a bug report in paragraphs of text is one of the most common problems. Developers do not have the time to read paragraphs of text. Clear, succinct, enumerated steps are always better.

One Report, Five Bugs

One report should only have a single bug in it. Grouping bugs, or listing a whole list of issues with a single document, is utterly unhelpful. In order to find developers to tackle issues, it is best to give them a single issue to focus on. They are unlikely to take on a bug that has multiple issues listed

Missing Details/Steps

All bug reports should have at minimum:

  1. your Operating System and version of LibreOffice;
  2. clear reproducible steps;
  3. expected results;
  4. observed results; and
  5. a simple attachment where appropriate.

Adding Superfluous Information

Adding a lot of extra details that aren’t relevant is another common problem. Examples include:

  1. “this is a blocker”;
  2. a long list of reasons why it’s a blocker;
  3. “I can’t use LibreOffice because of this bug”;
  4. “LibreOffice sucks” (or any variation of that); and
  5. I’m going to start using your competitor unless you fix it.

Complex Attachments

Attachments should be as simple as possible. Take the time to prune your examples to the bare minimum. This helps tremendously in diagnosing problems.

Assuming Contributors Know Everything

Do not assume contributors know what you’re talking about. Describe your steps clearly, each step of the way.

Comment obtenir un backtrace (sous Windows)