Como reportar um bug (erro) no LibreOffice

From The Document Foundation Wiki
< QA‎ | BugReport
Jump to: navigation, search

Reportar bugs (erros) no LibreOffice

O problema é realmente um bug?

Se você precisa de ajuda usando o LibreOffice, considere postar sua questão na lista de usuários.

Procurando por um reporte de bug existente ou similar

ANTES de criar um novo reporte de bug, por favor, verifique se o problema já foi reportado. Se sim, talvez você possa contribuir com informações adicionais no reporte de bug existente?

Peça ajuda para alguém à reproduzir o bug

Considere pedir ajuda à alguém para reproduzir o seu reporte de bug na lista de discussão ou no canal IRC do #libreoffice connect via webchat.

Reportando um bug

Os bugs do LibreOffice devem ser relatados no bugzilla. Você pode reportar um bug diretamente para o produto "LibreOffice".

Dependendo do tipo de bug, você pode escolher um componente diferente:

  • Para problemas no portal LibreOffice.org, use o componente WWW;
  • Para bugs em geral, use os componentes Writer, Presentation, Spreadsheet, Database, or Drawing correspondentes.

Para qualquer outro problema, escolha outros componentes. Clicando em um componente da lista aparecerá uma dica.

Se você não está certo de qual componente seu problema está relacionado, escolha o componente Libreoffice. Um revisor de bugs atribuirá ao componente apropriado.

Por favor, arquive um reporte de bug para cada caso! Se este sistema de rastreamento de bugs parecer assustador, com todas estas escolhas e regras, você pode postar seu problema na lista de discussão ou http://pt-br.libreofficeforum.org/forum ; você encontrará ajuda lá.

Nota: A redação do seu problema ou bug deve obrigatoriamente ser em inglês. Não há como contornar este fato. Se necessário, peça ajuda aos colegas da comunidade para traduzir para o inglês e poste o texto. Todos os diálogos na resolução do bug serão em inglês.

Reportando bugs no Ubuntu

A lista corrente de casos específicos para o Ubuntu está disponível aqui:

Você pode reportar bugs específicos do Ubuntu se você tem o LibreOffice instalado do PPA correspondente. Para reportar um bug específico do Ubuntu, primeiro verifique a lista de casos atuais, então:

  • Se você está usando o Ubuntu 10.04 LTS ou Ubuntu 10.10, use este formulário e especifique libreoffice no In what package did you find this bug?.
  • Se você está usando o Ubuntu 11.04, abra a janela do terminal (em Aplicações > Acessórios > Terminal) e digite ubuntu-bug libreoffice[ENTER], então siga as instruções para completar o reporte.

Lembre-se de etiquetar (tag) o reporte com lo33 e inclua detalhes tais como você instalou o LibreOffice, qual a plataforma que usa (32 ou 64-bits) e passos para reproduzir o problema. Preenchendo o relatório de bugs em FreeDesktop.org como descrito acima também é muito útil como "reporte central" para poderem ser verificados (e possivelmente testados e corrigidos) em outras versões do LibreOffice.

O que deve ser incluído no relatório do bug

As informações abaixo irão nos ajudar a reproduzir ou a localizar o problema e assim a correção pode estar disponível mais cedo para você:

  • Se você não tem muita experiência em reportar um bug, por favor, leia as orientações para escrever um bug (bug writing guidelines), no link no topo da página Enter bug!
  • Use a Correta seleção do Componente(Component), Versão(Version) e Status Inicial (Initial Status), tendo em mente as dicas nos Detalhes do Relatório de Bugs.
  • Adicionalmente, selecione detalhes sobre a versão do sistema e arquitetura, como por exemplo, "openSUSE 11.2 em x86_64" ou "Windows 7 32-bit".
    • Para linux, qual o desktop você usa, como por exemplo, KDE ou GNOME.
  • Versão do LibreOffice, isto é, "3.2.0". Obtenha esta informação no diálogo "Ajuda > Sobre o LibreOffice". Se está usando uma pré-compilação do LibreOffice, no Linux, diga qual a versão exata dos pacotes no seu sistema de gerenciamento de pacotes. Para Windows, o nome exato do arquivo de instalação, e de onde foi baixado.
    • Adicionalmente, informação sobre a localização instalada e usada (idioma do UI, idioma do documento) podem ser úteis.
    • Se um LibreOffice 32-bit é usado em um sistema (Linux) de 64-bit.
    • Origem do pacote fonte, se este não for uma compilação oficial do LibreOffice.
  • Por favor, contribua com um resumo completo para o problema que deseja reportar.
    • Não: "UI broken"
    • Sim: "Menu 'Arquivo -> Salvar como' não disponível (acinzentado)"
  • Passos para reproduzir o problema, mencionando cada pequeno detalhe, pois pode ser importante.
    • Assim, não escreva: "Open document"
    • Mas: "Em um nova planilha, use o menu 'Arquivo -> Abrir (diálogo do Bro/LibO) -> tipo de arquivo "Documento de texto" -> selecionando o documento de exemplo em anexo -> duplo clique.
    • Disponibilize uma descrição exata do seu problema
      • Não: "Formatação incorreta"
      • Sim: "Eu esperava xxx' por causa de yyy, mas eu vi zzz
  • Outros detalhes importantes (isto é, capturas de telas, backtrace, strace). Por favor, mencione que seu documento de exemplo pode não mostrar o seu problema se algum outro usuário abri-lo porque ele usa um sistema operacional diferente, tenha outras configurações para o Bro/LibO ou alguma outra coisa. Assim, uma captura de tela (screenshot) pode ajudar. Algumas vezes uma captura de tela é mais util se vocë editá-la (com o DRAW), adicionando comentários e marcando as áreas relevantes.
  • Se você quer anexar mais de uma captura de tela (screenshot) que você pode coletar todos eles em um documento (copiando/colando em um documento do Draw) e anexar em formato de PDF. Por favor, adicione um breve comentário para cada imagem para dizer o que você quer demonstrar com isso.

Como obter um log do strace (no Linux)

Na maioria dos casos, basta iniciar a aplicação da seguinte forma:

strace -o /tmp/strace.log -f -tt -s 512 libreoffice

Então execute os passos para reproduzir o problema e saia da aplicação. O comando libreoffice pode ser substituído por/opt/libreoffice/program/soffice caso não tenha a integração com o ambiente de trabalho instalada.

Por favor, comprima o log antes de anexar ao relatório de bugs:

bzip2 /tmp/strace.log

Se o LibreOffice de 32-bit estiver rodando em um sistema de 64-bit, será necessário instalar o pacote strace-32bit e iniciar o binário de 32 bits diretamente:

cd /opt/libreoffice/program
strace32 -o /tmp/strace.log -f -tt -s 512 ./soffice.bin

Como obter o backtrace (no Linux)

O backtrace é muito útil quando a aplicação congela ou termina anormalmente (crash). Você pode utilizar os seguintes passos:

  1. Instale os pacotes libreoffice*-debuginfo, se disponíveis em sua distribuição. Se você não tem eles, o backtrace é menos útil, mas poderia prover potencialmente mais alguma informação ao final.
  2. Inicie o debugger com o binário real e registre a saída (log):
cd /opt/libreoffice/program
gdb ./soffice.bin 2>&1 | tee /tmp/gdb.log
  1. Dentro do debugger, inicie a aplicação:
run

Você precisaria especificar as opções na linha de comando do LibreOffice, usando run -writer, ou run /caminho/para/documento.odt.

  1. Faça os passos para reproduzir o crash ou congelamento da aplicação. Se a aplicação congelar, será necessário pressionar CTRL+C para obter a de volta a linha de comando do gdb.
  2. Imprima o backtrace:
    backtrace
    
  3. Imprima o backtrace de todas as threads:
    thread apply all bt
    
  4. Saia do debugger:
    quit
    
  5. Anexe o gdb.log completo ao relatório.

Como obter o log do valgrind (no Linux)

O log do valgrind log é muito útil quando a aplicação congela ou termina anormalmente (crash) e o backtrace não é suficiente. Considere os seguintes passos:

  1. Instale os pacotes libreoffice*-debuginfo . (se disponíveis, e/ou de sua distribuição)
  2. Inicie o debugger com o binário real e registre a saída:
cd /opt/libreoffice/program
valgrind--tool=memcheck --num-callers=128 --trace-children=yes ./soffice.bin2>&1 | tee /tmp/valgrind.log
  1. Execute os passos para reproduzir o crash ou congelamento da aplicação. Note que em geral acaba funcionando com o valgrind por que ele ajuda a manter a memória limpa. De qualquer forma, ele ajudará a detectar o perigo e colocará algumas informações úteis no registro (log). Observe também que o valgrind imprime muitos avisos o tempo todo. Você precisa realmente repetir os passos problemáticos para colocar dados importantes no registro (log).
  2. Saia do LibreOffice.
  3. Comprima os dados do valgring.log caso seja maior que 10kB
bzip2 /tmp/valgrind.log
  1. Anexe o log ao relatório do bug.